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ANNOTATSIYA 

 
Hisoblash texnikasida dasturlash tushunchasi juda keng tushunchadir. Bu tushuncha 

zamirida komp`yuterlarga ishonchli ishlaydigan amaliy va tizimli dasturlar tuzish, 

ma`lumotlarni tezkor qayta ishlash natijasida vaqt va xotirani tejash va boshqa muammolar 

yotadi.  
Hisoblash texnikasi juda jadal rivojlanib xalq xo‟jaligining barcha tarmoqlariga kirib 

bormoqda, jumladan ishlab chiqarish, boshqarish, moliya tizimlarida hamda harbiy 

texnikada keng ko‟llanmoqda. Shu bilan bir qatorda kompyuterda axborotlarini qayta 

ishlash, saqlash va uzatish muammosi hozirgi paytning aktual muammolaridan biri 

hisoblanadi. 

Ushbu uslubiy ko‟rsatmalar "Kasbiy ta`lim" fakulteti talablariga mo‟ljallangan bo‟lib, 

unda kompyuterda Vizual dasturlash tillari yordamida dasturlar yaratish usullari, vazifalari, 

tijorat ishlarida komp`yuter axborotlarini dasturlar yordamida qayta ishlash va boshka bir 

qancha masalalar bo‟yicha nazorat topshiriqlari va ularni echishga tegishli bo‟lgan nazariy 

materiallar keltirilgan. 

 

 

"Informatika va axborot texnologiyalari" kafedrasi 
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1 - MARUZA 

Yordamchi (ilova) dasturlar uchun Visual Basic haqli versiyasi 

VBA-Visual Basic for Application-bu nom Microsoft kompaniyasi tomonidan Office 

dasturlarining dasturlash tiliga berilgan nomdir. VBA, shuningdek, boshqa ishlab 

chiqaruvchilar uchun ham yaroqli bo‟lib, ular bu tildan o‟z dasturlarida foydalanishlari 

mumkin. VBA va Visual Basic ning avtonom ishlovchi versiya lariorasidagi farqni bilish 

uchun ikki tashkil etuvchini farqlash kerak: 

1. Visual Basic tilining negizi. 

Ob`ektlar, yani tugma, ro‟yxatlar oynasi va Active X boshqaruv elementlaridir. 

VBA da ham, Visual Basic ning avtonom ishlovchi versiyasida ham til negizi (asosi) 

o‟zgarmaydi. SHu bilan bir vaqtda bu til-bu ob`ektlar to‟plami bo‟lib, ularning tarkibi 

o‟zgarib turadi. VBA bilan ishlash imkoni bo‟lgan dasturda o‟ziga xos dastur ob`ektlari 

bo‟ladi va ulardan siz o‟z kodingizda foydalanishingiz mumkin. 

Misol uchun, Wordda Dosument (Hujjat) va Paragraph (Abzats) ob`ektlari bor. Siz bu 

ob`ektlar bilan ishlashni o‟rganib olgan bo‟lsangiz, VBA kodi yordamida bu ob`ektlar bilan 

ishlash imkoniga ega bo‟lasiz.  

SHunisi ehtiborga loyiqki, sistemangizda Office dasturi o‟rnatilgan bo‟lsa, Office 

dasturlarining istalgan elementi uchun VBA kodini yozish mumkin. Masalan, Excelda 

yozilgan VBA kodini Word uchun yoki Visual Basic avtonom dasturida yozilgan koddan 

Office dasturining istalgan elementida foydalanish mumkin. 

 

Boshqa farqlar 

VBA da Visual Basicning avtonom versiyasidagiga o‟xshash matn muharriri va sozlagich 

(otladchik) bor, lekin bu elementlar o‟z imkoniyatlari bo‟yicha bir nechta cheklashlarga ega. 

VBA da kodni avtonom EXE – faylgacha kompilyatsiya qilish imkoniyati yo‟q, bundan 

tashqari, VBA (native code) protsessorning bevosita yo‟riqnomasigacha qadar kompilyatsiya 

qila olmaydi. 

SHu bilan birga VBA da Data boshqarish elementi ham yo‟q. Lekin ma`lumot bazalari 

orqali “sof” VBA kodi bilan ishlash imkoningiz bor. 

VBA ning noyob imkoniyati ham bor dastur tuzishni makroslar yozishdan boshlashingiz 

mumkin, yahni Office ning siz uchun kod yozadi. 
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VBA Excel, Word, Access va Power Point dasturlarining bir qismi hisoblanadi. OutLook 

dasturi esa Visual Basic ning boshqa, imkoniyati kamroq vbceript versiyasidan foydalanadi. 

VBA ni o’rnatish 

VBA Office dasturlarini o‟rnatishganda avtomatik tarzda o‟rnatiladi. Lekin VBAning 

ma`lumotnomasi o‟rnatilmaydi. VBA da dastur tuzish jarayonida ma`lumotnoma zarur 

bo‟lishi mumkin. SHu bilan birga VBA bilan ishlashda axborotlar bazasi bilan ishlash 

imkonini beruvchi ob`ektlarni o‟rnatish zaruriyati ham yuzaga kelishi mumkin. 

VBA komponentlarini o’rnatish 

VBA malumotnomasi fayllarini o‟rnatish uchun Officeni o‟rnatish dasturini ishga tushiring. 

“Dobavit (Udalit komponenti)” (Add/ Remove components) Word, Excel va PowerPoint 

buyrug‟ini tanlang. “Spravka i fayli primerov” (Help files and samples) satrini belgilang. 

Ascess uchun “Spravka po programmirovaniyu” (Programming Help) satrini belgilash 

lozim. Har bir dastur o‟z ob`ektlari uchun ma`lumotnoma o‟rnatadi, shu bilan birga 

ma`lumotnoma fayllari turlichadir. 

  

Agar sizda axborotlar bazalari bilan ishlovchi kod yozish zarurati yuzaga kelsa, Visual Basic 

uchun axborotlar bazasi bilan ishlash imkonini beruvchi ob`ektlarni (Data Acsess Objects 

For Visual Basic) o‟rnatish zarur. Buning uchun Office ni o‟rnatish dasturining “Dostup k 

dannыm” Data Access bo‟limini belgilash zarur. 

Topshiriq №1 
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2 - MARUZA 

VBA dasturlash vositalari 

VBA o‟zining dasturlash muhitiga ega. U Office ning barcha dasturlari uchun bir xil. 

  

 

  

Word va Excel dan VBA ni chaqirish 

VBA ga kirish quyidagicha amalga oshiriladi.  

Servis>Makros>Redaktor 

VisualBasic (Tools>Macro>Visual Basic Editor)  

VBA malumotnomasi katta hajmni egallaydi. Word va Exsel sizga malumotnomaning faqat 

eng zarur elementlariyb o‟rnatish uchun zarur. Misol uchun, Word va Exsel ga bu 

malumotnoma zarur, Power Point uchun esa ikkilamchi vosita hisoblanadi. 

VBA ma`lumotnomasi fayllari katta hajmni egallaydi. Word va Exsel sizga 

ma`lumotnomaning faqat eng zarur elementlarini o‟rnatish uchun zarur. Misol uchun, Word 

va Exsel ga bu malumotnoma zarur, Power Point uchun esa ikkilamchi vosita hisoblanadi. 
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VBA ni ishga tushirish-ning boshqa bir usuli menyudan Servis>Makros>Makroslar 

(Tools>Macro>Macros) ni tanlash va “Edit” (Tahrir) tugmasini bosish yoki Create 

(“Yaratish”) tugmachasini bosib, yangi makros yozishni boshlashdir. 

 

Topshiriq №2 

1. Word da Yangi maroslar yarating va ularni nomlang. Qanday nomlar berish mumkin 

emas va nima uchunligini tushuntiring. 

2. Excel da yangi makroslar yarating. Wordda yarailgan makros bilan farqini aniqlang. 

 

3 - MARUZA 

VBA muhiti 

VBA dasturlar muhiti mustaqil (avtonom) dastur kabi ishlaydi va avtonom Visual Basic ga 

ko‟p jihatdan o‟xshash. 

 

 

Visual Basic va VBA da ekvivalent tugmalar bir-biriga to‟g‟ri keladi. Masalan, dasturni 

ishga tushirish uchun F5 tugmasini bosing. 
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Excel da makros yozish 

 

1. Excel ni ishga tushiring va yangi ish kitobi ochilganligini tekshiring. So‟ngra menyudan 

Servis>Makros>Nachat zapis 

(Tools>Macro>Record New Macro) ni tanlang. 

 

2. Paydo bo‟lgan dialog oynasida makros nomini yozing, masalan, “Ochiq makros”. 

“Soxranit v” (Store Macro in) ro‟yxatida “Eta kniga” (“This Workbook”) satri tanlangan-

ligini tekshirib ko‟ring. OK ni bosing. 

VBA da dasturlashni boshlashning eng qulay yo‟li makros yozishdir, chunki makros sizning 

o‟rniga Visual Basic kodi o‟zi yozadi. 

 

3. Makrorekorder oynasi paydo bo‟lganligiga ehtibor qiling. Bu oyna aktiv holatda bo‟lsa, 

sizning barcha harakatingiz yoziladi. Endi menyusidan Excel Faile>Open (Fayl>otkrqt) ni 

tanlang va hoxi-shingiz bo‟yicha istalgan ishchi kitobni oching. Siz tanlagan kitob 

ochilganda “Ostanovit zapis” (Stop Recordihg) tugmasini bosing. 
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4. Siz makros ishini osonlik bilan tekshirib ko‟rishingiz mumkin. Ochgan ishchi kitobingizni 

yoping. Servis > Makros > Makrosq  

(Tools > Macro > Macros) menyusiga kiring “Makros otkrqt” nomini tanlang va “Vqpolnit” 

(Run) tugmasini bosing. Ishchi kitob yana boshqatdan ochiladi. 

Makros yozish jarayonida makrosning qaerda saqlanayotganligiga etibor bering. Makros 

ishga tushishi uchun makros yozilgan kitob ishga tushirilgan bo‟lishi zarur. Makrosni 

istalgan vaqtda ishga tushirish uchun esa uni “Lichnaya kniga makrosov” (Personal Macro 

Work book). Makroslar shaxsiy kitobida saqlash lozim. 

 

Makrosning tuzilmasi 

 

1. O‟zingiz yaratgan makrosni ko‟rish uchun, makros yozilgan kitobning ochiqligini 

tekshiring. So‟ngra makroslar ro‟yxatni ochish uchun Servis>Makros> Makrosq (Tools> 

Macro>Macros)ni tanlang. Makros tanlang va uni o‟zgartirish uchun “Izmenit” (Edit) 

tugmasini bosing. 

2. Visual Basic endi ochiq holda, uning oynasida esa sizning “Makros ochiq” nomli 

makrosingiz turibdi. 

U ikkita satrli kodga ega: 

ChDir “C:/mydata”  

Satri sizning ishchi kitobingiz joylashgan katalogni joriy katolog deb elon qiladi.  

WorkBooks. Open FileName:= “C:/mydata/myfile.xls” satri esa faylni ochadi. 

WorkBooks-bu Exsel ob`ektlarining kolleko‟iyasi bo‟lib, Excelda ochilgan barcha kitoblarni 

ko‟rsatadi. 

Open-WorkBooksning uslubi bo‟lib, u Excelga ko‟rsatilgan ishchi kitobni ochishni 

buyuradi. 
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FileName – bu nomlangan argument bo‟lib unga“:=” operatsiyasi yordamida berilishi, yahni 

qiymat, faylning to‟liq nomi va uning joylashgan joyi ko‟rsatilishi mumkin.  

Excel ob`ektlari nomlari haqida to‟liq ma`lumot olish uchun Excelda Visual Basic 

ma`lumotnomasidan foydalaning. 

 

3. Siz makros kodini o‟zgartirishingiz yoki yangi yo‟riqnomalar yozib, makrosni 

kengaytirishingiz mumkin. 

Masalan, makrosga quyidagi kodni yozsangiz, Excel birinchi uyaga bugungi sanani yozadi: 

Active SHeet. Cells (1,1). Value = Str$ (Now) 

Boshqa ishchi kitobni ochish uchun kodni osonlikcha o‟zgartirishingiz mumkin. Kodni bu 

tarzda, yani qo‟lda tahrir qolish imkoni bilan yozish katta imkoniyatlarga ega. 

 

Topshiriq № 3 

1. Yangi makros yozing va uning operatorlarini o‟zgartirib, kiritilgan har bir operator 

haqida ma`lumot bering. 

2. Makrosdagi buyruqlar orqali yacheyka, yacheykalar guruhi, sahifa va kitobga 

murojaat qiling. 

 

4 - MARUZA 

Makrosni ishga tushirishning uchta usuli 

Makros yaratilgandan so‟ng tabiiyki, savol tug‟iladi, uni qay tarzda ishga tushiriladi? 

Makrosni ishga tushirishning bir nechta usuli bor. Oldingi bo‟limda makrosni menyudan 

Servis> Makros> Makrosq (Tools> Macro>Macros) satrni tanlab ishga tushirishni 

ko‟rdingiz. Quyida makrosni ishga tushirishning yana uchta usulini keltiramiz. 
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Bu bo‟limda asosan Excel haqida gapirilsa ham Officening boshqa dasturlarida ham shu 

bo‟limdagi maslahatlardan foydalanish mumkin. 

 

Makrosni klavishlar birikmasi yordamida ishga tushiring 

1. Makroslar ro‟yxatini oching va “Parametrq” (Options) tugmasini bosing. “Sochetanie 

klavish” (SHort Key) oynasiga istalgan belgi, masalan “O”ni kiriting. OK tugmasini 

bosing va makroslar ro‟yxatini yoping. Endi Ctrl+SHift+O klavishlar g birikmasi 

makrosni bu ishga tushiradi. 

 

Klavishlar birikmasini shu erda yozing 

2. Makrosni ishchi varaqdan ishga tushirish 

Makrosni ishga tushirish uchun tugmani bevosita ishchi varag‟iga joylashtirish mumkin. 

1. Excelning “Vid” View menyusidan “Paneli instrumentov” (Toolbars) Cfnhbyb njgkfyu df 

,e thlf“Elementq upravleniya” (Boshqarish elementlari) (Control Tool va satri 

belgilanganligiga ishonch hosil qiling. 

 

2. Ishchi varaqqa tugmani joylashtiring va tugma chegaralarini kengaytiring. 

3. Sichqoncha o‟ng tugmasini bosing va qalqib chiqqan menyudan “Isxodnqy tekst” (View 

code) satrini tanlab, tugma Click hodisasi uchun kodni oching. 

Quyidagi satrni yozing: 

(Call Makros Otkrыt, yoki sizning makrosingiz nomi). 
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Makros ochish (Yoki makrosingiz nomi) kod muharririni yoping, endi siz joylashtirgan 

tugma makrosni ishga tushiradi. 

Excelda dasturlash holatidan chiqish uchun uning ishchi varag‟ida mana shu tugmani bosing. 

 

3. Makrosni menyudan ishga tushirish 

Siz o‟zingiz yaratgan makros uchun menyuda quyidagiga alohida satr yaratishingiz mumkin: 

 

1. Excel ning “Servis” (Tools) menyusidan “Nastroyka” (Customize) satrini tanlang. So‟ngra 

“Komandы” (Command) ni belgilang. Chap tomondagi aylantiriluvchi ro‟yxatdan 

“Makrosы” (Macros) ni tanlang. 

2. Endi oynaning o‟ng tomonida “Nastraivaemaya komanda menyu” 

(Sustom Menu Item)ni tanlang va sichqoncha chap tugmasini bosilgan holda ushlab turing. 

3. Menyuning “Servis” (Tools) satrini Makros menyusiga tortib o‟tkazing, so‟ngra paydo 

bo‟lgan qora chiziqni kuzatgan holda bu satrni pastga tushiring, sichqoncha tugmasini qo‟yib 

yuborsangiz menyuning yangi satri qora chiziq turgan maydonga joylashtiriladi. 
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Agar siz o‟zingiz yaratgan bir nechta makros bilan ishlasangiz, u holda yuqori darajadagi 

yangi asboblar chizg‟ichi yoki yangi menyu hosil qilishingiz mumkin. Bu ishlarni amalga 

oshirish uchun Excel ma`lumotnomasidan foydalaning. 

  

 

2. Menyuning yangi satriga o‟ng bosing. “Imya” (“Name”) oynasida menyu satri nomini 

yozing. Keyin “Naznachit makros” (Assign Macro) satrini bosing va o‟z 

makrosingizni tanlang. Yuqoridagi qadamlarni amalga oshirgach “Nastroyka” 

(Cuztomize) dialog oynasini yoping. 

 

Topshiriq № 4 

1. Yangi makroslar yarating va ularga murojaatning uchusulini ko‟rsating. 

2. Yangi makros yarating va oldingi makrosni chaqiring. 
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5 - MARUZA 

Avtomatik tarzda bajariluvchi makroslar 

Birorta xujjat ochilganda yoki malum bir harakatga javob tariqasida bajarilishi mumkin 

bo‟lgan makros yaratishingiz mumkin. Qo‟yida ana shunday makros yaratishga misol 

keltirilgan. 

Excel ishchi kitobini ishga tushirishga javob tariqasida bajariluvchi makros. 

 

1. Excel ishchi kitoblaridan birortasini oching yoki yangisini yarating. Visual Basic 

muharririni oching. Agar loyiha oynasi ochilmagan bo‟lsa “Vid” (View) menyusidan “Okno 

proekta” (Project Explorer) satrini tanlang. Loyiha oynasida This Workbook satrini toping 

va o‟ng bosing. Qalqib chiquvchi menyudan “Programma” (View code) satrini tanlang. 

2. Chap ro‟yxatdan Workbook satrini tanlang. O‟ng tomondagi ro‟yxatda Open (Otkrqt) 

hodisasi ko‟rsatilganligini tekshirib ko‟ring, keyin esa istalgan kodni, misol uchun, 

tashakkur ehlon qiluvchi panel kodini yozishingiz mumkin. 

Private SuB WorkBook – Open  

MsgBook (“Ushbu kitobni ochganingiz uchun tashakur”) 

End SuB 
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Word hujjatlari ham Open hodisasiga ega. 

Ro‟yxatda ko‟rsatilgan boshqa ko‟pgina hodisalar uchun ham kod yozishingiz mumkin. 

 

3. Visual Basic muharririni yoping va ishchi kitobni saqlang. So‟ngra uni oching, kitob 

ochilishi bilan kod ishga tushadi va tashakkur elon qilingan panel paydo bo‟ladi. Bundan 

tashqari, vaqtni, sanani ko‟rsatuvchi yoki global o‟zgaruvchilarning boshlang‟ich 

qiymatlarini ko‟rsatuvchi kod yozish mumkin. 

Siz makrosga ega xujjatni ochayotganingizda ogohlantiruvchi panel paydo bo‟ladi. Bu 

dialog oynasini makroviruslardan himoyalanishga imkon beradi. Agar siz ishchi kitobni va 

makrosni o‟zingiz yaratgan bo‟lsangiz yoki ular olishgan manbaga ishonchimiz komil bo‟lsa 

bu ogohlantiruvchi dialog oynasini bekor qilishingiz mumkin. 

Loyiha oynasi haqida batafsilroq 

Visual Basic For Application ning loyihalar oynasi (Project Explorer) siz yaratgan shakl va 

kodlar qaerda saqlanayotganligini ko‟rsatadi hamda ular tahrir qilish uchun ochish imkonini 

beradi. Office matnidagi Visual Basic kodi va shakllari xujjatlarda yoki andazalarda 

saqlanadi. Yani Office dasturlarida yaratilgan hujjatlarni VBA mahsuli deb atash mumkin. 

Siz Office hujjatlarini yoki andazalarini saqlash jarayonida ulardan Visual Basic 

elementlarini ham saqlaysiz. 

Loyihalar oynasining qay tarzda ishlashini bilib olish uchun uni amalda sinab ko‟rgan 

mahqul. 

Ekcel da loyiha oynasi. 

“Ob`ekt” (Object) tugmasini tanlangan ob`ektni ko‟rish uchun bosing  
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Tanlangan ob`ekt kodini ochish uchun “Programma” (View Code) tugmasini bosing. 

Tanlangan ishchi varoq yoki kitobni ikki marta bosing yoki Open (ochish) yoki Change 

(Almashti-rish) hodisalariga javob tariqasida bajariluvchi kod yozish uchun “Programma” 

(ViewCode) tugmani bosing. 

 

 

Papkalar shaklida tashkil qilingan loyihalarni ko‟rish uchun “Papka” (Folder) tugmasini 

bosing.  

Excelda ochiladigan har bir hujjat (dokument) loyiha hisoblanadi. Makroslar shaxsiy kitobi 

“personal Macro Workbook” ham shu erda ko‟rsatilgan.  

Modullar funktsiyalar, ketma-ketliklar yoki global o‟zgaruvchilar qiymatlari kodiga ega 

bo‟lishi mumkin.  

Word da loyihalar oynasi 

Word loyiha oynasi Excel loyiha oynasiga o‟xshashdir. Lekin o‟ziga xos malum farqlari 

ham bor. Masalan, Word loyihasida Normal andazasi bor. Undan tashqari, bu erda murojaat 

hisobi boshqa usulda tashkil etilgan. 

Normal andazasi kodi va shaklini har qanday hujjatga qo‟llash mumkin. 
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VBA ga murojaatlar Visual Basic avtonom versiyasidagi kabi ishlaydi. 

 

Topshiriq № 5 

1. Yaratgan makroslaringiz va formalaringizni qattiq diskdagi fayllarda saqlang. 

2. Qattiq diskda saqlangan makroslarni loihaga yuklang va yangi modullar qo‟shing. 

 

6 - MARUZA 

VBA da uyalar qiymatlarini yozish 

Excel da Visual Basic bilan ishlash jarayonida ko‟pincha yacheykalarga qiymat 

berishingizga to‟g‟ri keladi. Quyida keltirilgan misolda ishchi kitobga qiymat va formula 

yozish tartibi keltirilgan. 

 

1 .Yangi kitob yarating va Visual Basic muharririni oching. “Vid” (View) menyusidan 

“Okno proekta” (Project Explorer) satrini tanlang. Loyihani sichqoncha o‟ng tugmasi 

yordamida bosing va qalqib chiquvchi menyudan Vstavit>Modul (Insert>Module) satrini 

tanlang. Bu modul loyiha oynasida modul 1 (Module 1) nomi bilan chiqadi. 

2. Kod muharriri avtomat tarzda ochiladi. Siz yangi tartib (proo‟edura) yaratishingiz zarur. 

Buning uchun siz Insert menyusida Procedure (Protsedura) satrini tanlashingiz mumkin edi, 
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lekin eng qulay yo‟li Sub WriteCells ni muharrrirga yozishdir. Enter tugmasini bossangiz, 

VBA End Sub operatorini avtomatik tarzda yozib qo‟yadi. Hozirgina siz WriteCells nomi 

bilan bo‟sh makros yaratdingiz. Uning kodini yozamiz: 

With Active SHeet 

.Cells (1,1) . Value = “Yanv-Mar” 

.Cells (1,2) . Value = 123 

.Cells (2,1) . Value = “Apr-Iyun” 

.Cells (2,2) . Value = 456 

.Cells (4,1) . Value = “Jami” 

.Cells (4,2) . Value = “ = Sum (B1...B2) 

End With 

 

Nomlangan (diapazon) – VBA kodida yacheykalarni belgilashning qulay usulidir. Misol 

uchun, agar sizni “ Totalval ” diapazon qiziqtirsa, kodda bu oraliqqa Range (“Totalval”) 

nomli murojaatlarini berish mumkin. 

Excel da formula yozishda, formulani oddiy matndan farqlash uchun “+” dan foydalanish 

zarur. 

 

3. Makros ishga tushirilgach, avtomatik tarzda Excel da kod ichiga yozilgan qiymatlar paydo 

bo‟ladi.  
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Word makrosidan matn kiritish 

Word makrosidan matn kiritish- bu, Word bilan ishlash jarayonida hujjatga makros 

yordamida matn qo‟yishdir. Bu bo‟limda Word makrosi yordamida matn kiritishga oid 

sodda misol keltirilgan. 

 

1. Word ning yangi hujjatini yarating, Vstavit(Insert) menyusidan (xat cho‟p) (Bookmark) 

satrini tanlang. Zakladkaga nom bering, masalan, “Mening xatcho‟pim”. Word da 

xatcho‟plardan foydalanish, Excel da nomlangan diapazon lardan foydalanishga o‟xshashdir. 

Visual Basic bilan ishlashda ikkalasi ham foydalidir. 

2. Visual Basic muharririni ochib, loyiha oynasi ochilgan-ochilmaganligini yana bir marta 

tekshirib ko‟ring. Siz uni “Vid” menyusidan toplashingiz mumkin. Sichqoncha o‟ng 

tugmasini xujjat loyiha ustida yozingbosing va menyudan Vstavit>Modul (Insert>Module) 

satrini tanlang. Kod muharririni ochib,: Sub „matn kiriting. 

End Sub ni muharrirning o‟zi yozadi. 

 

Endi quyidagi kodni yozing: 

With Activedocument 

If.Bookmarks.Exists(“Menimatnim”) Then bookmarks (“Menimatnim”).Select 
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End If 

End With 

Selection. Insert After(“Bu matn makrosdan orqali yozilgan”) 

Selection. Collapse (WdCollapseEnd) 

 

3. Makrosni ishga tushiring va Word hujjatini tekshirib ko‟ring. Matn avtomatik kiritilgan 

edi. 

Siz makrosni yoki Visual Basic muharriridan, yoki bevosita Word hujjatidan ishga 

tushirishingiz mumkin, buning uchun Word ning Servis>Makrossq (Tools>Macros) 

menyusidan foydalanish zarur. 

Topshiriq №6 

1. Word da yangi makros yarating. Uni maxsus tugmalar ketma-ketligiga ulang. 

2. Word va Excel makroslaridagi buyruqlar farqlarini sanab o‟ting. 

 

7 - MARUZA 

Wordda dialog oynasi yaratish 

Visual Basic “Vizual” degan nomni oqlaydi. chunki siz shakllardan va dialog oynalaridan 

foydalanuvchi dastur yaratishingiz mumkin. Mazkur bo‟lim misoli sodda bo‟lishiga 

qaramasdan, VBA imkoniyatlaridan foydalanish bu misollarda cheklovlarsiz namoyish 

qilingan. Siz shaklda ActiveX elementlaridan foydalanishingiz mumkin, bqlar hujjatga 

diagrammalar, multimedia va animao‟iyalarni kiritish imkonini beradi. 

Dialog oynasini yaratish va undan foydalanish 

Mazkur loyihadan maqsad, makrosni tuzish bo‟lib, u ikkita andazadan biri asosida yangi 

hujjat yaratadi. 
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1. Word da yangi hujjat yarating va Visual Basic muharririni oching. Yangi hujjat bilan 

bog‟liq loyiha oynasiga o‟ng bosing va menyudan Insert>UserForm ni tanlang.  

Javob tariqasida yangi shakl ochiladi va asboblar paneli paydo bo‟ladi. 

Agar siz makrosdan muntazam foydalansangiz, uni hujjatda emas, balki Normal.dot 

andozasida saqlagan mahqul. ,Eksperiment tariqasida yaratilgan makroslarni, esa hujjat 

(dokument)ning o‟zida saqlash maqsadga muvofiq. 

 

2. SHaklni Visual Basic ning avtonom versiyasida ishlaydigan qilib yarating. Rasmda 

ko‟rsatilgan tarzda shaklga qayta ulagich tugma va ikkita sarlavhali tugma joylashtiring. 

Yuqoridagi qayta ulagich tugmaning Value xususiyatini True holatiga o‟tkazing. “OK” 

tugmachasi uchun Default, “Cancel” tugmasi uchun esa yuqoridagi ko‟rsatkichini True 

holatiga o‟tkazing.  

Enter yoki Escape klavishlari bosilganda dialogning qanday ishlashini hodisani Default va 

Cancel tugmalari belgilaydi. 

3. SHakl kod muharirini ochish uchun ikki marta bosing va chap tomondagi ro‟yxatdan 

“Umumiy soha” (General) satrini tanlang. O‟ng tomondagi ro‟yxatdan “Tavsif” 

(Declarations) satrini tanlang. Kod muharririni ochib quyidagi kodni yozing: 

Public DocOption As Integer 
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Bu o‟zgaruvchi, foydalanuvchi tomonidan dialogda tanlash natijasi qiymatini saqlaydi. 

 

4. “OK” tugmasining Click (Bosish) hodisasi uchun kod muharririni oching, quyidagi kodni 

yozing: 

If Option Button 1. Value = True Then  

User Form 1. DocOption = 1 

Elself OptionButton 2. Value = True Then 

UserForm 1. DocOption = 2 

Else 

UserForm 1. DocOption = 0 

End If 

Me. Hide 

“Otmena” tugmachasini ikki marta bosing va yagona satrni kiriting: 

Me. Hide. 

5. So‟ngra loyihaga modul qo‟ying va agar bor bo‟lsa, uni oching. 

Kod muharririni oching va yozing: 

SuB DosStart () 

UserFopm 1. SHow 

Select, Case UserForm 2. Doc Option 

Case1 standart, dokument 

Document Add Normal. DOT foydalanadi 

Case 2 Dokument pismo 

Documents. Add Template:= “C:\Programm Files-\Microsoft Office\SHablonq \ pisma i 

faksq\ Standartnoe pismo. dot\ 

End Select 

End SuB 

Sistemangizda Wordning o‟rnatilgan joyiga qarab, andaza yo‟lini va nomini to‟g‟ri 

ko‟rsatishingiz kerak. 
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6. Visual Basic ni yoping va Wordga qayting. Keyin DocStart makrosini ishga tushiring, u 

yangi tanlangan andaza asosida hujjat yaratadi.  

 

 

Topshiriq №7 

1. Forma va boshqarish ob`ektlaridan foydalanib dastur yarating. 

2. Kalkulyator dasturini yarating. 

 

8 - MARUZA 

Office-Yordamchini dasturlash 

Skrepka (Qistirgich) va Barbos nomli Office yordamchilar bahzi foydalanuvchilarga 

yoqmasligi mumkin. Agar sizga Office Yordamchi (Office Assistant) yoqsa, uni Visual 

Basic kodiga boshqarishingiz mumkin. Bu bo‟limda keltirilgan misol maxsus dialog oynasi 

o‟rniga Office yordamchisidan foydalanishni o‟rgatadi. 

Yordamchi – bu dialog oynalari hosil qilishning oson va tezkor usulidir, lekin u maxsus 

shakl kabi unchalik moslashuvchan emas. 

1. Docstart makrosi yozilgan hujjatga qayting va Visual Basic ni ishga tushiring. Dosstart ni 

saqlovchi molni ikki katta bosing va kodga quyidagi o‟zgartirishlarni kiriting: 

Sub DocStart () 

Dim OptionChosen As Integer 

With Assistant 

. Vilible = True 

. Animation = 

mso Animation GetAttention Minor 
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With.NewBalloon 

.Heading= “ Yangi xujjat yaratish” 

.Text = “Hujjat turini tanlang” 

.Labels(1). Text = “Umumiy hujjat” 

.Labels(1). Text = “Xat” 

. Mode =msoModeModal 

Option Chosen=. SHow 

End With 

End With 

.... Doc Start ning eski davomi davomi. 

Office- Yordamchini uning “Parametrы” (Options) dialog oynasidan tanlanadi. 

 

3. Hujjatga qayting va Docstartni bajaring. Bu gal Yordamchi paydo bo‟ladi. Makros esa 

oldingidek ishlayveradi. 

Yordamchi haqida batafsilroq malumot 

Offise - Yordamchini dasturlash Visual Basicning Office bilan ishlashiga yaxshi misol 

bo‟ladi. O‟zingizning Yordamchingizni yaratish uchun juda ko‟p vaqt va katta tajriba kerak 

bo‟ladi. Lekin Offisega kiritilgan Yordamchini asos qilib olib uning barcha qulayliklaridan 

foydalanishingiz mumkin. 

Offise - Yordamchi ichkaridan ActiveX yordamida boshqariladi. Visual Basic ning u bilan 

ishlashiga imkoniyat yaratish uchun “Ssqlki” (References) dialogida Microsoft Offise 8.0 

Objest LiBrary satrini belgilash zarur. Agar siz Visual Basicni Worddan ishlatsangiz, bu satr 

belgilangan bo‟ladi. 

Bu satrni belgilab qo‟ying, u Visual Basic uchun Offise –Yordamchini ishlatish imkonini 

beradi. 
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Offise - yordamchini dasturlashni o‟rganish oson ishdir, uni o‟rgangach, siz Offise ni 

dasturlashni yanada chuqurroq o‟rganishingiz mumkin. 

Murojaat o‟rnatilishi bilan Offise – Yordamchi Assistant ning xususiyatlari va uslublarini 

Visual Basic ning tashkil etuvchisi kabi ishlatish mumkin. Asosiy qiynchilik yordamchi 

xususiyatlar va uslublar qanday ishni bajarishini bilib olishdir. Buning uchun kod muharriri 

ichida nuqta yozishingiz bilan mavjud harakatlar ro‟yxati paydo bo‟ladi. Boshqa axborot 

manbai o‟rnatilgan ma`lumotnomadir. O‟z kodingizda Assistant so‟zini tanlang va 

ma`lumotnomaning kerakli bo‟limini ochish uchun F1 klavishni bosing. 

Topshiriq №8 

1. Yordamchi imkoniyatlaridan foydalanuvchi dastur yarating. 

2. Yordamchi xususiyatlarini o‟zgartirish imkonini beruvchi dastur yarating. 
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9 - MARUZA 

Qalqib chiquvchi malumotnoma 

  

O‟rnatilgan ma`lumotnoma 

  

1. Bu misolni bajarish uchun Excelda yangi kitob yarating, unga Savdo (savdo) deb nom 

bering, unda “Savdo hajmi” nomi bilan yacheyka tanlang (Total Sales). Bu yacheykaga katta 

miqdor (pul birligi) mablag‟ joylashtiring kitobni saqlang va Excel ni yoping. 

2. Yangi Word hujjatini yarating va “Savdo hajmi” yacheykasiga murojat qiluvchi 

(xatcho‟p) zakladka matnini yozing. Bu erda yacheyka nomini aynan Exceldagidek yozish 

shart emas, bu ish faqat qulaylik uchun qilingan. 

3. GetSales Total (Savdo hajmini olish) makrosini yaratish uchun 

Cervis>Makros>Makrosq> Sozdat (Tools>Macro>Macros>Create) -Cervis>Makros> 

Makroslar> Yaratish)ni tanlang. 
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4. Makros kodini yozishdan oldin Visual Basic Object Library yo‟llanmasi Microsoft Excel 

8.0 ga murojat qilayotganligini tekshirib ko‟ring. Visual Basic menyusidan Servis>Ssыlki 

(Tools>References) ni tanlang. 

Kod yozish jarayonida Sales. XLS faylining joyini to‟g‟ri ko‟rsating. 

Excelni Worddan boshqarish 

Siz offise dasturidan bajariladan makrosni muvoffaqiyat bilan yaratganingizdan so‟ng, endi, 

navbatdagi qadamingiz bir dasturni boshqa dasturdan boshqarishni organish bo‟ladi. Bunga 

misol qilib Word hujjatiga Excel jadvalidan axborotni kiritish talab qilinadigan vaziyatni 

kqrish mumkin. 

5. Endi siz Excel ni boshqaruvchi kodni yozishingiz mumkin. Quyida keltiriladigan – Create 

Object- kodi Excelni fon rejimida ishga tushiradi, o‟z navbatida siz Excelda “Ishchi kitobni 

ochish” yo‟riqnomasini bajarish imkoniga ega bo‟lasiz. 

SuB GetSales Total () 

Dim XL As Excel. Application 

Dim s Amount As String 

Set xL= Create Object (“Excel. Application”) 

XL.Workbooks. Open (“C:\MYDATA\Sules.xls”) 

sAmount= Str (xl. Activesheet.Ronde (“Savdo hajmi”) Select 

Selection.Insert After (“$” + Trim$ (sAmount)) 

Set xl=Nothing 

End SuB 

6. Wordga qayting va makrosni ishga tushiring. Agar kod yozishda xatolikka yo‟l 

qo‟ymagan bo‟lsangiz hujjatingizda savdo hajmi paydo bo‟ladi. 
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Visual Basicdan Office ni ishlatish 

Visual Basic avtonom versiyasida siz Office dasturlarining biridan boshqasini (Worddan 

Excel ni) boshqaribgina qolmasdan, balki istalgan Office elementini boshqarish imkoniga 

egasiz. Quyida keltirilgan misolda Word VBA uchun yozilgan kodni Visual Basic ning 

avtonom versiyasi uchun qo‟llaymiz. 

Hozirgi kunda nafaqat Office dasturlarigina emas, balki bu sistemani qo‟llab quvvatlaydigan 

boshqa dasturlarni ham avtomatlashtirish mumkin. 

 

1. Visual Basic to‟liq versiyasini ishga tushiring va yangi loyiha tuzing. SHaklga rasmda 

ko‟rsatilganidek, buyruq tugmasi va yozuv joylashtiring. 
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2 .Project (loyiha) menyusini Reference (Yo‟llanma) satrida Microsoft Excel 8.0 

ObjectLibrary ga yo‟llanma ko‟rsatilgan-ligini tekshirib ko‟ring. Keyin dialogni yoping. 

3. Tugmachaning Click (Bosish) hodisasi uchun quyidagi kodni yozing: 

Dim Xl As. Excel. Application 

Dim sAmount As String 

Set xl.Create Object (“Excel. Application”) 

Xl. Workbooks. Open (“C:\MYDATA\Sales.xls”) 

sAmount= str (xl.ActiveSHeet. Range (Savdo hajmi).Value) 

Label1. Caption= “Savdo hajmi: “$” “$” Trim & (s Amount) 

Set xl = Nothing 

Bunday kodni ishlatishdan oldin, sistemangizni imkoniyatlrini tekshirib ko‟rishingiz zarur. 

Chunki Excelni fon rejimida ishga tushirish sistemaning ish unumini pasaytiradi.. 

Boshlang‟ich darajadagi sistemalarda esa, umuman ishlamasligi ham mumkin. 

 

4. Dasturni ishga tushiring va tugmani bosing. Visual Basic Sales.XLS kitobidagi qiymatni 

yozuv-boshqaruv elementiga chiqaradi. 

Dastur bir nechta ob`ektlarga murojat qilgan holatda ishlaganda avvaliga adashishingiz 

mumkin. Lekin tajriba ortishi bilan bu muammo echiladi. Agar shunday tushunmovchiliklar 

yuzaga kelishining oldini olmoqchi bo‟lsangiz, Visible xususiyatini True holatiga o‟tkazib 

qo‟ying. 

 

Topshiriq № 9 

1. Word makrosi yordamida Excel dasturini ishga tushiring. 

2. Word makrosi yordamida Excel dasturidan ma`lumotlarni formaga oling. 
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10 - MARUZA 

Visual Basic dan Office ni ishlatish haqida maslahatlar  

Agar siz boshqa dasturlarni boshqaruvchi kodga nazar solsangiz unda to‟rtta asosiy 

bosqichni kuzatishingiz mumkin: 

1. Dim kaliti yordamida o‟zgaruvchini ehlon qilish. Doimo ehlon qilishda aniq ob`ekt, 

yani umumiy ob`ekt “AS Object” o‟rniga aynan “As Excel.Application”ni qo‟llang, 

bu o‟z navbatida dastur ish unumini oshiradi.  

2. Ob`ekt o‟zgaruvchisini to‟g‟ri o‟rnating, yahni uning nusxasiga ham murojat qiling. 

Buni amalga oshirish uchun Visual Basic ikkita muqobil funktsiyadan foydalanadi. 

Create Object funktsiyasi ishlab turgan ob`ektga murojat qiladi. Get Object 

funktsiyasi fayl nomini ko‟rsatkich sifatida ham olish imkoniyatiga ega, bu esa o‟z 

navbatida vaqtni tejash imkonini beradi.  

3. Ob`ektning uslubi va xususiyatlariga murojaat. Bu erda ishning asosiy qismi 

bajariladi.  

4. Ob`ektga Nothing o‟zgaruvchisini berish, bu o‟zgaruvchidan foydalanilsa, ob`ekt 

ishlatilmagan taqdirda uni xotiradan o‟chirish imkoni yaratiladi. Bahzi hollarda bu 

qadamni bajarishga zaruriyat bo‟lmasligi mumkin, lekin undan foydalanish 

dasturlashda yaxshi uslub hisoblanadi.  

 

Topshiriq № 10 

1. Makroslar yordamida Word va Excel dasturlariga murojaat qiling. 

2. Makroslar yordamida Word va Excel dasturlari aloqasini ta`minlang. 
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