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«Биз тескор техникавий тараққиёт, 

шиддат билан ривожланаётган ва 

мунтазам янгиланаётган замонавий 

юқори технологиялар, ахборот –

компьютер тизимлари асрида 

яшаётганимизни унутмаслигимиз 

керак». 

ИСЛОМ КАРИМОВ 

 

Ҳозирги кунда ахборот технологияларнинг янгиланиши, тармоқ 

технологияларини ривожланиши барча соҳалар сингари ўқитиш соҳасида 

ҳам катта ўзгаришларга олиб келмоқда. Маълумотларни узатиш тизими 

асосида ўқитишни ташкил этишга турли ёндашувлар мавжуд. Турли 

дастурий воситалар, услубият ва нормативлар ҳозирги кунда ушбу тизимнинг 

тез суръатларда ривожланишини таъминлаяпти.  

Ҳозирги кунда юқори самарага эга бўлган ўқитиш технологияларини 

ташкил этиш борасида фаол изланишлар олиб борилмоқда. Олиб борилаётган 

тадқиқотлар натижаси сифатидаги йўналишлардан самаралилари сифатида 

қуйидагиларни келтиришимиз мумкин: 

 Ўқувчининг индивидуал ҳусусиятларига ва билим олиш 

жараёнида ўқув материалини ўзлаштиришида вужудга 

келадиган ҳусусиятлари бўйича ўқувчи моделини автоматик 

тарзда қурадиган, ўқувчилар гуруҳининг умумлашган 

ҳусусиятлари бўйича ўқувчи  гуруҳ моделини қурувчи, ўқитиш 

муҳити ҳамда коммуникацион технологияларни алоҳида ўқувчи 

ёки ўқувчилар гуруҳи индувидуал ҳусусиятига созловчи 

интеллектуал ва дастурий агент (мультиагент)лар технологияси; 

 Интеллуктуал агент, билимлар тармоғи, тимсолларни аниқлаш 

ва нутқни генерациялаш технологиялари ва тамойиллари 

асосида мослашувчан интеллектуал тизимларни қуриш; 

 Ўқитишнинг ажратилган интерактив муҳитини ўйинли ва 

виртуал оламга асосланган ҳолда қайта қурилиши; 

 Web-lecturing технологияси, стримминг видео-аудио 

фрагментлари фаол қўлланилган интерактив ўқитиш ва ўқиш 

муҳитини қуриш; 

 Сўровлар бўйича фойдаланувчини индивидуаллаш-тириш  ва 

мослаштириш (адаптациялаш) имконини берувчи порталлар 

технологияси; 

 Интернетнинг янги технологияларини қамраб олган (XML, 

SMIL, VBnet каби) юқори самарали дастурлаш тилларининг 

ривожланиши; 

 Web саҳифаларнинг турли бўлакли тармоқларини 

бирлаштирувчи семантик Web-технологияси. 

Юқоридаги таъкидланганлардан келиб чиққан ҳолда янги 

технологияларга асосланган электрон дарс ишланмаларини яратиш, 

масофавий ўқитиш тизими, мустақил таълим кўринишлари ва анъанавий 
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кўринишдаги таълим тизимларида ёрдамчи восита сифатида қўлланилиши 

мумкин бўлган интеллектуаллаштирилган ўқитиш тизимлари ва улар 

ёрдамида ўқитиш жараёнини бошқариш шакллантириш ҳозирги замоннинг 

долзарб вазифаси ҳисобланади. Ушбу муаммони ижобий ҳал этилиши эса 

ўқув жараёнини юқори самарадорликка олиб келишини кўрамиз. 

Айни вақтда инсоният билим олиши ва уни такоминлаштириш 

борасида ўз олдига қўядиган мақсад ва вазифаларни янада 

мураккаблаштирмоқда. Инсон билими замон билан ҳамнафас бўлиши ва 

доимо янгиланишга муҳтожлик сезмоқда. Бу муҳтожликни барча 

соҳалардаги ахборот оқимининг тезкор суръатларда ўсиши ва кенг 

қамровлилиги билан изоҳлашимиз мумкин. 

Интернет технология дунё харитасида ягона web байроғи остида очиқ 

ахборот жамиятини вужудга келтирмоқда. Албатта, Ўзбекистон ҳам барча 

давлатлар каби ушбу тўрга чуқур «ўралиб» бормоқда. Бу эса Ўзбекистоннинг 

янги ахборот технологиялари билан қуроллантиришни талаб қилиб қўяди.  

Ўзбекистон Республикасининг «Таълим тўғрисида»ги қонуни ҳамда 

«Кадрлар тайёрлашнинг миллий дастури»да янги информацион 

технологияларини таълим бериш соҳасида қўллаш муҳим вазифа сифатида 

келтирилган. Шу қаторда қаралаётган масалалар қаторида нафақат 

масофавий ўқитиш тизими, балки мустақил ўқитиш, қўшимча ўқитиш 

жараёнларида компьютер воситали ўқитиш тизимларидан фойдаланишни 

ҳам киритишимиз мумкин. 

Бундай тизимларнинг муҳим элементларидан бири бу – ўқувчининг 

интеллектуал салоҳиятини аниқлаб берувчи тест мажмуасини қуриш, 

қолаверса ўқитиш жараёнида зарур бўладиган барча муҳим элементлар 

таснифлаб ўтилган. Бундай тизимларни қуриш борасида ҳозирги кунда турли 

таснифлашлар мавжуд. Уларни умумлаштириш ва оптималлаштириш 

мақсадга мувофиқ. Юқорида кўрсатилган тузилмали тизимларда ўқитувчи 

(тьютор) ҳамда ўқувчи (билим олувчи) ўртасида бевосита муносабатга 

асосига қурилмайди. Бунинг учун тизимнинг ўқувчининг индивидуал 

жиҳатларига мос равишда қуриладиган бошқарув қурилмаси асосида ташкил 

этиш мақсадга мувофиқ бўлади. Замонавий бошқарув тизимларида эса, 

албатта, компьютер ва ахборот-телекоммуникацион шу жумладан, сунъий 

интеллект технологияларига асосланган бўлади. 

Ўқувчи ва компьютер ўртасидаги автоматлаштирилган интерактив 

жараён тарзида қуриш лозим. Тизимнинг бундай қурилиши ўз навбатида бир 

қатор масалаларни қўяди. 

Ҳукуматимиз томонидан таълим соҳасининг ривожига, баркамол 

авлодни юксак-маънавиятли, замонавий билимлар эгаси бўлишига алоҳида 

эътибор қаратилиши таълим тизимини тубдан янгилаб, жаҳон андозаларига 

мос равишда ташкил этишга ундамоқда. 2012 йил февраль ойида Тошкент 

шаҳрида ўтказилган “Юксак билимли ва интеллектуал ривожланган авлодни 

тарбиялаш – мамлакатни барқарор тараққий эттириш ва модернизация 

қилишнинг энг муҳим шарти” мавзусидаги ҳалқаро симпозиумда таълим 

тизимига бўлган эзгу муносабат яққол ўз исботини топганлигини айтиш 

жоиз. Бугунги ахборотнинг глобаллашуви жараёнида таълим тизимини АКТ 

билан уйғунликда олиб бориш самарали натижалар бериши айни ҳақиқат.  
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Қуйида таклиф қилинаётган БМИда юқорида айтилган кўринишдаги 

тизимларни қуришдаги талабдан келиб чиқиб, ўрта махсус таълими тизимида 

ўқитиладиган “Растр графикаси асослари” фанининг “Potoshop дастурида 

ишлаш” мавзуси асосида электрон дарс ишланмаси яратиш       масалаларини 

қараб ўтамиз. 
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1.1. Компьютер графикасининг информацион жамиятдаги аҳамияти, 

роли ва ўрни. 

Компъютер графикаси геометрик жисмлар, шакл ва тамойилларнинг 

математик моделлари ҳамда уларни намойиш этиш усуллари тўғрисидаги 

фан сифатида қаралиши мумкин. Компъютер тасвирларига бўлган қизиқиш 

уларда жуда катта хажмдаги маълумотлар сақланиши билан изоҳланади: 

тасвирларни яққол намойиш этиш имконияти мавжуд бўлиб, уларни тахлил 

этиш учун ахборот технологиялар сохасида махсус билимлар талаб 

қилинмайди. 

Компъютер графикаси мустақил йўналиш сифатида XX асрнинг           

60-йилларида пайдо бўлди ва махсус амалий дастурлар пакети ишлаб 

чиқилди. Ўша пайтда кесмалар ёрдамида чизиш, кўринмас чизиқларни 

ўчириш, мураккаб сатрларни акслантириш усуллари, сояларни 

шакллантириш, ёритилганликни ҳисобга олиш тамойиллари ишлаб чиқилган 

эди. Бу йўналишдаги илк ишлар векторли графикани ривожлантиришга яъни, 

чизиқларни кесмалар орқали чизишга йўналтирилган эди. 70-йиллардан 

бошлаб назарий ва амалий ишларнинг аксарияти фазовий шакл ва 

объектларни ўрганишга қаратилган. Бу йўналиш уч ўлчовли графика (3D) 

номи билан аталади. Уч ўлчовли тасвирлврни моделлаштириш фазонинг ва 

жисмларнинг уч ўлчовлигини, кузатувчи ва ёритиш манбаларини 

жойлашишини ҳисобга олиш талаб этилади. Мураккаб сиртларни 

акслантириш, релефлар ва уларнинг ёритилганлигини моделлаштириш билан 

боғлиқ масалаларнинг пайдо бўлиши уч ўлчовли графикага бўлган эхтиёжни 

янада оширди.  

90-йилларда компьютер графикасининг қўлланиш соҳалари анча 

кенгайди, яъни уни кенг татбиқ қилиш имкониятлари пайдо бўлди. Натижада 

компъютер графикаси фаолияти дастурлаш ва компъютер техникаси билан 

боғлиқ бўлмаган мутахассисларнинг иш воситасига айланди. Компъютер 

графикасининг янги йўналишларидан бири хақиқий тасвирларни 

шакллантиришнинг услуб ва тамойилларини ишлаб чиқишга бағишланган. 

Бу тамойилларга кўра тасвирларни бевосита кузатиш ёки оддий қурилмалар 

ёрдамида рўйхатга олиш имконияти мавжуд бўлиш керак. Шундай 

тасвирларга эхтиёж дизайн, архитектура, реклама ва бошқа сохаларди пайдо 

бўлди. ЭХМлар функсионал имкониятларининг кенгайиши компъютер 

графикасининг ривожланишига асос яратди ва тасвирлар аниматциясини 

таъминловчи тизимлар яратилишига олиб келди. Бундай тизимларнинг 

қуйидаги учта гурухга ажратиш мумкин: 

 Кимё, тиббиёт, астрономия ва бошқа сохалардаги жараёнларни 

кўргазмали намойиш этиш; 

 Харакатдаги холатлар тасаввурини (иммитатция) пайдо этувчи 

тизимлар (Компъютер ўйинлари ва бошқалар); 

 Кино ва телевидения учун тасвирлар тайёрловчи тизимлар. 

Айнан шу йўналишларда компъютер графикасини ривожлантиришда 

асосий қийинчиликларга дуч келинди. Улар учун моделларнинг юқори 

аниқлигидан ташқари ЭХМ имкониятларига хам юқори талаблар қўйилади. 
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 Фан ва техника тараққиёти жамиятимизни информацион жамиятга 

айлантирди. Бу жамиятда фаолият кўрсатувчиларнинг аксарият қисми 

ахборотларни ишлаб чиқариш, сақлаш, қайта ишлаш ва амалга ошириш 

билан банддирлар. Бундай ишларни замонавий компьютерларсиз амалга 

ошириш қийин. Улардаги маълумотларни қайта ишлашни машина графикаси 

ёрдамида амалга ошириш фойдаланувчига катта қулайлик туғдиради. 

 Машина графикаси деганда объектларнинг ҳажм моделларини яратиш, 

сақлаш, ишлов бериш ва ЭҲМлар ёрдамида уларни номоён этиш 

тушунилади. Компьютер графикаси янги информацион технологиялар 

орасида тўхтовсиз ривожланиб бораётган йўналишлардан бири ҳисобланади. 

Бундай ривожланиш техника соҳасида ҳам (графика стансиялари), дастурий 

воситалар соҳасида ҳам кўзга ташланмоқда. Улар видеофилм кадрлари билан 

сифат бўйича таққослашга лойиқ ҳажмли ҳаракатланувчи тасвирларни 

яратишга имкон беради. Бу дастурий маҳсулотлар рекламалар ишлаб 

чиқарувчи воситалар ҳисобланиб, санат ва мультимедия технологияси 

соҳаларида қўлланилади. Бундан ташқари намойиш графикасига, геометрик 

моделлаштиришга, график интерфейсларни лойиҳалашга, анимация илм ва 

фаннинг барча соҳаларида, айниқса иқтисодий кўрсаткичларни таҳлил 

қилишда мувафақиятли қўлланилиши мумкин.  

 Компьютер графикаси дунё фанида янги фундаментал фан ҳисобланиб, 

ўтган асрнинг 60-йилларида пайдо бўлди ва ишлаб чиқаришнинг барча 

соҳасида кадрлар тайёрлаб беришда ўзига хос аҳамиятга эгадир.  

  Махсус дастурлар ёрдамида худди бир вароқ оқ қоғозга қалам ёки 

ручка билан ҳар хил расмларни солиш сингари компьютер экранида 

сичқонча ёрдамида расм чизиш, яъни тасвир ясаш, тузатиш ва уларни 

ҳаракатлантириш имкони яратилди. Бу дастурлар расм чизиш программалари 

ёки график муҳаррирлар ҳисобланиб, улар ёрдамида расмнинг элементлари 

бошқариб борилади. 

 Компьютер графикасининг жуда тез ривожланиб бориши ва ундаги 

техникавий, дастурий воситаларнинг янгиланиб бориши ушбу фанни ҳамиша 

такомиллаштиришни, бу соҳадаги янги йўналишларни тинмай ўрганиб 

боришни тақозо этади. Оҳирги йилларда бу соҳада жуда катта ўзгаришлар 

(силжишлар) юз берди, яъни 16млн. дан ортиқ ранг ва ранг турларни ўзида 

акс эттира оладиган дисплейлар, график ахборотларни кирувчи мослама – 

сканерлар, график иш стансиялари, дастурий воситалар соҳасида эса ҳақиқий 

компьютер дунёсини кашф қила оладиган амалий дастурлар вужудга келди.  
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1.2. Масаланинг қўйилиши ва унинг услубий аҳамияти. 

 

Ўқитиш жараёнида амалий масалаларни бажаришни ташкил этиш 

ҳамда автоматлаштиришда зарур бўладиган: ўқув материалини етказиш, ўқув 

материалидан ҳосил қилинувчи кўникма ва малакаларни баҳоловчи 

интерактивлик тамойилларини ўзида мужассамлаштирувчи электрон дарс 

ишланмани ишлаб чиқиш талаб этилади. 

Ишлаб чиқилиши лозим бўлган электрон дарс ишланма, ундаги 

бошқарув элементларини ҳосил қилиши лозим бўлади. Дастур шундай ишлаб 

чиқилишида ундан фойдаланиш фойдаланувчилар учун мураккаблик касб 

этмаслиги назарда тутилиши керак. Материал шакллантириш жараёнида 

савол-жавоблар блокини киритиш ўринли бўлади. 

Ўқув материалини шакллантиришда график имкониятлар билан 

бойитиш имкони бўлиши керак. Чунки ўқув материали берилишида график 

кўринишлар образлиликни ошириб, билимларни қабул қилишни 

осонлаштиради.  

Қолаверса ишлаб чиқилаётган тузилманинг педагогик жиҳатдан устун 

томонлари кўрсатилиши лозим бўлади. Юқоридаги билимлардан келиб 

чиққан ҳолда КҲКда ўқитиладиган “Растр графикаси асослари” фанининг 

“Potoshop дастурида ишлаш” мавзуси асосида электрон дарс ишланмаси 

яратиш асосий масала сифатида қўйилган.  
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1.3. Фанни ўрганишда ўқувчилар билими ва кўникмаларига 

қўйиладиган талаблар. 

Ҳозирги замон шароитида, юқори малакали кадрларни тайёрлашда, 

ўқитишнинг ҳозирги замон тизимлари ва янги педагогик технологиялари 

асосида амалга оширилиши мақсадга мувофиқдир. Янги педагогик 

технологияларни хислати шундаки, унда қўйилган мақсадларга эришиш 

кафолатини берувчи ўқув жараёни режалаштирилади ва амалга оширилади. 

Дарҳақиқат, машғулотларнинг муваффақиятли ўтишининг 80-фоизи таълим 

жараёнини тўғри лойиҳалаштириш, ташкил этиш ва уни амалга оширишга 

боғлиқдир. Ўқув жараёнларини лойиҳалаштиришда таълим мазмунини, 

таълим  мақсади, кутилаётган натижани тўғри белгилаш, таълим методлари, 

шакллари ва воситаларини тўғри танлаш, талабаларнинг билим, кўникма ва 

малакаларини баҳолашни аниқ мезонларини олдиндан ишлаб чиқиш, 

машғулотга ажратилган вақт ичида уларни тўғри амалга ошириш ва бир-бири 

билан уйғунлашувига эътиборни қаратиш мақсадга мувофиқдир.  

Ҳар қандай фаолият мақсади келажак фаолият натижасининг хаёлдаги 

қиёфасидир. Замонавий ўқитиш технологияси мақсадларга изчил мўлжал   

олишнинг асоси бўлиб, тезда ушбу борада қайтиб келадиган алоқа манбаи 

ҳисобланади. Бунда ўқув мақсадлари имкони борича аниқлаштирилади.  

Замонавий педагогик технология ўзининг педагогика ва бошқа фан     

ютуқлари билан боғлиқ хусусий назариясига эга; у биринчи галда ўқув-

тарбиявий жараённи илмий асосда қуришга йўналтирилган; ўқитишнинг 

ахборотли воситаларидан, дидактик материаллардан, фаол методлардан кенг 

фойдаланишга асосланган ўқитувчи ва талабаларнинг биргаликдаги 

фаолиятига замин яратади. 

Келажакда таълим тараққиётининг ҳаққоний двигатели сифатида 

ўқитувчи фаолиятини янгилашга, таълим-тарбия жараёнини мақбул 

(оптимал) қуришга, талаба ёшларда ҳур фикрлилик, билимга чанқоқлик, 

ватанга содиқлик, инсонпарварлик туйғуларини шакллантиришга ижобий 

таъсир кўрсатади. 
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 Ўрта махсус таълим тизимида ўқитиладиган асослари фани жуда ҳам 

қзиқарли, ҳаётий ва мураккаблиги билан бошқа фанлардан ажралиб туради.  

Юқоридаги фикрлардан келиб чиқиб, “Растр графикаси асослари” фанини 

ўрганиш натижасида АЛ ва КҲК талабалари эгаллайдиган билим ва 

кўникмаларга қўйиладиган талаблар қуйидагилардан иборат: 

 Биринчи навбатда Ахборот технологиялари йўналишидаги 

қолаверса барча КҲКларидаги ўқувчилар давомати яхши бўлиши 

кераклиги; 

 Ҳозирги замонавий дастурлаш тилларидан бирини мукаммал 

билиши; 

 Интернет ва телекоммуникацион технологияларни яхши 

тушуниши; 

 Ҳозирги замонавий ОТни ўрнатиш ва уларнинг иловалари билан 

ишлаш бўйича билимларга эга бўлиши; 

 Ишланган график махсулотларни ҳалқаро ареналарга чиқариш 

учун Web технологияларини ва интернетга маълумотларни 

жойлаштириш билимларига эга бўлиш; 

 Яратилган график ишланмани Давлат рўйхатидан ўтказиш учун 

Ўзбекистон Мулк агентлиги ҳужжатларини расмийлаштириш 

бўйича билимларга эга бўлиши керак; 

Педагогик фаолиятни самарали бўлиши учун ўқувчидан қобилиятнинг 

қуйидаги турлари мавжуд бўлиши ва тарбиялаб етиштирилиши лозим:  
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Юқоридаги қобилиятлар ўқувчида мужассам бўлса ушбу компьютер 

графикаси фанини пухта ўзлаштиради ва етук мутахсис бўлиб чиқади. 
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1.4. Замонавий компьютерлар асосида электрон графиклар қуришнинг 

асосий элементлари ва усулларини ишлаб чиқиш. 

Элактрон графикни тузиш ва уни тушиниш учун графика элементлари 

маъноси ва уларни турли холатларда қўшишни ўрганиш мухим хисобланади. 

Графика ёрдамида ифодаланадиган воқеликларни тўғри тушиниш учун 

ташкил этувчи хамма элементларининг тўплами (шкала, сарловхалар ва 

бошқалар) мавжуд бўлиши лозим. 

Тасвирлашнинг график усули ёки график тил – бу фикрни 

ифодалашнинг фазовий тасвирлаш ёки шартли равишда теккисликда акс 

эттириш усулларининг тўпламидир. График тасвирлашнинг наъмуналари-

геометрик фигуралар, турли хариталар, иқтисодий анализ диаграммалари, 

корхоналарнинг ташкилий-структуравий схемалари ва бошқалар бўлиши 

мумкин. Ақлий тасаввур ва қийматлар тўпламини ифодаловчи қийматларни 

тузиш жараёни графиклаштириш дейилади, унинг натижаси эса-графика 

дейилади. График шартли равишда воқеликни ёки қандайдир жараённи 

тасвирлайди. Графикада қўлланиладиган хамма белгилар ғоялар белгиси 

бўлиб, унинг ўзи яхлит холатда ғоялар тўплпмини ифодалайди. 

 Графика икки элементга бўлиниди: график қиёфа ва экспликация: 

 График қиёфа-чизмалар тўплами бўлиб, улар ўзаро боғланишлари 

билан биргаликда тушунилади.  

Экспликация  - график образ моҳиятини очиб берувчи шартли белгилар 

тўплами. График образ-символ, геометрик шакл кўринишида бўлиши 

мумкин. Шартли белгилар ёрдамида ифодаланган график образ маъноси 

унинг геометрик шаклига боғлиқ эмас, шароитга боғлиқ холда 

тушиниладиган образлар символи образларга таалуқлидир. Шартли белгилар 

қандайдир тушунчалар (символлар) билан пухта боғланган бўлиши, аниқ бир 

сохадаги белгилар тўплами эса махсус символлар билан ифодаланиши 

мумкин. 

 Симврол кўринишидаги икки ўлчовли график образлар графикани 

ташкил этади. Геометрик маънога эга бўлган ва шу шаклда бирор функция 

ёки тенгсизликни ифодаловчи образ геометрик графика дейилади. Масалан, 
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иқтисодий инфлация ўсишини кўрсатувчи эгри чизиқ функция кўринишида 

эмас, балки иқтисодий масала сифатида қизиқарлидир. 

 График образ бутун сон кўринишида ифодаланиши мумкин. Графика  

экспликацияси уч қисмга бўлинади: геометрик, идеографик ва 

хусусийлаштирилган.  

 Идеографик экспликация-шартли белгилар фигурали, чизиқли, 

фонли ва бошқалар (агар бу белгилар стандартлаштирилмаган бўлса) 

маъносини тушунтирилади, бу шартли белгилар графика элементларига аниқ 

бир маъно бағишлайди.  

 Геометрик экспликация-координата ўқлари, шкалалар, 

масштаблар. Улар ёрдамида геометрик қиёфалар геометрик хусусиятларга 

эга бўлади, чунки бу воситалар ёрдамида геометрик юзалар хоссаларидан 

фойдаланилади. 

 Хусусийлаштирилган экплекаця-сарловхалар, тушунтиришлар 

(сонлар ва белгилар) бўлиши мумкин. Тушунтиришлар графиканинг ушбу 

билимлар доирасида қандай жой эгалланганлигини кўрсатади ва тил нуқтаи 

назаридан графиканинг энг зарурий элементи хисобланади, чунки усиз 

графика хеч қандай маъна касб этмайди. 

 Эксплекациядан ташқари графикада қўшимча маънолар хам 

бўлиши мумкин: рақамли маънолар, такрорлаштирувчи қийматлар ва хоказо. 

Графикани қандайдур белгисига кўра гурухлаш эса бутун бир ахборот 

тўплами тўғрисида хукм чиқаришга асос бўлади. Берилган ахборотларни 

хронологик кетма-кетлиги бузилган тақдирда, графиканинг яхлитлик 

таассуроти бузилади. Шундай қилиб графика-бу махсус, фикран яхлит 

хаёлий ғояларнинг икки олчовли (ёки уч ўлчовли) тасвирда ифодаланган 

график қиёфаси ва унинг экспликациясидир. 

 Шартли белгилар график қуришнинг технологик асосини ташкил 

этиши туфайли графикада ишлатиладиган шартли белгиларни кўриб 

чиқамиз. Шартли белгилар-булар шундай чизмаларки, улар берилган сифат 

кўрсаткичларини шартли белгиларда ифодалайди. Бир хил тушунчаларни 

белгида- бир хил шарли белгилардан, турли тушунчаларни белгилашада 
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турли белгилардан фойдаланилади. Натижада, тўлиқ, шу билан бирга 

даражаланган қиёфалар вужудга келади:  

 Фигурали (харфлар, рақамлар, очиқ ва ёпиқ фигуралар схематик ва 

картина кўринишидаги тасвирлар); 

 Чизиқлар (нисбатларни белгилаш, алоқа чизиқлари, геометрик ўлчовларни 

кўрсатиш, йўналиши, кўриниши ва бошқалар); 

 Фон белгилари – майдон ва юзаларини ранг билан ёки штрихлар билан 

(уларнинг хусусиятларини кўрсатиш учун) қоплаш. 

Шартли белгилар чизма юзасида маълум бир тартибда 

жойлаштирилади. Масштабсиз графикларда белгилар эркин монтаж, зонали 

ва жадвал тўри кўринишида берилади. Бу ерда графикани ёрқинлаштирувчи 

восита сифатида рангдан фойдаланилади.  

Зонали тўр – берилган майдонни бўлакларга бўлиб, ҳар бир бўлакка 

махсус қийматни бириктириб қўйиш. Ҳар бир зона горизантал ёки вертикал 

полоса шаклида бўлиб, ўз сарлавҳасига эга бўлади.  

Жадвалли тўр – бу ўзаро кесишувчи зоналарнинг комбинациясидан 

иборат.  

Графика тузишда, яъни унинг технологик асосларини қуришда график 

муҳарририда чиқариладиган чизмалар сонини ҳам назарда тутиш керак. Бу 

ерда қўйиладиган асосий талаб – график муҳаррир томонидан 

кўрсатиладиган комплекснинг энг асосий қисм деталлари ва сояси биринчи 

навбатта, иккинчи навбатта иккинчи даражали деталлар, учинчи навбатта 

ёрдамчи деталлар кўрсатилади ва ҳоказо.  

Графиканинг юкламасини камайтириш қуйидаги усуллар билан амалга 

оширилади:  

1. Кетма – кет деталлаштириш усули (битта график ўрнига, 

дастлабкига ўхшаш графиклар сериясини чизиш); 

2. Уланиш усули (умумий тизимга бирлаштирилган ва бир неча турли 

нуқталардан олинган тасвир); 
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3. Асосий контур усули (умумий котурга эга бўлган графиклар 

сериясини тузиш ва ҳар графикка ўз ҳарактерига мос келувчи 

чизмалар чизиш); 

4. Оддий солиштириш усули (бир – бирига боғлиқ бўлмаган, бироқ бир 

хил қоидалар асосида тузилган графикаларни тўплаш). 
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1.5. Растр графикаси асослари фани ҳақида тушунчалар. 

Shaxsiy kompyuter va uning dasturiy ta'minoti rivojlanishi va 

takomillashtirilishi shunga olib keldiki, kompyuter yordamida oldinlari 

bajarilmagan vazifa va ishlar amalga oshirilishi mumkin bo'ldi. Shular qatoridan 

kompyuter yordamida tasvirlarni yaratish va ularga ishlov berish, ya'ni kompyuter 

grafikasi tushunchasi vujudga keldi. Albatta bundan oldin ham kompyuter 

grafikasi mavjud bo'lgan, lekin u asosan, dasturlash tillari yordamida yaratiladigan 

geometrik figura (shakllar) va tasvirlar bo'lgan. 

  Kompyuter grafikasi grafik interfeysga ega bo'lgan operasion sistemalar va 

dasturlar ishlab chiqarilganidan keyin keng tadbiq etila boshlandi. Kompyuter 

grafikasining yo'nalishlaridan biri bo`lgan rastrli turi bilan tanishib chiqamiz. 

 Rastrli grafikada har qanday tasvir nuqta - piksellardan tashkil topgan bo'ladi. Har 

bir piksel alohida rangga ega bo'ladi. Ular majmuasi esa yaxlit tasvirni tashkil 

etadi. Foydalanuvchi har bir pikselga ishlov berish imkoniga ega bo'ladi, tasvirdagi 

piksellar soni qanchalik ko'p bo'lsa, tasvir shunchalik yuqori sifatli bo'ladi. 

Tasvirdagi piksellar zichligi DPI (Dot Per Inch - dyuymdagi nuqtalar soni) 

deyiladi, ya'ni bir dyuymda (1 dyuym=2,54 sm) nechta nuqta joylashganligini 

belgilaydi. Gazeta va boshqa ro'znomalarda mazkur ko'rsatkich odatda 150 dpi, 

rangli jurnallarda 300 dpi, fotosurat va kompozisiyalarda 600-1200 dpi tashkil 

etadi. Ekranda tasvirlanadigan rasmlar uchun esa 72 dpi sifat ko'rsatkichi yetarli 

hisoblanadi. Shuni ta'kidlash kerakki, mazkur ko'rsatkichni belgilash yoki  

tanlashda rasional yondashuvdan kelib chiqish kerak, chunki har bir nuqta xotirada 

bir bit (agar tasvir oq-qora bo'lsa) joy egallaydi va ular tasvirda ko'payganida 

tasvirning xotirada egallaydigan hajmi ancha katta bo'ladi. Masalan, 300 dpi 

sifatga ega bo'lgan 2"x3,5" (5X9 sm2) o'lchamdagi tasvir taxminan 630 000 bitni 

tashkil etadi. Agar tasvir o'lchamlari katta bo'lsa, hajmi nihoyatda katta  

bo'lishi aniq. Tasvir hajmini katta bo'lishi qattiq diskda ko'proq joy egallashi va 

kompyuter tomonidan sekin qayta ishlanishiga olib keladi. 

  Rastrli kompyuter grafikasida ranglar tizimiga katta e'tibor qaratish kerak. 

Grafikada asosan RGB (Red, Green, Blue) va CMYK (Cyan, Magenta, Yellow, 

blacK) rang tizimlari qo'llaniladi. RGB ang tizimi ekranda tasvirlanadigan rasmlar 
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uchun (masalan veb-sahifada), CMYK rang tizimi asosan chop etiladigan tasvirlar 

uchun foydalaniladi. Rastrli grafika bilan ishlash dasturlari bir nechta vazifalarni 

bajarish imkonini beradi: 

     - Tasvirni import qilish - skaner, raqamli fotoapparatdan kiritish, boshqa 

formatdagi rasmlarni kiritish (bmp, jpg, png, tif, gif, psd, pdf, wmf va boshqalar); 

     - Tasvirni tahrirlash - o'zgartirishlar kiritish, ranglar bilan bo'yash, chizish, 

o'chirish, yorqinlik va aniqlik darajasini o'zgartirish; 

     - Rang tizimini o'zgartirish; 

     - Chop etish; 

     - Boshqa nom va kengaytma bilan saqlash; 

     - Har xil effektlarni qo'llash. 

Hozirgi kunda sodda va murakkab rastrli grafika tahrirlash dasturlari mavjud. 

Sodda grafik muharrirlardan biri - Windows operasion tizimi tarkibiga kiruvchi 

Paint dasturidir. Mazkur dastur oddiy amallarni bajarish imkonini beradi, lekin 

professional darajadagi imkoniyatlardan foydalanish uchun maxsus rastrli grafik 

dasturlaridan foydalanish kerak bo'ladi: Adobe Photoshop, Corel PhotoPaint, 

Macromedia Flash va hokazo. 

  Adobe Photoshop dasturi hozirgi kunda eng mashhur va butun dunyo 

mutaxassislari tomonidan tan olingan dastur hisoblanadi. Buning asosiy sabablari - 

uning boy va keng imkoniyatlari, qulay va oson interfeysi (muloqoti), deyarli 

barcha grafik formatlar va tizimlar bilan ishlashi.  Adobe Photoshop dasturining 

oxirgi versiyalari Adobe Photoshop 7.0, Adobe Photoshop CS, Adobe Photoshop 

CS2 bo'lib, ular deyarli barcha zamonaviy texnologiyalarni o'z tarkibiga olgan. 

Yana shuni takidlash joizki rastrli grafika vositalari bilan tayyorlangan 

tasvirlar komp’yuter dasturlar yordamida kamdan-kam holdagina yaratiladi. 

Ko`pincha ushbu maqsadda rassom tayyorlagan tasvirlar yoki rasmlar skanerlanadi. 

Rastrli tasvirlar bilan ishlashga mo`ljallangan ko`pgina grafik muharrirlar asosan 

tasvirlarga ishlov berishga mo`ljallangan. Internet tizimida ko`proq rastrli tasvirlar 

qo`llanilmoqda. 
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1.6.Электрон дарс ишланмаси яратиш асослари. 

 

Инсон фаолиятининг барча соҳасини компьютер технологиялари 

қамраб олмоқда, яъни ҳозир биз яшаётган давр компьютер асри кириб 

келиши деб қарашимиз мумкин. Бундай дейишимизга сабаб, компьютер 

бизнинг ҳаётимизнинг барча соҳаларини қамраб олмоқда. Шундай экан 

компьютер саводхонлиги иккинчи савод сифатида қаралмоқда. Бу эса ялпи 

компьютерлаштиришни тезлаштирмоқда. 

Компьютер технологиялари таълим жараёнига ҳам жадал суръатлар 

билан кириб келмоқда. Унинг воситасида ўқитувчи ва таълим олувчининг иш 

маҳсулдорлигини, таълим бериш ва мустақил таълим самарадорлигини 

ошириш асосий мақсаддир. Шу қаторда компьютер технологияларини тор ва 

кенг маънода ишлатиш мумкин. Биринчидан, ўқитиш воситаси сифатида 

қўллаш, иккинчидан, компьютерни таълим соҳасида кенг мақсадларда 

қўллаш тушинилади. 

Электрон дарс ишланмалар (ЭДИ) – биринчи навбатда янги ўқув 

материалини намойиш этиш, анъанавий босма чоп этилган қўлланмаларни 

тўлдирувчи, индивидуал ва индивидуаллашган тартибда таълим олишни 

таъминловчи ва олинган билим ҳамда кўникмаларни синовдан ўтказувчи 

компьютерли-информацион (маълумотлар ҳамда билимлар базаси 

кўринишида) дастурий воситасидир. 

ЭДИ лари МЎТ ва мустақил таълим тизимида қўшимча ёрдамчи восита 

сифатида қўлланилиши мумкин, чунки у  

- ўқув материалларини босма ўқув материалига нисбатан: 

индуктив ёндашув, эшитиш ва ҳиссий хотирасига ва шу 

кабиларга тушунча етказишда қулайликлар туғдиради; 

- ўқувчининг талабларига асосан, унинг тайёргарлик даражасига, 

интеллектуал имкониятларига ва қизиқишларига қараб кўникма 

хосил қилишига имконият яратади; 

- соҳа тушунчасига эътиборни жамлаб, кўпроқ масала қараш ва 

ечиш имкониятларини яратиб бергани холда, жуда ҳам катта 

ҳисоблар ва қайта ишловлардан озод қилади; 



19 

 

- иш жараёнининг барча босқичларида ўз-ўзини текшириш 

имконини беради; 

- ишни чиройли ва саришта қилиб ўқитувчига файл ёки босмадан 

чиқариб бериш имконини беради; 

- жудаям бардошли устоз бўлиб, фойдаланувчиларнинг охири йўқ 

саволлари билан ишлаши, у ҳоҳлаганича такрорий маротаба ўқув 

материалларини кўрсатиши мумкин. 

ЭДИ талаба учун катта аҳамиятга эга, чунки у тизимдан фан соҳаси 

бўйича йирик ва кенг қамровли маълумот олиши мумкин. 

ЭДИ амалий аудитория машғулотлари учун ҳам қўллашга қулайдир, 

чунки у: 

- кўп сонли масалалрни ечишда компьютердан фойдаланиш 

имконини бериб, олинган ечим таҳлили ва график 

интерпретацияси учун кетадиган вақтни тежайди; 

- ўқитувчи учун дарсни мустақил дарс формасига айлантиришга 

имкон беради, шу билан бирга ўқитувчи ва консултант ва раҳбар 

сифатида қолади; 

- ўқитувчи учун ўқувчиларнинг билим ва кўникмаларини 

компьютер тизими орқали аниқлаш ва баҳолаш имконини 

беради. 

ЭДИ лар, ўқув жараёнининг янги воситаси сифатида очиқ ёки қисман очиқ 

тизим бўлиши мумкин. Очиқ ва қисман очиқ тушунчаси орқали бу ерда ЭДИ 

ларнинг тузилиши ва таркибига ўзгартириш киритиш мумкинлиги ёки 

мумкин эмаслиги назарда тутилган. 
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1.7.Электрон дарс ишланмаси яратишнинг асосий талаб ва 

тамойиллари. 

Интерактив режимда ишлай олувчи дастурий тизим ЭДИларни 

қуриш, аввало, мавжуд масофавий ўқув қўлланмалар қуриш усулларини 

таҳлил қилиш ва ЭДИ моделларини қуришни таъминловчи тамойил ва 

категорияларни ишлаб чиқаришни талаб қилади. 

Дастурий тизим қуришдаги муаммо, ЭДИ моделини қуришда 

мураккаб архитектура, ечимларни қўллаш, фойдаланувчи билан мулоқотни 

шакллантириш, шу қаторда дастур коди ҳажмининг ошиб бориши 

ҳисобланади. Бугунги кунда ихтиёрий мураккаб жараёнларни яратишда 

унинг тизимли моделини қурмасдан ҳамда  визуал моделлаштириш усул ва 

воситаларидан фойдаланмасдан илож йўқ. 

ЭДИ моделини турли нуқтаи назарлардан келиб чиққан ҳолда баён 

этиши керак. Бу ЭДИнинг тўла модели бир қанча алоҳида ҳар томонни акс 

эттирувчи қисмлардан ташкил топиши лозим. Ташкил қилувчи моделни 

танлаш муаммога ёндашув ва қарор қабул қилишга боғлиқ.  

Ушбу кўринишдаги дастурий тизим қуриш масаласи ҳал қилиниши 

ЭДИни фойдаланувчи тушинувчи даражага олиб чиқиш мумкин. Бунга 

уларни қуришда иерархик тамойил ва график кўринишли тасаввур ҳосил 

қилиш йўли билан эришиш мумкин. Тизимнинг иерархик даражада қуриш 

таҳлил қилинувчи элементлар сонини қисқартиради. 

Қурилган ЭДИ модели унинг бутун фаолияти давомийлигида ишлаб 

боради. Бунга сабаб ЭДИ учун қўйиладиган талабнинг ўзгариши ва бу 

ўзгаришлар асосида қандайдир ҳато ва камчиликларни йўқотиш ёки янада 

мувофаққиятли ечимлар топилиши бўлиши мумкин. 

ЭДИларга қўйиладиган талабларни умумлаштирилган ва 

тизимлаштирилган кўринишда қуйидагича ифодаланиши мумкин: 

1. ЭДИ кўзни чарчатиб қўймаслиги учун ўзида минимум матнли 

ахборотни мужассамлаштирган бўлиши керак. Қўлланаётган 

шрифт ўлчами ва тури ҳам муҳим аҳамият касб этади. 

Тажрибадан шуни кўриш мумкинки, босма китобларда бўялган 

ва эгилтирилган ёзма усулларидан баъзи тушунчаларни 
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ажратиб кўрсатиш учун қўлланилади. ЭДИларда эса ажратиб 

кўрсатиш лозим бўлган алоҳида тушунчалар айри ҳолда, бўяш 

орқали ва фон билан ажратилиб кўрсатилиши мумкин. Бу эса 

тушуниш даражасини ортишига олиб келади. Бироқ ортиқча 

контрастлик ва ёрқинлилик ҳам салбий таъсирларга олиб 

келиши мумкин; 

2. Бундай материаллар кўпроқ безакли кўргазмалар билан 

бойитилиши лозим.  Морхелнинг таъкидлашича таълимда 

безакли кўргазмалар ўқувчини тафаккурлаши ва тасаввурини 

кенгайтиради ва таълим мазмунини бойитади. Бир қатор 

авторлар безакни юқори дидактик қийматга эга деб 

таъкидлашади. ЭДИ ҳажмини камайтириш ва тармоқдаги 

ишининг оптималлигини ошириш учун GIF, JPEG ва бошқа 

график ҳамда график жиҳатдан бўёқ палитраси камайтирилган 

ёки векторли  (WMF кабилар) график файллардан фойдаланиш 

мақсадга мувофиқдир чунки растрли графика бўлганлиги учун 

кўпроқ ранглар билан ишланади; 

3. Видеофрагментларни қўллаш жараён ва ҳодисаларни 

динамикада бериш имконини яратади. Файл ҳажми катталигини 

ҳисобга олмаган ҳолда бу жараённи қўллаш ўқувчи учун 

материални қабул қилиш даражасини оширишга ёрдам беради 

ва албатта билим сифатини оширади; 

4. Анъанавий таълим бериш формаси вербал ҳусусиятга эга. 

ЭДИларда аудио-видеофрагментлардан фойдаланишни қабул 

қилишни анъанавий даражага яқинлаштирибгина қолмай, балки 

қабул қилиш сифатини юқори даражага олиб чиқади. ЮНЕСКО 

ташкилотининг маълумотларига кўра–аудио ўзлаштириш 

жараёни ёрдамида ахборотнинг 12% ни, визуал ўзлаштириш 

жараёнида 25% га яқини, аудиовизуал ўзлаштириш жараёнида 

65% гача ҳиссий ўзлаштиришга эришилар экан. Бундан 

ташқари аудиторияда бундай усул қўлланганда аудио воситани 
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бир-бирига ҳалақит қилмаган ҳолда индивидуал фойдаланиш 

мумкин; 

5. ЭДИ ўзида қўлланма элементларига, имконият бўлса бошқа 

электрон қўлланма ва маълумотларга аниқ мурожаатли 

гиппермурожаатга эга бўлиши ҳамда ушбу мурожаатлар орқали 

керакли вараққа ўтиш имкониятини яратади; 

6. OLE ёки турдош технологиялар ёрдамида мисол, тест ва бошқа 

мақсадли дастурларни ишлатиб, кўрсатиб бериши; 

7. Материални ўрганувчи томонидан ўзлаштирилиши матн, 

графика ва бошқа элементларнинг варақдаги тартибланишига 

боғлиқ. Чунки анъанавий дарсликларда ўрганилаётган 

материалда бир пайтда тушунча ёзилган бетни очиб бири – 

бирига таққослаш имкони бор. ЭДИларда эса буни имкони йўқ. 

Лекин юқоридаги тартибот бўйича ЭДИ тартиблашни 

енгиллаштиришда белги қўйиш ва қўйилган белгини 

тартибланган кетма-кетлигини кўрсатиш лозим; 

8. ЭДИда албатта таклиф этиладиган адабиётлар рўйҳати (у босма 

шаклда чоп этилган бўлса ҳам) берилиши лозим. ЭДИ ОЎЮ 

учун тузилса, албатта, унда кутубхонадаги ушбу адабиётлар 

сони, журналлар ва мақолаларнинг аниқ координати 

кўрсатилиши лозим. Бундан ташқари ОЎЮ кутубхонаси эга 

бўлган электрон маълумотларга ҳамда INTERNET тармоғидаги 

электрон маълумотларга аниқ мурожаат бўлиши лозим. 

ЭДИларни қуриш жараёнида бошқа ўқитиш тизимларини қуриш каби 

унинг психологик томонига ҳам эътиборни қаратиш лозим. Бу одам билан 

компьютер ўртасидаги мулоқотни тўғри йўлга қўйиш масаласидир. Кўпроқ 

ушбу мулоқот жараёнини нотўғри бўлиши, яъни бузилишига бериладиган 

ёрдам (help) тизимининг жудаям катталиги ёки етишмаслиги, баҳолаш 

меъзонининг мувофиқ эмаслиги, ечилаётган вазифа, саволга жавоб, 

ёрдамнинг асосланмаганлигида деб қарашимиз мумкин. Бу албатта, 
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қисқартилиши лозим бўлган жойларнинг кенгайишига, ўқитиш вақтининг 

чўзилишига, ўқитишнинг асослилигини пасайишига олиб келиши мумкин. 

ЭДИларнинг қуришда амал қилинган бир қатор тамойилларни 

тизимлаштирилиб қуйидагиларга келиш мумкин: 

1. Квантлаш тамойили: материални модуллардан ташкил топган, 

минимал ҳажмга эга бўлган бироқ маъно жиҳатидан тугалланган 

бўлакларга бўлиш; 

2. Тўлақонлилик тамойили: ҳар бир модуль қуйидаги 

компоненталардан таркиб топиши мумкин: 

- назарий ядро, 

- назариёт бўйича назорат саволлари, 

- мисоллар, 

- мустақил ҳал этиш учун масала ва машқлар, 

- назорат иши, 

- контекст маълумот (Help), 

- тарихий шарх. 

3. Кўргазмалилик тамойили: ҳар-бир модуль тушунча ҳосил қилиш 

ва янги тушунчаларни ёдда сақлаб қолиш, усуллари акс этилган 

кадрлар коллекциясини минимум текст ва визуаллаштиришдан 

иборат бўлади; 

4. Тармоқланиш тамойили: фойдаланувчи учун бир модулдан 

иккинчи модулга ўтиш имкониятини яратиш мақсадида модуллар 

ўзаро гипперматнли мурожаатга эга бўлади; 

5. Бошқарув тамойили: ўқувчи экранда кадрлар алмашинувини 

мустақил бошқара олади. Яъни ўқувчи ўзи ўз олдига қўйилаётган 

масала мураккаблик даражасини белгилаб, текширувдан 

ўтказади; 

6. Мослашувчанлик тамойили: ўқув материали бўйича ўқувчи 

кейин олдинги квалификациясига қараб безак, график ва 

геометрик ифодалаш, яъни ЭДИ ўқув жараёнида фойдаланувчи 

эҳтиёжи асосида мослашуви учун шароит туғдириши; 
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7. Компьютер кўмаги тамойили: исталган пайтда фойдаланувчи 

компьютердан (тизимдан) зарурий кўмакни олиши лозим. Ушбу 

кўмак ўқувчи учун масала ва муаммоларни ҳал қилишда 

четлашишдан сақлаши, вақтни тежашда муҳим рол ўйнайди; 

8. Иҳчамлилик тамойили: ЭДИ шундай форматда бажарилиши 

лозимки, уларни битта ягона электрон комплексга йиғиш 

имкониятини туғдирсин, бундан ташқари бўлим ва мавзулар 

бўйича кутбхоналар ташкил қилиш, ўқитувчи ёки тадқиқотчи 

шахсий кутбхонасини ташкил этиш имконини туғдирсин. 

Бугунги кунда компьютер ўқув қўлланмаларининг икки хил 

йўналиши мавжуд: INTERNET–технологиялар ва CASE–технологиялари.  

Биринчи, INTERNET – технологиялари асосида қурилган қўлланма 

ўзида гипперматнли хужжатни ифодалаб, WWW (World Wide Web) варағи 

ҳисобланади. У HTML (Hyper Text Markup Language) ва JAVA каби дастурий 

тиллар ёрдамида амалга оширлади ва INTERNET ҳамда INTRANET 

тармоғида тарқатишга мўлжалланади. 

CASE – технологиясидан фойдаланиш деганда эса, ЭДИни анъанавий 

оддий тилларда қуришни тушинишимиз мумкин. 

Ушбу икки технологиянинг бир қатор ўзига ҳос томонлари мавжуд. 

INTERNET – технологиясининг афзаллиги шундан иборатки, унда 

маҳсулотни қай даражада олинганлигининг аҳамияти йўқ, тўғрилашлар, 

ўзгартиришлар киритиш осон кечади. Фойдаланувчи учун дастурни янгилаш 

бир нечта файлдан нусҳа олиш билан чекланилади (INTERNET тармоғидан). 

Шу қаторда фойдаланувчи INTERNET – технологияларидан фойдаланганида 

лицензияланган маҳсус дастур ҳарид қилишига зарурат қолмайди, яъни 

JAVA ва HTML матнли файллар билан ишлайди, улар учун эса 

компиляторларга зарурат йўқ. 

CASE – технологиялари оддий дастурлаш тилларидан 

фойдаланганлиги сабабли муаллиф фикрини яққолроқ рўёбга чиқара олади, 

INTERNET – технологияларидек қилиш мушкул ёки мумкин эмас деган 

хулоса чиқариши мумкин. CASE – технологияларидан фойдаланилган 
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дастурлар икки ихтиёрий компьютерда бир хил кўринишга эга бўлиши 

мумкин. INTERNET – технологиясида бундай эмас. Иккинчи компьютерда 

ахборот намойиши бошқача кўринишга келиши мумкин. 

ЭДИлар ва умуман барча ўқитиш дастурлари турлича тарзда 

қурилади ва тадбиқ қилинади. Бир мунча содда ҳолларда ўқитиш таъсири ва 

дастур, уларни беришни бошқарув бирлаштирилган, бошқаларида эса бу 

функциялар бўлинган, яъни: ўқитиш таъсири билимлар базаси кўринишида 

сақланади. Бошқарув дастури эса вақт оралиғидаги ўқитиш таъсирини 

аниқлаб беради. Баъзи холларда ўқитиш дастурларида ўқитиш таъсирларини 

ўзлари эмас, балки уларнинг компоненталаридан айримлари ишлатилади ва 

тизим буни генерациялайди. Баъзида эса, тизим ўқитиш дастури 

ишлашининг қатъий алгоритмига асосланади. Яна бир холларда тизим 

эксперт тизимнинг вазифасини бажаради. Бу унда ўқитиш стратегиясини 

қуришда маълум бир қонун – қоидага асосланиш, шунингдек тизим эмпирик 

маълумотлар тўплаб, мустақил ўқишни амалга оширган ва ўқитиш 

стратегиясини яхшилаган ҳолда янги қоидалар ишлаб чиқаради.  

Турли ўқитиш дастурларини лойиҳалаш ўзига ҳос жараёнга эга 

бўлади. Бу биргина уларнинг турларига қараб эмас балки тизимнинг 

интеллектуаллик даражасига қараб, яъни улар одамнинг ўқиш фаолиятини 

моделлаштиришини қанчалик тўлиқ амалга ошириши билан белгиланади. 

Ўқитиш дастурини лойиҳалаш – бу умумий тадқиқот стратегияси 

компонентаси бўлиб, у назарий муаммоларни ҳал этиш, компьютерли 

таълимни амалга ошириш технологиялари ва ўқитиш назарияси борасида 

тадқиқотлар мажмуи асосида лойиҳалаш технологияларидир. 

Ўқитиш дастурларини лойиҳалаш кўп даражали жараён бўлиб, уни 

қуйидаги даражаларга бўлиш мумкин: 

- концептуал; 

- технологик; 

- операционал; 

- амалга ошириш. 
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Концептуал даражада ўқитиш модели берилади: ўқитиш тизим 

шаклида ифодаланади, у икки тизим ости тизимдан иборат – ўқитувчи 

фаолияти ва ўқувчи фаолияти: ўқитишнинг барча компоненталари, шу 

жумладан мундарижа (бу ерда гап уни лойиҳалашнинг умумий тамойиллари 

ҳақида бораяпти) ва ўқитиш услуби (макро даражасида ифодаланувчи, яъни 

ўқитиш тури) ушбу ҳаракатлар контекстида қаралади. 

Бу ерда таълим тамойиллари ва психологик механизми баён 

қилинади. Улар таълим бериш жараёнида ўз нуқтаи-назаримизни ифодалайди 

ва таълимнинг назарий асоси ҳисобланади. 

Технологик даражада ўқув дастурлари ўқитиш фаолиятини микро 

даражада бошқариш кўринишида ифодаланади. Лойиҳа баёни концептуал 

даражадан фарқли ўқитиш технологияси даражасида баён этилади. 

Операционал даражада ўқув жараёнини дидактик масала ечими 

кўринишида ифодаланади. Бу ерда, биринчидан, компьютер ўқитиш 

фаолиятининг функциясини ўзида мужассам этса, иккинчидан, ўқитиш 

фаолиятини асосли бошқарув усуллари кўрсатилади. 

Қуриладиган тизим лойиҳасини қуйидагилар белгилаб кўрсатиши 

мумкин: 

- компьютер ўқитишнинг қандай кўриниш берилиши 

(такрорлаш, мустаҳкамлаш, ўқитишнинг тўлиқ кўриниши 

ва ҳаказо); 

- ўқитишни индивидуаллаштириш; 

- ўқувчи ўқишининг тарихи ҳисобга олиниши, ушбу 

маълумотнинг ишлатилиши; 

- тизимда мулоқотнинг қайси тури амалга оширилади; 

- тизимда ўқувчи томонидан бошқарувни амалга ошириш 

қай дражада йўлга қўйилади; 

- тизимда бошқарувнинг жавобга нисбатан ёки жараён 

бўйича бошқарув турларидан қайси биридан 

фойдаланилади;  
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- агар бошқарув жараён бўйича бўлса, масала ечимининг 

қайси нуқталарида ёрдам кўрсатилади ва бошқалар; 

- агар ўқитиш дастури интеллектуал тизим кўринишида 

қурилган бўлса, тизим модуллари ва улар орасидаги 

уйғунликни ёритиб бериш керак. 

Ўқитиш тизимини лойиҳалашнинг ушбу даражаси ўқитиш 

тизимининг дастурий таъминотини амалга ошириш учун асосий 

ҳисобланади.  

Амалга ошириш даражаси икки даражани ўзида мужассамлаштиради: 

педагогик ва дастурий амалиёт. 

Педагогик даража ўзида ўқитиш таъсирларини мужассамлаштириб, 

сценарийлар кўринишидаги амалиётга эга бўлади. Дастурий амалиёт эса, 

ўқитиш тизими ҳар-бир вақтда қандай таъсир кўрсатишини аниқлайди. 

Сценарийнинг икки бўлакка бўлиш мумкин – ички ва ташқи. Ташқи 

тасвирлаш асосий ва ёрдамчи таъсирларга бўлинади (ёки уларга талаблар, 

ушбу талаблар остида тезис ҳар бир таъсирни ишлаб чиқади), ички таъсир 

эса –ўқув фаолиятини бошқариш алгоритмини ўзида акс этиради. Ўқитиш 

тизими бирор дастур орқали амалга оширилса, сценарий бир ўқитиш 

таъсиридан бошқа ўқитиш таъсирига ўтиш алгоритмидан иборат бўлади. 
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1.8. Электрон дарс ишланмани яратиш  технологиясини ишлаб чиқиш. 

          Электрон дарс ишланманинг яратиш технологиясини, яъни 

фойдаланувчи кўриб турадиган элементларини кўриб чиқамиз. ЭДИнинг 

қиймати унинг мазмунидадир. Агар ўқувчи бу электрон қўлланмадан 

фойдаланиб кейинчалик имтихон топширадиган бўлса,  у ҳолда материал 

мазмунини 3та кўринишда беришни таклиф қиламиз:  

1. Мант, расм, жадвал, график шаклида ( яъни оддий қўлланмадаги шаклда, 

лекин бу ерда оддий қўлланма шаклига хос бўлмаган анимация, видео ва овоз 

элементлари, маълумотни излаш имкониятлари ҳам бўлиши мумкин). 

2. Схемакурс кўринишида, яъни дарслик структураси тушунарли бўлиши 

учун дарслик мазмуни қисқартирилган график-матн шаклда берилади.  

3. Тест тизими (ўз билимини текшириш) шаклида – тингловчига махсус 

интерактив тизим воситасида, ўқув материалини саволлар ва жавоблар 

шаклида берилиши. Тест компьютер билан беллашув, ўйин жихатлари билан 

ўқувчилар учун дарсликнинг  энг қизиқарли қисми бўлиши мумкин.  

     Битта материалнинг бундай учта шаклда берилиши уни такрорлаш ва 

эслаб қолиш имконини яратади.  

ЭДИнинг структурасига тўқталадиган бўлсак, у қуйидагиларни ўз ичига 

олиши лозим: 
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1.8.1-Расм. ЭДИнинг структураси. 
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     ЭДИ қўйиладиган яна бир талабга эътибор бериш лозим: ўқув материали 

ва унинг дастурий таъминоти ўз ишини автоматик тарзда бошлайдиган битта 

лазер дискда жойланиши лозим,  қаттиқ дискда эса фойдаланувчи ўзи 

яратган маълумотлар жойланиши мумкин. 

     Муқова. 

     Ишланма муқоваси ўз ичига график, анимация, видео ёки характланувчи 

дарслик аннотациясидан иборат бўлса ўзига жалб қилувчи хусусиятга эга 

бўлади. 

     Титул лист. 

     Титул листда дарслик номи, юқори ташкилот ҳақида, муаллифлик ҳуқуқи 

ҳақида, дарсликнинг аттестациядан ўтганлиги ҳақида маълумот, сана, 

ташкилот, муаллифлар ҳақида маълумотларни ўз ичига олади.  

     Мундарижа. 

     Мундарижа ишланманинг асосий элементи ҳисобланади. Бир тарафдан 

ишланманинг турли қисмларига тез ва қулай ўтиш учун тўлиқ бўлиши ва шу 

билан бирга битта экранда жоланиши керак. Амалиёт шуни кўрсатмоқдаки, 

бундай талабларга икки босқичли (мавзу\мавзуости) мундарижа жавоб 

беради. 

     Бундан ташқари мундарижа орқали: 

* ўз билимини текшириш тизимига; 

* чекланган текшириш тизимига; 

* матн фрагментини излаш қисмига; 

* таянч ибораларга; 

* адабиётлар рўйхатига; 

* дарсликнинг исталган қисмига ўтиш имконияти; 

* дарслик ишини тугатиш; 

* титул листга қайтиш имкониятлари мавжуд бўлиши керак. 

     Аннотация. 

Аннотация ишланманинг муқовасида жойлашган бўлиши мумкин. 

     Ўқув материалининг тўлиқ матни. 
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ЭДИнинг муваффақиятли бўлишининг шарти – унда ўқув материалининг 

тўлиқ бўлишидир, яъни матн, график, жадвал, иллюстрация, анимация, видео 

ва овоз қисмларини ўз ичига олишидир. Дарсликнинг битта саҳифасида матн 

ва унинг ичидаги график элементлар, саҳифанинг қисқача мазмуни ва 

материални ўрганиш жараёнини бошқариш элементлари жойлашади.  

ЭДИда ўқув материалининг тўлиқ бўлиши, таълим жараёнида ундан 

фойдаланиш ва қоғоздаги ўқув материалига мурожаат қилмасликни 

таъминлайди. Матндаги турли иборалар ва таърифларга, иллюстрациларга, 

жадвалларга, графикларга йўлловчи гиперматнлар туфайли ЭДИ қоғоз 

материалларга қараганда ўқув жараёнида қулай имкониятлар яратади. Шу 

билан бирга унинг иқчамлиги ва нисбатан арзонлиги таълим олувчининг 

эътиборидан холи бўлмайди. ЭДИда ўқув материалининг тўлиқ берилиши 

саҳифаларнинг кўпайиб кетишига олиб келади. Агар ҳар бир сақифага 

алоҳида ишлов берилса, у ҳолда бундай ЭДИни яратишга кўп вақт кетади. 

Агар саҳифага матнни оддий холатда жойлаштирилса, у ҳолда бу жараённи 

автоматлаштириш осонлашади. Бундан ташқари гиперматнларни яратишни 

автоматлаштириш ҳам қулайлашади. Кичик график объектлар эса матн ичида 

ҳам жойлаштириш мумкин. 

     Ишланма саҳифасининг структураси. 

* саҳифанинг ишланмада жойлашган ўрнини кўрсатувчи соҳаси ( саҳифа 

номери, мавзу ёки мавзу ости номланиши);  

* матннинг бир неча сатри.  

* Матнга график қўшимчалар (формула, график, жадвал ва ҳ.к.), 

гиперматнлар киритилиши мумкин; 

* саҳифадаги ўқув материалининг қисқача мазмуни жойлашган соҳа ( схема 

курс шаклида) ; 

* саҳифада бошқарув элементлари жойлашган соҳа ( олдинги, кейинги 

саҳифага, мундарижага ўтиш тугмалари, ёрдамчини чақириш тугмаси); 

* саҳифадаги матнга алоқали, катта илмострация ва жадваллар, ё дарслик 

ресурсларида сақланади, ёки бошқа саҳифаларда жойлашади. Улар экранга 



32 

 

гиперматнлар ёрдамида ёки саҳифадаги махсус тугмачалар ёрдамида 

чақирилади. 

ўқув материалининг қисқача мазмуни. 

* ўқув материалининг тўлиқ матни билан бир қаторда қисқача мазмунининг 

ҳам бўлиши жуда муҳим. Схемакурс шаклида, яъни график-матн шаклида 

(структурали блок-схема) берилиши яхши самара беради. 

     Ўз билимини текшириш тизими. 

     Ўз билимини текшириш тизимига алохида эътибор берилиши керак. 

ЭЎИнинг ҳамма қисмини қамраб олган, билим даражасини яхши назорат 

қиладиган бўлиши лозим. ЭЎИ базасидаги барча саволлар ўқувчи учун 

тушунарли ва қулай тарзда тақдим этилиши лозим. Шу билан бирга, ҳар бир 

жавоб баҳоланиши, умумий натижа ва вақт хисоби олиб борилиши керак.  

     Матн фрагментларини излаш. 

ЭДИда бундай функциянинг бўлиши шарт. Излаш икки вариантда бўлиши 

мумкин: изланаётган элементни алоҳида излаш ёки шу элементни ўз ичига 

олган сўзларни ҳам излаш.    

     Муаллифлар рўйхати. 

     Одатда, муаллифлар рўйхати алоҳида сахифада келтирилади. Бу сахифада 

нафақат ЭДИ муаллифлари, унинг электрон версиясини яратганларнинг ҳам 

рўйхати берилади. Бундан ташқари ишланмани яратган ташкилотнинг тўлиқ 

реквизитларини ҳам жойлаштириш мумкин. 

     Таянч иборалар. 

      Ибораларга берилган таъриф гиперматн ёрдамида намоён бўлиши 

мумкин, лекин бу сахифанинг гиперматнлар билан тўлиб кетишига олиб 

келади, чунки гиперматнлар нафақат ибораларнинг таърифига, иллюстрация, 

жадвал, графикларга ҳам йўлловчи бўлади. Шунинг учун таянч иборалар ва 

уларнинг таърифларини алоҳида сахифада жойлаштирган маъқул. 

Замонавий ахборот-коммуникация  технологияларининг ривожланиши 

инсоният олдида, таълим соҳасида янги имкониятлар яратибгина қолмасдан, 

янги вазифаларни ҳам юклади. Биз бу БМИда шу вазифалардан бирига, яъни 

замонавий ахборот технологияларининг мультимедиа воситаларидан 
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фойдаланган ҳолда таълим беришнинг янги босқичига, ЭДИларни таълим 

жараёнида қўллаш имкониятларига тўқталиб ўтдик. 
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1.9. Электрон ўқув ишланма яратишда фойдаланиладиган дастурий 

таъминотлар ва ҳисоблаш техникаси воситалари. 

“Potoshop дастурида ишлаш” мавзуси асосида электрон дарс 

ишланмаси яратиш”  мавзуси бўйича электрон ишланма яратиш учун албатта 

бошланғич маълумот сифатида бир неча воситалар талаб қилинади. Яъни бу 

масалани ҳал қилиш учун энг биринчи навбатда компьютер билан 

таъминланиши зарур. Маълумки, компьютер графикаси пакети 

дастурларининг эса, шу кунга қадар бир нечта версиялари яратилган. 

Версияни танлашда эса, албатта компьютер имкониятларини ҳисобга олиш 

лозим бўлади. Биз компьютер графикаси пакети дастури имкониятларини 

ҳисобга олган ҳолда замонавий компьютерлардан фойдаланишни назарда 

тутамиз.  

Энди бироз дастурий таъминотни, яъни ЭДИни яратиш учун зарур 

бўладиган тил ёки воситалар ҳақида тўхталиб ўтамиз. Компьютер графикаси 

дастурини ўргатувчи электрон қўлланмани яратиш бўйича албатта 

интернетда фойдаланиш имкониятларини ҳам ҳисобга олишимиз лозим. Бу 

эса, биздан Web саҳифаларни яратиш тиллари ёки воситаларидан бирини 

билишимизни талаб қилади.  

Маълумки, бугунги кунда FronPage 2000, FronPage 2003, Macromedia 

Flash MX, Macromedia Flash 2008, HTML, PHP каби кўплаб тиллар ва 

дастурий воситалар мавжуд. Агар биз буларнинг биридан фойдаланишимиз 

талаб қилинса, албатта ўзимиз учун маъқул ва бизга ўз имкониятлари билан 

ёрдам бера олувчи тил ёки воситалардан бирини танлаймиз . 

Масаламизни моҳиятидан келиб чиқадиган бўлсак, электрон услубий 

қўлланмаларни яратиш дастурий воситаларидан бири FrontPage 2003 ва 

Macromedia Flash дастурлари ўз имкониятлари ва масалани ҳал қилишда 

амалий ёрдам бера олиши билан маъқул келади.  

Масалани ҳал қилиш  учун компьютернинг конфиграцияси қуйидагича 

бўлса фойдадан холи эмас  
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 Motherboard Socket (i965G ASUS P5B-VM SE DDR2 800, SATA2, 

LAN, 6ch Audio, PCI-E, 6-ch Audio),  

 CPU(Dual Core Celeron 1,8 GHz 512kb 800MHz),  

 Оператив хотира (DDR II 1 Gb 800MHz), HDD(HDD 160 Gb Sata),  

 PCI-EXP Video(ATI Radeon HD HD 2600 XT DDR4, 670/1, 256bit, 

TV-Out, 2xDVI/HDMI),  

 DVD/RW(DVD-RW ASUS box SATA) ва бошқа қурилмаларни 

айтиш мумкин.  

Булардан ташқари қуйидаги мультимедиа ва қўшимча қурилмаларни 

борлиги мақсадга мувофиқ бўлади. Мультимедиа воситалари ёрдамида 

ахборотларни матнли, тасвирли, товушли ва анимацияли кўринишда 

намойиш этиш мумкин. Уларнинг вазифалари қуйидагича: 

- нутқли ахборотни киритиш-чиқариш қурилмалари (микрофон, 

кучайтиргичлар,  товуш  колонкалари); 

- анимацион ва видео маълумотларни киритиш ва чиқариш 

қурилмалари (видеокамералар, видеопроектор ва экранлар); 

- товушли  ва  видео  маълумотларни сақловчи оптик дисклар ва 

ҳоказолар. 
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1.10. КҲКларида ўқитиладиган “Растр графикаси асослари” фанининг 

“Potoshop дастурида ишлаш” мавзусини янги педагогик технологиялар 

бўйича лойиҳалаш. 

Вақт: 2 соат Талабалар сони: 30 та 

Ўқув 

машғулотининг 

шакли ва тури 

Амалий машғулот 

Машғулот режаси 1. Компьютер графика тушунчаси; 

2. Adobe PhotoShop дастурида ишлаш; 

 3. Adobe PhotoShop дастурнинг иш куроллар сохаси; 

 4. Adobe PhotoShop дастурнинг Выделение (Select) 

менюси; 

5. Adobe PhotoShop дастурнинг Редактирование (Edit) 

менюси; 

 6. Adobe PhotoShop дастурнинг Филтр менюсининг 

Извлеч (Extract) буйруги ёрдамида соха танлаш. 

Ўқув 

машғулотининг 

мақсади 

Талабаларга компьютер графикаси ҳақида тушунча 

бериш ва Adobe PhotoShop дастурида ишлаш 

кўникмаларини шаллантириш. 

Педагогик 

вазифалар: 

Талабаларга 

компьютер 

графика 

Ўқув фаолиятининг натижалари: 

1) Компьютер графика тушунчасини билади. 

2) Adobe PhotoShop дастурида ишлаш кўникмаси 

хосил бўлади. 

3) Турли хил расмлар устида амаллар бажара олади. 
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тушунчаси, Adobe 

PhotoShop 

дастурида ишлаш, 

дастурнинг иш 

куроллар сохаси ва 

юқори менюлари 

билан ишлашни 

ўргатади. 

 

Таълим усуллари Тушунтириш, савол-жавоб, машқ, кетма-кетликни 

аниқлаш методи. 

Таълим шакли Оммавий, гуруҳли. 

Таълим воситалари Масалалар, тарқатма материаллар, услубий кўрсатма, 

доска, мел, компьютерлар.  

Таълим шароити Техник жиҳозланган хона. 

Мониторинг ва 

баҳолаш 

Оғзаки, тезкор сўров, амалий вазифалар. 
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Амалий машғулотнинг технологик харитаси 

 

Иш 

босқичлари ва 

вақти 

Фаолият мазмуни 

Таълим берувчи Таълим олувчилар 

1-босқич.  

Ўқув 

машғулотига 

кириш. 

(15 дақ.) 

Мавзунинг номи, режаси, мақсад, 

баҳолаш мезони ва кутилаётган 

натижаларни етказади. 

Талабаларнинг назарий билимини 

савол-жавоб усулида фаоллаштиради 

(1-илова). 

Тинглайдилар, ёзиб 

оладилар.  

 

 

Жавоб берадилар. 

 

2-босқич. 

Асосий 

(55 дақ.) 

Ўтилган мавзуни такрорлайди. 

Вазифа беради. (2-илова) 

Талабаларга ўқув топшириқларини 

бажаришга доир намунавий мисолни 

ишлаб кўрсатади(3-илова)  ва 

топшириқларни тарқатади(4-илова). 

Гуруҳ ишини ташкиллаштиради, 

йўриқномалар беради, кузатади, 

хатоларни кўрсатади.  

Биргаликда бажарилган ишларнинг 

тўлиқлигини баҳолайди, машғулотни  

 якунлайди(5-илова). 

Вазифани бажарадилар. 

 

Ўқув топшириқларини 

бажарадилар. 

 

 

 

 

Якуний хулосани 

берадилар. 

3-босқич. 

Якуний  

(10 дақ.) 

Дарсга умумий хулоса қилади. 

Талабаларнинг бажарган ишларини 

баҳолайди. Фаол иштирок этган 

талабаларни баҳолайди. 

Уйга вазифа беради. 

Тинглайди. 

 

 

 

Ёзиб олади. 
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1-илова 

 

Кириш 

PhotoShop дастури растр тасвирларни тахрирлаш дастури. Дастур 

ёрдамида фото расмларни тахрирлаш кулай. PhotoShop 5.5 дастурини 

ўрганиш учун 4-та амалий дарс хавола килинади 

1 дарс - Белгилаш амаллари; 

2 дарс – Каватлар билан ишлаш асослари; 

3 дарс – Фото тасвирни тугрилаш 

4 дарс – Illustrator графикасини PhotoShop расми билан бирлаштириш 

 

PhotoShop дастурини умумий куриниши: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Белгилаш билан ишлаш. 

Бошланиши. 

 

1. “File > Open” менюсига чертиб Photoshop 5.5\Training\Photoshop 

5.0\Tutorial\Lesson01\ папкага кириб End01.psd   файлини очинг. 

2. End01.psd бу килинадиган ишни натижа куриниши. Куринг ва эслаб 

колинг. End01.psd файлини беркитинг. 

3. Шу папкада “File > Open” килиб Start01.psd файлини очинг. 

4. “File > Save As” килиб Start01.psd файлини Work01 номи билан кайта 

сакланг. 

 

Туртбурчак белгилаш ускунаси билан ишлаш. 

1. Ускуналар панелида туртбурчак ( ) белгилаш ускунасига чертинг. 

2. Расмдаги ковунни чап томонининг юкори кисмидан унг томонга 

тортиб тугри туртбурчак хосил килинг. 
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Изох: Белгиланган кисмдаги кайта жойлаштириш мумкин. 

 

3. Курсаткични белгиланган кисмдан ташкарига олиб чикиб 1 марта 

чертинг, белгилаш йуколади. 

 

4. Ковунни кайта белгиланг: Белгилашни учириш учун “Select > 

Deselect” буйругини беринг ёки ихтиёрий кисмда чертиб белгилашни 

йукотинг. 

 



41 

 

Эллипс белгилаш ускунаси билан ишлаш. 

 

1. Масштаб ( ) ускунасини танланг ва олича расмида чертинг токи 

масштаби 300% га катталашсин. 

2. Ускуналар панелида туртбурчак ( ) белгилаш ускунаси устида 

сичкончани босиб туриб куйиб юборинг.Туртбурчак ( ) белгилаш 

ускунасини элипс ( ) белгилаш ускунасига алмаштиринг. 

3. Сичконча ёрдамида оличани чап юкори кисмидан бошлаб унг пастги 

кисмигача белгиланг ва сичконча тугмасини куйиб юборманг. 

 
 

Белгилаш жараёнида белгиланган кисмни кайта жойлаштириш. 

 

1. Сичкончани куйиб юбормасдан туриб пробел тугмасини босиб, 

белгиланган кисмни кайта жойлаштиринг. 

2. Бушлик тугмани куйиб юборинг ва сичконча ёрдамида белгилашни 

давом эттиринг. Белгилаб кайта жойлаштириб, оличани тулик 

белгилашга эришинг. 

3. Олича тула белгилангандан сунг сичкончани куйиб юборинг. 

  

Объектни уртасидан белгилаш 

 

Изох: Баъзан белгилашни уртадан бошлаш маъкул. 

1. Белгилашни бекор килинг “Select > Deselect” 

2. Белгилаш курсаткичини тахминан оличанинг уртасига урнатинг. 

3. Alt тугмасини босган холда оличани белгиланг. 

4. Белгилаб булиб, биринчи сичкончани куйиб юборинг кейин Alt 

тугмасини куйиб юборинг. 

 

Белгиланган кисмни жойлаштириш. 

 

1. Оличани белгилаб булганингиздан кейин силжитиш ( ) ускунасига 

чертинг ва белгиланган оличага курсаткични урнатинг. 

2. Оличани сабзининг булагига жойлаштиринг. 

 
3. Белгилашни бекор килинг: “Select > Deselect”. 
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Нусха олиш. 

 

1. Хужжатни тулик очиш учун менюдан “View > Fit on Screen” танланг. 

2. Элипс ( ) ускунасини танланг. 

3. Сабзи билан оличани белгиланг. 

 

4. Силжитиш ( ) ускунасини танлаб, ясалган кузни ковуннинг чап 

кисмига жойлаштиринг. 

5. Иккинчи кузни яратиш учун  Alt тугмасини босиб, силжитиш ( ) 

курсаткичи ёрдамида унг тарафга нусха олинг. 

Изох: Текис нусха олиш учун Alt га кушимча Shift-ни босиш мумкин. 

 
Ctrl тугмаси ёрдамида белгилашни кучириш. 

 

1. Элипс ( ) ускунасини танланг. 

2. Киви мевасини белгиланг. 

3. Белгилаш ускунаси ёрдамида кучириш учун Ctrl тугмасини босиб 

сичконча билан белгиланган киви мевасини ковун устига кучиринг. 

 
 

Йуналиш тугмалари ёрдамида силжитиш. 

 

1. Киви меваси белгиланган холда йуналиш тугмалари ёрдамида киви 

мевасини  жилдиришга харакат килинг. 

Изох: Йуналиш тугмалари ёрдамида экранда 1 пикселга жилдириш 

мумкин.Баъзан белгилаш чегараси ишга халакит килади. Шунинг учун 

белгилаш кисмини вактинча учириш мумкин. 

2. Менюда “View > Hide > Edges” танлансин. 

Изох: Белгилаш чегараси учади. 

3. Shift тугмаси босилган холда йуналиш тугмаларда белгиланган кисмни 

хар тарафга силжитиб куринг. 

Изох: Shift тугмаси босилганда, силжиш 10 пикселга булади. 
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4. Киви мевасини керакли жойга жойлаштиринг ва меню ёрдамида 

белгилаш чегараларини ёкиб куйиш учун: “View > Show Edges”. 

 

Сехрли таёкча ёрдамида белгилаш. 

1. Икки марта сехрли таёкча ( ) ускунасига чертиб созлаш ойнасини 

очинг.Сезгирлик параметрини (Tolerance) 32 килинг ва сехрли таёкча 

курсаткичи билан нокни уртасига чертинг 

 

 
2. Нокни белгиланмаган кисмларини  белгилаш учун Shift тугмасини 

босиб туриб, сехрли таёкча ( ) билан кушилмаган кисмига чертинг. 

 
Кушимча: Ортикча белгиланса Alt тугмасини босиб туриб белгилашни 

таёкча билан камайтириш мумкин. 

 

 

 

Lasso ускунаси ёрдамида белгилаш. 

 

1. Капалак расмига масштаб ( ) ускунаси ёрдамида чертиб, куриш 

масштабини 300% га урнатинг. 

2. Lasso ( ) ускунасини танланг ва капалакни чап юкори бурчагидан 

бошлаб унг юкори бурчагигача белгилаб тортинг. Сичкончани куйиб 

юборманг. 

3. Alt  тугмасини босиб сичконча тугмасини куйиб юборинг. Капалакни 

унг кирраларини сичконча билан чертиб – чертиб белгиланг.(Alt 

тугмасини куйиб юбормаган холда) 

 
 

4. Унг пастки бурчагига белгилаш етганда  сичкончани босиб, Alt  

тугмасини куйиб юбориб капалакни пастки кисмларини белгилаб, чап 

пастки бурчагига курсаткични  олиб боринг. 
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5. Alt тугмасини босиб, чап кирраларини чертиб – чертиб белгиланг. 

6. Курсаткични чап юкори бурчагига олиб борганингизда сичкончани 

босиб туриб Alt тугмасини куйиб юборинг ва белгилашни тугатиш 

учун сичконча тугмасини куйиб юборинг. 

7. Хужжатни тулик экранда куриш учун менюдан “View > Fit on Screen”. 

 

Белгилашни кушиш ва айриш. 

 

1. Кузикоринга масштаб ( ) ускунасини чертиб 300% 

катталаштирамиз. 

2. Lasso ( ) ускунани танлаб, кузикорин атрофини белгиланг. 

3. Shift тугмасини босган холда кушилмаган кисмларни Lasso ( ) 

ускунаси ёрдамида чизиб белгилашга кушинг. 

 
4. Alt тугмасини босган холда ортикча кисмларини кесиб ташлаш 

мумкин. 

 
 

5. Хужжатни тулик экранга кайтаринг меню ёрдамида “View > Fit on 

Screen” танланг. 

 

6. Кузикорин калпокчасини ковун бошига урнатинг. 

 

Магнит Lasso билан  белгилаш. 

 

1. Grapfruit меваси масштабини 200% килинг. 

2. Lasso ( ) ускунасини босиб тургиб Magnetic Lasso ( ) 

ускунасига утиб олинг. 

3. Grapfruit кизил кисмини пастки чап бурчагидан бошлаб, кизил 

кисмини атрофини белгиланг. 
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4. Grapfruit ни пастки унг бурчагига етканингизда Magnetic Lasso 

курсаткичи билан 2 марта чертинг ва автоматик равишда белгилашни 

тугатинг. 

5. Икки марта кул ( ) тугмасига чертиб, расмни тулик экранга  очинг. 

6. Силжитиш ( ) ускунасини танлаб Grapfruit ни ковуннинг чап 

кулоги урнига олиб боринг. Белгилашни учирманг. 

 

Белгилашни трансформациялаш. 

 

Кулогини ясаш учун Grapfruit ни айлантириш керак ва унг кулогини 

ясаш учун чапидан нусха олиб аксини топиш керак. 

1. Менюда “Edit > Free Transform” ни танланг. 

2. Чап кулогини керагича айлантиринг. 

3. Кулогини кичрайтириш учун Shift тугмасини босиб туриб объектни 

кичрайтиринг. 

4. Кулогини керагича кайта жойлаштириб урнатинг. 

 
5. Трансформацияни тугатиш учун Enter ни босинг. 

6. Чап кулогидан унг кулогига нусха олинг. Shift, Alt тугмаси ёрдамида. 

7. Унг кулогини аксини топиш учун менюда  

“Edit > Transform > Fleep Horizontal” ни танланг. 

8. Керагича унг кулогини силжитиб тугриланг. 

9. Белгилашни бекор килинг: “Select > Deselect”. 

 

Белгилаш комбинациялари. 

 

1. Туртбурчак ( ) белгилаш ускунасини танланг. 

2. Кукатни белгиланг. 

3. Сехрли таёкча ( ) ускунасини танланг ва Alt тугмасини босинг. 

4. Белгиланган кисмни ок жойида чертинг. 

 



46 

 

5. Ковуннинг кошларини ясанг. 

 
 

Расмни кесиш. 

 

1. Кесиш ускунасини ( ) танланг. 

2. Ясалган одамчани белгиланг. 

3. Керак булса белгилаш чегараларини узгартиринг. 

 
4. Кесиш учун Enter тугмасини чертинг. 

Изох: Мева ва сабзавотли одамча тайёр. 

 

 

Бошланиши 

 

1. “File > Open” менюсига  чертиб Photoshop 5.5 \Training\Photoshop 

5.0\Tutorial\Lesson02\ папкага кириб End02.psd  файлини очинг. 

2. End02.psd бу килинадиган ишни натижа куриниши. Куринг ва эслаб 

колинг. End02.psd файлини беркитинг. 

3. Шу папкада “File > Open” килиб Start02.psd файлини очинг. 

4. “File > Save As” буйругини бериб Start02.psd файлини Work02 номи 

билан кайта сакланг. 

 

Кават ташкил этиш 

 

1. “File > Open” буйругини бериб  Clock  файлини очинг. 
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2. Кучириш ( ) ускунасини танлаб, Shift тугмасини босиб туриб , соат 

расмини  клавиатура устига кучиринг. 

  
3. Clock файлини беркитинг . 

4. Layers ойнасида Layer 1 булимида икки марта чертинг. 

 
5. Layers Options мулокот  ойнасида Name сатрида Soat номини териб 

OK тугмасига чертинг 

Изох: Натижада Layer 1 кават Soat  номини олади. Layers  ойнасида  Soat  

каватидан ташкари яна учта кават мавжуд. Каватни куриш учун, кават 

номини  

 

чап тарафидан куз ( ) белгисини куйиш керак. Каватни куринмас 

холатга 

 

 утказиш учун куз ( ) белгисини учириш керак. 

 

Белгилаб учириш 

 

1. Soat каватига утинг (сичконча билан Soat кават номига чертинг, ёнида 

чизиш ( ) белгиси пайдо булади) 

2. Колган каватларни куринмас килинг (куз ( ) белгиларини учиринг) 

3. «Сехрли» ( ) белгилаш  ускунасини олиб соат расмини ок кисмига 

чертинг ва белгиланган ок кисмини [Delete] ёки [Supr] тугмаси билан 

учиринг. 

 
4. Белгиланишни олиш учун “Select > Deselect” амалини бажаринг. 

5. Энди клавиатура Background каватини ёкинг. 
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Каватлар тартибини узгартириш 

 

1. Guage ва Bearing  каватларини ёкинг. 

 
2. Соатни биринчи кават килиш учун Layers ойнасида Soat номли каватга 

чертиб, биринчи уринга тортиб жойлаштиринг. 

 
 

Кават холатини узгартириш 
 

1. Soat каватини фаол килинг (Layers ойнасида Soat – га чертинг!) 

Opacity созлаш ускунасини 50% килинг. Натижани куринг. 

 
2. Энди Mode кисмида Screen булимини танланг ва Opacity – ни 90% 

килинг 

 
3. “File > Save” саклаш амалини бажаринг. 

 

Объектни айлантириш 
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1. Soat расмини клавиатурани пастки унг томонига кучиринг (кучириш 

( ) ускунасини ишлатинг) 

 
2.  “Edit > Free Transform” килинг. Соат расмини озгина буринг. 

3. Shift тугмаси босилган холда соат расмини кичрайтиринг. 

4. Кераклича расм жойланишини тугриланг 

5. Enter тугмасини босиб Free Transform амалини тугатинг. 

 
 

Каватга градиентли ранг кушиш 

 

1. Background каватини чертиб фаол килинг. 

2. Меню “Layers > New Layer” буйругини танланг (янги кават кушиш) 

 
3. Мулокот ойнада Gradient номини теринг ва OK тугмасини чертинг. 

4. Икки марта “Gradient” ( ) ускунасида чертинг. 

5. “Options”  ойнасида градиент турини “Gredient: Foreground to 

Transporent” – ни танланг 

6. Ранглар ойнасида Swatches варагида пушти рангни танланг. 

 

7. Gradient каватини фаол килинг ва Gradient ( ) ускунаси билан 

расмни унг тарафдан чап тарафга тортинг. 

 

 

1. Layers ойнасида Soat каватига чертинг 
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2. Матн ускунасини ( ) танланг ва расмни тепа чап тарафига чертинг. 

Натижада матн ойнаси очилади. 

3. Матн киритиш ойнасида Color туртбурчагига чертиб керакли рангни 

танланг. 

4. Font менюсида керакли шрифтни танланг, Size =70 улчамини урнатинг. 

5. Z2000 ёзувини теринг 

 
6. Расм ойнасида янги ёзувни тортиш амали ёрдамида жойлаштиринг. 

7. Матн ойнасида OK тугмасига чертинг. 

Эътибор берсангиз Layers ойнасида янги кават пайдо булган. 

 

Матнга эффект кушиш. 

 

1. Матн каватини фаол килиб “Layer > Effect > Bevel and Emboss” 

килинг 

2. Effects мулокот ойнасида  Opacity  Highlight 20% килинг 

3. Shadow 40% 

4. Style менюсида Emboss ни танланг ва эффектларни урнатиш учун OK 

килинг. 

 
 

Бошланиши. 

1. ”File > Open” менюсига чертиб Photoshop 5.0\Training\Lesson03 

папкага кириб End03 файлини очинг. 

2. End03 бу килинадиган ишни натижа куриниши. Куринг ва эслаб 

колинг. 

3. Шу папкада “File > Open” килиб Start03  файлини очинг. 

4. ”File > Save as” килиб Start03 файлини Work03 номи билан кайта 

сакланг. 
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Расмни кесиш 

 

1. Кесиш ( ) ускунасини танлаб, расмни тахминан туртбурчакга олинг. 

 
2. Белгиланган кисмини четидан айлантиринг ва керагича кичрайтиринг. 

 
3. Кесиш учун Enter – ни босинг. 

 
 

Расмни равшанлантириш. 

 

1. “Image > Adjust > Levels” меню булимларини танланг. 

2. Чап ва унг учбурчак белгиларини графикни усиш жойига келтиринг ва 

ОК килинг. 

 
3. “File > Save” килинг. 
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Расмни рангини созлаш. 

 

1. Меню “Layer > New > Adjustment Layer” булимларини танланг пайдо 

булган ойнада Type-ни Color Balance холатига урнатинг ва Name-га 

Rang Sozlash номини териб OK тугмасини чертинг. 

2. Кизил рангни камайтириш учун Red биринчи созловчи ускунани (-15) 

килинг. 

3. Green Зангори рангини кушиш учун (+8) килинг ва OK тугмасини 

чертинг. 

 
4. Натижани куриш учун Layer  ойнасида Rang Sozlash каватини ёкинг, 

кейин учиринг. 

5. Rang Sozlash каватини ёкиб “File > Save” килинг. 

Кушимча: 
 Рангларни кайта созлаш учун Rang Sozlash каватига икки марта 

чертинг. 

 

Расмда ранг узгартириш. 

 

1. Layer ойнасида Background каватини танланг. 

2. Масштаб ( ) ускунаси ёрдамида керакли кисмга бир марта чертинг. 

3. Туртбурчак ( ) белгилаш ускунаси ёрдамида керакли кисмни 

белгиланг. 

 
 

4. Ранг узгартириш учун “Image > Adjust > Replace Color” менюнинг 

булимларига киринг. 
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5. Биринчи ранг олувчи пипетка  ускунасига чертиб, асосий расмда 

керакли рангни курсатинг. 

6. Иккинчи ранг олувчи плус пипетка  ускунани олиб, керакли 

рангларни белгиланишга кушинг. 

 
7. Белгилаш сезгирлигини Fuzziness – ни 61 – га урнатинг. 

8. Рангни узгартириш учун Hue – (149), Saturation – (-17), Lightness – (-

33) га урнатинг ва ОК тугмасини чертинг. 

9. Расмни тулик ойнада куриш учун, икки марта кул ( )  ускунасига 

чертинг. 

10. “Select > Deselect” булимларини танланг. 

11. “File > Save”  буйругини беринг. 

 

 

Рангни ловиллатиш. 

 

1. Мочалка ( )  ускунасини танланг. 

2. Sponge мочалка ( ) ускунасини Options ойнасида Saturate холатини 

урнатинг, кучини 90% килинг. 

3. Brushes («Щеткалар») ойнасида иккинчи сатрда охиргисини танланг. 

 

4. Расмни керакли кисмини Sponge ( ) ускунаси билан ишкаланг, токи 

ранглар ловиллаб ёнсин. 

 
 

 

 

Рангни очиш. 

 

1. Dodge ( ) ускунасини танлаб Options ойнасида Highlights 

менюсини танлаб, кучини 50% килинг. 
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2. Brushes («Щёткалар») ойнасида иккинчи катордаги уртанчасини 

танланг. 

 
3. Dodge ускунаси билан суртиб кайикни ён кисмини очинг. 

 
 

Кераксиз кисмларни учириш. 

 

1. Rubber Stamp ( )  ускунасини олинг. 

2. Rubber Stamp Options ойнасида Aligned холатини учиринг. 

3. Расмни сув кисмида Rubber Stamp ( ) ускунаси урнатиб, Alt 

тугмасини босиб туриб,  сичконча билан бир марта чертинг. 

4. Кичкина кайикни Rubber Stamp ( ) ускунаси билан учиринг. 

 
5. “File > Save” буйругини беринг. 

 

Расмга бошка расмни кушиш. 

 

1. «Сехрли» таёкча ( ) белгилаш ускунаси билан расм осмонини 

белгиланг, осмон кисмларини белгилашда Shift тугмасини босиб туриб 

белгиланг. 

2. Clouds номли файлни очинг. 

3. “Select > All” ёрдамида булутлар расмини тулик белгиланг ва “Edit > 

Copy” килинг. 

4. Асосий расмга утиб “Edit > Paste Into” буйругини  беринг. 

 

5. Кучириш ( ) ускунаси ёрдамида булутларни кераклича 

жойлаштириш мумкин. 
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6. Янги булутлар каватини куриниш холатини Layers ойнасида Opacity – 

ни 55% килинг. 

7. “File > Save” буйругини беринг. 

 
8. Каватларни бирлаштириш учун “Layer > Flatten Image” булимларини 

танланг. 

9. “File > Save As” булимни танлаб пайдо булган ойнада Сохранить 

тугмасини чертинг. 

 

Расмга фильтр урнатиш. 

 

1. “Filter > Sharpen > Unsharpen Mask” булимига киринг. 

 
2. Amount созлагични 120% килинг. 

3. OK тугмасини босинг. 

 

Расмни саклаш. 

 

1. “Image > Mode > CMYK” булимларини танланг. 

Изох: (CMYK – ранг системаси, принтерга ранглар тури чикиши учун 

ишлатилади.) 

2. File > Save as буйругини беринг. 

3. Format менюсида TIFF холатини танланг. 

4. Сохранить тугмасини чертинг. 

  

  

 

1. “File > Open” менюсига чертиб Photoshop5.0\Training\Lesson04\ 

папкасига кириб End04 файлини очинг. 

2. End04 бу килинадиган ишни натижа куриниши. Куринг ва эслаб 

колинг.End04 файлни беркитинг. 

3. Шу папкада “File > Open” буйругини бериб, Start04 файлини очинг. 

4. “File > Save as” килиб Start03 файлини Work04 номи билан кайта 

сакланг. 

 

Adobe Ilustrator файлини кушиш. 
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1. Танланг “File > Place” ва Logo.ai файлини очинг. 

2. Shift тугмасини босиб, фирма белгисини кераклича катта кичиклигини 

узгартиринг. 

3. Кераклича белгини буринг. 

 

4. Кучириш ( ) ускунаси билан яхшилаб жойлаштириб, Enter 

тугмасини чертинг. 

 

Белгини булиш. 

 

1. Polygon Lasso ( ) ускунаси ёрдамида гугурт кутини тепа туртбурчак 

кисмини белгиланг. 

 
2. “Layer > New > Layer Via Cut”  булимлари ёрдамида Logo каватни 

иккига булинг натижада янги кават пайдо булади. Каватларни учириб 

( ), ёкиб натижани куринг. 

3. Layer1 каватни фаол килиб. “Edit > Transform > Skew”  булимларини 

танланг. 

4. Белгиланган каватни бурчакларидан тортиб кераклича куринишни 

узгартиринг. 

 
5. Узгаришлар тугагач Enter тугмасини чертинг. 

 

Расмни созлаш. 

 

1. Layer1 кават фаол булиб уни куриниши холатини Layers ойнасида 

Opacity – сини 60% килинг. 

2. Менюсида Multiply режимини урнатиб Logo.ai каватини фаол килинг 

ва куриниш холатини Opacity 70% килинг. 

 
3. “File > Save” 
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Тасвирни экспорт килиш 
 

Кушимча:  Photoshop -да расмни экспорт килиш мумкин. Бунда тасвирни 

тиник жойлари белгиланади. 

 

1. Background кавати фаоллаштиринг. 

2. Polygon Lasso ( ) ускунаси ёрдамида кутини чегараларини 

белгиланг. Шу кадамда “Select > Inverse” ёрдамида тасвирнинг 

фонини белгиланг. 

 
 

Изох: Энди биз экспорт устаси билан ишлашга тайёрмиз. 

 

3. Куйидаги булимларни танланг “Help > Export Transporant Image” 

4. Биринчи-мулокот дарчасида 2чи-холатни танланг. (2-чи холат бу I have 

selected the area to be make transporent – таржимаси: “Мен шаффоф 

тасвирни хосил килиш учун керакли майдони белгиладим”). 

5. Кейинги мулокот дарчасида: Print  - режимини танлаймиз.Сунгра Next 

чертилади. 

6. Кейинги саклаш мулокот дарчада: узингизни папкангизга 

“ESPWork01” номи билан сакланг.  

7. ESP  Options  мулокот дарчасида: Preview майдонига TIFF 8 bits/pixel 

холатини танлаб – OK тугмаси чертилади. 

8. Охирги мулокот дарчасида «Finish» чертилади. Шаффоф тасвир 

дарчаларини беркитамиз. 

9. Mailer.ai файлни очиб, яратилган шаффоф расмни “File > Place” 

буйруги ёрдамида урнитиб, керакли жойга жойлаштиринг.   
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1.11. Электрон дарс ишланмасидан фойдаланиш йўриқномаси. 

БМИда тайёрланган электрон дарс ишланма замонавий дастурлаш 

тиллари ва воситаларидан фойдаланиб тайёрланган бўлиб, жуда қулай 

интерфейсга эга ва Potoshop дастурини ўрганишга қулай деб хисоблайман. 

Қуйда электрон дарс ишланмадаги айрим ойналарни келтириб ўтамиз. 

  
1.11.1-Расм. Электрон дарс ишланманинг ойна кўриниши. 

Ушбу ойна юқорида айтиб ўтганимиздек замонавий дастурлаш тиллари 

ва воситаларидан фойдаланиб тузилган бўлиб, Potoshop дастурини ўргангани 

кирган ўрганувчига чиройли кўриниш хосил қилади. Электрон дарс 

ишланмасида 4 та бўлим бўлиб, бу бўлимлар  Potoshop дастурини ўрганиш 

учун хизмат қилади. 
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1.11.2-Расм. Электрон дарс ишланмасида ёзувлар билан ишлаш 

ойнаси. 
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1.11.3-Расм. Potoshop дастурида юқори менюлари билан ишлаш 

ойнаси. 

  
1.11.4-Расм. Potoshop дастурида расмлар билан ишлаш ойнаси. 

 

Келажакда ушбу электрон дарсликни ривожлантириб, 

такомиллаштириш имкониятларини ҳосил қиламиз. 
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1.12. Электрон маълумотлар базасининг иқтисодий самаралари ва 

дастур таннархи. 

Республикамизда олиб борилаётган туб иқтисодий ислоҳотлар таълим 

соҳасида ҳам изчил ва узлуксиз ўзгаришларни амалга оширишни тақозо 

этмоқда. Иқтисодиётнинг бозор муносабатларига ўтиши кадрларни тайёрлаш 

соҳасида жаҳон андозаларга мос равишда туб ўзгаришлар қилинишини талаб 

этади. Маълумки, фирмалар, корхоналар ва ташкилотларнинг самарали 

ишлашини ундаги мавжуд бўлган малакали ва билимли ходимлар 

таъминлайди. Шу жиҳатдан ҳозирги вақтда малакали ва ишбилармон 

ходимларни шакллантиришга эришиш муҳим ижтимоий-иқтисодий аҳамият 

касб этади. 

Жаҳон молиявий-иқтисодий инқирозидан чиқиш йўлларини чуқур таҳлил 

қилиш асосида, уни бартараф этиш чораларини мамлакатимиз Президенти 

И.А.Каримов қуйидагича таъкидлаган “Иқтисодиётнинг реал сектори 

корхоналарининг молиявий барқарорлигини, биринчи навбатда, ишлаб 

чиқаришни модернизация қилиш, маҳсулот таннархини пасайтириш, 

кооперация алоқаларини кенгайтириш, мамлакатимиз ишлаб чиқарувчилари 

маҳсулотларига ички талабни рағбатлантириш ҳисобига таъминлаш бўйича 

чора-тадбирлар комплекси амалга оширилди.  

Ўзгариб турувчи бозор шароитларини илғаб олиш, уларни моҳиятини, 

қонуниятларини чуқур таҳлил қилиш, кўп вариантли ечимларни яратиш ва 

оптимал иқтисодий қарорлар қабул қилиш, кейинчалик, бу қарорлар 

бажарилишини компьютер орқали мониторинг қилиш, зарур бўлса, олдинги 

қарорларга оператив тарзда ўзгартиришлар киритишда иқтисодий билимлар 

муҳим аҳамиятга эга.  

Ноаниқлик, таваккалчилик ва юқори рақобат шароитида самарали 

қарорлар қабул қилиш мураккаб ва анча харажатларни талаб қиладиган 

жараён ҳисобланади. Яна шуни ҳам ҳисобга олиш лозимки, иқтисодий 

жараёнлар устидан турли хил “эксперимент” олиб бориш ҳар доим ҳам 

ижобий натижа бермаслиги мумкин.  

 Юқоридаги билимларга таянган ҳолда “КҲКда ўқитиладиган “Растр 

графикаси асослари” фанининг “Potoshop дастурида ишлаш” мавзуси 
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асосида электрон дарс ишланмаси яратиш” мавзусига тегишли бўлган 

дастурий таъминотни иқтисодий самаралари ва таннархини қуйидагича 

ҳисоблаймиз:  

Дастурнинг таннархи ва сотув нархини аниқлаш 

 

Маълумки, ҳар кандай яратилган дастур таъминоти интеллектуал ишлаб 

чикариш махсулоти, яъни товар ҳисобланади. Демак, ҳар кандай товар каби 

унинг ҳам ўзига хос иқтисодий кўрсаткичлари мавжуд. Бу кўрсаткичлар 

товарнинг, яъни дастур таъминотининг таннархи, сотилиш баҳоси ва 

рентабеллик даражаси ҳисобланади. 

 Дастур таъминотининг иқтисодий кўрсаткичларини ҳисоблашда бир 

канча бошланғич маълумотларни эътиборга олиш лозим бўлади: 

 

1. Дастурчига белгиланган меҳнатга ҳақ тўлашнинг ягона тариф 

сеткаси бўйича разряди; 

2. Дастурчининг маҳсулот ишлаб чикариш учун сарфлаган иш кунлари 

сони; 

3. Дастурчини ижтимоий ҳимоялаш, рағбатлантириш фонди ставкаси; 

4.Дастурни яратишда фойдаланилган техник воситалар 

(компъютер,принтер,сканер,модем ва х.з); 

5.Дастурни яратишда фойдаланилган асосий воситалар (бино, каттик 

мебель,турли жиҳозлар); 

6 Дастурда яратиш чоғида керак бўлиши мумкин бўлган кўзда 

тутилмаган харажатлар; 

7. Асосий ва қўшимча солиқлар бўйича ажратмалар; 

8. Корхона фойдаси ставкаси. 

 Юқоридаги келтирилган бошланғич маълумотлар меъёрий 

ҳужжатларда белгиланган қоидалар асосида аниқланади. Меъёрий 

ҳужжатларда келтирилмаган қўшимча харажатлар фоиз ҳисобида аниқланиб, 

хақиқий харажатлар билан ҳосил бўлган фарқ корхона фойдаси ҳисобига 

қопланади. 

1. Бошланғич маълумотларни ҳисоблаш 

 

-дастур таъминотини яратиш билан банд бўлган ходим сони -1 та (битирувчи 

талаба ) ; 

-ягона тариф сеткаси бўйича разряди 8, тариф коэффициенти 4,640 

- дастурчининг иш кунлари сони -9 кун; 

- дастурчини ижтимоий ҳимоялаш, рағбатлантириш фонди ставкаси-41%; 

- дастурни яратишда фойдаланилган техник воситалар:  

 компьютер Pentium IV-750000 сўм; 

 модем Zyxel Prestije 700-350000 сўм; 

 сканер HP Scanjet 4500C-180000 сўм; 
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 принтер HP 1010-249000 сўм. 

(дастур НамМПИ, 2-бино, 125-хонада бажарилган) 

-дастурни яратишда фойдаланилган асосий воситалар баҳоси -3000000 сўм 

(НамМПИ,2-бино , 125-хонани умумий нархи); 

- кўзда тутилмаган харажатлар -4,3% ; 

- ягона ижтимоий тўлов -25%; 

-корхона фойдаси ставкаси -20%; 

 

2.Дастурчининг асосий иш хақи суммасини ҳисоблаш. 

 

а) Ойлик маош суммасини ҳисоби. 

Тариф сеткаси бўйича маош суммаси дастурчининг ягона тариф сеткаси 

бўйича разрядига мос тариф коэффициентини минимал иш хақига 

кўпайтириш натижасида аниқланади.  

Илова1: Ўзбекистон Республикаси президентининг  2012 йилдан Ўзбекистон 

Республикаси худудида энг кам иш хақи ойига 79590 сўм миқдорида 

белгиланди: 

Sойлик=79590 cўм*4,640 = 369297,60 сўм 

 

б) Асосий иш хақи суммасини аниқлаш. 

     Энди дастурчининг иш кунларига нисбатан маоши (Sасосий иш хақи ) , яьни 

асосий иш хақини аниқлаймиз. Бунинг учун ,тариф сеткаси бўйича ойлик 

маоши суммаси (S ойлик ) ни йил бўйича бир ойдаги ўртача иш кунлари сони 

(25,4)га бўлиб, дастурни бажаришга сарфланган иш кунлари сони 9 кунга 

кўпайтирилади: 

 

     S асосий иш хақ =Sойлик/25,4 кун * 9 кун=130853,48 сўм 

 

3. Рағбатлантириш фонди суммаси ҳисоби  

 

Илова2: дастурчи дастурни яратиш давомида маълум миқдорда нурланиш 

олганлиги, интеллектуал маҳсулот яратаётганлиги учун рағбатлантириш 

фондидан 41% ажратма ажрадик .У ҳолда рағбатлантириш фонди суммаси 

асосий иш хақи (Sасосий иш хақи)ни 41% миқдорида аниқланади . 

Sрағбат=Sасосий иш хақи *0,41=53649,93 сўм  

 

4.Маош фондини хисоблаш  

 

Маош фондини асосий иш хақи (Sасосий иш хақи )ни рағбатлантириш 

     фонди суммаси(Sрағбат)га қўйиш орқали аниқланади . 

Sмаош фонди =Sасосий иш хақи +Sрағбат=130853,48сум+53649,93сум=184503,41 сўм 

 

5.Ягона ижтимоий тўлов суммасини ҳисоби 
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Илова3: Ўзбекистон Республикаси Солиқ кодексига ўзгартириш киритиш 

тўғрисидаги Президент фармонига кўра ягона ижтимоий тўлов миқдори 2007 

йил 1-январдан 25 % қилиб белгиланди. 

 

       Sяит=Sмаош фонди*0,25=184503,41сум*0,25=46125,85 сўм 

 

6.Электр энергияси сарфи 

 

Илова4: Компьютер 1 соатда ўртача 0,250 квт электр энергияси сарф қилади. 

Ҳар куни ўртача 3 соатдан компьютерда ишланди деб ҳисобланиб, 9 кунга 

сарфланадиган электр энергияси суммаси аниқланади. Ўзбекистон 

Республикаси Молия Вазирлиги томонидан тасдиқланган 19-03-22-05-ЎзР-

21-2009-сонли реестрига асосан 2013 йил 1 апрелдан бюджет ташкилотлари 1 

квт/соат электр энергияси сарфи учун 112 сўм 2 тийин ҳисобида тўлайдилар. 

Sэлектр=0,250квт/соат*3соат* 9 кун*112,2 сўм=757,35 сўм 

 

7.Фойдаланилган техник воситалар амортизацияси. 

   

Илова5: Ўзбекистон Республикаси Вазирлар Махкамасининг 31 декабр 

1996 йил 469- сонли буйруғини 15- иловасининг 2-бандига асосан, 

компьютерлар, периферик қурилмалар ва маълумотларни қайта ишловчи 

воситаларнинг  эскириш муддати этиб 5 йил белгиланган: 

Атех.вос.=(750000+180000+249000+350000)/5йил/12ой/25,4кун*9 кун = 9029,53 

сўм 

8.Асосий воситаларнинг эскириш киймати(амортизацияси)  

 

Илова6: Ўзбекистон Республикаси Вазирлар Махкамасининг 31 декабр 1996 

йил 469- сонли буйруғини 15- иловасининг 1-бандига асосан, бино, қаттиқ 

мебель ва бошқа воситаларнинг эскириш қиймати учун 5% ажратма 

ажратилади. НамМПИ, 2-бино, 125-хонадаги компьютерлар сонини ҳам 

асосий воситалар амортизацияси ажратмасини ҳисоблашда ҳисобга олиш 

керак, яьни битирувчи 1 та компьютер ўрни учун асосий восита 

амортизациясини тўлайди.  

Sас.вос=3000000сум/20йил/12 ой/25,4 кун /20 та компьютер*9 кун =221,46 сум   

 

9.Дастур таннархи 

 

Дастур таннархи дастурни яратишга сарфланган барча ҳаражат суммалари 

йиғиндисидан ташкил топади. 

 яитфондимаошвосасвостехэлектртаннарх SSSSSS .... 757,35 сўм +9029,53 

сўм +_221,46 сум 184503,41 сўм +46125,85 сўм =240637,59 сум 

 

10. Кўзда тутилмаган ҳаражатлар 

 



65 

 

Илова7: Дастурни яратишда дискеталар, принтер бўёқлари ва бошқа кўзда 

тутилмаган ҳаражатларни қоплаш учун дастур таннархидан ажратма миқдори 

белгилаб қўйилади (4,3%): 

 
сумSS таннарххаражат 42.10347043.0*59.240637043,0*   

 

11.Дастурнинг умумий таннархи. 

 

Дастур умумий таннархи дастур таннархи ва кўзда тутилмаган ҳаражатлар 

йиғиндисидан  ташкил топади: 
сумсумсумSSS харажаттаннархтаннархум 01,25098542,1034759.240637.   

 

12.Корхона фойдаси ставкаси 

 

Яратилган дастурий таъминотни сотув нархини белгилашда унинг умумий 

таннархи ва фойда ставкаси йиғиндиси олинади. Фойда ставкачи эса одатда 

умумий таннархнинг 20% миқдорида белгиланади: 
сумSS таннархумфойда 00,5019720,0*01,25098520,0*.   

13.Дастурнинг корхона баҳоси 

 

Дастурнинг корхона баҳоси умумий таннарх ва корхона фойдаси 

суммаларининг йиғинисидан ташкил топади: 
сумсумсумSSS фойдатаннархумбахосикорх 01,3011825019701,250985.. 

 

14. Қўшимча қиймат солиғи 

 

Қўшимча қиймат солиғи маҳсулотни сотувчи ёки харид қилувчи томонидан 

тўланади ва одатда корхона баҳосини 20% ини ташкил қилади. 

 

сумSS бахосикоркксолиги 40,6023620,0*01,30118220,0*.   

 

15. Дастурни сотиш баҳоси  

 

Дастурни сотиш баҳоси дастурнинг корхона баҳоси билан қўшимча қиймат 

солиқ йиғиндисидан ташкил топади: 
сумсумSSS кксолигибахосикор 41,36141840,6023601,301182.   

 

Шундай қилиб, яратилган дастурий таъминотнинг сотув баҳоси  361418,41  

сўмни ташкил этди. 
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ХУЛОСА 

Хулоса қилиб шуни айтиш мумкинки ҳозирги шиддат билан 

ривожланаётган замонда, бизнинг мамлакатимизда таълим соҳасига катта 

эътибор берилмоқда. Ҳозирги замон талабалари юксак маънавиятли, 

замонавий техникаларни мукаммал биладиган ёшлардир.  

Шундай экан дарс машғулотларида айниқса “Информатика ва 

информацион технологиялар” йўналишидаги талабаларга билим беришда 

дарс машғулотларига ўқитувчи биринчи навбатда пухта тайёрланиб кириши 

лозим бўлади. Юқоридаги бўлимларда такидлаганимиздек дарс ўтиш 

жараёнида доимо муваффақият келтирадиган универсал ўқитиш усули йўқ 

деб такидлаган эдик. Модомики шундай экан ўқитувчи мавзунинг 

моҳиятидан, талабалар руҳиятидан келиб чиқиб ананавий ва интерфаол 

усулларни қўллаб дарс машғулотларини олиб бориш лозим бўлади. 

Мен БМИ тайёрлаш ва ёзиш жараёнида шундай хулосага келдим. 

Булардан ташқари БМИ тайёрлаш жараёнида қуйидаги натижаларга 

эришдим:         

 КҲКларида ўқитиладиган растр графикаси асослари фанининг мақсад 

ва вазифалари ҳақида тушунчалар олинди; 

 Компьютер графикасининг информацион жамиятдаги аҳамияти, роли 

ва ўрни ўрганилди; 

 Замонавий компьютерлар асосида электрон графиклар қуришнинг 

асосий элементлари ва усуллари ишлаб чиқилди; 

 Электрон дарс ишланмаси яратиш асослари ўрганилди; 

 Электрон дарс ишланмаси яратишнинг асосий талаб ва тамойиллари 

кўриб ўтилди; 

 Электрон дарс ишланмани яратиш  технологиясини ишлаб чиқилди; 

 Ўқитиш жараёнида анъанавий ва янги педагогик технологиялардан 

мутаносиб фойдаланиш самаралари тахлил қилиб берилди; 

 Янги педагогик технологиялардан фойдаланиб “Растр графикаси 

асослари” фанининг “Potoshop дастурида ишлаш” мавзуси 

лойиҳаланди. 
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Хулоса қилиб айтганда, дарс самарадорлигини таъминлашни мақсад 

қилиб олган ўқитувчи интерфаол дарс усулларидан ўз ўрнида моҳирона 

фойдалансагина ўз мақсадига эришади. 
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Илова. 

Style switcher used only for demo purpouse. 

function setActiveStyleSheet(title) { 

  var i, a, main; 

  for(i=0; (a = document.getElementsByTagName("link")[i]); i++) { 

    if(a.getAttribute("rel").indexOf("style") != -1 && a.getAttribute("title")) { 

      a.disabled = true; 

      if(a.getAttribute("title") == title) a.disabled = false; 

    } 

  } 

} 

 

function getActiveStyleSheet() { 

  var i, a; 

  for(i=0; (a = document.getElementsByTagName("link")[i]); i++) { 

    if(a.getAttribute("rel").indexOf("style") != -1 && a.getAttribute("title") 

&& !a.disabled) return a.getAttribute("title"); 

  } 

  return null; 

} 

 

function getPreferredStyleSheet() { 

  var i, a; 

  for(i=0; (a = document.getElementsByTagName("link")[i]); i++) { 

    if(a.getAttribute("rel").indexOf("style") != -1 

       && a.getAttribute("rel").indexOf("alt") == -1 

       && a.getAttribute("title") 

       ) return a.getAttribute("title"); 

  } 

  return null; 

} 

 

function createCookie(name,value,days) { 

  if (days) { 

    var date = new Date(); 

    date.setTime(date.getTime()+(days*24*60*60*1000)); 

    var expires = "; expires="+date.toGMTString(); 

  } 

  else expires = ""; 

  document.cookie = name+"="+value+expires+"; path=/"; 

} 

 

function readCookie(name) { 

  var nameEQ = name + "="; 

  var ca = document.cookie.split(';'); 

  for(var i=0;i < ca.length;i++) { 
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    var c = ca[i]; 

    while (c.charAt(0)==' ') c = c.substring(1,c.length); 

    if (c.indexOf(nameEQ) == 0) return c.substring(nameEQ.length,c.length); 

  } 

  return null; 

} 

window.onload = function(e) { 

  var cookie = readCookie("style"); 

  var title = cookie ? cookie : getPreferredStyleSheet(); 

  setActiveStyleSheet(title); 

} 

window.onunload = function(e) { 

  var title = getActiveStyleSheet(); 

  createCookie("style", title, 365); 

} 

var cookie = readCookie("style"); 

var title = cookie ? cookie : getPreferredStyleSheet(); 

setActiveStyleSheet(title); 

body, ul, li, p, h1, h2, h3, h4, h5, h6 { 

 margin: 0; 

 padding: 0; 

 list-style-type: none; 

} 

body { 

 background: #E0E0E0; 

} 

div#wrapper { 

 width: 800px; 

 margin: 40px auto; 

} 

/** GENERAL STYLES **/ 

div#nav ul.main li.fr { 

 float: right; 

} 

/** MAIN MENU STYLE **/ 

div#nav { 

 width: 800px; 

 clear: both; 

} 

div#nav ul.main { 

 float: left; 

 height: 50px; 

 width: 770px; 

 padding: 0 15px; 

 background: rgb(45,56,58); 

 background-image: -webkit-gradient(linear, left top, left bottom, color-

stop(1%, rgb(45,56,58)), color-stop(100%, rgb(21,30,33))); 
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 background: -webkit-linear-gradient(top, rgb(45,56,58) 1%, rgb(21,30,33) 

100%); 

 background: -moz-linear-gradient(top, rgb(45,56,58) 1%, rgb(21,30,33) 

100%); 

 background: -o-linear-gradient(top, rgb(45,56,58) 1%, rgb(21,30,33) 100%); 

 background: -ms-linear-gradient(top, rgb(45,56,58) 1%, rgb(21,30,33) 

100%); 

 background: linear-gradient(top, rgb(45,56,58) 1%, rgb(21,30,33) 100%); 

 filter: progid:DXImageTransform.Microsoft.gradient( 

startColorstr='#2d383a', endColorstr='#151e21',GradientType=0 ); 

 -webkit-border-radius: 4px 4px 0 0; 

 -moz-border-radius: 4px 4px 0 0; 

 -o-border-radius: 4px 4px 0 0; 

 -ms-border-radius: 4px 4px 0 0; 

 -khtml-border-radius: 4px 4px 0 0; 

 border-radius: 4px 4px 0 0; 

 border-bottom: 3px solid #6C442E; 

} 

div#nav ul.main li { 

 float: left; 

 position: relative; 

} 

div#nav ul.main li:hover { 

 -webkit-box-shadow: inset 0 4px 10px #222; 

 -moz-box-shadow: inset 0 4px 10px #222; 

 box-shadow: inset 0 4px 10px #222; 

} 

div#nav ul.main li:first-child { 

} 

div#nav ul.main li a { 

 display: block; 

 color: #F4F4F4; 

 font: normal 12px/50px Arial, sans-serif; 

 text-decoration: none; 

 padding: 0 15px; 

 position: relative; 

} 

div#nav ul.main li:hover:after { 

 content: ''; 

 position: absolute; 

 bottom: 0; 

 left: 44%; 

 border-color: transparent transparent #6C442E transparent; 

 border-style: solid; 

 border-width: 6px; 

 width: 0; 

 height: 0; 
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} 

/* SUB MENU STYLE - dropdown 1st level*/ 

div#nav ul.main li ul.sub, div#nav ul.main li ul.sub_rt { 

 display: none; 

 border-top: 3px solid #6C442E; 

 border-bottom: 3px solid #6C442E; 

} 

div#nav ul.main li:hover ul.sub { 

 display: block; 

 position: absolute; 

 top: 50px; 

 left: 0; 

 background: #6C442E; 

} 

div#nav ul.main li:hover ul.sub_rt { 

 display: block; 

 position: absolute; 

 top: 50px; 

 right: 0; 

 background: #6C442E; 

} 

div#nav ul.main li ul.sub li, div#nav ul.main li ul.sub_rt li { 

 width: 140px; 

 border-bottom: 1px dotted #BB7F5F; 

 position: relative; 

} 

div#nav ul.main li ul.sub li:first-child, div#nav ul.main li ul.sub_rt li:first-

child { 

 margin-left: 0; 

} 

div#nav ul.main li ul.sub li:last-child, div#nav ul.main li ul.sub_rt li:last-child 

{ 

 border-bottom: none; 

} 

div#nav ul.main li ul.sub li:hover, div#nav ul.main li ul.sub_rt li:hover { 

 -webkit-box-shadow: 0 0 0 #000; 

 -moz-box-shadow: 0 0 0 #000; 

 box-shadow: 0 0 0 #000; 

 background: #432A1C; 

} 

div#nav ul.main li ul.sub li:hover:after, div#nav ul.main li ul.sub_rt 

li:hover:after { 

 content: ''; 

 position: absolute; 

 border: 0; 

} 

div#nav ul.main li ul.sub li a, div#nav ul.main li ul.sub_rt li a { 
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 display: block; 

 color: #F4F4F4; 

 font: normal 11px/30px Arial, sans-serif; 

} 

div#nav ul.main li ul.sub li a:hover, div#nav ul.main li ul.sub_rt li a:hover { 

 background: #432A1C; 

} 

div#nav ul.main li ul.sub li span.rightarrow { 

 position: absolute; 

 z-index: 500; 

 right: 0px; 

 top: 10px; 

 border-color: transparent transparent transparent #432A1C; 

 border-style: solid; 

 border-width: 6px; 

 width: 0; 

 height: 0; 

} 

div#nav ul.main li ul.sub_rt li span.leftarrow { 

 position: absolute; 

 z-index: 500; 

 right: 6px; 

 top: 10px; 

 border-color: transparent #432A1C transparent transparent; 

 border-style: solid; 

 border-width: 6px; 

 width: 0; 

 height: 0; 

} 

/* SUB_2nd MENU STYLE - dropdown 2nd level*/ 

div#nav ul.main li ul.sub li ul.sub_2nd { 

 display: none; 

 border-top: 3px solid #6C442E; 

 border-bottom: 3px solid #6C442E; 

} 

div#nav ul.main li ul.sub li:hover ul.sub_2nd { 

 display: block; 

 position: absolute; 

 z-index: 55; 

 top: -3px; 

 left: 140px; 

 background: #6C442E; 

} 

div#nav ul.main li ul.sub_rt li ul.sub_2nd_rt { 

 display: none; 

 border-top: 3px solid #6C442E; 

 border-bottom: 3px solid #6C442E; 
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} 

div#nav ul.main li ul.sub_rt li:hover ul.sub_2nd_rt { 

 display: block; 

 position: absolute; 

 z-index: 777; 

 top: -3px; 

 right: 140px; 

 background: #6C442E; 

} 

/* 

div#nav ul.main li ul.sub_rt li a { 

text-align: right; 

} 

div#nav ul.main li ul.sub_rt li ul.sub_2nd_rt li a { 

text-align: right; 

} 

/**** MENU ELEMENTS *************\ 

-other elements like form, 

buttons and other are styled here. 

\**** Form elements *************/ 

div#nav ul.main li ul.sub_rt li.form { 

 background: #6C442E; 

 padding: 0 15px; 

 width: 150px; 

 font: normal 11px/24px Arial, sans-serif; 

} 

div#nav ul.main li ul.sub_rt li.form:hover { 

 background: #6C442E; 

} 

li.form input[type=text], li.form input[type=password] { 

 width: 138px; 

 height: 20px; 

 padding: 0 5px; 

 border: 1px solid #432A1C; 

 color: #222; 

 font: normal 11px Arial, sans-serif; 

 font-style: italic; 

 margin: 0; 

 -webkit-box-shadow: inset 3px 3px 3px #CCCCCC; 

 -moz-box-shadow: inset 3px 3px 3px #CCCCCC; 

 box-shadow: inset 3px 3px 3px #CCCCCC; 

} 

li.form input[type=text]:focus, li.form input[type=password]:focus { 

 outline: none; 

} 

li.form label { 

 color: #F4F4F4; 
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} 

li.form button { 

 padding: 3px 9px; 

 border: 1px solid #222; 

 -webkit-border-radius: 3px; 

 -moz-border-radius: 3px; 

 -o-border-radius: 3px; 

 -ms-border-radius: 3px; 

 -khtml-border-radius: 3px; 

 border-radius: 3px; 

 margin-top: 7px; 

 margin-bottom: 10px; 

 color: #F4F4F4; 

 font: normal 11px Arial, sans-serif; 

 position: relative; 

 cursor: pointer; 

 outline: none; 

 background: rgb(45,56,58); 

 background-image: -webkit-gradient(linear, left top, left bottom, color-

stop(1%, rgb(45,56,58)), color-stop(100%, rgb(21,30,33))); 

 background: -webkit-linear-gradient(top, rgb(45,56,58) 1%, rgb(21,30,33) 

100%); 

 background: -moz-linear-gradient(top, rgb(45,56,58) 1%, rgb(21,30,33) 

100%); 

 background: -o-linear-gradient(top, rgb(45,56,58) 1%, rgb(21,30,33) 100%); 

 background: -ms-linear-gradient(top, rgb(45,56,58) 1%, rgb(21,30,33) 

100%); 

 background: linear-gradient(top, rgb(45,56,58) 1%, rgb(21,30,33) 100%); 

 filter: progid:DXImageTransform.Microsoft.gradient( 

startColorstr='#2d383a', endColorstr='#151e21',GradientType=0 ); 

} 

li.form button:after { 

 content: '\00a0'; 

 position: absolute; 

 display: block; 

 background: transparent; 

 top: 0; 

 left: 0; 

 width: 100%; 

 z-index: 999; 

 -webkit-border-radius: 3px; 

 -moz-border-radius: 3px; 

 -o-border-radius: 3px; 

 -ms-border-radius: 3px; 

 -khtml-border-radius: 3px; 

 border-radius: 3px; 

 border-top: 1px solid #555555; 
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} 

li.form input[type=checkbox] { 

 position: relative; 

 top: 3px; 

} 

li.form { 

 width: 200px; 

} 

li.form input.search { 

 width: 83px; 

 float: left; 

 margin-top: 7px; 

} 

li.form button.searchbtn { 

 float: left; 

 border-left: 0; 

 -webkit-border-radius: 0 3px 3px 0; 

 -moz-border-radius: 0 3px 3px 0; 

 -o-border-radius: 0 3px 3px 0; 

 -ms-border-radius: 0 3px 3px 0; 

 -khtml-border-radius: 0 3px 3px 0; 

 border-radius: 0 3px 3px 0; 

 margin-left: -1px; 

 


