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              LESSON 1.            Computer Graphics 

 

• “Computer graphics refers to using a computer to create or manipulate any kind of 

picture, image, or diagram.” 

• Typically you manipulate an image on your computer with a graphics editing program 

– MS Paint 

– Adobe Photoshop 

– GIMP 

– Etc. 

                            Bitmapped Graphics. 

• There are two basic types of graphics: 

– Bitmapped and 

– Vector 

• Bitmapped graphics are much more common 

• Often they are called raster graphics 

• When you create a bitmapped graphic you are basically creating a bunch of colored 

dots. 

• The bitmapped graphic is stored as an array of dots, or pixels 

• Each pixel gets assigned a specific color 

• The more pixels you have, the more detailed the image can be 

– Imagine only have one pixel, all you get is a dot 

• Some common bitmap graphics programs are: 

– Photoshop 

– Paint Shop Pro 

– GIMP 

– Photo-Paint 

– Graphic Converter 

• These are paint programs. 

 



 

 

Exaggerated Example of a Bitmap Image 

 

                             

                             Vector Graphics 

• The second major type of computer graphics 

• Vector graphics are created and manipulated using drawing programs (as opposed to 

paint programs for bitmapped graphics) 

• Instead of using pixels to describe the image, it describes the image using shapes 

– Circles 

– Lines 

– Curves 

• Also has to store the color of these shapes 

• A verbal example would be something like: 

– “A yellow circle with a center here and a radius of x, a purple line from here to 

here” 

                        

                     Bitmap vs. Vector Images. 

• Bitmap and vector images are obviously different 

• Both have strengths and weaknesses 



• They don‟t manipulate images in the same way 

• They don‟t store images in the same way 

• The images are edited differently.  

                   

            Common File Formats 

  Bitmap Formats 

• GIF: graphics interchange format 

• JPEG: joint photographic experts group 

• PNG: portable network graphic 

• BMP: Windows bitmap 

• TIFF: tagged image file format 

• Common File Formats 

        Vector Formats 

• SVG : scalable vector graphics 

• EPS: encapsulated postscript 

• CMX: Corel meta exchange 

• PICT: Macintosh Picture 

• WMF: Windows metafile 

 

     Colour Gamut Differences 

With RGB colours the graphics are made up from Red, Green and Blue, with CMYK the 

colours are made up from Cyan, Magenta, Yellow and Black. 

 

 
 

           CMYK colours 

 



are subtractive meaning the starting canvas 

is white and colours are added to block out 

parts of the spectrum. 

 

 
 

 

 

RGB colours 

are additive meaning that the starting point 

is a black canvas (i.e. a computer screen) and 

colours are added to create the final image. 

ROUTE 

               

 

                         Why Print files need to be CMYK 

The RGB colour spectrum is much larger than the CMYK spectrum. i.e. there are colours that 

can b 

created in RGB that are not available CMYK. This problem is most apparent with very bright 

colour 

such as a fluorescent orange or green. Commercial presses print onto white paper using 

CMYK colours, in order to get the best results files should be prepared with this in mind. 

Below shows examples of filessubmitted in RGB colour that have been automatically 

converted into CMYK before printing. 

 



 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



  

 

 

Converting RGB files to CMYK and re-balancing colour 

Using software such as photoshop is possible to readjust the colour balance after conversion 

to more 

closely match the intended colour output. If using RGB elements i.e. images in the design 

stage it is 

worth converting the elements into CMYK and rebalancing the colours during the design 

process. 

 

 

 

 

 

 
 

 

LESSON 2.  Using Corel Draw File 



How to Start and Open a Drawing  

To Start and Open a Drawing  

   At the beginning, you can start a new Corel Draw 10 drawing in a blank page. A 

blank page allows you to specify every aspect of a drawing in the Corel Draw 10 

software.   

 

  The available templates included the following categories:  

 Full page  

 Label  

 Booklet  

 Side-fold  

 Web  

 Browse  

How to Import a File  

To Import a File  

  Below is the Import utility of Corel Draw. Select a File Name and File Type to import 

file. Most graphic files are allowed to import, such as files in the formats of BMP, GIF, 

JPEG, TIFF, etc.   



 

 You are allowed to import files that have been created in other graphics applications.  

How to Export a File  

To Export a File  

 Below is the Export utility of Corel Draw. Select a File Name and File Type to export 

your Corel Draw file for usage in other graphics applications. You can export your 

files to the formats of CMX, BMP, GIF, JPEG, TIFF, etc.   

 

You can export a file to a selected file format, such as CMX, JPG, GIF…. In addition, 

you can also export a file by saving the opened file under a different file name.  

How to Edit Merge Fields to Print  

To Edit Merge Fields to Print  



 

Step 1  

 First of all, you have to click on the File tab from the menu bar and select Print 

Merge, followed by Edit Merge Fields.  

Step 2  

 Follow the instructions in the Print Merge Wizard to edit Merge Fields.  

How to Perform a Merge to Print  

To Perform a Merge to Print  

 

Step 1  

 At the beginning, you will need to select the File tab from the menu bar and 

choose PrintMerge. After that click Perform Merge.  

  Step 2  

 Then specify the printer settings in your computer.  

  Step 3  

 Finally, click on the Print button.  

How to Create Merge Fields  

To Create Merge Fields   

 

  Step 1  

 You have to click on the File tab from the menu bar and choose Print Merge 

followed by Create Merge Fields.  

  Step 2  



 After that follow the instructions in the Print Merge Wizard to create Merge 

Fields.   

How to Publish in the Web  

To Publish in the Web  

  To publish the Corel Draw files and objects to HTML, you can set the document 

elements to be Web-compatible.   

 Select the settings that you want, and check the pre-flight issues.  

 

How to Save a Document as a PDF file 

To Save a Document as a PDF file  

 Step 1  

 At the beginning, you will need to select the File tab from the menu bar and 

select Publish to PDF a shown as the picture above.  

 Step 2  

 Choose one selection from the PDF style list box.  

 Step 3  

 After that click the drive and folder where you want to save the PDF file to.  



 Step 4  

 Finally, type a filename for this file.  

How to Access to the Drawing  

Information  

To Access to the Drawing Information  

 

You can access to the drawing information, such as File name and location, Number of 

pages,layers, page size in a drawing, resolution, number of objects, number of points… 

etc as shown as  

the image above. You will be able to save or print the Drawing Information.   

Click on „Close‟ button if you want to close the Information window.  

 

LESSON 3. Working Corel Draw Pages  

How to Duplicate an Object  

To Duplicate an Object  

 

 Step 1  



 First of all, you have to select an object that you want to duplicate or make a 

second copy.  

 Step 2  

 Click Edit tab from the menu bar and choose Duplicate a shown as the picture 

above.  

 Step 3  

 - This will duplicate the selected object in the drawing.  

     How to Clone an Object  

To Clone an Object  

 

 You can create a copy of an object that is linked to the original object. All changes to 

the original object will be reflected automatically in the clone.  

 Step 1  

!"At the beginning, you have to select an object that you want to clone.  

 Step 2  

!"Then select Edit tab from the menu bar and choose Duplicate.  

How to Insert an Embedded Object  

To Insert an Embedded Object  

 

Step 1  

!"Click on the Edit tab from the menu bar and choose Insert Internet Object followed 

by Embedded file.  

Step 2  

!"You have to enable the Create option from the File option.  



Step 3  

!"Then click on the Browse button.  

Step 4  

!"Type in a filename.  

Step 5  

!"Then, click Insert button to insert the object.  

How to Create Web-enabled Objects  

To Create Web-enabled Objects  

 

You can create web-enabled objects for viewing optima in browsers, such as:  

Simple Button  

Submit Button  

Reset Button  

Radio Button  

Check Box  

Text Edit Field  

Text Edit Box  

Popup Menu  

Options List  



 However, you can also convert text to a Web compatible format so that it can be 

edited in a browser.  

How to Create Bar Codes  

To Create Bar Codes  

  You can create a bar codes by using the Barcode Wizard Encodes as shown as the 

image below.  

  Step 1  

!"Click on the Edit tab from the menu bar and choose Insert Bar Code.  

!"After that choose a bar code format from the standard formats list box.  

 

Step 2.  

!"Type in the characters that you want to encode in the text box and click Next.  

 

 

How to View in Different Modes  

To View in Different Modes  

You will need to select the View tab and click one of the following modes:  



 

Simple wire-frame displays an outline of the drawing by hiding fills, extrusions, 

contours, dropshadows, and intermediate blend shapes. „Normal‟ displays a drawing 

that contains high-resolution bitmapped images.  

How to Work with Rulers  

To Work with Rulers  

The rulers let you measure the size and position of the objects in your drawing.  

 

Check on the „Rulers‟ to display the size and position of the object for a precise 

drawing.  

How to Work with Grid  

To Work with Grid  

You have to click on the View tab from the menu bar and select Grid as shown in the 

image below.  

 

The grid is a series of intersecting dashed lines or dots, which you can use to precisely 

align and position objects in the drawing window.  

How to Add a Page  

To Add a Page  



 

Step 1  

!"At the beginning, you have to click on the Layout tab from the menu bar and choose 

Insert page.  

Step 2  

!"Key in the number of pages that you want to insert as shown as the image above.  

Step 3  

!"This will add new page(s) to the current drawing.  

How to Rename a Page  

To Rename a Page  

 

Step 1  

!"You will need to select the Layout tab from the menu bar and select Rename page.  

Step 2  

!"Type in the name of the page that you want to give.  

Step 3  

!"This will rename the page in the current drawing.  



How to Delete a Page  

To Delete a Page  

Step 1  

!"First of all, you have to click on the Layout tab from the menu bar and select Delete  

Page.  

Step 2  

!"Then, type the number of the page that you want to delete.  

Step 3  

!"This will delete the selected page from the current drawing.  

How to Re-arrange the Order of  

Pages  

To Re-arrange the Order of Pages  

Step 1  

!"Click on the View tab from the menu bar and choose Page Sorter View.  

 

Step 2  

!"After that click and drag a page to its new location.  

Step 3  

!"This will re-arrange the pages in order inside the current drawing.  

How to Zoom in and out of a Drawing  

To Zoom in and out of a Drawing  

 



Step 1  

!"You can work with this zooming option by opening the Zoom fly-out, or click the 

Zoomtool.  

Step 2  

!"You can zoom in (look nearer) the drawing by double-clicking on the drawing.  

Step 3  

!"Right click on the mouse button to zoom out (look farther away) from the drawing.  

How to Pane in the Drawing Window  

To Pane in the Drawing Window  

Step 1  

!"At the beginning, you have to click on the Hand tool at the zoom fly-out.  

Step 2  

!"Drag in the drawing window until the location you want the area to be displayed.  

 

How to Go to a Specific Page in the  

Drawing  

To Go to a Specific Page in the Drawing  

 



You can go to a specific page in the drawing by clicking on one of the following 

buttons:  

1.  First page - moves to the first page  

2.  Back one - moves back one page  

3.  Page number - display the current page number of total pages  

4.  Forward one - moves forward one page  

5.  Last page - moves to the last page  

How to Preview the Selected Objects  

To Preview the Selected Objects  

Step 1  

!"First of all, you have to click on the objects that you want to preview.  

Step 2  

!"Then, click on the View tab from the menu bar and choose Preview Selected Only.  

Step 3  

!"Then click on the View tab from the menu bar and choose Full-Screen Preview 

asshown as the image below.  

 

How to Specify the Preview Mode  

To Specify the Preview Mode  

Step 1  

!"At the beginning, you have to click on the Tools tab from the menu bar and choose 

Options.  

Step 2  



!"After that double-click on the Workspace and Display.  

Step 3  

!"Finally, you have to enable the normal view or enhanced view.  

 

How to View the Facing Pages  

To View the Facing Pages  

Step 1  

!"First, you will need to select the Layout menu followed by Page Setup in the menu.  

Step 2  

!"Then, click Layout in the list of categories.  

Step 3  

!"Choose Left side-starts the document on a left-facing page, or Right side-starts 

thedocument on a right-facing page  

 

LESSON 4. Use color with certainty 



CorelDRAW Graphics Suite X10 makes it easierthan ever to achieve accurate color 

representationevery step of the way. Whether you‟re importinga client‟s mock-up, 

working with previousdesigns, or sending a project to a print shop or 

manufacturing facility, you can be certain thatyour colors are true. 

Document/Image palettes: With bothCorelDRAWX10  acustom color palette is 

automatically created onthe fly for each design project. The palette issaved with the 

file, which gives you quick accessto this project‟s colors in the future. 

 

 
A custom color palette is created on the fly for each project. 

 

Default Color Management Settingsdialog box: For CorelDRAW Graphics 

Suite X10,the color management engine has beencompletely redesigned. The new 

Default ColorManagement Settings dialog box lets you setdefault color profiles, 

policies, and renderingintents for each application. This new approachhelps you easily 

achieve accurate colorrepresentation while also providing greatercontrol for more 

advanced users. 

 



 
CorelDRAW Graphics Suite X10 features a completely 

redesigned color management engine. 

 

 

Give it a try 

Exploring the default color managementsettings 

1 In CorelDRAW X10, click Tools � ColorManagement � Default Settings. 

2 In the Default Color ManagementSettings dialog box, note the Description 

section. 

As you point to each control, new informationabout that control is provided. 

 

Document Color Settings dialogbox: With the introduction of the 

DocumentColor Settings dialog box, you can adjust colorsettings that apply only to the 

current document.These document-specific settings override thedefault application 

settings while you are workingon that file. 

 

Primary Color Mode setting: Whilecontinuing to support RGB, CMYK, and 

grayscaleobjects within the same document, CorelDRAWX10 provides a new Primary 

Color Mode setting,which governs the default color mode on exportand the default 

palette colors (RGB or CMYK). 

Color Proof Settings:All color proof settings are grouped within asingle docker, 

which lets you save presets andprepare artwork for various output devices 

moreefficiently. The docker helps you save time byproviding a list of output devices 

which you canchoose from to preview the output. Whenseeking approval from clients, 

you can easilyexport soft proofs and print hard proofs from thedocker. 

 



 
 

You can now proof colors as you go. 

 

Color sampling options: The additionof the Eyedropper tool to various color 

dialogboxes lets you conveniently sample and matchcolors from a document without 

closing thedialog box. The Eyedropper tool is also available 

on color palettes, as well as in color pickers onthe property bar. 

 
 

You can now sample color from within certain dialog boxes. 

 

 

Enhanced! Application of sampled color:When you sample color with the Eyedropper 

toolin CorelDRAW X10, the Apply Color mode isautomatically activated so that you 

canimmediately apply the sampled color to another 

object. You can also drag a color directly fromone object to another. 

 



 
 

You can now apply color immediately after sampling. 

 

Give it a try 

 

Applying sampled color 

1 In CorelDRAW X5, click File � Open. 

2 Browse to the Press Materials � Reviewer‟sGuide � Sample Files folder and 

double-clickthe filename leaf - apply color.cdr. 

3 In the toolbox, click the Color Eyedroppertool. 

4 Click anywhere on the leaf to select a color.Note how the new tooltip includes the 

colorvalues for the color that you‟re hovering over. 

5 Click another object to apply the sampled color. 

 

 

Enhanced! Hex color values: The suite nowprovides multiple options for viewing 

hexadecimal (hex) color values and lets youchoose colors by using their hex value. 

Webdesigners often specify colors in standard hexformat, which ensures consistent 

colorrepresentation. With CorelDRAW X5, you canview hex values in the Uniform 

Fill dialog box, inthe Eyedropper tooltip, in the Color docker, and 

on the status bar. With Corel PHOTO-PAINT X5,hex values appear in the Eyedropper 

tooltip, inthe Info docker, and on the status bar. 

 

Output with ease 

 

With its industry-leading file format compatibility,CorelDRAW Graphics Suite X5 

provides theflexibility today‟s designers need for outputtingtheir work. The same 

design may be needed forWeb banners, printed ads or brochures, and 

T-shirts, billboards, or digital signs. 



New! Collect for Output option: The newCollect for Output option helps you gather 

fonts,color profiles, and other file information, makingit easier to share your work with 

a print serviceprovider. 

Enhanced! Web graphics: The suite nowprovides optimization filters that produce 

consistent, high-quality Web output. In addition,more comprehensive transparency 

controls letyou easily manipulate transparency on the fly. 

 

 

 
 

You can fine-tune your Web output while 

previewing the changes in real time. 

LESSON 5.Working With Various Shapes  

How to Draw a Calligraphic Line  

To Draw a Calligraphic Line  

Step 1  

!"You have to click on the Artistic Media tool at the Curve fly-out.  

Step 2  

!"Then, click the Calligraphic button on the property bar.  

Step 3  

!"Type in the values in the Calligraphic angle box.  

Step 4  

!"Drag until the line to the shape that you satisfied.  



 

 

How to Draw a Preset Line  

To Draw a Preset Line  

 

Step 1  

!"At the beginning, you have to click on the Artistic Media tool at the Curve fly-out.  

Step 2  

!"Then, click on the Preset button on the property bar.  

Step 3  

!"Choose a preset line shape from the Preset stroke list list box.  

Step 4  

!"Drag the line to the shape that you want.  

How to Draw a Pressure-Sensitive Line  

To Draw a Pressure-Sensitive Line  

Step 1  



!"At the beginning, you will need to select the Artistic Media Tool again at the Curve 

fly-out.  

Step 2  

!"Then, click Pressure button on the property bar.  

Step 3  

!"After that drag until the line to the shape that you want.  

 

How to Draw a Straight Line  

To Draw a Straight Line  

!"You have to click on the Freehand tool at the Curve fly-out and click the location 

whereyou want to start the line.  

!"Finally, click where you want to end it.  

 

How to Draw a Straight Bezier Lines  

To Draw a Straight Bezier Lines  

!"Open the Curve fly-out, and click on the Bezier tool a shown as the picture below.  

!"Clicks where you want to start the line, and click where you want to change the 

direction,then press space bar to finish the line.  



 

How to Draw a Rectangle  

To Draw a Rectangle  

!"To do so, click the Rectangle tool, and drag in the drawing window until it becomes 

therectangle that you want.  

 

How to Round the Corners of a Rectangle  

To Round the Corners of a Rectangle  

Step 1  

!"You have to click on the Shape tool at the Shape fly-out a shown as the picture 

below.  

Step 2  

!"Then, click a rectangle and drag a corner node along the outline of the shape.  

 

How to Draw an Arc  

To Draw an Arc  

!"First of all, you have to click on the Shape tool at the Shape fly-out.  

!"Click the node of the ellipse or circle, and drag outside the shape's perimeter.  



 

How to Draw an Ellipse  

To Draw an Ellipse  

!"First, you will need to select the Ellipse tool, and drag in the drawing window until 

the  

ellipse becomes to the shape that you want.  

 

How to Draw Polygon  

To Draw Polygon  

!"Click the Polygon tool at the Object fly-out, and drag in the drawing window until 

thepolygon become the size that you want. This is shown at the image below.  

 

How to Reshape a Polygon  

To Reshape a Polygon  

!"To do so, you ought to change the number of sides of a polygon or number of points 

on a star.  



!"Select a polygon and type in a value in the Number of points on the field as shown 

below:  

 

How to Draw a Spiral  

To Draw a Spiral  

Step 1  

!"At the beginning, you have to click on the Spiral tool at the Object fly-out.  

Step 2  

!"Then, type in the values in the Spiral revolutions box on the property bar.  

Step 3  

!"On the property bar, click Symmetrical Spiral or Logarithmic Spiral buttons.  

Step 4  

!"Drag diagonally in the drawing window until the spiral becomes the required size.  



 

How to Draw a Grid  

To Draw a Grid  

Step 1  

!"To draw a Grid, click on the Graph Paper tool at the Object fly-out.  

Step 2  

!"After that type in the values in the top and bottom portions of the graph paper 

columnsand rows as shown as the image.  

Step 3  

!"Then, position the cursor where you want the grid to appear and drag diagonally.  

 

How to Add Text to a Pre-defined  

Form To Add Text to a Pre-defined Form  



 

Step 1  

!"To add text, you have to click on the Text tool.  

Step 2  

!"Then, position the cursor inside the shape's outline until it changes to a Text cursor 

box.  

Step 3  

!"Finally, type the format of the font inside the shape. 

How to Change Pre-defined Shape by using its Glyphs  

To Change Pre-defined Shape by using its Glyphs  

Step 1  

!"To do so, you will need to select a shape with a glyph.  

Step 2  

!"Then, drag the glyph until it becomes the form that you want.  

 

How to add Text to a Pre-defined  

Form To add Text to a Pre-defined Form  



 

Step 1  

!"You will need to select the Text tool and position the cursor inside the shape's 

outlineuntil it changes to a Text cursor box a shown as the picture above.  

Step 2  

!"Then, type and format the font inside the shape.  

How to draw a Pre-defined Shape  

To draw a Pre-defined Shape  

 

Step 1  

!"Open the Perfect shapes fly-out, and click one of the tools.  

Step 2  

!"Then, click a shape at perfect shapes picker.  

Step 3  

!"Drag in the drawing window until it becomes the shape and the size that you want.  

Working With Objects  

How to Deselect the Objects  

To Deselect the Objects  

 



!"To deselect objects, you have to click on the Pick tool, and click to a blank space in 

thedrawing window to deselect a single object.  

!"Hold down SHIFT and click the object by using the Pick tool to deselect a single 

object inmultiple selected objects.  

How to select Multiple or an Object  

To select Multiple or an Object  

!"Click an object with the Pick tool to select an object.   

!"Hold down SHIFT, and click each object that you want to select the multiple objects.  

 

How to Position an Object  

To Position an Object  

 

 

Select an object and type a value in the x-axis and y-axis stacked boxes as shown at the 

pictureabove.  

How to Position an Object by using a  

Different Anchor Point  

To Position an Object by using a Different Anchor Point  



 

Step 1  

!"First of all, you have to click on an object and select Window followed by Dockers.  

!"After that you ought to choose Transformations Then, select Positions.  

Step 2  

!"You have to disable the Relative position check box and type in the value for 

horizontaland vertical.  

Step 3  

!"Finally, click on Apply.  

How to Set the Nudge Distances  

To Set the Nudge Distances  

Step 1  

!"At the beginning, you have to click on the Tools tab from the menu bar and 

selectOptions.  

Step 2  

!"Double-click the Document and click Rulers.  

!"Type in a value for Nudge, Super nudge or the Micro nudge a shown as the 

pictureabove.  



 

 

How to Scale an Object  

To Scale an Object  

Step 1  

!"You have to select an object first and click the Window tab from the menu bar and 

select Dockers.  

!"After that click Transformations followed by Scale.  

Step 2  

!"Then type in the horizontal and vertical values.  

 

How to Control the Size of an Object  



To Control the Size of an Object  

You can drag any of the corner selection handles to size a selected object.  

 

How to Skew an Object  

To Skew an Object  

Step 1  

!"First of all, you have to click on an object.  

!"Then, select Window tab from the menu bar and select Dockers.   

!"After that choose Transformations followed by Skew.  

Step2  

!"Type in the horizontal and vertical values.  

 

How to Stretch an Object  

To Stretch an Object  

Step 1  

!"You will need to select an object. Click on the Window tab from the menu bar 

andchoose Dockers. Then choose Transformations followed by Size.  



Step 2  

!"After that enable the non-proportional option if you want to change the object's 

anchorpoint.  

Step 3  

!"Type a value in the width and height boxes as shown at the picture below.  

 

How to Mirror an Object  

To Mirror an Object  

Step 1  

!"At the beginning, you will need to select an object and click on the Window tab from 

the menu bar and choose Dockers. After that choose Transformation followed by 

Scale.  

Step 2  

!"Click horizontal or vertical buttons to flip the object left to right or top to bottom.  

 



 

 

 

 

How to Rotate an Object  

To Rotate an Object  

 

 

Step 1  

!"To rotate an object, you have to select an object that you want to rotate. Click on the  

Window tab from the menu bar and choose Dockers followed by Transformations.  

Then, click Rotate.  

 

Step 2  

!"After that type an Angle value in the box.  

 

Step 3  

!"Type values in horizontal and vertical coordinates boxes to rotate the object.  

 

 



 

 

 

 

 

 

How to Rotate an Object around a  

Ruler Coordinate  

To Rotate an Object around a Ruler Coordinate  

 

 

 

 



 

 

Step 1  

!"First, you will need to select an object and click the Free Transform at Shape edit fly- 

out.  

 

Step 2  

!"Type in the values in horizontal or vertical ruler or both.  

 

Step 3  

!"Now, type an Angle value to rotate the object.  

 

 

 

 

 

How to Change the Order of an  

Object  

To Change the Order of an Object  

 

You can change the stacking order of objects on a layer by sending objects to the front, 

back,  

behind or in front of other objects.  



 

 

 

 

 

Step 1  

!"You will need to select an object.  

 

Step 2  

!"Select Arrange tab from the menu bar and select Order.  

!"Click on the order to arrange the object.  

 

 

 

 

How to Reverse the Order of Multiple  

Objects  

To Reverse the Order of Multiple Objects  

 

 



 

 

 

Step 1  

!"First of all, you have to click on the objects that you want to reverse.  

 

Step 2  

!"After that click on the Arrange tab from the menu bar and select Order followed by  

Reverse Order as shown at the picture above.  

 

 

 

 

How to Group the Objects  

To Group the Objects  

 

 

Step 1  

!"First of all, you have to click on the objects that you want to group.  

 

Step 2  

!"Then, click on the Arrange tab from the menu bar and choose Group.  



 

 

 

 

 

 

 

 

How to Combine the Objects  

To Combine the Objects  

 

 

Step 1  

!"At the beginning, you have to click on the objects that you want to combine.  

 

Step 2  

!"Then click Arrange tab from the menu bar and select Combine.  

 

 

 

 

 



 

 

 

How to Ungroup the Objects  

To Ungroup the Objects  

 

Step 1  

!"To ungroup objects, you have to select the grouped object or all the grouped objects.  

 

Step 2  

!"Then, click Arrange tab from the menu bar and choose Ungroup.  

 

 

 

 

 

 

 

How to Align a Series of Objects  

To Align a Series of Objects  

 

 



Step 1  

!"First of all, you have to select the objects that you want to align.  

!"Then, click on the Arrange tab from the menu bar and choose Align and Distribute.  

 

Step 2  

!"After that, click the Align tab and enable the check boxes that correspond to the  

horizontal and vertical alignment as shown at the picture below.  

 

Step 3  

!"Enable Edge of page or Center of page to align to grid at the align area.  

 

 

 

 

 

How to Snap Objects  

To Snap Objects  

 



 

 

 

Step 1  

!"At the beginning, you will need to select the objects that you want to snap.  

 

Step 2  

!"After that, click the View menu and select Snap to Objects.  

 

 

 

How to Revert to a Clone Master  

To Revert to a Clone Master  

 

 

Step 1  

!"To do so, you are prompted to right-click a modified clone, and click Revert To 

Master  

as the picture shown.  

 

Step 2  

!"Enable one of the clones at check boxes, like Clone Fill, to restore the master fill  

attributes.  



 

 

 

 

 

 

 

 

How to Blend Objects  

To Blend Objects  

 

 

 

 

You can blend along a straight line.  

Open the Interactive tools fly-out, and click the Interactive Blend tool as shown at the 

image  

above.   

After that you have to select the first object and drag over the second object.  



 

 

 

 

How to Start or End an Objects in a  

Blend  

To Start or End an Objects in a Blend  

 

 

 

 

You can select the start or end object.  

First of all, you have to select a blend. Click on the Start and end object properties 

button  

followed by the Show Start, or Show End button.  

 

LESSON 6. Working With Special Effects. 

How to Create a New Spray List  

To Create a New Spray List  

 

 



 

 

 

Step 1  

!"You will need to select the Effects menu and click Artistic Media.   

!"After that choose an object or a set of grouped objects.  

 

Step 2  

!"Click on the Save button in the Artistic Media Docker window.  

 

 

 

 



 

How to Offset the Lines that you  

Spray  

To Offset the Lines that you Spray 

 

 

Step 1  

!"First of all, you have to select a spray list and click on the Offset button.  

 

Step 2  

!"Then, enable the Use Offset check box to offset the objects from the path of the line  

sprayed and choose an offset direction from the Offset direction.  

 

 

 

 

 

 

How to Draw a Callout  



To Draw a Callout  

 

 

 

 

Step 1  

!"To draw a callout, you are prompted to select Dimension tool at the Curve fly-out.  

 

Step 2  

!"After that click the Callout tool. Then click on the place where you want the first 

callout  

segment to start.  

!"Click on the second segment to start and select the place to enter the callout text.  

!"Finally, type in the text that you want.  

 

 

 

How to Draw a Dimension Line  

To Draw a Dimension Line  

 



 

 

!"You have to click the Dimension tool at the Curve fly-out.  

!"Then, click the Vertical, Horizontal, or Slanted Dimension tool buttons to draw a  

dimension line.  

!"Select the start and end points of the dimension line and click where you want to 

place  

the dimension text.  

 

 

 

 

How to Set the Dimension Units  

To Set the Dimension Units  

 

 

 

 



 

First of all, you have to select a dimension line and click on the Show Units for 

Dimension  

button.   

Then, choose the options from the following list boxes:  

!"Dimension style list box  

!"Dimension precision list box  

!"Dimension units list box  

 

 

 

 

 

How to Copy a Distortion  

To Copy a Distortion  

 

 

 

 

 



Step 1  

!"At the beginning, you will need to choose the object, which you want to copy as a  

distortion.  

 

Step 2  

!"Click on the Effects tab from the menu bar and choose Copy Effect followed by  

Distortion From.  

 

Step 3  

!"Finally, you have to click on a distorted object to complete.  

 

 

 

 

 

 

How to Distort an Object  

To Distort an Object  

 

 

Step 1  

!"First of all, you have to click the Interactive Distortion tool in the Tool fly-out.  

 



Step 2  

!"After that click Push and pull, or Zipper, or Twister distortion buttons and specify the  

settings.  

 

Step 3  

!"Click on the place where you want to place the center of distortion.  

 

 

 

 

 

 

 

 

How to Remove a Distortion  

To Remove a Distortion  

 

!"At the beginning, you have to select a distorted object that you wish to remove.  

!"Then, click on the Effects menu and choose Clear distortion as shown at the picture  

below.  

 



 

 

 

 

 

 

 

 

How to Change the Mapping Mode  

To Change the Mapping Mode  

 

 

 

 

 

Step 1  

!"You are prompted to click the Interactive Envelope tool at the Interactive tools fly-

out.  



 

Step 2  

!"Then, click an object with an envelope. Choose once from the Mapping mode list 

box.  

 

Step 3  

!"After that drag the nodes or the nodes' control points.  

 

 

 

 

 

How to Create a Rollover Object  

To Create a Rollover Object  

 

 

Step 1  

!"To create a Rollover object, you have to select an object to be created.  

 

Step 2  

!"Then choose the Effects tab from the menu bar and choose Rollover followed by 

Create  

Rollover.  

 



 

 

 

 

 

 

How to Edit a Rollover Object  

To Edit a Rollover Object  

 

 

Step 1  

!"First of all, you have to select an object that you wish to edit and then click the 

Effects  

tab from the menu bar and choose Rollover. After that click Edit Rollover.  

 

Step 2  

!"Then, specify attributes of the object.  

!"Click on the Effects menu and choose Rollover followed by Finish Editing Rollover.  

!"A drawing in which you are editing a rollover cannot be closed. You must finish 

editing  

the button before that.  

 



 

 

 

 

How to Apply a Uniform Fill  

To Apply a Uniform Fill  

 

 

Step 1  

!"At the beginning, you have to select an object that you can apply a Uniform Fill 

effect.   

!"Then click the Interactive Fill tool at the Interactive Fills fly-out.  

 

Step 2  

!"Choose the Uniform Fill from the Fill Type list box.  

 

 



 

 

 

 

 

 

 

How to Apply a Mesh Fill to an Object  

To Apply a Mesh Fill to an Object  

 

 



 

 

 

Step 1  

!"You will need to choose an object to apply a Mesh Fill effect.  

 

Step 2  

!"Click the Interactive Mesh Fill tool at the Interactive fill fly-out.  

 

Step 3  

!"Type the number of columns or rows in the top portion or bottom portion of the Grid 

size  

box and press the Enter key.  

 

Step 3  

!"Then you can adjust the grid nodes on the object.  

How to Apply Special Effects to  



Bitmapped Images  

To Apply Special Effects to Bitmapped Images  

 

The special effects that can apply to a wide range of bitmapped images:  

 

 

a.  The three-dimensional special effect can create the illusion of three-dimensional  

depth.  

b.  The art strokes effect can apply hand-painted techniques.  

c.  The blur effects make an image to simulate gradual change, movement, or  

speckling.  

 

 

 

How to Apply a Special Effect  

To Apply a Special Effect  

 

 

 

 



The picture at above shows the type of available Special Effects in Corel Draw 10, 

such as 3D  

Effects, Art Strokes, Blur, Color Transform, Contour, Creative, Distort, Noise and 

Sharpen  

effects.  

To apply a special effect on a picture or object, choose the object. Then select a Special 

Effect  

type from the list above.   

You can then adjust any special-effect settings to the selected object.  

 

How to Apply a Color or Tone Effect  

To Apply a Color or Tone Effect  

 

 

 

 

 

Step 1  

!"You will need to select a bitmapped image.  

 

Step 2  

!"Then click the Effects menu and choose Adjust.   

!"After that click a color or tone effect to specify any settings.  



 

 

How to Add an Artistic Text  

To Add an Artistic Text  

 

 

 

 

 

Click any place in the drawing window by using the Text tool.  

You can then begin to type in the text that you want on the drawing. Apply Artistic text 

effect on  

the text when you need.  

 

How to Fit the Text to a Path  

To Fit the Text to a Path  

 

!"You will need to select the path by using the Pick tool.  

!"Then, click on the Text tab from the menu bar and choose Fit Text To Path.  

!"Type along the path. The text will then fit to the path.  



 

 

 

Lesson7. Adobe Photoshop CS5 

1. Begin by opening Adobe Photoshop CS5. 

On a PC, click Start > Programs > Adobe > Photoshop CS5, or click on the shortcut on the desktop. 

On a Mac, click Macintosh HD > Applications > Adobe Photoshop CS5 > Photoshop CS5 shown in 
Figure 1, or click the icon in the Dock. 

 



 

Figure 1. Navigation to Photoshop CS5 on a Mac 

Setting up the document 

Setting up your document correctly from the start will make your job much easier as you work through your 
project. This will require some advanced planning. For example, if your fnal output will be a brochure, you may 
need to set up your document to be horizontal and double-sided. 

To create a new document, click File > New. This will open the Document Setup dialog box (Figure 2). 



 

Figure 2. Document Setup dialog box 

Here you will be able to name your fle, set up the correct page size, and orientation for your document. Options 
include, but are not limited to: 

Page Size and Orientation 

Change the page size by typing in new values for width and height. Page size represents the fnal size you want after 
bleeds or trimming other marks outside the page. In the Preset dropdown menu you can fnd such common sizes 
as letter, legal, tabloid, etc. Typing in exact values for Height and Width gives you more control over the size and 
orientation of your page. 

Resolution 

Resolution is the number of pixels on a printed area of an image. The higher the resolution, the more pixels there 
are on the page, the better the quality of the image. However, high resolution increases the size of the fle. The 
standard recommended resolution for printed images is 150-300, for Web im ages it is 72. 

Color Mode 

Choose a color mode that will best ft your project. For example, when making a graphic for a web site choose 
RGB. When making an image for print choose CMYK. 

Background Contents 

Choose the background: white, color or transparent. When you have entered all of your document settings click 
Ok. 

Opening an image from a disk 



If the image you have is saved on a disk, select File > Open, and then navigate to the disk drive where your image is saved. 
Choose the image fle and click Open. At this point, you may want to save your image under a different name so that you 
can always have the original to fall back on in case of a mistake. To save your fle, select File > Save As and type in the 
new name of the fle in the dialogue box.. 



 

 

Figure 3. This is the layout of Adobe Photoshop interface. 

Menu Bar 

If you look at the top of the screen you will see the Menu bar which contains all the main functions of Photoshop, 
such as File, Edit, Image, Layer, Select, Filter, Analysis, 3D, View, Window, and Help. 

Toolbar 

Most of the major tools are located in the Toolbar for easy access. 

The Image 

The image will appear in its own window once you open a fle. 

Image Name 

The name of any image that you open will be at the top of the image window as shown above. 

Palettes 

2. Interface Layout 



Palettes contain functions that help you monitor and modify images. By default, palettes are stacked together in 
groups. These are the palettes that are usually visible: Color, Adjustments and Layers. If none of the palettes are 
visible, go to Window in the Menu bar and choose the palettes you need. 



3. Palettes 

Below is the description of the most commonly used palettes in Adobe Photoshop CS5. Palettes used for more 
advanced image editing will be covered in the Adobe Photoshop CS5 Tutorial -Intermediate. 

Color, Swatches, Style 

The Color palette (Figure 4) displays the current foreground and background colors and RGB values for these colors. Yo u 
can use the sliders to change the foreground and background colors in different color modes. Yo u can also choose a color 
from the spectrum of colors displayed in the color ramp at the bottom of the palette. 

 

Figure 4. Color palette 

In the Swatches palette (Figure 5) you can choose a foreground or background color and add acustomized color to the 
library. 

 

Figure 5. Swatches palette 

The Styles palette (Figure 6) allows you to view, select, and apply preset layer styles. By default, a preset style replaces the 
current layer style. Yo u can use the styles in the palette or add your own using the Create New Style icon. 
 

 

Figure 6. Styles palette 



History 

The History palette (Figure 7) stores and displays each action performed allowing you jump to any recent stage of the 
image alteration. The alterations should be created during the current working session; after saving or closing the 
document the History palette clears all the contents. Each time you apply a change to an image, the new state of that 
image is added to the palette. It is important to know that once you click on any of the previous stages, all the 
changes that were made after it will be lost. 

 

Figure 7. History palette 

Adjustments 

The Adjustment layers palette give you the ability to apply an effect to a group of layers in Photoshop, and then you can 
edit that effect later, while preserving the original layers. 

 

Figure 8. Adjustments palette 



Layers 

Layers let you organize your work into distinct levels that can be edited and viewed as individual units. Every Photoshop 
CS5 document contains at least one layer. Creating multiple layers lets you easily control how your artwork is printed, 
displayed, and edited. Yo u will use the Layers palette (Figure 6) often while creating a document, so it is crucial to 
understand what it does and how to use it. 

A) Layer Visibility -The eye shows that the selected layer is visible. Click on or off to see or to hide a layer. 

B) Layer Locking Options -Click the checkered square icon to lock Transparency; click the brush icon to lock the Image; 
click the arrow icon to lock the Position; click the lock icon to lock all options. 

C) Layer Blending Mode -Defnes how the layer’s pixels blend with underlying pixels in the image. By choosing a particular 
blending mode from the dropdown menu you can create a variety of special effects. 

D) Fill -By typing in a value or dragging the slider you can specify the transparency. Layers Palette color of the image or 
object. 

E) Opacity -By typing in a value or dragging a slider you can specify the transparency of the entire layer. 

 

Figure 9. Layer palette 



F) Layer Lock -The icon shows when the layer is locked and disappears when it is unlocked. Double-click the 
icon to unlock the layer. 

G) Layer Options Menu -Click the black triangle to see the following options: New Layer, Duplicate Layer, 
Delete Layer, Layer Properties, etc. Some of the options are presented as icons at the bottom of the Layers 
palette. 

H) Link Layers – Can be used to link layers together. 

I) Layer Styles -If a layer has a style, an “F” icon shows at the bottom of the Layers palette. Click the little black triangle to 
see style options. 

J) Layer Mask -A grayscale image, with parts painted in black hidden, parts painted in white showing, and parts painted in 
gray shades showing in various levels of transparency. 

K) Layer Set -This option helps to organize images with multiple layers. Click the icon to create a folder for several 
layers. 

L) Create New Fill or Adjustment Layer -Have the same opacity and blending mode options as image layers and can be 
rearranged, deleted, hidden and duplicated in the same manner as image layers. Click the icon and select an option to 
create a new fll or adjustment layer. 

M) Create New Layer -Click this icon to create a new layer. 

N) Delete Layer - To delete a layer, select a layer in the Layers palette and drag it to the trash can icon; or, select a layer 

and click the icon. 

 

Lesson8. Toolbox 

If you used other Adobe products, such as Illustrator or InDesign, you should be familiar with the toolbox in 
Adobe Photoshop CS5 as it shares some of the tools from these applications. If you are a new user of 
Adobe products, you should keep in mind that you might not need to use all of the tools. In this tutorial, 
only the basic tools will be discussed in depth. 

Some tools in the toolbar have additional “hidden” tools. These tools have small black triangles in the right-
hand corner. To view the “hidden” tools, click and hold down on any tool that has a black triangle in the 
corner (Figure 10). 



 

 

 Selection Tools 

Move 

 

Used to select and move objects on the page. 

Click the tool button, then click on any object on the page you wish to move. 

 

Marquee 

 

Selects an object by drawing a rectangle or an ellipse around it. 

Click the tool button, choose a rectangular or an elliptical marquee. Drag the marquee over 
the area of the image you wish to select. 

 

Lasso 

 

Selects an object by drawing a freehand border around it. 

Click the tool button, drag to draw a freehand border around the are of the image you wish 
to select. 

 

Magic Wand Selects all objects in a document with the same or similar fll color, stroke weight, stroke color, 
opacity or blending mode. By specifying the color range or tolerance, you can control what the 
Magic Wand tool selects. 

 

Crop 

 

 

Click the tool button, then click and drag the tool over the part of the image that you want to 
keep. Resize the selected area dragging the squares at the sides and corners. Click the Return/Enter 
key when your crop box is sized correctly. 



 

Eye Dropper      Takes color samples from colors on the page and displays them in the Color Boxes. 

Select the tool, click on the color in the image you wish to sample. The Color Box will display 
this color. 



 Alteration Tools 

Healing Brush        Corrects small blemishes in scanned photos. 

Select the tool, hold down the ALT key and left-click on the base color you need to heal. Then 
left-click over the blemish. 

Brush Draws brush strokes of different thicknesses and colors. 

Select the tool. Then click on the selected area, drag to draw lines. Use the Options bar to 
change the brush, mode, opacity and fow. 

 

Clone Stamp 

 

Takes a sample of an image and applies over another image, or a part of the same 
image. 

Select the tool. Hold down the ALT key and left-click on a certain point of the document 
where you want to start your copy point. Then, put your mouse over whatever part of the 
new document you want the picture to go to. Hold down the left mouse button and drag 
the mouse across the page to copy the picture. 

 

Art History 
Brush 

 

Paints over an image using the source data from a specifed history state or snapshot. Select 

the tool, specify the brush, blending mode, opacity, style, area and tolerance. 

 

Eraser Removes part of an existing path or stroke. Yo u can use the Erase tool on paths, but not on 
text. 

Select the tool, click on the part of the image you wish to erase. Drag to erase pixels. 

 

Gradient 



Applies a gradient fll to a selected part of the image or to an entire layer. 

Select an area you wish to apply gradient to, click the tool button, choose a fll in the Options 
bar, click on the starting point, and hold the mouse down and drag to the end point. 

 

Blur Blurs the sharp edges of an image. 

Select an area where you wish to apply the tool. Click the tool button and choose the brush, 
mode, and strength. Drag the brush along the edges.  



Drawing and Selection Tools 

Path Selection Selects paths and path segments. 

Select the tool, click anywhere on the path. 

 

Type Types text on a page. Every time you click the Type Tool on a new portion of the page a new 
layer will be created. 

Select the tool, click on the page and begin to type. Yo u can specify the font and size in the 
Options bar. Yo u can also resize and transform the text box by dragging the squares at the 
sides and corners. Use the Move Tool to move the text on the page. 

 

Pen 

 

Draws smooth-edged paths. 

 

Select the tool, click on the page and drag to draw a path. Click and drag the anchor points 
to modify the path. 

 

Line Shape 

 

Draws a straight line. Other shapes that are hidden in this tool are: Rounded Rectangle Tool, 
Ellipse Tool, Polygon Tool, Line Tool, and Custom Shape Tool. 

Select the tool, click and drag on the page to draw a line. 

Assiting Tools 

Hand 
 



Allows 

you to 

move 

around 

within the image. 

Select the tool, click on the spot on the page, hold the mouse button down, drag to move 
in the area. 

 



Magnify 

 



Magnifes or reduces the display of any area in your image window. 

Select the tool, choose Zoom In or Zoom Out in the Options bar, click on the area of the image you wish to magnify 
or reduce. 

Lesson9. Color Boxes and Modes 

Color Boxes The foreground color appears in the upper color selection box and represents a color that is 
currently active. The background color appears in the lower box and represents an inactive color. 

1. To change the foreground color, click the upper color selection box in the Toolbox. 

2. To change the background color, click the lower color selection box in the Toolbox. 

3. To reverse the foreground and background colors, click the Switch Colors icon (the 
arrow) in the toolbox. 

4. To restore the default foreground and background colors, click the Default Colors icon (the little 
black and white boxes) in the toolbox. 

Note: If you are using the Gradient Tool, the currently selected foreground and background colors 
will be the default colors of the gradient. 

10. Basic Image Editing 



Now that you know how to fnd your way around in the Adobe Photoshop CS5 interface and are familiar with the most 
common commands, palletes, and tools, you can start doing some basic image editing. In the next few chapters of this 
tutorial you will learn how to crop, resize, correct, and sharp/blur your images. 



11. Cropping 

Cropping is one of the most basic editing techniques that can improve your images. Cropping helps to bring out the 
most important features in your image and focus the viewers’ attention on these features. Cropping also allows you 
to make your image a standard photo size. 

There are several ways to crop images in Adobe Photoshop: 

1. Cropping with the Crop Tool 
2. Cropping to a specifc size 
3. Cropping with the Marquee Tool 

Cropping with the Crop Tool 

The Crop Tool allows you to make a precise selection of an image you wish to edit. To crop with the Crop Tool, 
follow these steps: 

1. Open the image you wish to crop (see Getting Started for detailed instructions). 
2. Select the Crop Tool from the Toolbox (see Selection Tools for location and description). 
3. Click on your image once and drag the mouse out to make a cropping border (See Figure 11). 

 

Figure 11. Cropping border 



4. Resize the border by dragging the squares at the sides and corners till you are satisfed with the way your image 
looks. 

5. Once you are completely satisfed with your cropped image, press Enter. 

Note: Yo u can also rotate your cropping border. Move the cursor outside the border, you will see how it turns into a 
double-headed arrow (Figure 12). Drag the arrows in the directions you wish to rotate your selection. 

 

Figure 12. Rotating the cropping border 

Cropping to a specifc size 

If you wish to print your digital photos or other images on standard size photo paper, you will have to crop your images 
to a specifc size, such as 8x10. To crop an image to a specifc size, do the following: 

1. Open the image you wish to crop. 
2. Select the Crop Tool from the Toolbox. 
3. In the Options bar, specify the values for Width and Height (Figure 13). 

 

Figure 13. Crop Tool Options bar 



4. Click in your image and drag the cropping border. Notice that the border is con strained -you cannot make it 
wider or longer than the specifed values (Figure 14). For example, if you entered 8 for Width and 10 for Height, 
whatever size you make the border, the area within it will ft on an 8x10 photo. 



Figure 14. Cropping to a specifc size 

5. Once you are completely satisfed with your cropped image, press Enter. 

Cropping with the Marquee Tool 

If you are in a hurry and need just a simple crop, you can use the Marquee Tool and a menu command. To crop with the 
Marquee Tool, follow the steps below: 

1. Open the image you wish to crop. 
2. Select the Rectangular Marquee Tool from the Toolbox (see Selection Tools). 



3. Click and drag the mouse to draw a marquee around the area you wish to crop (Figure 15). 



 

Figure 15. Drawing a marquee 4. In the main menu, go to 

Image > Crop (Figure 16). The image will be immediately cropped. 
 

 

Figure 16. Image > Crop 

 

 

 



 



12. Resizing

Resizing in Photoshop can help you print your images in standard photo sizes, resize and preserve the high quality of 
digital photos, and enlarge small images to a poster size. 

Resizing to a specifc size 

To resize your image to a preset size, follow the steps below: 

1. In the main menu, go to File > New. 
2. In the New dialog box, click on the Preset dropdown menu. Yo u will see several preset sizes, such as 2x3, 4x6 and 

5x7 with the preset resolution of 300 ppi (Figure 17). 

 

Figure 17. Preset size in the New dialog box 

3. Choose the size that you wish and click OK. 

Note: All the preset sizes are in portrait orientation. If you wish to resize an image with the landscape orientation, you 
need to create your own preset. To create your own size, do the following: 

1. Type in the values for Width and Height, for example 7x5. 
2. Type in your desired resolution (150 ppi for high quality prints, and 72 ppi is good for web images). 
3. Click the Save Preset button 



Resizing digital photos 

Digital photos usually have large dimensions but low resolution, 72 ppi, which effects their quality when their size is 
decreased or increased. When printed, the photos with the changed size will look pixilated. To resize the digital photos 
without loosing the quality, follow these steps: 

1. Open the digital photo you wish to resize. 
2. In the main menu, go to View > Rulers. Yo u will see the dimension of your photo (Figure 18). 

 

Figure 18. Dimensions of a digital photo 

3. In the main menu, go to Image > Image Size. 
4. In the Image Size dialog box, check the Resample Image box off (Figure 19). Type in your desired resolution 

(anything between 150 and 300 ppi). The photo is now 3.208 x 3.083 inches. 

 

Figure 19. Changing resolution 



Enlarging 

If you want to make your digital photo into a poster size image, you can do it in the Image Size dialog box. However, just 
increasing the dimensions will make the image appear blurry and pixilated. To enlarge the image without loosing the 
quality, follow these steps: 

1. Open the digital image you wish to enlarge. 
2. In the main menu, go to Image > Image Size. 
3. In the Image Size dialog box, make sure the Resample Image box is checked off and choose Bicubic Smoother 

from the dropdown box (Figure 20). 

 

Figure 20. Increasing the size by 10 percent 

4. Change the Document Size measurements to Percent. Type in 110; this will in crease the size of the image by 
10 percent (Figure 20). 



5. Continue enlarging by 10 percent till you are satisfed with the size. 



13. Correcting 

Digital cameras tend to cause various problems, such as “red eye” or “hot spots”, if you use fash, or underexposure, if 
you don’t. In Photoshop, you can correct these problems, as well as adjust the overall color of your digital photo. 

Red Eye Removal 

The digital camera fash is located right above the lens, which causes the “red-eye”; however, you can fx your photos 
easily in Photoshop. To remove the “red eye”, follow the steps below: 

1. Open a photo you wish to correct. 
2. Select the Zoom Tool from the Toolbox. Click and drag a rectangle around the eye (Figure 21). 

 

Figure 21. Red eye zoomed in 3. Make sure your 

default Foreground and Background colors are black and white. 

■j Ч 

4. Click and hold on the little black triangle of the Healing Brush Tool button and select the Red Eye Tool. 
(Figure 22). 

 
Figure 22. Red Eye Tool 



5. Click on the red part of the eye and paint, holding down the mouse button. Yo u will see how the red will 
disappear (Figure 23). 

 

Figure 23. Red eye corrected 

Hot Spot Removal 

Using a fash can also cause another problem -shiny areas on people’s faces or the fash refection in the shiny surfaces. To 
correct this problem, follow the steps below: 

1. Open the photo you wish to correct. 
2. Select the Clone Stamp Tool from the Toolbox. 
3. In the Options bar, change the Blend Mode from Normal to Darken (Figure 24). 

 

Figure 24. Setting the options for the Clone Stamp Tool 

4. Set the Opacity to 50 percent. 
5. Choose a soft-edged brush, set the diameter to 40 or 50. 
6. tHold down the Shift key and click in the clean area (without “hot spots”) to get a sample of color (Figure 

25). 

 

Figure 25. Clone Stamp selection 7. Paint over 

the “hot spot”, the light area will gradually darken (Figure 26). 

 

 



 

Figure 26. Corrected image 



Adding Flash 

If you took pictures indoors without a fash they will turn out underexposed and dark; in Photoshop, you can make 
your photos lighter. To fx underexposed photos, follow these steps: 

1. Open a digital photo you wish to correct (Figure 27). 

 

Figure 27. Underexposed photo 

2. In the main menu, go to Layers > Duplicate. In the next window, name the layer Layer 1. 
3. Make sure Layer 1 is selected in the Layers palette. In the Blending Mode drop down box, change the Blending 

Mode to Screen (Figure 28). The whole image will lighten. 

 

Figure 28. Changing the Blending Mode 



4. Keep duplicating Layer 1 till you are satisfed with the your image (Figure 29). 

 

Figure 29. Corrected photo 

Color Adjustment 

Color adjustment options in Photoshop CS5 can help you to make your digital photos look more natural. To color 
correct your images, follow these steps: 

1. Open the image you wish to correct. 
2. In the main menu, go to Image > Adjustments > Levels. Yo u will see a dialog box displaying a diagram of the 

colors in your image (Figure 30). The black triangle is for shadows, the gray is for midtones, the white is for highlights. In 
the Channels dropdown menu, you can choose between RGB, Red, Green, or Blue. These indicate whether your changes 
effect all the colors, or just one (red, green, or blue). 

 

Figure 30. Levels dialog box 



3. Make sure the Preview box is checked off. Choose the channel you wish to change and drag the triangles. 
Dragging the black triangle to the right will make the shadows in your photo darker; dragging the white triangle to the 
left will make the higlights in your photo lighter; dragging the gray triangle to the left will make the midtones in your 
photo lighter, dragging it to the right will make the midtones darker. Yo u will be able to see the changes in your 
image. 

 

Figure 31. Underexposed photo 

Figure 32. Corrected photo 



 

Remember to save your work often. Saving frequently lessens the risk of losing the work you have been doing. To save 
your Photoshop document, do the following: 

1. Click File > Save. 
2. Navigate to the place you would like your document to be saved by using the drop down menu and the 

navigation window. 
3. Enter the name of your document in the Save As text feld. 
4. Choose a format to save your project in from the Format dropdown menu. (Figure 33) 

 

Figure 33. Saving a document 

5. Click the Save button in the bottom right corner of the dialogue box. 
6. Check to make sure that your document is saved in the place you intended. 



Note: If you save your fle as PSD (default Photoshop saving format) your layers will be preserved, but the fle size will 
be large. If you save your fle as JPEG (a common image format) your layers will be fattened and become one layer. 
The fle size though will be signifcantly smaller. 

LESSON-10. The principles of Web-pages creation. HTML Basics 

Welcome to HTML Basics. This workshop leads you through the basics of Hyper Text 
Markup Language (HTML). HTML is the building block for web pages. You will learn to use 
HTML to author an HTML page to display in a web browser. 

Objectives: 

By the end of this workshop, you will be able to: 

■ Use a text editor to author an HTML document. 
■ Be able to use basic tags to denote paragraphs, emphasis or special type. 
■ Create hyperlinks to other documents. 
■ Create an email link. 
■ Add images to your document. 
■ Use a table for layout. 
■ Apply colors to your HTML document. 

Prerequisites: 

You will need a text editor, such as Notepad and an Internet browser, such as Internet 
Explorer or Netscape. 

Q: What is Notepad and where do I get it? 

A: Notepad is the default Windows text editor. On most Windows systems, click your 
Start 

button and choose Programs then Accessories. It should be a little blue notebook. 

Mac Users: SimpleText is the default text editor on the Mac. In OSX use TextEdit and 
change the following preferences: Select (in the preferences window) Plain text 
instead of Rich text and then select Ignore rich text commands in HTML files. This is 
very important because if you don't do this HTML codes probably won't work. 

One thing you should avoid using is a word processor (like Microsoft Word) for 
authoring your HTML documents. 

What is an html File? 

HTML is a format that tells a computer how to display a web page. The documents 
themselves are plain text files with special "tags" or codes that a web browser uses to 
interpret and display information on your computer screen. 

■ HTML stands for Hyper Text Markup Language 
■ An HTML file is a text file containing small markup tags 
■ The markup tags tell the Web browser how to display the page 
■ An HTML file must have an htm or html file extension 

Try It? 

Open your text editor and type the following text: 



<html> 

<head> 

<title>My First Webpage</title> 

</head> 

<body> 

This is my first homepage. <b>This text is bold</b> 

</body> 

</html> 

Save the file as mypage.html. Start your Internet browser. Select Open (or Open Page) in 
the File menu of your browser. A dialog box will appear. Select Browse (or Choose File) 
and locate the html file you just created - mypage.html - select it and click Open. Now you 
should see an address in the 



dialog box, for example C:\MyDocuments\mypage.html. Click OK, and the browser will 
display the page. To view how the page should look, visit this web page: 

http://profdevtrain.austincc.edu/html/mypage.html 

Example Explained 

What you just made is a skeleton html document. This is the minimum required 
information for a web document and all web documents should contain these basic 
components. The first tag in your html document is <html>. This tag tells your browser 
that this is the start of an html document. The last tag in your document is </html>. 
This tag tells your browser that this is the end of the html document. 

The text between the <head> tag and the </head> tag is header information. Header 
information is not displayed in the browser window. 

The text between the <title> tags is the title of your document. The <title> tag is 
used to uniquely identify each document and is also displayed in the title bar of the 
browser window. 

The text between the <body> tags is the text that will be displayed in your browser. 

The text between the <b> and </b> tags will be displayed in a bold font. 

HTM or HTML Extension? 

When you save an HTML file, you can use either the .htm or the .html extension. The .htm 
extension comes from the past when some of the commonly used software only allowed 
three letter extensions. It is perfectly safe to use either .html or .htm, but be consistent. 
mypage.htm and mypage.html are treated as different files by the browser. 

How to View HTML Source 

A good way to learn HTML is to look at how other people have coded their html pages. To 
find out, simply click on the View option in your browsers toolbar and select Source or 
Page Source. This will open a window that shows you the actual HTML of the page. Go 
ahead and view the source html for this page. 

HTML Tags 

What are HTML tags? 

■ HTML tags are used to mark-up HTML elements 
■ HTML tags are surrounded by the two characters < and > 
■ The surrounding characters are called angle brackets 
■ HTML tags normally come in pairs like <b> and </b> 
■ The first tag in a pair is the start tag, the second tag is the end tag 
■ The text between the start and end tags is the element content 
■ HTML tags are not case sensitive, <b> means the same as <B> 

Logical vs. Physical Tags 

In HTML there are both logical tags and physical tags. Logical tags are designed to describe 
(to the browser) the enclosed text's meaning. An example of a logical tag is the <strong> 
</strong> tag. By placing text in between these tags you are telling the browser that 
the text has some greater importance. By default all browsers make the text appear bold 
when in between the <strong> and </strong> tags. 

../../../../../MyDocuments/mypage.html
http://profdevtrain.austincc.edu/html/mypage.html


Physical tags on the other hand provide specific instructions on how to display the text 
they enclose. Examples of physical tags include: 

■ <b>: Makes the text bold. 
■ <big>: Makes the text usually one size bigger than what's around it. 
■ <i>: Makes text italic. 



Physical tags were invented to add style to HTML pages because style sheets were not 
around, though the original intention of HTML was to not have physical tags. Rather than 
use physical tags to style your HTML pages, you should use style sheets. 

HTML Elements 

Remember the HTML example from the previous page: 

<html> 

<head> 

<title>My First Webpage</title> 

</head> 

<body> 

This is my first homepage. <b>This text is bold</b> 

</body> 

</html> 

This is an HTML element: 

<b>This text is 

bold</b> 

The HTML element begins with a start tag: <b> 

The content of the HTML element is: This text is bold 

The HTML element ends with an end tag: </b> 

The purpose of the <b> tag is to define an HTML element that should be displayed as 

bold. 

This is also an HTML element: 

<body> 

This is my first homepage. <b>This text is bold</b> 

</body> 

This HTML element starts with the start tag <body>, and ends with the end tag 
</body>. The purpose of the <body> tag is to define the HTML element that 
contains the body of the HTML document. 

Nested Tags 

You may have noticed in the example above, the <body> tag also contains other tags, 
like the <b> tab. When you enclose an element in with multiple tags, the last tag opened 
should be the first tag closed. For example: 

<p><b><em>This is NOT the proper way to close nested tags.</p></em></b> 

<p><b><em>This is the proper way to close nested tags. </em></b></p> 



Note: It doesn't matter which tag is first, but they must be closed in the proper 

order. 

Why Use Lowercase Tags? 

You may notice we've used lowercase tags even though I said that HTML tags are not case 
sensitive. <B> means the same as <b>. The World Wide Web Consortium (W3C), the 
group responsible for developing web standards, recommends lowercase tags in their 
HTML 4 recommendation, and XHTML (the next generation HTML) requires lowercase 
tags. 

Tag Attributes 

Tags can have attributes. Attributes can provide additional information about the HTML 
elements on your page. The <tag> tells the browser to do something, while the attribute 
tells the browser how to do it. For instance, if we add the bgcolor attribute, we can tell the 
browser that the background color of your page should be blue, like this: <body 
bgcolor="blue">. 



This tag defines an HTML table: <table>. With an added border attribute, you can tell 
the browser that the table should have no borders: <table border="0">. Attributes 
always come in name/value pairs like this: name="value". Attributes are always added to 
the start tag of an HTML element and the value is surrounded by quotes. 

Quote Styles, "red" or 'red'? 

Attribute values should always be enclosed in quotes. Double style quotes are the most 
common, but single style quotes are also allowed. In some rare situations, like when the 
attribute value itself contains quotes, it is necessary to use single quotes: 

name='George "machine Gun" Kelly' 

Note: Some tags we will discuss are deprecated, meaning the World Wide Web 
Consortium (W3C) the governing body that sets HTML, XML, CSS, and other technical 
standards decided those tags and attributes are marked for deletion in future 
versions of HTML and XHTML. Browsers should continue to support deprecated tags 
and attributes, but eventually these tags are likely to become obsolete and so future 
support cannot be guaranteed. 

For a complete list of tags, visit W3C.org. 

 

LESSON-11. Basic HTML Tags.Working with texts in HTML. 

The most important tags in HTML are tags that define headings, paragraphs and line breaks. 

Basic HTML Tags 
 

Tag Description 

<html> Defines an HTML document 

<body> Defines the document's body 

<h1> to <h6> Defines header 1 to header 6 

<p> Defines a paragraph 

<br> Inserts a single line break 

<hr> Defines a horizontal rule 

<!--> Defines a comment 

Headings 

Headings are defined with the <h1> to <h6> tags. <h1> defines the largest heading while <h6> defines the 
smallest. 

<h1>This is a heading</h1> 

<h2>This is a heading</h2> 



<h3>This is a heading</h3> 

<h4>This is a heading</h4> <h5>This is a 

heading</h5> <h6> This is a heading</h6> 

HTML automatically adds an extra blank line before and after a heading. A useful heading attribute is align. 



<h5 align="left">I can align headings </h5> 

<h5 align="center">This is a centered heading </h5> 

<h5 align="right">This is a heading aligned to the right </h5> 

Paragraphs 

Paragraphs are defined with the <p> tag. Think of a paragraph as a block of text. You can use the align attribute 
with a paragraph tag as well. 

<p align="left">This is a paragraph</p> 

<p align="center">this is another paragraph</p> 

Important: You must indicate paragraphs with <p> elements. A browser ignores any indentations or blank 
lines in the source text. Without <p> elements, the document becomes one large paragraph. HTML 
automatically adds an extra blank line before and after a paragraph. 

Line Breaks 

The <br> tag is used when you want to start a new line, but don't want to start a new paragraph. The <br> tag 
forces a line break wherever you place it. It is similar to single spacing in a document. 

 

This Code Would Display 

<p>This <br> is a para<br> graph 

with line breaks</p> 
This 

is a para 

graph with line breaks 
The <br> tag has no closing tag. 

Horizontal Rule 

The <hr> element is used for horizontal rules that act as dividers between sections, like this: 

The horizontal rule does not have a closing tag. It takes attributes such as align and width. For instance: 
 

This Code Would Display 

<hr width="50%" align="center">           ------------------------------- 

 

Comments in HTML 

The comment tag is used to insert a comment in the HTML source code. A comment can be placed anywhere in the 
document and the browser will ignore everything inside the brackets. You can use comments to write notes to 
yourself, or write a helpful message to someone looking at your source code. 

 

This Code Would Display 

<p> This html comment would <!-- This This HTML comment would be displayed like 

is a comment --> be displayed like 

this. this.</p> 



Notice you don't see the text between the tags <!-- and -->. If you look at the source code, you would see the 
comment. To view the source code for this page, in your browser window, select View and then select Source. 



Note: You need an exclamation point after the opening bracket <!-- but not before the closing bracket -
->. 

HTML automatically adds an extra blank line before and after some elements, like before and after a paragraph, 
and before and after a heading. If you want to insert blank lines into your document, use the <br> tag. 

Try It Out! 

Open your text editor and type the following text: 

<html> 

<head> 

<title>My First Webpage</title> 

</head> 

<body> 

<h1 align="center">My First Webpage</h1> 

<p>Welcome to my first web page. I am writing this page using a text editor 

and plain 

old html.</p> 

<p>By learning html, I'll be able to create web pages like a pro....<br> 

which I am of course.</p> 

</body> 

</html> 

Save the page as mypage2.html. Open the file in your Internet browser. To view how the page should look, visit 
this web page: http://profdevtrain.austincc.edu/html/mypage2.html 

Other HTML Tags 

As mentioned before, there are logical styles that describe what the text should be and physical styles which 
actually provide physical formatting. It is recommended to use the logical tags and use style sheets to style the text 
in those tags. 

Logical Tags Physical Tags 
 

Tag Description 

<abbr> Defines an abbreviation 

<acronym> Defines an acronym 

<address> Defines an address element 

<cite> Defines a citation 

<code> Defines computer code text 

<blockquote> Defines a long quotation 

<del> Defines text 

<dfn> Defines a definition term 

<em> Defines emphasized text 

<ins> Defines inserted text 

<kbd> Defines keyboard text 

Tag Description 

<b> Defines bold text 

<big> Defines big text 

<i> Defines italic text 

<small> Defines small text 

<sup> Defines superscripted text 

<sub> Defines subscripted text 

<tt> Defines teletype text 

<u> Deprecated. Use styles instead 

http://profdevtrain.austincc.edu/html/mypage2.html


<pre> Defines preformatted text 

<q> Defines a short quotation 

<samp> Defines sample computer code 

<strong> Defines strong text 

<var> Defines a variable 

Character tags like <strong> and <em> produce the same physical display as <b> and <i> but are more 
uniformly supported across different browsers. 



Some Examples: 

The following paragraph uses the <blockquote> tag. In the previous sentence, the blockquote tag is enclosed in 
the <samp> Sample tag. 

We the people of the United States, in order to form a more perfect Union, establish Justice, insure 
domestic Tranquility, provide for the common defense, promote the general Welfare, and secure the 
Blessings of Liberty to ourselves and our Posterity, do ordain and establish this Constitution for the United 
States of America. 

Although most browsers render blockquoted text by indenting it, that's not specifically what it's designed to do. It's 
conceivable that some future browser may render blockquoted text in some other way. However, for the time 
being, it is perfectly safe to indent blocks of text with the <blockquote>. 

This Code 

<abbr title="World Wide Web">WWW</abbr> 

Would Display 

WWW 

When you hold your mouse pointer over the WWW, text in the title attribute will appear in. 

HTML Character Entities 

Some characters have a special meaning in HTML, like the less than sign (<) that defines the start of an HTML tag. If 
we want the browser to actually display these characters we must insert character entities in place of the actual 
characters themselves. 

The Most Common Character Entities: 
 

Result Description Entity Name Entity Number 

 non-breaking space &nbsp; &#160; 

< less than &lt; &#60; 

> greater than &gt; &#62; 

& ampersand &amp; &#38; 

" quotation mark &quot; &#34; 

' apostrophe &apos; (does not work in IE) &#39; 

A character entity has three parts: an ampersand (&), an entity name or an entity number, and finally a semicolon 
(;). The & means we are beginning a special character, the ; means ending a special character and the letters in 
between are sort of an abbreviation for what it's for. To display a less than sign in an HTML document we must 
write: &lt; or &#60; The advantage of using a name instead of a number is that a name is easier to remember. The 
disadvantage is that not all browsers support the newest entity names, while the support for entity numbers is very 
good in almost all browsers. 

Note: Entities are case sensitive. 

Non-breaking Space 

The most common character entity in HTML is the non-breaking space &nbsp;. Normally HTML will truncate spaces 
in your text. If you add 10 spaces in your text, HTML will remove 9 of them. To add spaces to your text, use the 
&nbsp; character entity. 

 



This Code Would Display 

<p> This code         would appear 

as this.</p> 
This code would appear as this. 



This Code Would Display 

<p> This code &nbsp;&nbsp;&nbsp; would This code     would appear with three extra 
appear with three extra spaces.</p>   spaces. 

To see a list of character entities, visit this page: 

http://profdevtrain.austincc.edu/html/entities.htm 

HTML Fonts 

The <font> tag in HTML is deprecated. The World Wide Web Consortium (W3C) has removed the <font> tag 
from its recommendations. In future versions of HTML, style sheets (CSS) will be used to define the layout and 
display properties of HTML elements. 

The <font> Tag Should NOT be used. 

HTML Backgrounds 

Backgrounds 

The <body> tag has two attributes where you can specify backgrounds. The background can be a color or an 
image. 

Bgcolor 

The bgcolor attribute specifies a background-color for an HTML page. The value of this attribute can be a 
hexadecimal number, an RGB value, or a color name: 

<body bgcolor="#000000"> 

<body bgcolor="rgb(0,0,0)"> 

<body bgcolor="black"> 

The lines above all set the background-color to black. 

Background 

The background attribute can also specify a background-image for an HTML page. The value of this attribute is 
the URL of the image you want to use. If the image is smaller than the browser window, the image will repeat 
itself until it fills the entire browser window. 

<body background="clouds.gif"> 

<body background="http://profdevtrain.austincc.edu/html/graphics/clouds.gif"> 

The URL can be relative (as in the first line above) or absolute (as in the second line above). If you want to 
use a background image, you should keep in mind: 

■ Will the background image increase the loading time too much? 
■ Will the background image look good with other images on the page? 
■ Will the background image look good with the text colors on the page? 
■ Will the background image look good when it is repeated on the page? 
■ Will the background image take away the focus from the text? 

Note: The bgcolor, background, and the text attributes in the <body> tag are deprecated in the latest 
versions of HTML (HTML 4 and XHTML). The World Wide Web Consortium (W3C) has removed these 

http://profdevtrain.austincc.edu/html/entities.htm
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attributes from its recommendations. Style sheets (CSS) should be used instead (to define the layout and 
display properties of HTML elements). 

Try It Out! 

Open your text editor and type the following text: 



<html> 

<head> 

<title>My First Webpage</title> 

</head> 

<body background="http://profdevtrain.austincc.edu/html/graphics/clouds.gif" 

bgcolor="#EDDD9E"> 

<h1 align="center">My First Webpage</h1> 

<p>Welcome to my <strong>first</strong> webpage. I am writing this page using 

a text 

editor and plain old html.</p> 

<p>By learning html, I'll be able to create webpages like a 

<del>beginner</del> 

pro....<br> 

which I am of course.</p> 

</body> 

</html> 

Save your page as mypage3.html and view it in your browser. To view how the page should look, visit this web 
page: http://profdevtrain.austincc.edu/html/mypage3.html Notice we gave our page a background color as well 
as a background image. If for some reason the web page is unable to find the picture, it will display our background 
color. 

HTML Colors 

Color Values 

Colors are defined using a hexadecimal notation for the combination of red, green, and blue color values (RGB). The 
lowest value that can be given to one light source is 0 (hex #00). The highest value is 255 (hex #FF). This table shows 
the result of combining red, green, and blue: 

 

 

 

 

 

 

 

 

Color Names 

A collection of color names is supported by most browsers. To view a table of color names that are supported by 
most browsers visit this web page: 

http://profdevtrain.austincc.edu/html/color_names.htm 

http://profdevtrain.austincc.edu/html/graphics/clouds.gif
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Note: Only 16 color names are supported by the W3C HTML 4.0 standard (aqua, black, blue, fuchsia, gray, 
green, lime, maroon, navy, olive, purple, red, silver, teal, white, and yellow). For all other colors you should 
use the Color HEX value. 

 



 

 

 

 

 

 

 

 

  Web Safe Colors 

A few years ago, when most computers supported only 256 different colors, a list of 216 Web Safe Colors was 
suggested as a Web standard. The reason for this was that the Microsoft and Mac operating system used 40 
different "reserved" fixed system colors (about 20 each). This 216 cross platform web safe color palette was 
originally created to ensure that all computers would display all colors correctly when running a 256 color palette. 
To view the 216 Cross Platform Colors visit this web page: 

http://profdevtrain.austincc.edu/html/216.html 

16 Million Different Colors 

The combination of Red, Green and Blue values from 0 to 255 gives a total of more than 16 million different colors 
to play with (256 x 256 x 256). Most modern monitors are capable of displaying at least 16,384 different colors. To 
assist you in using color schemes, check out 

http://wellstyled.com/tools/colorscheme2/index-en.html. This site lets you test different color schemes for page 
backgrounds, text and links. 

 

Lesson-12. Tables in HTML 

Tables are defined with the <table> tag. A table is divided into rows (with 
the <tr> tag), and each row is divided into data cells (with the <td> tag). 
The letters td stands for table data, which is the content of a data cell. A data 
cell can contain text, images, lists, paragraphs, forms, horizontal rules, tables, 
etc. 
 

This Code Would Display 
<table> 
<tr> 
<td>row 1, cell 1</td> 
<td>row 1, cell 2</td> 
</tr> 
<tr> 
<td>row 2, cell 1</td> 
<td>row 2, cell 2</td> 
</tr> 
</table> 

row 1, cell 1 row 1, 
cell 2 row 2, cell 1 
row 2, cell 2 

Tables and the Border Attribute 

http://profdevtrain.austincc.edu/html/216.html
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To display a table with borders, you will use the border attribute. 
 

This Code Would Display 
<table border="1"> 
<tr> 
<td>Row 1, cell 1</td> 
<td>Row 1, cell 2</td> 
</tr> 
</table> 

   

row 1, cell 1 row 1, 

cell 2 

 
  



and.... 

 

 

 

 

 

 

Open up your text editor. Type in your <html>, <head> and <body> 
tags. From here on I will only be writing what goes between the <body> 
tags. Type in the following: 
<table border="1"> 
<tr> 
<td>Tables can be used to layout information</td> 
<td>&nbsp; <img 
src="http://profdevtrain.austincc.edu/html/graphics/c
hef.gif"> &nbsp; 
</td> 
</tr> 
</table> 

Save your page as mytable1.html and view it in your browser. To see how 
your page should look visit this web page: 
http://profdevtrain.austincc.edu/html/mytable1.html 

Headings in a Table 

Headings in a table are defined with the <th> tag. 

 

 

 

<table 
border="5"> 
<tr> 
<td>Row 1, 
<td>Row 1, 
</tr> 
</table> 

cell 
1</td> 
cell 
2</td> 

http://profdevtrain.austincc.edu/html/graphics/chef.gif
http://profdevtrain.austincc.edu/html/graphics/chef.gif
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Cell Padding and Spacing 

The <table> tag has two attributes known as cellspacing and cellpadding. 
Here is a table example without these properties. These properties may be 
used separately or together. 
 

 

This Code 

Would Display 
<table border="1">  
<tr>  
<td>some text</td>  <td>some text</td> 
</tr> 
<tr> 
<td>some text</td> 
<td>some text</td> 

  some 

text 

some 

text 

 
some 

text 

some 

text 

 

 
</tr>  
</table>  



Cellspacing is the pixel width between the individual data cells in the table (The 
thickness of the lines making the table grid). The default is zero. If the border is 
set at 0, the cellspacing lines will be invisible. 
 

This Code Would Display 
<table border="1" 
cellspacing="5"> 
<tr> 
<td>some text</td> 
<td>some text</td> 
</tr><tr> 
<td>some text</td> 
<td>some text</td> 
</tr> 
</table> 

 

 

 

some text some text  

some text some text 
  

Cellpadding is the pixel space between the cell contents and the cell border. 
The default for this property is also zero. This feature is not used often, but 
sometimes comes in handy when you have your borders turned on and you 
want the contents to be away from the border a bit for easy viewing. 
Cellpadding is invisible, even with the border property turned on. Cellpadding 
can be handled in a style sheet. 
 

This Code Would Display 
<table border="1" 
cellpadding="10"> 
<tr> 
<td>some text</td> 
<td>some text</td> 
</tr><tr> 
<td>some text</td> 
<td>some text</td> 
</tr> 
</table> 

    

 some 

text 

some 

text 

 

some 

text 

some 

text 
   

Table Tags 
 

Tag Description 
<table> Defines a table 
<th> Defines a table header 
<tr> Defines a table row 
<td> Defines a table cell 
<caption

> 

Defines a table caption 
<colgro

up> 

Defines groups of table columns 
<col> Defines the attribute values for one or more 

columns in a table Table Size 

Table Width 

The width attribute can be used to define the width of your table. It can be 
defined as a fixed width or a relative width. A fixed table width is one where the 
width of the table is specified in pixels. For example, this code, <table 
width="550">, will produce a table that is 550 pixels wide. A relative table 



width is specified as a percentage of the width of the visitor's viewing window. 
Hence this code, <table width="80%">, will produce a table that 
occupies 80 percent of the screen. 

This table width is 250 pixels 

This table width is 50% 



There are arguments in favor of giving your tables a relative width because 
such table widths yield pages that work regardless of the visitor's screen 
resolution. For example, a table width of 100% will always span the entire 
width of the browser window whether the visitor has a 800x600 display or a 
1024x768 display (etc). Your visitor never needs to scroll horizontally to read 
your page, something that is regarded by most people as being very annoying. 

HTML Layout - Using Tables 

One very common practice with HTML, is to An HTML <table> is used to 
divide a part of 
use HTML tables to format the layout of an this Web page into two columns. 

HTML page. The trick is to use a table without borders, 

A part of this page is formatted with two and maybe a little extra cell-
padding. 

columns. As you can see on this page, there No matter how much text you 
add to this 

is a left column and a right column. page, it will stay inside its column 
borders. 
This text is displayed in the left column. 

Try It Out! 

Let's put everything you've learned together to create a simple page. Open 
your text editor and type the following text: 

<html
> 
<head
> 
<title>My First Web 
Page </title> </head> 
<body> 
<table width="90%" 
cellpadding="5" cellspacing="0" 
> <tr bgcolor="#EDDD9E"> 
<td width="200" valign="top"><img 

src="graphics/contact.gif" width="100" 
height="100"></td> 
<td valign="top"><h1 
align="right">Janet Doeson</h1> 
<h3 align="right">Technical 
Specialist</h3></td> </tr> <tr> 
<td 
width="200
"> 
<h3>Menu</
h3> <ul> 

<li><a href="home.html">Home</a></li> 
<li> <a href="faq.html">FAQ</a></li> 
<li> <a 
href="contact.html">Contact</a></li> 



<li> <a href="Ошибка! Недопустимый 
объект гиперссылки.> </li> </ul></td> 
<td valign="top"><h2 align="center">Welcome!</h2> 
<p>Welcome to my first webpage. I created this 

webpage without the assistance of a webpage editor. 
Just my little text editor and a keen understanding 
of html.</p> 
<p>Look around. Notice I'm able to use paragraphs, 
lists and headings. You may not be able to tell, but 
the layout is done with a table. I'm very clever. 
</p> <blockquote> 

<p>I always wanted to be somebody, but now I 
realize I should have been more specific.</p> 

<cite>Lily Tomlin </cite> 
</blockquote>   </td> </tr> 
</table> 
<hr width="90%" 
align="left"> 
<address> 
Janet Doeson<br> Technical Specialist<br> 
512.555.5555 </address> <p>Contact me at <a 
href="mailto:jdoeson@acme.com">jdoeson@acme.com</
a> </p> 

mailto:jdoeson@acme.com%22%3ejdoeson@acme.com%3c/a
mailto:jdoeson@acme.com%22%3ejdoeson@acme.com%3c/a


</bo
dy> 
</ht
ml> 

Save your page as mytable2.html and view it in your browser. To see how 
your page should look visit this web page: 
http://profdevtrain.austincc.edu/html/mytable2.html 

I have indented some of the HTML code in the above example. Indenting the 
code can make your HTML document easier to read. 

Create Your Own Page 

It’s time to create your own page. Use your text editor to create a page which 

contains the following: 

• the required HTML page codes 
• link to another web page 
• an email link 
• a picture/graphic 
• a list of information 

Save the file as xyhtml_basics.html where xy is your initials. Email the file to 

jmorales@austincc.edu. 

Lesson-13. HTML Images 

The Image Tag and the Src Attribute 

The <img> tag is empty, which means that it contains attributes only and it 
has no closing tag. To display an image on a page, you need to use the src 
attribute. Src stands for "source". The value of the src attribute is the URL of the 
image you want to display on your page. The syntax of defining an image: 
 

 

 

 

Not only 
does the source attribute specify what image to use, but where the image is 
located. The above image, graphics/chef.gif, means that the browser will 
look for the image name chef.gif in a graphics folder in the same folder as 
the html document itself. 

 

 

http://profdevtrain.austincc.edu/html/mytable2.html
mailto:jmorales@austincc.edu
mailto:jmorales@austincc.edu


 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 

The browser puts the image where the image tag occurs in the document. If 
you put an image tag between two paragraphs, the browser shows the first 
paragraph, then the image, and then the second paragraph. 

The Alt Attribute 

The alt attribute is used to define an alternate text for an image. The value 
of the alt attribute is author-defined text: 

<img src="graphics/chef.gif" alt="Smiling Happy Chef 

"> 

The alt attribute tells the reader what he or she is missing on a page if the 
browser can't load images. The browser will then display the alternate text 
instead of the image. It is a good practice to include the alt attribute for each 
image on a page, to improve the display and usefulness of your document for 
people who have text-only browsers or use screen readers. 

Image Dimensions 

 



When you have an image, the browser usually figures out how big the image is 
all by itself. If you put in the image dimensions in pixels however, the browser 
simply reserves a space for the image, then 



loads the rest of the page. Once the entire page is loads it can go back and fill in 
the images. Without dimensions, when it runs into an image, the browser has to 
pause loading the page, load the image, then continue loading the page. The 
chef image would then be: 

<img src="graphics/chef.gif" width="130" height="101" 

alt="Smiling Happy Chef"> 

Open the file mypage2.html in your text editor and add code highlighted in 

bold: 

<html> 

<head> 
<title>My First Webpage</title> 

</head> 

<body> 
<h1 align="center">My First Web page</h1> 

<p>Welcome to my first webpage. I am writing this page using a text editor and 
plain old html.</p> 

<p>By learning html, I'll be able to create web pages like a pro....<br> 
which I am of course.</p> 

<!-- Who would have guessed how easy this would be :) --> 

<p><img src="graphics/chef.gif" width="130" height="101" alt="Smiling 
Happy Chef" 
align="center"></p> 

<p align="center">This is my Chef</p> 

</body> 
</html> 

Save your page as mypage5.html and view it in your browser. To see how your 
page should look visit this web page: 
http://profdevtrain.austincc.edu/html/mypage5.html 

 

LESSON-14. HTML Lists 

HTML provides a simple way to show unordered lists (bullet lists) or ordered 

lists (numbered lists). 

Unordered Lists 

http://profdevtrain.austincc.edu/html/mypage5.html


An unordered list is a list of items marked with bullets (typically small black 
circles). An unordered list starts with the <ul> tag. Each list item starts with 
the <li> tag. 
 

This Code Would Display 
<ul>  
<li>Coffee</li> ■    Coffee 
<li>Milk</li> ■    Milk 
</ul>  

Ordered Lists 

An ordered list is also a list of items. The list items are marked with numbers. 
An ordered list starts with the <ol> tag. Each list item starts with the <li> 
tag. 
 

This Code Would Display 
<ol>  
<li>Coffee</li> 1.  Coffee 
<li>Milk</li> 2.  Milk 
</ol>  

Inside a list item you can put paragraphs, line breaks, images, links, other lists, 

etc. 

Definition Lists 

Definition lists consist of two parts: a term and a description. To mark up a 
definition list, you need 

three HTML elements; a container <dl>, a definition term <dt>, and a definition 
description <dd>. 
 

This Code Would Display 
<dl> 
<dt>Cascading Style 
Sheets</dt> 
<dd>Style sheets are 
used to provide 
presentational 
suggestions for 
documents marked up in 
HTML. 
</dd> 
</dl> 

Cascading Style Sheets 

Style sheets are used to 
provide presentational 
suggestions for documents 
marked up in HTML. 

Inside a definition-list definition (the <dd> tag) you can put paragraphs, 
line breaks, images, links, other lists, etc 



Try It Out 

Open your text editor and type the following: 

<html> 
<head> 
<title>My First Webpage</title> 
</head> 
<body bgcolor="#EDDD9E"> 
<h1 align="center">My First Webpage</h1> 
<p>Welcome to my <strong>first</strong> webpage. I am 
writing this page using a text 
editor and plain old html.</p> 
<p>By learning html, I'll be able to create web pages 
like a pro....<br> 
which I am of course.</p> 
Here's what I've learned: 
<ul> 
<li>How to use HTML tags</li> 
<li>How to use HTML colors</li> 
<li>How to create Lists</li> 
</ul> 
</body> 
</html> 

Save your page as mypage4.html and view it in your browser. To see how your 
page should look visit this web page: 
http://profdevtrain.austincc.edu/html/mypage4.html 

HTML Links 

HTML uses the <a> anchor tag to create a link to another document or web 

page. 

The Anchor Tag and the Href Attribute 

An anchor can point to any resource on the Web: an HTML page, an image, a 
sound file, a movie, etc. The syntax of creating an anchor: 

<a href="url">Text to be displayed</a> 

The <a> tag is used to create an anchor to link from, the href attribute is used 
to tell the address of the document or page we are linking to, and the words 
between the open and close of the anchor tag will be displayed as a hyperlink. 
 

http://profdevtrain.austincc.edu/html/mypage4.html


This Code Would Display 
<a 

href="http://www.austincc.edu/">

Visit ACC!</a> 

Visit ACC! 

The Target Attribute 

With the target attribute, you can define where the linked document will be 
opened. By default, the 

link will open in the current window. The code below will open the document in 
a new browser window: 

<a href=http://www.austincc.edu/ target="_blank">Visit 

ACC!</a> 

Email Links 

To create an email link, you will use mailto: plus your email address. Here is a 

link to ACC's Help Desk: 

<a href="mailto:helpdesk@austincc.edu">Email Help 

Desk</a> 

To add a subject for the email message, you would add ?subject= after 
the email address. For example: 

<a href="mailto:helpdesk@austincc.edu?subject=Email 

Assistance">Email Help Desk</a> 

http://www.austincc.edu/%22%3eVisit
http://www.austincc.edu/%22%3eVisit
http://www.austincc.edu/
http://www.austincc.edu/
mailto:helpdesk@austincc.edu%22%3eEmail
mailto:helpdesk@austincc.edu?subject=Email
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The Anchor Tag and the Name Attribute 

The name attribute is used to create a named anchor. When using 
named anchors we can create links that can jump directly to a specific 
section on a page, instead of letting the user scroll around to find 
what he/she is looking for. Unlike an anchor that uses href, a named 
anchor doesn't change the appearance of the text (unless you set 
styles for that anchor) or indicate in any way that there is anything 
special about the text. Below is the syntax of a named anchor: 

<a name="top">Text to be displayed</a> 

To link directly to the top section, add a # sign and the name of the 
anchor to the end of a URL, like this: 
 

 

Note: Always add a trailing slash to subfolder references. If you link 
like this: href="http://profdevtrain.austincc.edu/html", you will 
generate two HTTP requests to the server, because the server will add 
a slash to the address and create a new request like this: 
href="http://profdevtrain.austincc.edu/html/" 

Named anchors are often used to create "table of contents" at the 
beginning of a large document. Each chapter within the document is 
given a named anchor, and links to each of these anchors are put at 
the top of the document. If a browser cannot find a named anchor 
that has been specified, it goes to the top of the document. No error 
occurs. 

 

http://profdevtrain.austincc.edu/html
http://profdevtrain.austincc.edu/html/
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LESSON-15. Website Design 

Web Site Development with FrontPage/Swish 

 

STIMULATE 5  
International Training Program about INFORMATION  

in 2005 

Course Overview: 

This web design course teaches how to plan, organize, and create a web 

site from start to finish.  
By the end of this design course, students will have created a well-designed 

web site and publish it. 

Lesson 1: Creating Web Pages 

This lesson teaches you how to work with text and hyperlinks; add pictures, 

animations, clip art, and files; format lists; position objects; design a 
feedback form; make a photo gallery; design a Web site structure; and 

create a Web site. 

Lesson 2: Enhancing and Publishing a Web Site 

In this lesson, you will learn how to set up navigation, add shared borders 

and link bars to pages, insert page banners, apply and customize a 
graphical theme, check spelling and replace text across the Web site, sort 

and organize files and folders, view Web site reports, and preview and 
publish the finished Web site. 

Lesson 3: Using Swish 

In this lesson, you will learn how to design animation banners and icons. 
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Opening FrontPage 

To run Microsoft FrontPage, do the following: 

 On the Windows taskbar, click the Start button , point to Programs, and 

then click Microsoft FrontPage. 

 

If this is the first time you’ve used FrontPage, the program opens and displays a 

blank page ready for editing. 

 

Notes 

o If FrontPage has been used to edit another Web site, it will open the last 

Web site automatically. 

 

o To close a Web site: on the File menu, click Close Web. 

Workspace Overview 

FrontPage 2002 has an integrated interface that helps you create and edit Web pages as 

well as manage entire Web sites within one application. All toolbars and menu behaviors 

are consistent with Microsoft Office XP programs, so toolbars and menus can be fully 

customized. You can also use convenient keyboard shortcuts to accelerate common tasks 

such as opening Web sites and pages, printing, and many other commands. 

 

The graphic and table below highlight some of the commonly used elements of the 

FrontPage 2002 interface. 

 

 
 

Item Description 

Page Tab An easy way to select the page you want 
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when you have several pages open. 

Title Bar Displays the name of the current page, and 

its location in your Web site. 

Menu Bar Contains menus like File, Edit, View, and 

Insert, and is the starting point for many of 

the tasks you will undertake in FrontPage. 

Ask a Question Box To find more information about a procedure 

in FrontPage, type a question in the Ask a 

Question box, which accesses the online 

Help system. 

Close Page This button closes the page that is currently 

in view. 

Scroll Bars These let you move the page so a different 

portion is displayed. 

Status Bar Represents the state of a current task. For 

instance, the Status Bar may display the text 

“Retrieving Index.htm” when opening the 

home page, or show the destination of a 

hyperlink when you move your mouse cursor 

over a link in the Normal pane. 

Page View Panes These represent the different panes of the 

workspace. For example, the Normal pane 

is where you will do most of your work in 

this tutorial. Other panes are the HTML 

pane and the Preview pane. 

Progress Indicator Shows the status of a current action. 

Estimated Download Time Gives you an idea of how long it will take a 

user to view your page in a Web browser. 

Task Pane A pane within Office XP programs that 

provide commonly used commands. Its 

location and small size allow you to use 

these commands while still working on your 

files. 

Standard and Formatting toolbars Displayed by default. They provide easy 

access to the commands you will use most 

often when working in FrontPage. 

Views bar What you see in the main program window 

depends on the currently selected view. The 

icons on the Views bar provide different 

ways of looking at the information on your 

page or in your Web site.  
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To create a home page 

The home page is the front door to your Web site. It provides information about the 

content or subject matter of your site in order to spark interest in your site visitors. The 

home page also contains the links to the other pages in your Web site. 

 

1. On the blank page in Page view, type Welcome to Stimulate5! and then press 

ENTER. 

 

Just like in a word processor, pressing ENTER puts the cursor on a new line. 

 

2. Next, type the sentence Take a look around to learn more about our sporting 

goods, see pictures of our merchandise, and look at our Sports Photo 

Gallery. 

 

3. Press ENTER. 

 

Most of the content for your Stimulate5 site is already created. When you’re ready 

to make your own Web site, FrontPage lets you import any of your existing 

documents directly onto your Web pages without having to retype anything. 

 

Your page should now look like this: 

 

 
 

Next, you will add a picture to the Web page. Pictures can be scanned photographs, 

drawings, or computer graphics created in a drawing or image-editing program. 
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For this example, the picture you’ll insert is a graphic of the FrontPage logo: 

 

 
 

To insert a graphic on the home page 

1. On the Insert menu, point to Picture, and then click From File. 

 

FrontPage displays the Picture dialog box. 

 

Note   The picture file you’ll insert is located in the Tutorial folder that was installed 

with the FrontPage program files. 

 

2. Next to Look In, select the hard disk where you installed the tutorial. 

 

You most likely installed the tutorial on your C or D drive. 

 

3. Navigate to the folder named FPTutor2002 by double-clicking each folder in this 

path until the Look in box displays FPTutor2002. 

 

You will see several files in the FPTutor2002 folder. By default, FrontPage searches 

for picture files when you are inserting a picture. 

 

4. Click the file named frontpage, and then click Insert. 

 

FrontPage inserts the selected picture file on the current page. It is a graphic that 

your site visitors will be able to click to learn more about FrontPage 2002. 

 

5. Press ENTER to create a new line. 

 

Your page should now look like this: 
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Merely inserting a picture of a button doesn’t mean that anything will happen when 

someone clicks it in a Web browser. To make a picture or a word clickable, it must have a 

hyperlink associated with it. 

 

A hyperlink is a pointer from text or from a picture to another page or file on the World 

Wide Web or on an intranet. On the World Wide Web, hyperlinks are the primary way to 

navigate between pages and other Web sites. 

 

In the next steps, you’ll create a hyperlink from the graphic you just placed on the home 

page. 

 

To create a hyperlink from a picture 

1. On the home page, click the picture of the FrontPage 2002 button you inserted. 

 

When a picture is selected, it is shown with file handles — eight small squares 

around the outline of the picture. These can be used to resize a picture or change 

its appearance. When a picture is selected, FrontPage also displays the Pictures 

toolbar. The Pictures toolbar provides picture editing and formatting tools, which 

you’ll learn about later. 

 

Note   If the Pictures toolbar doesn’t appear automatically, on View menu, 

point to Toolbars, and then click Pictures. 

 

2. On the Insert menu, click Hyperlink. 

 

FrontPage displays the Insert Hyperlink dialog box. Here, you specify the target 

of the hyperlink you are creating. 

 

3. In the Address box, type www.microsoft.com/frontpage. 
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To save the current page 

Now that you’ve invested some time and completed a number of steps, it’s a good idea to 

save your page. 

 

1. On the File menu, click Save As. 

 

FrontPage displays the Save As dialog box. Here, you can specify the location for the 

current page, and review or change the page title, the file name, and the file type. 

 

2. In the Save As dialog box, click the My Documents icon on the vertical places bar. 

 

The contents of your My Documents folder are displayed. If no files are displayed in 

the file list, then you currently do not have any other Web pages stored here. 

 

3. Next to the Page title field, click the Change title button. 

 

FrontPage displays the Set Page Title dialog box. Here, the default page title is 

based on the first line of text on the current page. A title identifies the contents of a 

page when it is displayed in a Web browser. For this tutorial, you’ll change the page 

title to something more descriptive. 

 

4. In the Set Page title box, type Home Page and then click OK. 

 

5. In the File name box, change the suggested text to homepage, and then click 

Save. 

 

FrontPage saves the current page. 
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Page View Options 

While creating the home page, you’ve worked exclusively in normal Page view, but there 

are three different ways you can choose to look at the current page. 

To display HTML tags on the current page 

 In Page view , click Reveal Tags on the View menu. 

 

 FrontPage displays graphical representations of standard HTML tags for the current 

page. This display is useful for people who want to know where HTML tags are 

placed while they design their pages. 

 

 To hide the tags, click Reveal Tags on the View menu a second time. 

 

To display the HTML of the current page 

 

 In Page view, click the HTML button at the bottom of the page. 

 

This causes FrontPage to display the HTML code that it has created so far while you 

were designing the home page. Web browsers decode these instructions to display 

the page. The HTML pane is intended for experienced Web developers and page 

designers who want to customize the HTML that FrontPage creates. 

 

 If you want to set your preferences for the way FrontPage will generate HTML code, 

click Page Options on the Tools menu, and then click the HTML Source tab. If 

you’re not experienced in HTML, you don’t need to make any changes here. Click 

Cancel to close the Page Options dialog box. 

 

 Click the Normal button at the bottom of the page to return to the Normal pane. 

To preview the current page 

 Click the Preview button at the bottom of the page. 

 

Note   If you do not have Microsoft Internet Explorer installed on your computer, 

the Preview tab will not be displayed, and you will not be able to preview your 

pages this way. For more information, see Before You Begin. 

 

 Click the Normal button at the bottom of the page to return to the Normal pane 

once again. 
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Creating a Web site with FrontPage 

A Web site is the collection of a home page and its associated pages, graphics, documents, 

multimedia, and other files. Web sites are stored on a Web server or on a computer’s hard 

drive. FrontPage-based Web sites also contain files that support FrontPage-specific 

functionality and allow Web sites to be opened, copied, edited, published, and 

administered with FrontPage. 

 

When you save your pages to a Web site, FrontPage can automatically manage and repair 

hyperlinks, organize files and folders, maintain dynamic link bars, check spelling across all 

pages in the Web site, and generate reports that point out problems with your pages and 

files. 

 

To create a new Web site 

 

1. On the File menu, click Close to close the current page. 

 

2. On the File menu, point to New, and then click Page or Web. 

 

FrontPage displays the New Page or Web task pane. Here, you can choose from 

several Web site templates and wizards, specify where you want to save your Web 

site, and specify what you want to call it. 

 

3. Under New from template, click Web Site Templates. 

 

4. Click One Page Web, and then press TAB. 

 

Pressing the TAB key moves the selection to the field where you specify the name 

and location of the new Web site. 

 

5. In the Specify the location of the new Web box, change the suggested name to 

<drive>:\My Documents\My Webs\ Stimulate5, and then click OK. 

 

Notes 

 

 <drive> represents your local hard disk, which is usually C:\ or D:\. 

 

 FrontPage creates a new Web site named “Stimulate5,” and displays its name and 

location in the title bar at the top of the FrontPage program window. 

 

 Because you’ll be working with several files in your Web site, FrontPage also 

displays the Folder List, where you can see the files and folders in your current 

Web site, similar to files and folders in Microsoft Windows Explorer. You’ll learn how 

to use the Folder List later, in Lesson 2. 

 

6. If the Folder List is not showing, do the following: 
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 On the standard toolbar, click the arrow to the right of Toggle Pane , and 

then click Folder List. 

7. Click the Navigation icon  on the Views bar. 

 

When you have a Web site open, the icons on the Views bar let you look at the 

information in your Web site in different ways. 

 

Navigation view shows a graphical representation of the structure of your Web site. 

Because you created a one-page Web site, FrontPage has automatically designated it 

as the Web site’s home page — indicated with a small icon of a house . 

 

While in Navigation view, FrontPage also displays the Navigation toolbar. You can 

drag the Navigation toolbar anywhere on your screen. 

 

 
 

Next to the Views bar, FrontPage displays the optional Folder List, just like it did in 

Page view. 
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Creating Web site Content 

Now that the home page is part of the current Web site, you will create the content for the 

other pages in the Stimulate5 Web site. 

 

Edit the About Us page 

1. Click the Navigation icon on the Views bar to switch back to Navigation view. 

 

Notes 

 

o The Folder List now shows the two picture files you saved to the current 

Web site. The file Index.htm is the new home page. You can later discard 

the remaining copy of the home page from your My Documents folder. 

 

o In the Folder List, the file names of the other pages were automatically 

derived from the page titles you typed into the pages in Navigation view. 

For this tutorial, we won’t change the names. 

 

2. Double-click the About Us page to open it in Page view. 

 

This page will provide some background about your fictional company for site 

visitors. For this tutorial, we have provided this text for you, so you can simply 

insert it on the page without having to type it. 

Designing a Page 

To help the reader differentiate the paragraph headings, list of products, and event details 

that the text on this page talks about, you will add some pictures, format paragraph 

styles, and create a bulleted list. 

 

To create a bulleted list 

1. With the Products page still displayed in Page view, find the words “Team Bag.” 

 

If the entire product list is not visible, use the scrollbar to bring the entire list into 

view. 

 

The list begins with “Team Bag” and ends with “Goal Netting.” 

 

2. Click just to the left of the letter T in “Team Bag,” hold down SHIFT, click just after 

the word “Netting,” and then release SHIFT. This will select the entire list. 

 

3. On the Formatting toolbar, click the Bullets  button. 

 

FrontPage converts the selected text to a bulleted list. 
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4. Click anywhere on the page to deselect the list. 

 

Your page should now look like this: 

 

 
 

You can also create numbered lists with FrontPage. When you add new items to a 

numbered list, FrontPage automatically numbers them sequentially. You can add to 

bulleted and numbered lists by pressing ENTER after an item in the list. To end a list, 

press ENTER twice after typing the last list item. 

 

Next, you will place four pictures on the current page and use positioning features in 

FrontPage to align the pictures with the paragraphs they are associated with. This will 

create a more interesting page layout. 

 

To position pictures with text 

1. With the Products page still displayed in Page view, place your cursor after the text 

“Featured Items of the Week.” 

 

2. Click Insert Picture From File  on the standard toolbar. 

 

When you last inserted a picture, you did not have a Web site open, and FrontPage 

automatically displayed the Select File dialog box. Now that a Web site is open, 

FrontPage assumes you want to work with pictures that are already part of your Web 

site, and therefore displays the Picture dialog box. 

 

Because you haven’t yet added the picture you want to the current Web site, click 

the drop-down menu next to Look in, and navigate to the FPTutor2002 folder. 

 

Note   The folder is located at <drive>:\FPTutor2002, where <drive> represents 

the hard disk where you installed the tutorial. 
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4. Click the file named FPTutor001, and then click Insert. 

 

FrontPage inserts a picture of a soccer ball just after the text “Featured Items of the 

Week.” 

 

5. Next, click the picture of the soccer ball to select it. 

 

6. On the Format menu, click Position. 

 

FrontPage displays the Position dialog box. 

 

7. Under Wrapping style, click Right, and then click OK. 

 

The picture is aligned with the right margin of the current page, and the bulleted list 

flows to the left of it. 

 

8. On the toolbar, click the Save button to save changes to the Products page. 

 

9. In the Save Embedded Files dialog box, click OK. 

 

Your page should now look like this: 

 

 
 

You can either place pictures one by one in this way, or you can import the pictures you 

will use on your pages all at once. While importing single files is done in Page view, 

inserting a group of files or entire folders is done in Folders view. 
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To create a feedback form 

1. In Page view, press CTRL+END to quickly jump to the bottom of the current page, or 

scroll all the way down using the scroll bar. 

 

2. On the new, blank line, type Give Us Your Feedback! and then press ENTER. 

 

3. On the Insert menu, point to Form, and then click Textbox. 

 

FrontPage inserts a new form with a text box on the current page. The dashed lines 

indicate the form’s boundary. By default, the new form also contains Submit and 

Reset buttons. 

 

Next, you will customize the default form by adding more form-fields and form-field 

labels, so site visitors know what kind of information you want them to enter. 

 

To customize the form 

1. Click on the Submit button, and then click Center  on the toolbar. 

 

2. Press the left arrow to place the cursor before the Submit button, and press ENTER. 

 

Pressing ENTER adds a blank line to the form. 

 

3. Click the text box and press the back arrow to place the cursor at the beginning of 

the form. 

 

4. On the first line, type Your Name: and then press SHIFT+ENTER. 

 

Holding SHIFT while pressing ENTER creates a line break. Line breaks are useful for 

spacing lines of text more closely together than standard paragraph spacing. 

 

4. Move the cursor after the text box, and press ENTER. 

 

5. On the next line, type Your E-mail Address: and then press SHIFT+ENTER. 

 

6. On the Insert menu, point to Form, click Text Box once more, and then press 

ENTER. 

 

7. On the next line, type Your comments: and then press SHIFT+ENTER. 

 

8. On the Insert menu, point to Form, and then click Text Area. 

 

FrontPage inserts a scrolling text input field into the form. 

 

9. Double-click the scrolling text box you just inserted. 

 

FrontPage displays the Scrolling Text Box Properties dialog box. Here, you can 

change the appearance of the text box. 
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10. In the TextArea Box Properties dialog box, change the Width in characters to 30 

and the Number of lines to 5, and then click OK. 

 

The scrolling text box has increased in size, which will encourage site visitors to write 

more than just a few lines. 

 

Now that your form and the Products page are finished, it’s a good idea to save 

your work. 

 

Note   You can’t test your form until you publish your Web site. You’ll learn how to 

publish your Web site in Lesson 2. 

 

11. On the toolbar, click the Save button to save changes to the Products page. 

 

Your page should now look like this: 

 

 
 

Good work! The feedback form is finished and so is the Products page. In the next part of 

the lesson, we’ll add the last two pages — an online photo gallery and a list of links to 

some sites on the World Wide Web. 
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Creating a Photo Gallery 

The World Wide Web has a graphical interface, so it’s no surprise that many popular Web 

sites feature photographs and other types of graphics. Scanners and digital cameras have 

become much more affordable, and many photo-developing services now offer pictures on 

CD-ROMs so you can share them online. 

 

FrontPage 2002 provides several layouts in which you can arrange your graphics. For this 

tutorial, we will use the Horizontal layout. 

 

To edit the Photo Gallery page 

1. On the Insert menu, click Web Component. 

 

2. In the left pane, click Photo Gallery. 

 

3. In the right pane, select the first layout option (the Horizontal Layout), and then click 

Finish. 

 

4. The Photo Gallery Properties dialog box automatically opens. 

 

5. Click Add, and then click Pictures from Files. 

 

6. Click Open, and then click OK. 

 

7. On the standard toolbar, click the Save button to save changes to the Photo 

Gallery page. 

 

8. In the Save Embedded Files dialog box, click OK. 

 

9. Your page should now look like this: 
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Linking to Other Web Sites 

When you create your own Web site, you can create hyperlinks pointing to other Web sites 

that relate to the subject matter of your own pages. This lets visitors browse to similar 

sites without having to search for them. 

To create hyperlinks from text 

1. On the Links page, press the DOWN ARROW key, type MSN Sports and then press 

ENTER. 

 

2. Click and drag the mouse over the words you just typed to select them. 

 

3. On the Insert menu, click Hyperlink. 

 

FrontPage displays the Insert Hyperlink dialog box. Here, you specify the target of 

the hyperlink you are creating. This can be a page or a file in your Web site, on your 

local file system, on a Web server, or on another site on the World Wide Web. 

 

5. In the URL box, type www.msnbc.com/msn/msnsports_front.asp, and then 

click OK. 

 

Notice that FrontPage automatically adds the HTTP prefix. 
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Applying a Theme 

FrontPage includes more than 50 professionally designed themes with matching color 

schemes that you can apply to any or all pages in your Web site. A theme consists of 

design elements for bullets, fonts, pictures, navigation buttons, and other graphics. When 

applied, a theme gives pages, page banners, navigation bars, and other elements of a 

Web site an attractive and consistent appearance. 

 

To apply a theme to the Web site 

1. Click the Page tab for index.htm. 

 

FrontPage brings the home page back into view. 

 

2. On the Format menu, click Theme. 

 

FrontPage displays the Themes dialog box. Here, you can select from a list of 

themes that FrontPage installed by default. 

 

3. Click on some of the different theme names in the scrolling list box. 

 

When you click the name of a theme, the Sample of Theme window shows a 

sample of the graphical elements that are contained in the selected theme. This way, 

you can first preview a theme before applying it to select or all pages in your Web 

site. 

 

4. Click Yes to apply the theme. 

 

The theme named Blends is applied to all the pages in your current Web site. 

 

To save the home page, click Save on the File menu, or click the Save button on the 

toolbar. 

 

Your page should now look like this: 

 

 

 

As you can see, applying the theme has 

dramatically changed the appearance of the 

home page. The page banner and 

navigation buttons are no longer plain text; 

now they’re graphics. 
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Organizing the Files in your Web site 

Now that your Web site contains several pages and files, you will use Folders view to 

organize them. Similar to Windows Explorer, Folders view lets you manage the files and 

folders in your Web site. You can safely rearrange the pages and files in your Web site 

without breaking hyperlinks, page banner titles, or navigation button labels. 

 

In Folders view, FrontPage displays a hierarchical list of the folders in your Web site on 

the left side of the screen. Clicking on a folder in the Folder List displays its contents on 

the right side — the Contents pane. 

 

 
 

In the following steps, you will move all the picture files in the Stimulate5 Web site to the 

Images folder FrontPage created as part of the Web site. 

 

To move picture files to the Images folder 

1. On the Views bar, click the Folders icon . 

 

FrontPage switches to Folders view. 

 

2. In the Folder List pane, click the top-level folder labeled 

<drive>:\My Documents\My Webs\Stimulate5. 

 

This will ensure that the contents pane displays all of the folders and files contained 

in the root Web site. 

 

When you work with your own Web sites, you can group sound files, movie clips, and 

other types of files in their own folders. You can create new folders in Folders view as 

needed and delete the ones you no longer need. 

 

To create a new folder 

 

1.  In the Folder List, click the folder in which you want to create a new subfolder. 
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Folders can be expanded and collapsed in the Folder List to bring their subfolders 

into view. Click the plus (+) and minus (-) signs next to a folder’s name to display or 

hide its subfolders. 

 

2. On the File menu, point to New and then click Folder. 

 

FrontPage creates a new folder with a temporary name. 

 

3. When the folder’s temporary name (New_Folder) is selected, type a new name for 

the folder, then press ENTER. 

 

The new folder is renamed, and you can now drag and drop files into it. 

 

For this tutorial, we don’t need the extra folder you just created, so you will delete it 

before we get ready to publish the Web site. 

 

4. In the Folder List, right-click the folder you just created. 

 

5. On the shortcut menu, click Delete. 

 

6. In the Confirm Delete dialog box, click Yes. 

 

FrontPage removes the folder from the Web site. 

 

Generating a Site Summary 

Reports view is an important tool that shows you the overall health and condition of your 

Web site before you publish it to the World Wide Web. You can generate custom reports 

about your Web site in up to 14 categories. 

 

To generate a Site Summary report 

 On the Views bar, click the Reports icon . 

 

FrontPage switches to Reports view. The default report is the Site Summary. This 

report shows you the overall statistics of the pages and files in the Stimulate5 Web 

site. Here are some important ones to look at before you publish your Web site: 

 

 All files: You currently have 23 files in your Web site, totaling approximately 435 

KB. This is the amount of space you’ll need to have available on the Web server 

that will host your Web site. 

 Slow pages: This category shows pages that are slow to download at the targeted 

download speed. 

 Broken hyperlinks: If any broken hyperlinks are reported here, double-click the 

Broken hyperlinks row to view details about this category. FrontPage lists 

unverified hyperlinks, such as the external hyperlinks on your Links page, and 

links that are broken and do not work. 
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 Functioning hyperlinks: You can verify that a hyperlink still points to an active 

Web site by right-clicking the link in Reports view and choosing Verify from the 

shortcut menu. To fix a broken hyperlink, you must open the page it is on and 

repair the URL the hyperlink points to. 

 

 

Completing Web Site Tasks 
 

Tasks view displays the list of all outstanding tasks associated with the current Web site. 

Tasks are items that need your attention before you publish the Web site. 

 

If you are working in a Web development environment or on an intranet, Tasks view 

makes it easy to track Web site tasks and assign them to other authors who work on the 

same Web site. 

 

To complete tasks in Tasks view 

1. On the Views bar, click the Tasks icon . 

 

FrontPage displays the Tasks list. 

 

2. Double-click the first task on the list, labeled Fix misspelled words. 

 

FrontPage displays the Task Details dialog box. Here, you can see details about the 

task youve selected. You can set the priority of the task, assign it to another author 

on your network, or complete the task and remove it from the list. 

 

3. In the Task Details dialog box, click Start Task. 

 

FrontPage switches to Page view and opens the page containing the misspelled 

words. 

 

4. In the Spelling dialog box, click Add when FrontPage questions the name 

Stimulate5. 

 

This adds the word Stimulate5 to the dictionary. 

 

Although it is not required that you complete every task before publishing your Web site, it 

is a good idea to review this list when you are finished making changes to the Web site. 

Tasks view helps you manage Web sites by flagging important reminders for you. 
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Publishing the Stimulate5 Web site 

When you publish your Web site on the World Wide Web — or your company intranet — 

FrontPage automatically verifies your hyperlinks, the addresses of your pages, and the 

paths to your files. 

 

Note   If you do not want to publish the Stimulate5 Web site to your Web server, read this 

procedure for reference only, without actually completing the steps. 

 

To publish the current Web site 

1. Close all open pages in Page view. 

 

2. On the File menu, click Publish Web, or click the Publish Web button  on the 

toolbar.  

 

FrontPage displays the Publish Web dialog box. Here, you specify the location on 

the World Wide Web or your corporate intranet to which you want to publish your 

Web site. Your Internet service provider can tell you this information. 

 

You need Internet access through an Internet service provider before you can publish 

your Web site to the World Wide Web. If you want to sign on with a Web Presence 

Provider that can host FrontPage-enabled Web sites, click the Click here to learn 

more link in the Publish Destination dialog box. 

 

 
 

3. In the Publish Web dialog box, enter the URL of your target Web server, (such as 

http://example.microsoft.com/~myweb), and then click Publish. 

 

FrontPage publishes the current Web site from your computer to the World Wide Web 

or intranet Web server you specified. 
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Macromedia Dreamweaver Tutorial 

Instructions: 
^ Work through this tutorial ^ Ask when you need help ^ 

Complete all tasks set in the tutorial ^ Refer back to this 

tutorial when you design your own website ^ Enjoy 

 

SET UP A NEW SITE 

 

Open Dreamweaver 
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Click on Manage Sites on the right hand side of the screen (underline and in blue) In 

Manage Sites dialogue Box click on^New Then click on Site 

 

 

Click on Next 

 No, I do not want to use a server technology Next 

 Edit local copies on my machine, then upload to server when ready Next 

'How do you connect to your remote server?' 

Local/Network 

What folder on your server do you want to save your files in?

 

A new site can now be set up Change 'Unnamed Site1' to your name 
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And select 'Local View' 
It will now give you the site you have set up 

Site - .............  

 

CREATE THE FIRST WEBPAGE 

 

Click on the folder icon 

Create a folder called 'webl' in My 

Documents Open Select 

Next 

® No, do not enable check in and check out 

Next 

Summary: Your site has the following settings 

Done 

Done 

On right hand side of screen, under 'Files', you'll see your name and Remote 

View Click on the ▼ next to 'Remote View' 
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This new file is going to be your home page 

In place of untitled.htm type: Index.html 

Make sure to type the filename and .html, otherwise Dreamweaver will not recognise it 

as a webpage 

If that happens you'll have to rename the file at a later 

stage To rename the file: 

Press F2 

or Right-click on the file 

Edit 

Rename 

To Edit or work on this page, double-click on Index.html - it will open the page and you can now design your 

website 

PAGE PROPERTIES 

To select background colour/picture, font and colour, link colours, 

etc: Ctrl J 

or Click on Page Properties at the bottom of the screen or click on Modify in the 

top toolbar 

and select Page Properties 

 

To select a colour for the background, click on the ▼ in the box next to 'background colour' and select your 

preferred colour by clicking on it 

 

Be careful with your colour choices as text can be hard to read on some of the 

colours Click on Ok 

This will take you back to this Index page, now with your chosen background colour 

 

This will give you the Page 
Properties dialogue box 
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At the bottom of the screen are the 'Properties' - this is where you change font, the size, colour, select bold 

or italics It is not possible to use WordArt in Dreamweaver, but you can type your heading in 'Word' and 

simply copy and paste it to your webpage 

(Ctrl C to copy and Ctrl V to paste) 

Type your name on the index page, using WordArt or normal text. Make sure it stands out. To centre it click 

on = at the bottom of the page. 

Enter to go down. Insert a picture underneath your name. Do NOT copy and paste pictures. As you did with 

WordArt. insert it the proper way. 

INSERT A PICTURE 

To insert a picture: 

Click on Insert 

Image 

Browse for the picture in your area. It is always a good idea to have a 'My Pictures' folder 

where you save all your pictures Select picture, click on OK 

Dreamweaver will now tell you the file is outside the root folder of your site, and ask you 'Would you 

like to copy the file there now?' 

Click on Yes 

Click on Save, to save it in your website folder 

It is possible to resize the picture in Dreamweaver, by simply dragging it smaller, or changing the size at the 

bottom of the screen where it shows the picture width (W) and height (H) - but it is not a good idea as it 

often distorts the picture. Resize it in Paint/Fireworks/Photoshop or any other programme you prefer to use 

It is possible to change the appearance of a picture with, for example, a border: 

Select the picture 

Next to 'Border' at the bottom f the screen, type 5 and enter - the higher the number the thicker the 

border 

PREVIEW WEBSITE 
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SAVE 

Make sure to save your work often, using Ctrl S or File, Save 

• You now have the first page of your webpage 

• It is called Index.html 

• On it is a background colour of your choice 

• Using WordArt your name is centred on the page 

• There is a picture on the webpage 

• There is a border around the picture 

• You have previewed the website 

• It is saved

To preview the website you have created: 

Click on the ▼ next to the little globejust above the webpage Select Preview in iexplorer 

 

This is going to open the page as an internet site 



166 
Dreamweaver Tutorial 

©S Pretorius/2007 

 

 

OPEN THE WEBSITE

 

 

INSERT A PAGE

 

 

Type the name of the second page, for example Hobbies.html 

 

| FI usan (Site - Susan) 

! ! ! ........... Index, html 

I I I ............ #) Index_clip_image001 

Open Dreamweaver 
On the right-hand side of the screen, change it toyour area 
(H:) 

 

Locate the website you created 

Right-click on the website folder Select New File 
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i . ») Sunset, jpg 

Й1 | hobbies.html i :P> --lP=1| The Shnw 

Make sure to add the extension .html or .htm, otherwise Dreamweaver won't recognise it as a 

webpage (If you made a mistake, rename the file - instructions at the top of page 3 of this tutorial) 

Enter 

Double-click to open the page 

Select an appropriate background colour (Page 3)
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BULLETED LISTS 

Type Hobbies/Sport on this page, using WordArt (Page 4). 

Make sure it is left-aligned, in other words on the left-hand side of the screen Select the left-align icon in 

Properties at the bottom of the screen 

 

 

You are going to list your hobbies/sport as a bulleted list, on the left-hand side of the 

webpage To select a bulleted list, click on the 'list' icon in Properties 

 

Type your list, enter between each one - a bullet point will appear (The list must consist of at least six 

hobbies and/or sporting activities) 

 

When finish with your list, enter twice 

Find six suitable pictures/images to illustrate your hobbies/sport typed in the bulleted list - save these in your 

Pictures folder 

• You now have the second page of your webpage 

• It is called Hobbies.html 

• On it is a background colour of your choice 

• Using WordArt 'Hobbies/sport' is left-aligned on the page 

• There is a Bulleted list underneath the heading, listing at least six activities 

• It is saved 

• There are six suitable pictures saved in your 'Pictures' folder 

• There are NO pictures on the webpage! 
TABLE 

 

ii 

 

Press Enter to go down 

 

Page Pn 
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Open the second page of the website you have created Underneath the bulleted list, insert a table 

Click on the table icon in the Common toolbar, just above the webpage - it is next to the little anchor 

 

 

In the Table dialogue box, select a table of: 

2 rows and 3 columns 512 pixels 

wide 0 Border thickness 0 Cell 

padding 

0 Cell spacing 

Click on OK 

 

Do not change the size of the cells in the table, as it will adjust automatically to allow the image to fit 

 

Resize the picture to: 

W (width) ± 250 H (height) ± 100 

To change the size of the picture to the above size: 

Click on the picture 

Resize it in the Properties box, by typing in 250 and 100, enter 

 

 

 

 

A table will appear under your list 

 

Click in the first cell 

 

Insert an image in this cell (page 4) 
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It is more acceptable to resize the pictures by using another programme, for example Paint, Photoshop, 

Fireworks - but do it in the Properties box for the purposes of this tutorial 

Now insert pictures in all the cells - six in total 

 

 

 

Save the website (Ctrl S)  
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PICTURE AS BACKGROUND 

Create another page on your existing website. Name this page 

Family.html Select a picture as background, instead of using a colour: 

Click on Page Properties at the bottom of the screen 

 

Click on the Browse button, next to Background Image 

Look for a suitable image in your Pictures folder Click 

OK 

 

 

 

 

 

 

 

 

 

 

 

 

 

Dreamweaver will go through the normal procedure to save it in the website folder. Click on Yes when it 

asks you 'Would you like to copy the file there now?' 

Then click on Save 
The name of the picture will now appear in the area next to Background Image 

• j | 

Background image: | 1018.jpg 

Browse.. 
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Click on OK 

(Set the size of the photo/image to 1024 x 768 pixels, using Fireworks - then it won't be tiled 

on your webpage)
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by changing the 
 

When using an image as background, you will have to make sure the text is still 

readable colour of the font, which can be done in Page Properties or Click on Text 

in the toolbar at the top of the screen 

 

Click on Color 
Select a suitable colour 

 

Write about your family, choosing a suitable font and font size Save 

• This is the third page, called Family.html 

• You have used a background image 

• There is some information about your family 

• It is saved
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At the top of each webpage of your website, insert a table with: 

1 row 3 columns 150 pixels 

3 Border thickness 0 Cell padding 0 Cell spacing 

In the Properties window, underneath the page, 

click on Align 

and choose Center - to place the table on the centre of the 

page 

 

 

Type in the three cells: 
HOME HOBBIES FAMILY 

 

 



 

 

 

 

 

Font: 24 and Bold 
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HOME HOBBIES FAMILY 

Select the table by clicking when you see a blackarrow on the left-hand 
side of the table. Ctrl C to copy 

 

Open Index.html, move your title down and Ctrl V to paste the table 
above your name 

 

Do the same for the Family page 

To link HOME to the home page, which is called 

Index.html: Highlight the word HOME in the table 

 

 

 

 

In the blank space next to Link, in Properties, type the name of the 

home page. Ensure the spelling is exactly the same 

 

HOME should now be blue and underlined 
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Do exactly the same to link HOBBIES and FAMILY - typing in the correct 
page titles. Repeat this on all three pages 

 

Save all the pages (Ctrl S) and preview to test whether the links are 
working 

 

You now have: 

• A three page, linked website 

• Basic knowledge to create a website! 
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-Q- 

WHAT IS A WEB SERVER?

 

 

 

Never trust a computer you can’t threw out a window. 

—Steve Wozniak 

 

n this chapter we provide some background information on how documents 

are published on the World Wide Web. We explain how computers on the 

Internet talk to each other and, more important, how Web pages get from a 

Web server to a browser. When setting up a Web server, it is important to know 

a little about the underlying technology: the communications protocols, 

network terminology, and document formats. 

 

CHAPTER OBJECTIVES  

In this chapter you will learn about:  

• Client/server Basics Page 2 

Electronic Publishing Page 10 

HTTP Overview Page 19 

• Other Web-Related servers Page 29 

I 
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LAB 

1.1 

2 Lab 1.1: Client/Server Basics 

L A B  1 . 1  

CLIENT/SERVER BASICS 

LAB OBJECTIVES 

After completing this lab, you will be able to: 

• Understand Client/Server Concepts 

• Describe Basic Functionality of Web Stervers and 

Browsers 

Before we even start to talk about Web servers, let’s look at clients and servers 

in general. In network terminology, a client is a piece of hardware or software 

used to communicate with a data provider (server). Normally, only one user uses 

a specific client at a time. A client connects to a server to send and receive 

information. Think of a client as a program that gets information from somewhere 

else. A server is usually a large computer capable of providing data to many 

clients at the same time. The word server can mean the physical computer or 

piece of hardware, or it can refer to the actual server software or daemon running 

on that machine. A daemon is a program that offers a service to other programs, 

usually over a network. It accepts requests from clients, processes the requests, 

and returns the results to the requesting client. Although the client and server 

can be on the same machine, they are usually on separate machines connected 

by some kind of network. 

The World Wide Web (WWW) uses this client/server model to allow millions of 

users to access Web sites all over the world. A Web server is a specific type of 

server that knows how to communicate with clients using the HyperText Transfer 

Protocol (HTTP). A protocol is just a standard set of rules that allow a client and 

server to communicate. For a client and server to communicate, they must speak 

the same protocol. HTTP allows clients to request documents and servers to 

respond with those documents. We will look at HTTP in more detail in Lab 1.3, 

but for now, think 
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Lab 1.1: Client/Sever Basics 3 

of it as a small language. On the Web, the clients are Web browsers—ap-

plications especially well suited for displaying HTML content. Web servers wait 

for clients to connect and when a connection is established, they receive a 

request from the client and then respond—usually returning a document or 

image. The Web server process is usually referred to as the HTTPD, or HTTP 

daemon. 

NETWORK CONNECTIONSAND PORTS 

To connect to a server, the client must be able to communicate with it over the 

network. Computers connected to the Internet typically communicate using 

TCP/IP (Transmission Control Protocol and the Internet Protocol). TCP/IP allows 

different types of computers to communicate at a low level; it is up to 

applications, however, to determine how client and server software talk to each 

other. Applications such as e-mail, ftp, and Web browsers use their own 

protocols (SMTP, HTTP, etc.) to communicate on the application level while 

using TCP/IP at the network level. 

TCP/IP uses IP addresses to communicate between computers. Each computer 

on the Internet has its own unique IP address. When a computer wants to send a 

message to another machine on the Internet, it specifies the address of the other 

machine and the message finds its way through the network. This is similar to 

how a letter finds its way through the postal system. The destination computer 

may have many different services running on it, so to specify which service we 

want to communicate with, we must use a port number. Each service has a 

unique number assigned to it known as a port number. Most of the services have 

standard port numbers. 

SERVERSAND BROWSERS 

The main goal of any Web server is to provide documents to clients. The first 

Web servers were very simple and did little more than this. Today’s Web servers 

are full of features that allow them to do more than just respond to simple 

requests for static documents, and many provide easy-to-use graphical user 

interfaces for administration and customization. Today’s servers support options 

that allow the creation of dynamic documents—documents that are generated on 

the fly, not stored on disk. 

The purpose of a Web browser is to retrieve and display information from a Web 

server by using HTTP. A browser allows any user to access a server easily. 

Without even knowing what a Web server is, a user can easily obtain information 

from one just by entering a URL. Browsers have evolved 
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also, adding features that far extend the capabilities of browsers that once 

displayed only basic HTML. 

BROWSER PLUG-INS 

A plug-in extends the capabilities of a browser by allowing it to display more than 

just HTML documents. Adobe’s Acrobat plug-in allows browsers to display PDF 

(Portable Document Format) files, and Macromedia Shockwave and Flash plug-

ins allow authors to embed multimedia applications in Web pages. Plug-ins 

typically rely on the browser to retrieve the content (using HTTP) and then 

display it themselves. Plug-ins such as Real Networks’ RealPlayer, however, are 

able to use their own protocols instead of HTTP to retrieve content. RealPlayer 

enables browsers to play streaming audio and video, which has different 

requirements than text documents, so a protocol other than HTTP is used by the 

plug-in to enhance performance. Helper applications are similar to plug-ins; they 

allow you to view content that your browser cannot. Unlike plug-ins, helper 

applications run outside the browser. They are stand-alone applications and they 

cannot be used to embed content in Web pages. 

LAB 1.1 EXERCISES 

1.1.1 Understand Client/SErver Concepts 

a) What are the benefits of using a client/server model? 

b) Give an example of another type of client/server application. 

c) How does a hostname get translated into an address? Find out the IP 

address of a host (try www.phptr.com). 

 

http://www.phptr.com/
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1.1.2 Describe Basic Functionality OFWEB SERVERS AND BROWSERS 

a) What is the primary function of an HTTP server? 

b) Who developed the first Web server? What other early Web servers 

were developed? 

c) What is the primary function of a Web browser? 

d) What was the first Web browser? Why did it succeed where similar 

services (such as ftp, gopher, and WAIS) failed? 

LAB 1.1 EXERCISE ANSWERS 

1.1.1 Understand CLIENT/SERVER Concepts 

a) What are the benefits of using a client/server model? 

Answer: Making data available on a server can make it possible for many 

clients; to access that data. Clients can be dispersed geographically. Clients 

are sure to receive the most up-to-date information. The framework of the 

server can be changed (database back ends ^n be switched) without 

affecting the clients Sferver maintenance is easier if all clients are 

connecting to one place. 

The client/server model is ideal for distributed applications. A server allows 

clients access to current data and allows clients to be dispersed anywhere there 

is network connectivity. A client generally asks a server for a 
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resource but does not care how the server gets that resource. Therefore, the server’s 

underlying technology can be changed without changing the client’s functionality. For 

instance, you could change your server to access an Oracle database instead of a 

Microsoft database. Another benefit to having all services provided through a central 

server is that maintaining those services becomes a little easier—or at least more 

manageable. 

One of the benefits of this model is that all account information is located in a central 

place. Consider the example of a bank with automated teller machines (ATMs). If bank 

account information were stored at each ATM site, it would be much harder to keep 

accounts up to date. By centralizing account information, many clients are able to get 

up-to-date account information easily. Administration is also easier when there is just 

one central server to worry about. It is easier to monitor and maintain one server or 

even a number of servers when they are all in one centralized location. 

b) Give an example of another type of client/server application. 

Answer: A classic example of client/server is a bank ATM network. Think of the 

ATMs as dients—one user at a time can use each ATM to make withdrawals from 

their account. Each ATM connects to a central computer (a server) to verify your 

PN number and gain access to your account information. 

c) How does a hostname get translated into an address? Find out the IP 

address of a host (try www.phptr.com). 

Answer: When a client wants to talk to a server, it must know the \P address. A user 

will usually enter a hostname rather than \P address, though, and the computer 

will then resolve the hostname into an \P address that it can use:. When the client 

makes an initial request to talk with a server, it specifies which \P address it wants to 

talk with (the unique \P address of the server) and specifies a port number. A port 

number is used to specify which service the client wishes to use (HTTP, telnet, ftp, 

etc.). Think of this like a telephone call: a telephone number is like an \P address and 

a port is an extension. Fbrts allow networked computers to provide many services 

but use only a single address. 

Applications use standard port numbers to communicate. Some standard services and 

ports are:

 

 

 

 

FTP 

Telnet 

SMTP (e-mail) 

HTTP 

20, 21 

23 25 

80 

http://www.phptr.com/
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When you type a URL into a Web browser to request a Web page via HTTP, it 

will try to connect to the server at port 80 unless you specify a different port 

number. There may be times when you want to run a service on a nonstandard 

port. For instance, you might have a production Web server running on port 80 

but set up another HTTPD on port 8080 for testing purposes. On UNIX servers, 

port numbers below 1024 are available only for use by programs running as the 

root user (the system administrator). Ports above 1023 are available to programs 

running as any normal user provided that the port is not already in use. Once a 

daemon starts running on a port, any client can connect to it. 

1.1.2 Describe Basic Functionality OF WEB SERVERS AND BROWSERS 

a) What is the primary function of an HTTP server? 

Answer: The primary function of an HTTP server is to service client requests 

for documents. It waits for HTTP requests and then returns data for each 

one. An HTTP daemon provides an HTTP service. It allows a server to 

support client requests for documents. It generates errors when invalid 

requests are received or when a document cannot be found. The Web server 

process also generates log files of requests, errors, and other information. 

b) Who developed the first Web server? What other early Web 

servers were developed? 

Answer: The European Laboratory for F&rtide Physics (CERN) produced 

one of the first Web servers The World Wide Web Consortium (W3C) took over 

development of the CERN HTTFD (also known as the W3C HTTPD), but no 

longer supports it. The W3C currently supports a aa-based server known as 

Jgpaw/. Both the CERN HTTFD and Jigsaw/ are reference implementations, 

meaning that they illustrate features of HTTP but are not meant for large-

scale production use:. Source code is available for both servers and they are 

excellent points of reference for developers wishing to write their own HTTP 

daemons 

The National Center for Supercomputing Applications (NCSA) also created an 

HTTP server early in the evolution of the Internet. The CERN HTTPD was 

difficult to configure and not available for many platforms, so NCSA wrote their 

own version. The NCSA server quickly became the most popular Web server on 

the WWW from 1993 to 1995. Like the CERN server, however, development on 

the NCSA HTTPD has also ceased. Apache is a popular server based on the 

NCSA implementation. Originally written using existing code from the NCSA 

HTTPD, it has since been rewritten completely. Currently, Apache is the most 

widely used Web server software, with close to 50 percent market share. 
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Apache, CERN, and NCSA all released the source code for their Web servers. This 

made fixing bugs easier because anyone could see how the server worked. These 

servers make excellent examples for Web server developers, and they allow easy 

modification or customization of any aspect of the server. 

c) What is the primary function of a Web browser? 

Answer: The primary function of a Web browser is to display HTML documents Al-

though it can be used to view local documents on a hard drive, it is normally used 

as a client to retrieve documents from an HTTP server. Although browser 

software has expanded over the past few years to include such services as e-mail and 

news, its primary function is to format HTML documents for display. 

d) What was the first Web browser? Why did it succeed where similar 

services (such as ftp, gopher, and WAlS^ failed? 

Answer: The first real HTML browser, NCSA Mosaic* came into being in early 

1993. Although the hypertext documents had been around for some time, 

Mosaic had several essential features that made it popular right from the start. 

First, it was free, as are most browsers even today. Second, it was available for all 

major platforms: UNIX, Macintosh, and Microsoft Windows. Third, it was easy to 

create content—no special software was required to write HTML, only a text 

editor. Before Mosaic* only text- based clients such as gopher, WAIS, telnet, and 

FTP were widely available for retrieving information on the Internet. An easy-to-

use GUI interface and easy-to-create content launched the Web in the form of 

NCSA Mosaic clients and HTTFD servers

  

LAB 1.1 SELF-REVIEW QUESTIONS 

To test your procress, you should be able to answer the following questions. 

1) A Web server is which of the following? 

a)  ____ Software 

b)  ____ Hardware 

c)  ____ Both a and b 

2) A Web server can run on just about any type of machine, not just a huge, 

expensive server. 

a)  ____ True 

b)  ____ False 

3) A browser utilizes which of the following technologies? (Choose all that apply.) 

a)  ____ A network 

b)  ____ A Web server 

c)  ____ A phone line 

d)  ____ HTTP 
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Lab 1.1: Client/Server Basics 9 

4) Which of the following may be a reason for running a Web server on a port 

other than port 80? 

_ You don’t have access to port 80 (since you aren’t root). 

_ You are running multiple Web servers on the same machine. _ You 

don’t have enough memory. 

_ Both a and b All of the above

 

5) A server can 

also be a client. 

a)  _____ True 

b)  _____False 

Answers appear in Appendix A
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L A B  1 . 2

ELECTRONIC PUBLISHING 

LAB OBJECTIVES 

After completing this lab, you will be able to: 

• Understand the Basics of Creating Hypertext 

Documents 

• Understand the Difference between ASCII and Binary 

Files 

• Give Examples of MIMETypes

 

To understand more about Web servers and HTTP transactions, one must also be 

aware of how authors create and publish electronic documents. Although the focus of 

this book is not content creation, it is a good idea to familiarize yourself with some of 

the more technical aspects of electronic documents. 

One of the strengths of the Web is the support of hypertext documents. A hypertext 

document contains hyperlinks (commonly referred to as links) that allow the reader to 

jump easily from one document to another, or to move around the current document. 

Links allow the user to follow a specific thread or view quickly documents on related 

topics. The Web is not limited to text documents, though; HTML documents can 

contain images, sounds, animations, and even video. Web publishing is about creating 

hypermedia, not just hypertext. 

In the Web-publishing realm, we deal with two types of files: ASCII text files and binary 

files. ASCII files can be HTML or plain text or some other simple format. Most other 

files tend to be of the binary kind. A simple 
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text editor (notepad, emacs, vi) can create ASCII text files. You can create HTML 

documents by writing the HTML tags yourself with a text editor. Most Web 

authors will use a good text editor to do some of their authoring but supplement 

its use with a specialized HTML authoring package. Netscape Composer, 

Microsoft FrontPage, Macromedia Dreamweaver, and Adobe PageMill are some 

widely used HTML authoring packages. 

ASCII TEXT FILES 

Strictly speaking, an HTML document is just an ASCII text file. ASCII is the most 

common way of storing plain text on a computer. It uses numerical values (from 

0 to 127) to represent letters, numbers, and other characters. Each byte of the 

file represents a specific character. For example, the letter “A” is represented by 

the number 65, the letter “B” by 66, and so on. For a list of all the ASCII values, 

see Appendix B. 

ASCII text files are not compressed and can usually be viewed or edited by any 

simple text editor. Most operating systems can view and edit plain text files 

easily. Most use ASCII for representing text. Part of the appeal of HTML is that it 

is very easy to view the source code. This allows anyone to see how a certain 

effect was created. 

BINARY FILES 

A binary file is one that generally does not contain plain text in ASCII format. 

Images, sounds, and even compressed ASCII files are all binary files. To view 

them, an application must interpret the file. Word processors also create binary 

files—although they create text documents; the application saves the document 

in a binary format. Your word processor may be able to read and write ASCII 

files, too, but the files do not contain formatting information (fonts, margin 

settings, and the like). Any image or sound editing application also deals with 

binary files. 

IMAGES 

There are hundreds of file formats available for storing graphics and images. 

Web browsers typically support only a handful of image formats, however. The 

most common types of images are GIF and JPEG formats. Each of these 

formats has strengths and weaknesses. Both formats use compression to reduce 

the size of the file. GIF uses a lossless compression, meaning that it does not 

lose any of the image quality. JPEG images, on the other hand, use a lossy 

compression in which a relatively small file size is achieved with sacrifice to the 

image quality. GIF supports up to 256 colors, while JPEG images support 

millions of colors. 
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Another format that is just recently gaining popularity in Web publishing is the 

PNG (portable network graphic) format. PNG images offer millions of colors, 

lossless compression, and other features that make them a good alternative to 

GIF images in many cases. Table 1.1 summarizes the differences in these image 

formats. 

AUDIO 

Most browsers have the ability to play sound files. This ability allows Web authors to include sound 

clips in their HTML documents. Audio vT" files 

are embedded in a page to play automatically, or they can be used as vT" 

links to be played when a user clicks on a link to the sound file. There are three 

sound formats commonly used on the Web, one corresponding to each of the 

three major platforms. Most current browsers with audio capabilities can support 

all three formats, so authors are free to choose which format to use and not 

worry too much about compatibility issues. 

Table 1.2 summarizes the differences in the three most common audio formats: 

WAV, AIFF, and AU. 

MIMETYPES 

The multipurpose internet mail extensions (MIME) are a set of rules that allow 

multimedia documents to be exchanged among many different computer 

systems. MIME was originally designed for sending attachments in e-mail, but it 

is also incorporated into HTTP. MIME uses media types and subtypes to 

describe the format of a file. 

A Web server must determine the MIME type of a file before it sends it to the 

browser. To do this, it looks at the filename extension (suffix) and then tries to 

find that suffix in the MIME types database. Usually, this database is just a text 

file named MIME.types that contains a list of media types and their associated 

file extensions. It then sends the MIME type along with the document to the 

browser. The browser can use the MIME type to determine how it should display 

the document. Both the 

 

12 Lab 1.2: Electronic FLibiishing  

Table 1.1 • Image File Formats  

GIF JPEG PNG 

256 colors (8-bit) 16 million colors (24-bit) 16 million colors (24-
bit) 

Lossless 
compression 

Lossy compression Lossless compression 

Transparency No transparency Transparency and 
opacity 

Can be animated No animation No animation 
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server and client must have a simple MIME types database. On the server it is 

usually a text file. On the client, each user may have its own MIME settings, 

either in a file or as part of the operating system configuration. Windows 

maintains file type associations in the registry, while UNIX typically uses text 

files. Maintaining a database for each user allows users to customize their tools 

to use different applications, depending on what type of file they’re trying to view. 

There are currently seven different media types in use: application, audio, image, 

message, multipart, text, and video. These media types provide a high-level 

description of the type of data sent. MIME also uses subtypes to further describe 

the actual data. For example, HTML is a text format, so it falls into the text media 

type. Its subtype is just html, so the MIME type for an HTML document would be 

text/html. A plain text document is described by text/plain. Images fall into the 

image category; image/gif describes a GIF image and image/jpeg describes a 

JPEG image file. 

LAB 1.2 EXERCISES 

1.2.1 Understand the Basics of Creating 

Hypertext Documents 

Use a text editor (not a word processor or publishing program) to create a simple 

HTML document with a hyperlink to the FTentice Hall Web site 
(http://www.phptr.com/). 

 Lab 1.2: Electronic Publishing 13 

Table 1.2 • Audio File Formats  

WAV Files AIFF Files AU Files 

Originated on Windows- Originated on Originated on Sun 

based machine Macintosh (audio Microsystems work- 

(introduced with interchange file stations (UNIX) 
Windows 3.0) format)  

8-kHz, 8-bit mono to 8-kHz, 8-bit mono to 8-kHz, 8-bit mono to 

44-kHz, 16-bit stereo 48-kHz, 16-bit stereo 48-kHz, 16-bit stereo 

Formally known as Used for Red Book CD The “original” Internet 

RIFF WAVE audio audio sound file format 

Can be compressed or Not compressed; very Can be compressed or 

Uncompressed pure format uncompressed 

 

http://www.phptr.com/
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a) What happens when you view your page in a browser?
 

 

 

 

b) Click on the hyperlink; it should display the Prentice Hall home page. View the source of the Prentice Hall home 

page. What do you see? 

1.2.2 Understand THE Difference between ASCII and 

Binary FILES 

a) Find an image on the Prentice Hall home page. Can you determine what 

type of image it is? 

-Ф-  -----------------------------------  -Ф- 

b) View the image by itself, then view the source of the image in the 

browser as you did with an HTML file. What do you see? 

1.2.3 Give Examples of MIME TYPES 

a) View any Web page from a browser. How can you determine what the 

MiME type of the document is? 
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b) How are MIME types used when requesting or receiving documents on 

the Web? 

LAB 1.2 EXERCISE ANSWERS 

1.2.1 Understand the Basics of Creating 

Hypertext Documents 

use a text editor (not a word processor or publishing program) to create a simple 

HTML document with a hyperlink to the Prentice Hall Web site 
(http://www.phptr.com/). 

a) What happens when you view your page in a browser? 

Answer: If you created a valid HTML document and saved it with a .html 

extension, it should look like a simple Web page—as you’d expect. If you 

saved it with a .txt extension (which is the default for many text editors), you 

might be looking at the source HTML in your browser rather than a formatted 

version. And, of course, if the HTML you entered is not valid, you might see 

some rather strange results in the browser. 

Here is a simple example HTML document: 

<HTML> 
<TITLE>My web Page</TITLE> 

This is a simple web page.<BR> 

<A HREF=http://www.phptr.com>Click Here for Prentice Hall</A> 

</HTML> 

To create an HTML document, simply enter this text into a text editor and save it 

as myfile.html. In Windows, use notepad by clicking on the “Run” option in the 

Start menu, and entering “notepad” as the program to open. Enter the text to 

create your document and then save it as myfile.html in the directory of your 

choice. It is very important to save it with a .html extension; if you don’t, the 

browser will not know that it is an HTML document. 

 

http://www.phptr.com/
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b) Click on the hyperlink; it should display the Prentice Hall home page. 
View the source of the Prentice Hall home page. What do you see? 

Answer: Viewing the source of any HTML document you find on the Web 

should show you the source code used to generate the document. For very 

complex paces, a lot of source is displayed, and it is often hard to read. For 

simpler pages, however, you can see exactly how the page is put together. 

This text that you are viewing is plain ASCI\ text with no special formatting. 

Clicking the right mouse button in Netscape or Internet Explorer brings up a 

menu that allows you to view the source of the current document. The “View Info” 

option in Netscape gives you valuable information about the page also. If you 

right-click on an image or other object in a page, the menu displays different 

options. 

1.2.2 Understand THE Difference between ASCII and 

Binary FILES 

a) Find an image on the Prentice Hall home page. Can you 

determine what type of image it is? 

Answer: \f you can determine the name of the image file, you should be able 

to determine the type by the filename extension. To find the name of the 

image, you might try looking at the source code. The filenames for all images in the 

document should be in the <img> tags. 

Another way to get more information about an image is to right-click on the image 

in the browser to bring up the options menu. For Netscape, click on “View 

Image.” This displays the image by itself in the browser window. Now right-click 

on the image and select “View Info.” This should display some information about 

the image, including its MIME type. In Internet Explorer, you can right-click on an 

image in an HTML document and select properties from the pop-up menu. This 

will also display the type, size, and other information about the image. 

b) View the image by itself, then view the source of the image in 

the browser as you did with an HTML file. What do you see? 

Answer: \n Netscape, do a “View \mage” as in Exercise 1.2.1. Now right-click 

on the image and select “View Source” or select “Page Source” from the view 

menu. You should see a page full of garbage characters. This is binary data. 

Unlike ASCH text files, images are not meant to be viewed in text mode. 
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1.2.3 Give Examples of MIM E TYPES 

a) View any Web page from a browser. How can you determine what 

the MiME type of the document is? 

Answer: In Netscape, you can get information about the page that you’re 

currently viewing by selecting “Page Info” from the view menu. In Internet 

Explorer, you can right-click in the document and select “Ropertie£’ from the 

option menu. Along with the MIME type, you can view other information about 

the document that is provided from the HTTP headers. Netscape shows the 

last modified time, when the document expires, and whether or not the 

document is cached. 

For HTML documents you should see that the MIME type is text/html. The media 

type is “text”—HTML is fundamentally text. The subtype is html, which further 

describes the type of text. 

b) How are MIME types used when requesting or receiving documents 

on the Web? 

Answer: A browser is able to specify what types of data it is capable of 

displaying and it specifies this by using MIME types When a server returns a 

document, it must tell the browser what type of data is being returned, and it 

also specifies this by using a standard MIME type. 

LAB 1.2 SELF-REVIEW QUESTIONS 

To test your progress, you should be able to answer the following questions. 

1) An HTML file contains: 

a)  ____ Text 

b)  ____ Images 

c)  ____ Both text and images 

d)  ____ Binary data 

2) Which of the following types of tools cannot be used to create 

hypertext documents? 

a)  ____ A simple text editor 

b)  ____ A word processing program 

c)  ____ An automatic HTML generator 

d)  ____ A graphics utility 

e)  ____ All of these are capable of creating hypertext documents. 
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3) Mime types are important for which of the following reasons? 

a)  _____ They allow the browser and server to communicate. 

b)  ____ They tell applications what kinds of documents are being sent. 

c)  ____ They speed the transmission of binary files. 

d)  ____ FTP uses them to determine how to transfer files. 

4) What is the MIME type of an HTML document? 

a)  ____ html/text 

b)  ____ HTML 

c)  ____ text/html 

d)  ____ text/plain 

5) Why is a simple text editor useful to a webmaster? 

a)  ____ It generates plain text files with no special characters. 

b)  _____ Text editors are generally available on all platforms. 

c)  ____ In many cases it’s quicker than using a large application. 

d)  ____ All of the above 

Answers appear in Appendix A. 
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L A B  1 . 3

HTTP OVERVIEW 

LAB OBJECTIVES 

After completing this lab, you will be able to: 

• Identify the Parts of an HTTPTransaction 

• Identify HTTP Request Methods 

• Identify HTTP Headers and Sferver Responses 

-Ф- HTTP transactions -ф. 

As you learned in Lab 1.1, HTTP is a protocol that allows Web browsers to talk 

to servers and exchange information. HTTP provides a standard way of 

communicating between browsers and Web servers—so any browser can talk 

to any server, provided that they both conform to the HTTP specification. HTTP 

expects the client to initiate a request and the server to respond. Each request 

and response has three parts: the request or status line, the header fields, and 

the entity body. 

• FOR EXAMFLE 

When you type a URL into your browser, it initiates an HTTP request to a Web 

server. That request has the following sections: 

• Request line. This line contains a request method, the document 

location, and the protocol version. 

• Header section. This series of lines contains HTTP headers that 

are used to pass other information about the request, and about the 

client itself, to the server. A blank line then separates the header 

section from the entity body. 

• Entity body. This section contains other data to be passed to the 

server. There is usually information here only when a form is 

submitted. 
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If we typed http://webmaster.merrimack.edu/simple.html as a URL into Netscape, 

the browser would issue an HTTP request similar to the following: 

GET /simple.html HTTP/1.0 

User-Agent: Mozilla/4.5 [en] (X11; SunOS 5.5.1 sun4m) Accept: image/gif, image/x-

xbitmap, image/jpeg, */* 

There is a request line, followed by two HTTP headers and no entity body. The 

request line has three parts: a request method, the document location, and the 

protocol version. In this case the method is a GET method, the document 

requested is simple.html, and the protocol is HTTP version 1.0. The client also 

passes the User-Agent and Accept headers to the server.

 
The server then responds to the request in a similar fashion: 

• Status line. This line contains the protocol version, a status code, 

and a reason phrase. 

• Header section. This series of lines contains HTTP headers that are used to pass other 

information about the response, and about the server itself, to the client. A blank line 

then separates -Q- 

the header section from the entity body. 

• Entity body. This section, if present, contains the document (or object) requested. 

For the previous example, the server response might look something like this: 

HTTP/1.1 200 OK 

Date: Mon, 04 Jan 1999 00:33:10 GMT Server: Apache/1.3.1 (Unix) 

Last-Modified: Tue, 20 Oct 1998 21:00:39 GMT Content-Length: 49 Content-Type: text/html 

<HTML> 

Welcome to the webmaster server... </HTML> 

There is a status line, followed by a header section containing five headers, and 

the entity body, which is a simple HTML document. Like the request line, the 

status line has three parts: the protocol version, a status code, and a reason 

phrase. In this case, the server is using HTTP version 

 

http://webmaster.merrimack.edu/simple.html
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1.1, and the HTTP response code is 200, which means that the client’s request was successful 

and the server’s response contains the data requested. The header section contains several 

headers that tell us a little bit about the server and the document returned in the entity body. 

REQUEST METHODS 

The request line of a client request contains an HTTP command called a request method. The 

server uses the method command to determine what to do with the request. There are currently 

several methods defined by the HTTP 1.1 standard, but only a few are widely 

supported by HTTP servers. The most widely used methods are GET, HEAD, 

and POST. Method commands should be in all-capital letters. 

THE GET METHOD 

The GET method is used to retrieve information from the server. It is most commonly used to 

retrieve documents from the Web server. Nothing is passed to the server in the entity body 

because this method is simply a request. The document returned by the server could be a static 

HTML document, output generated by a CGI program, or it could be an error generated by the 

server if something is wrong with the request. The previous example illustrates a GET method. 

The GET method can pass information to the server (usually to a CGI program), but it must 

be included as part of the URL. To pass parameters as part of the URL, the URL must be 

followed by a question mark (?) and then the parameter pairs. 

THE HEAD METHOD 

The HEAD method is identical to the GET method except that the server does not return a 

document; it returns only the header section for the request. The HEAD method is useful for 

verifying that a document exists for checking links or to get information about the file type and 

modification time only. 

THE POST METHOD 

The POST method allows the server to receive data from the client. It is most commonly used to 

send the data in HTML forms to the server for processing. This method passes data to the 

server in the entity body of the request. 
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The PUT method is becoming more widely supported. It is used for publishing documents to the 

Web server from a client. Many of the latest HTML authoring packages support posting 

documents to a Web server via the PUT method (more on this in Chapter 3). The DELETE 

method is used to remove a document from a Web server. 

SERVER RESPONSES 

After an HTTP server receives a request, it attempts to process the request. If a document is 

requested, the Web server will attempt to find the document and return it. If form information is 

passed to the server, the HTTPD passes that information to the appropriate resource for 

processing and returns any output. If the resource requested cannot be located, or if there is 

something wrong with the request itself, the server generates an error. 

The server response, like the client request, has three parts: the status line, header fields, and 

the entity body. The status line contains three things: the protocol version, the status code, and 

a description phrase. The protocol should always be HTTP. The status code is a three-digit inte-

ger result code defined by the HTTP specification. The first digit of the status code 

represents the category of the response. There are currently five categories: 

1) Informational. The request was received and is being processed. 

2) Success. The client request was successful. 

3) Redirection. The client request was not performed; further action must be taken 

by the client. 

4) Client error. The client’s request was incomplete or incorrect and cannot be 

fulfilled. 

5) Server error. The request was not fulfilled, due to a server problem. 

Here are some of the most common response codes. 

INFORMATIONAL 1XX 

100 Continue The initial part of the request has been received and the client should 

continue. 
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302 Found (Moved Temporarily) 
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404 Not Found 
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SUCCESSFUL 2XX

This is probably the most common response; it means that 

the client’s request was successful and the server’s 

response contains the resource requested. 

The request was successful but the response is empty. 

The client should not do anything when it receives this 

message.
 

 

REDIRECTION 3XX 301 

Moved Permanently 

304 Not Modified 

The URL requested is no longer 

valid. The server should return 

the new location. 

The URL requested currently re-

sides in a different location. 

The client performed a condi-

tional GET (If-Modified-Since 

header) and the document has 

not been modified. The entity 

body is not sent.

 
CLIENT ERROR 4XX 

400 Bad Request The server could not understand the request. 

403 Forbidden The client requested data that it did not 
have per- 

mission to access. 

The resource requested was not found on the server.
 

SERVER ERROR 5XX 500 

Internal Server Error 

Something unexpected 

happened on the server side. The most 

common reason for receiving this error is a 

problem with a server side program.

 

HTTP HEADERS 

The HTTP header section is used to transfer information between the client and 

server. A header has a name and a value associated with it. There is one header 

per line and each line contains the header name followed by a colon, a space, 

and the value of the header name. Headers are used to transfer information 

about the client to the server, and vice versa. They are also used to transfer data 

related to the returned document, 
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Content-Length 

Content-Type 

Expires 

Last-Modified 
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cache parameters, cookies, and other session information. Some of the most 

common HTTP headers are described below. 

CLIENT REQUEST HEADERS

 

 

 

 

 

 

 

 

 

SERVER RESPONSE HEADERS 

Server Contains information about the server software handling 

the request. 

Set-Cookie Allows the server to set a cookie on the client browser (if permitted) 

for the given URL or domain. 

ENTITY HEADERS
 

Specifies the size (in bytes) of the data transferred in the 

entity body. This header is sent for most static 

documents, but not for dynamically generated content 

(i.e., CGI programs). 

Specifies the MIME type of the data returned in the entity 

body. 

Specifies the time/date after which the response is 

considered outdated. This header is useful for caching 

documents—if the browser knows when the document 

will change, it does not need to retrieve a fresh copy until 

then. 

Specifies the date and time the document was last 

modified. 

Accept 

Cookie 

If-Modified-Since 
LAB 

1.3 

Referer 

User-Agent 

Used to specify which media types the client prefers to 

accept. 

Contains cookie information (name/value pair, etc.) for 

the URL requested. 

Used to do a conditional GET request. The server will 

return the document only if it has been modified since the 

date specified. 

Allows the client to specify the URL of the page from 

which the currently requested URL was obtained. 

Contains information about the client program 

originating the request. It is used to identify the 

browser software. 
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LAB 1.3 EXERCISES 

1.3.1 Identifythe Partsofan HTTP Transaction 

a) What are the three parts of every HTTP transaction? 

LAB 
1.3 

1.3.2 Identify HTTP Request Methods 

a) Name the three most widely used request methods. 

b) What is the difference between a GET and a POST method? 
-Ф- -Ф- 

c) What is the difference between a HEAD and a GET method? 

1.3.3 Identify HTTP Headers and SERVER Responses 

a) What header is sent by the client to identify and give information about 

the browser? 
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26 Lab 1.3: HTTP Overview b) What header is sent by the server so that the browser 
can determine what type of content is being returned? 

c) What header is sent by the server to identify the server software? 

LAB 1.3 EXERCISE ANSWERS 

1.3.1 Identifythe Partsofan HTTP Transaction 

a) What are the three parts of every HTTP transaction? 

Answer: A request or response line, a header section, and an entity body. 

A request line is sent as the first line of all HTTP requests. The browser then 

sends any relevant headers. An entity body is sent only when data other than the 

headers needs to be sent to the server. A GET method does not usually contain 

an entity body, but a POST or PUT method usually does. 

A response line is sent as the first line of all HTTP responses. The server then 

sends any relevant headers and the entity body. The entity body is usually the 

document requested, but it could also be error information if an error occurred 

while trying to retrieve the document. 

1.3.2 Identify HTTP Request M ethods 

a) Name the three most widely used request methods. 

Answer: GET, POST, and HEAD. 

Currently, these are the most widely used request methods. As new features are 

added to the HTTP specification, other methods may become more widely used. 

b) What is the difference between a GET and a POST method? 
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Answer: The GET method contains no entity body. To pass data to the server it 

must include the data in the URL The POST method transfers data in the entity 

body. 

c) What is the difference between a HEAD and a GET method? 

Answer: The HEAD method is used to return the header section for a specific 

document; it does not return the document itself. 

1.3.3 Identify HTTP Headers and SERVER Responses 

a) What header is sent by the client to identify and give information about the 

browser? 

Answer: The User-Agent request header contains information about the client 

program originating the request. This is not a required header, but most 

browsers send it when making a request. The server can use this header to determine 

what browser is requesting a document and to tailor its response if necessary. 

Netscape sends a User-Agent header similar to the following: 

Mozilla/4.5 [en] (X11; U; SunOS 5.5.1 sun4m) 

Internet Explorer sends a User-Agent header similar to the following: 

Mozilla/4.0 (compatible; MSIE 4.01; Windows 98) 

b) What header is sent by the server so that the browser can determine what type 

of content is being returned? 

Answer: The Content-Type header indicates the media type of the data contained in the 

entity body. The server determines the type of data by looking at the file 

extension and referencing the M\ME types file. 

c) What header is sent by the server to identify the server software? 

Answer: The Server header field contains information about the HTTPD 
software. 

The Apache Web server returns a Server header similar to the following: 

Server: Apache/1.3.1 (Unix) 

Microsoft’s IIS returns a Server header similar to the following: 

Server: Microsoft-IIS/4.0 
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LAB 1.3 SELF-REVIEW QUESTIONS 

To test your progress, you should be able to answer the following questions. 

1) What is the first thing that is passed to the server when an HTTP 

transaction begins? 

a)  ____ The request line 

b)  ____ The entity body 

c)  ____ The transaction line 

d)  ____ The header section 

2) The GET method is the only method that retrieves information from the 

server. 

a)  ____ True 

b)  ____ False 

3) What is the Referer header used for? 

a)  ____ It refers people to your site. 

b)  ____ It redirects URLs that no longer exist. 

c)  ____ It shows the link that was clicked to get to the page being requested. 

d)  ____ It is not used. 

4) Headers are used by the browser to determine when a document will expire. 

a)  ____ True 

b)  ____ False 

Answers appear in Appendix A 
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L A B  1 . 4  

OTHER WEB-RELATED SERVERS 

LAB OBJECTIVES 

After completing this lab, you will be able to: 

 Understand the Functionality of Proxy Servers Identify  

 Other SfervicesThat May Run Alongside an HTTP Server 

A server that can communicate by HTTP is a great thing because it is able to 

communicate with millions of other computers. Any browser can retrieve your pages 

and view them. For many people, a system running an HTTP server suits their 

needs just fine, but there are other servers that you should know about. In this lab 

we discuss a few of the most common servers that run alongside an HTTP server. 

PROXY SERVERS 

A proxy server is an intermediary server that goes between a client and the 

destination server—a middleman. A browser configured to use a proxy server for all 

requests allows the proxy server to process the request and response. Instead of 

connecting directly to the destination server when a request for a URL is made, the 

browser sends the request to the proxy. The proxy then passes the request to the 

destination server, receives the response, and passes the response back to the 

browser. This may sound like a lot of work, but having a proxy machine in the 

middle of the transaction allows some extra processing of the returned data to take 

place. 

Proxy servers have three main uses: security, content filtering, and caching. Used 

for security purposes, the proxy can act as a firewall, allow- 

-Q-
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ing only HTTP traffic through and rejecting other protocols. A firewall limits what kinds of 

services are available to people outside your local network. You might only want to allow 

HTTP requests to get to your server and deny FTP, telnet, and other services. Proxies 

can also filter data, restricting access to certain sites or analyzing content for question-

able material. Caching proxy servers help improve performance by storing frequently 

accessed documents locally. 

Security uses of proxy servers are covered in detail in Chapter 10, so let’s take a look at 

the other two uses for proxies: filtering and caching. Restricting access to content based 

on file type is another possible use for a proxy. In terms of security, html documents are 

reasonably harmless, but executable files can pose a threat to security. A system 

administrator may choose to allow only nonexecutable content through the proxy, 

blocking .exe files and similar documents that execute on local hosts. By allowing only 

simple text documents and images through the proxy, it is much more difficult for viruses 

and hackers to gain access to computers on your side of the proxy. 

Not all Web pages are cacheable, because content is dynamically generated. HTTP 

headers play a big role in determining if a new document needs to be retrieved or if the 

cached document is still valid. The Expires HTTP header specifies when the document 

may change. A Web cache can look at this header to determine if the document is still 

valid. If the Expires header is set to a time in the past, a new document is retrieved; oth-

erwise, the cached version is returned. If the server did not set an Expires header, the 

client can use the If-Modified-Since header to fetch the document only if it had not been 

modified since a certain date. The client requests the document conditionally with a GET 

method, and the server returns the document or issues a 304—Not Modified response 

code if the document has not changed. 

Your browser software must be explicitly configured to use a proxy server. Figure 1.1 

shows a sample configuration dialog from Netscape Navigator. We use MediaOne 

Express as our Internet service provider (ISP) at home and they provide a proxy cache 

server for their users. The cache server stores frequently accessed Web pages so when 

one is requested, the cache server can return the page rather than retrieving it from a 

distant server on the Internet. Using the proxy server makes pages that we go to load 

much quicker. It also makes better use of the ISP’s bandwidth by going outside the local 

network only when new pages need to be retrieved. 
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Figure 1.1 • Netscape Navigator Proxy Settings 
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• FOR 

EXAMPLE 

To 

configure 

your 

browser to 

use a proxy 

server, you 

must first 

obtain the 

names of 

your local 

proxies or a 

URL that 

has the 

correct 

proxy 

configu-

ration 

information. 

Your ISP might provide proxy servers, but not all do. For Netscape: 

• Click on “Preferences” in the Edit menu. 

• Select “Proxies” from the Advanced tab. 

• The default is a direct connection to the Internet—no proxies. Clicking on 

“Manual Proxy Configuration” allows you to select “View,” which brings up 

the dialog shown in Figure 1.1. Automatic Proxy configuration allows you to 

specify a URL containing proxy information. This allows the system 

administrator to change proxies dynamically. 
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If you don’t have a proxy server already, you can set one up yourself. Many of the 

Web server packages discussed in Lab 4.1 offer proxy services in addition to 

normal HTTP server capabilities. 

STREAMING AUDIO AND VIDEO 

For a browser to play an audio or video file, it must first download the entire file. 

Over a modem connection, it takes a long time to download a few minutes of audio 

or a few seconds of video. The solution: streaming media, which allow a media 

player (or plug-in) to start playing multimedia content while the data is still being 

received. Instead of having to wait for the entire file to download, the player can 

start almost immediately. A streaming media server can broadcast live audio/video 

feeds (from a video capture card, for instance) or serve prerecorded clips. 

HTTP does not support streaming media, so a different server must be used to 

publish streaming media. Browsers don’t support streaming media, so a plug-in 

must be used to view any type of streaming content. When a user clicks on a link 

for a streamed file, the browser will start up the appropriate player. That player will 

connect to the server at a specific port and request a file or live stream, much like 

an HTTP transaction. As the player starts receiving the data, it may store a few 

seconds’ worth in a buffer and then start to play the stream—whether audio, video, 

or both. With traditional audio and video files, the entire file must be downloaded 

before a player can read it. In addition, unlike HTTP, many streaming media 

formats may use UDP instead of TCP/IP as a network protocol. 

UDP is good at transmitting very small pieces of data quickly, and for digital audio 

and video, it works quite well. Unlike TCP/IP, UDP will not retransmit data if there is 

an error. This is fine for digital audio and video because a few bits lost here or there 

will hardly be noticeable. Lost or delayed data may account for pops and clicks in 

audio as it plays back. While TCP/IP offers reliability, it is somewhat slower than 

UDP, so it is used primarily when a UDP connection is unavailable for some 

reason. 

The two leading streaming media packages are RealNetworks’ RealSystem and 

Microsoft’s Windows Media (formerly NetShow). Both packages offer similar 

features and quality. 

FTP (File Transfer Protocol) is used to transfer files between computers on a 

network. A host with a Web server running on it may also set up an FTP server so 

that Web pages can be uploaded to the server easily. Like HTTP, 
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FTP relies on client and server software. The FTP daemon (FTPD) is a program 

that runs on the server and allows clients to connect. It provides a means of 

authentication so that only authorized users can transfer files to and from the 

server. UNIX servers generally install an FTPD by default, and an FTP server can 

be installed on Windows NT along with Microsoft’s IIS (Internet Information Server). 

FTP clients are available for just about any operating system. UNIX and Microsoft 

Windows both come with a simple, text-based FTP client that can be used to 

transfer files to any server running an FTPD. Although FTP is not the only way to 

transfer files to a server, it is one of the most widely supported. 

DATABASES 

Most business sites rely on some sort of database, either for E-commerce 

transaction processing or to allow access to current support documents or 

product information, for example. A database provides an efficient, organized 

way to store lots of information. Unfortunately, most databases don’t provide a 

friendly interface that anyone can use to access this information. The Web 

provides a familiar, easy-to-use way of accessing data, and a Web developer can 

easily write programs that run on the Web server and display information from a 

database. 

A large corporate database should typically be installed on its own dedicated server 

and not on a machine also used as a Web server. A large database requires lots of 

memory, disk space, and CPU power, so installing it on a machine that is also 

trying to process Web pages may be a bad idea. The database will also have a 

daemon running to respond to queries; this allows programs on the Web server to 

communicate with the database server. This type of database daemon is often 

called a listener. Many database packages now come with tools to make authoring 

Web-database applications much easier. Products such as Oracle 8I include HTML 

generation tools, integration with Java, and may even provide a Web server built 

into the database software. 

By default, HTTP traffic is transmitted in clear text; it is not encrypted. This is fine 

for most general surfing, but if you want to start sending confidential information 

over the Web, it becomes an issue. Secure Sockets Layer (SSL) is a protocol that 

allows secure, encrypted communication over TCP/IP. It is often used with HTTP to 

allow information to be exchanged securely between a browser and a Web server. 

Most commercial Web server software includes an SSL server that can run 

alongside the http daemon. SSL is used mostly for Web transactions, but it can be 

used to encrypt any communications over TCP/IP. Netscape developed the SSL 
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standard that is now supported by most browsers. SSL is covered in more detail 

in Lab 4.5 and Chapter 13. 

LAB 1.4 EXERCISES 

1.4.1 Understand THE Functionality of PROXY Servers 

a) What are the benefits of a caching proxy server?

  

 

b) How is a proxy used to filter content?
 

 

 

c) Explain what happens when a URL is requested by a browser that is 

configured to use a proxy. 

1.4.2 Identify Other SErvicesthat MAY Run Alongside AN HTTP 

Server 

a) Why is a streaming audio server useful if you want to deliver audio 

content? 

b) Why is an FTP server useful on a machine running a Web server? 
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LAB 1.4 EXERCISE ANSWERS 

1.4.1 Understand the Functionality of Proxy Servers 
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a) What are the benefits of a caching proxy server? 

Answer: A caching proxy server helps improve performance for intranets. In general terms, 

a cache is something that keeps frequently u^ data available for quick access. 

When a u^ requests a URL, the proxy server checks to ^ if it has a local copy. If it 

does, that copy may get returned rather than fetching the document from the real Web site 

again. This is similar to the disk cache that Web browsers u^, but by keeping all the 

documents on a local server, many users are able to benefit. The speed of 

intranets is typically very fast compared to the connection to the Internet, ^ 

retrieving files from a local server is noticeably faster than retrieving files from 

an external server somewhere on the Internet. 

To improve performance without using a dedicated proxy cache server, your Web 

browser most likely has a local disk cache that holds many of the Web pages you 

have recently viewed. If you go back to one of those pages, your browser will just grab 

the file off the hard drive rather than retrieve the same document from the Web server. 

This saves network bandwidth and makes browsing much faster on your end. 

b) How is a proxy used to filter content? 

Answer: There are many reasons to filter Web content; the most common is to 

deny access to certain pages Many schools set up proxy servers to filter 

“inappropriate” content. When the proxy receives a page that contains certain 

words that are deemed unsuitable, instead of returning the pace to the browser, it 

will return a pace saying that the page requested cannot be viewed. This method 

restricts access on a per-page baas. Some pages at a given site are viewable, 

while others that contain questionable material are blocked. Another method of 

restricting access is on a per-site baas. The proxy can be configured to block 

access to entire Web sites that are considered unacceptable. 

c) Explain what happens when a URL is requested by a browser that is 

configured to use a proxy. 

Answer: The browser will actually make an HTTP connection to the proxy server, 

not the Web server requested. The proxy receives the request from the browser 

and then makes a connection to the Web server for that URL. The proxy server 

retrieves the response and then returns the data to the client requesting it. 
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1.4.2 Identify Other SErvicesThat MAY Run Alongside AN HTTP Server 

a) Why is a streaming audio server useful if you want to deliver audio content? 

Answer: Streaming audio allows users to listen to long audio dips (or even live audio feeds) 

without having to wait for a large audio file to download. The client will start playing the audio 
almost instantly. This works well as long as the network is fast enough to support the constant 
flow of data. Compression algorithms make the audio data small enough that even a modem 
connection is fast enough for decent-sounding audio transmission. 

b) Why is an FTP server useful on a machine running a Web server? 

Answer: FTP provides an easy, standard way of transferring files to a Web server. FTP clients are 

available for many platforms, so just about anyone can use it. Since Web pages may be created on 

other machines, there must be a way to publish those files to the server. FTP provides some security 

by requiring a login and password, although anonymous logins are possible. Most server 

operating systems provide an FTP daemon as part of the core OS. 

LAB 1.4 SELF-REVIEW Q U E S T I O N S  

To test your progress, you should be able to answer the following questions. 

1) Proxy servers are required to allow an intranet to access the Internet. 

a)  _____True 
b)  ____ False 

2) A proxy server can be used for caching or filtering, but not both. 

a)  _____True 

b)  ____ False 

3) Which of the following is not used to transfer files to a Web server? 

a)  _____MS FrontPage server extensions 

b)  ____ FTP 

c)  _____Telnet 

d)  _____A modem 

4) Which of the following is not a function of a proxy server? 

a)  _____S&curity 

b)  ____ CGI programming 

c)  _____Caching 

d)  _____Filtering 

Answers appear in Appendix A. 
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Chapter 1: What Is A Web Server? 37 

C H A P T E R  1  

e- 

 

TEST YOUR THINKING 

The projects in this section use the skills you’ve acquired in this chapter. The answers to these 

projects are available to instructors only through a Prentice Hall sales representative and are intended 

to be used in classroom discussion and assessment. 

1) Create a simple HTML document on your local system and view it with your favorite browser. 

a) Try changing the extension from .html to .txt and view it in your browser. Is anything different? 

2) Upload the document to a server using FTP Open the correct URL up with a browser. 

3) Connect to the server at port 80 with a telnet client; issue a GET command to retrieve the file. 
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LESSON 18. 

4) CREATION OF SITES-SATELLITES IN WEB SERVERS 

5) http://zn.uz/ru/-creation of sites-satellites 
 
- === ABOUT THE PROJECT === - 
 
Information-educational network ZiyoNET invites you 
to create an own site. It is a site-satellite on the 
domain of the third level. 
 
Having created own site, you can: 
 
* To tell to people about itself 
* To share the knowledge and experience 
* To place the useful and interesting information 
* To present available at you and the information in 
a kind convenient for using 
* To communicate with acquaintances 
* To find new friends 
* To receive councils 
* To fill up the knowledge 
 
Now on portal ZiyoNET it is already created more 
than 1000 sites-satellites in various directions, such 
as formation, a science, culture, a society, sports, hi-
tech, business, news, entertainments and others. 
 
Free of charge to receive the site very simply! Follow 
following councils: 
 
Step 1. 
 
It is necessary to be registered in system ID.UZ and 
to receive status Real ID. That it to receive it is 
necessary to leave inquiry at a forum. Then 
somebody from the participants of a forum having 
status Open ID or Real ID should confirm, that the 
questionnaire really belongs to the specified person. 
Then administration ID.UZ establishes status Real ID 
to the questionnaire of the user. After that be 
authorised on site ZiyoNET.UZ 
 
Step 2. 
 
In the top part of sites ZiyoNET.UZ or id.uz you will 
see the button «to Create a site», by its pressing you 
on the screen will have a window with rules of 
creation and use of sites-satellites. Attentively read 
them. 
 
If all suits you, note point «It agree with rules». 
 

mhtml:file://C:/Users/User/Desktop/WEB%20конструктор%20для%20TASIX/Zn.uz%20-%20сайты-сателлиты%20_%20ZIYONET%20_%20UZINFOCOM%20_%20ВКонтакте.mht!/away.php?to=http://zn.uz/ru/
mhtml:file://C:/Users/User/Desktop/WEB%20конструктор%20для%20TASIX/Zn.uz%20-%20сайты-сателлиты%20_%20ZIYONET%20_%20UZINFOCOM%20_%20ВКонтакте.mht!/away.php?to=http://ID.UZ
mhtml:file://C:/Users/User/Desktop/WEB%20конструктор%20для%20TASIX/Zn.uz%20-%20сайты-сателлиты%20_%20ZIYONET%20_%20UZINFOCOM%20_%20ВКонтакте.mht!/away.php?to=http://ID.UZ
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mhtml:file://C:/Users/User/Desktop/WEB%20конструктор%20для%20TASIX/Zn.uz%20-%20сайты-сателлиты%20_%20ZIYONET%20_%20UZINFOCOM%20_%20ВКонтакте.mht!/away.php?to=http://id.uz
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Further it is necessary to fill obligatory fields where 
you specify: site heading, the domain – the address 
of your site on the Internet (the name сайта.zn.uz), 
section and the site description. In the list it is 
presented more than ten names of sections and 
subsections. You with ease can choose a suitable 
theme for your site. After filling of all fields, press the 
button «to Receive a site». In the opened window 
there will be a message on demand acceptance. The 
manager will check up correctness of filling of all 
points and conformity to rules of creation of a site. 
 
Step 3. 
 
After acknowledgement of the demand for 
registration of site-satellite ZiyoNET, on your e-mail 
the address of your site and the administrative panel 
will come. If the created site-satellite bears the 
character, not allowing to publish it on a portal, it will 
be removed, and on the electronic address of the 
owner of a site refusal with reason instructions will 
be sent. In this case it is necessary to familiarise 
attentively once again with Rules of creation and use 
of sites-satellites ZiyoNET and anew to send the 
demand for site registration. 
 
The system of administration of a site is simple 
enough and clear. 
 
Web the Designer gives you the full control over a 
site. You can create new documents and edit already 
existing. All changes entered by you will immediately 
appear on a site. 
 
Also you can: 
 
* To add or delete users 
* To add references and pages 
* To use all possibilities of the designer of sites (to 
create sections and headings) 
* To edit and place on a site the news, useful and is 
fascinating-entertaining information (in text, a photo 
and video a format). 
 
Answers to your questions on creation of sites-
satellites ZiyoNET can be received at a forum 
(http://uforum.uz/forumdisplay.php? f=487 
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