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Adobe Photoshop dasturida tasvirga ishlov berish. Qatlamlar bilan ishlash.

1. Adobe Photoshop 7.0 Programmasi bilan tanishuv
2. Qatlamlar xagida tushuncha va yangi gatlam yaratish.
3. Xosil gilingan gatlam ustida bir nechta ammalar bajarish.

4. Xosil gilingan hamma gatlamlarni o’chirib tashlash.



Adobe Photoshop 7.0 Programmasi bilan tanishuv

Programmani ishga tushirish: Windows 95, 98, ME, 2000, XR ili NT operatsion
sistemasida ke Start (Pusk) tugmasiga bosing paneli zadach bo’limida joylashgan
Programs (Programmy) bo’limiga kiring so’ngra Adobe, Photoshop 7.0 ichidagi
Adobe Photoshop 7.0 elementi ustiga sichqoncha bilan bosing . Adobe
Photoshop 7 programmasi mavsum programmalar orasida  superxit produktga
aylandi. Uni ustiga bu programmaning xar bir soni 0’zida yangi elementlarni
mujassamlashtirgan. Bu o’zgarishlar Photoshop 07 versiyasida xam kuzatiladi.
Ishlab chigaruvchilar bu programmadagi bir gator kamchiliklarni bartaraf gilishdi ,
bularga Windows i Mac OS X. Qismida , Photoshop 7 nixoyat virtual xotira
sistemasini ishlaishni o’gandi , natijada Operativ xotiraning bir gancha gismi tejab
golindi. Bu tejmkorlik kata xajimga ega bo’lgan tasvirlar Bilan ishlaganda
seziladi. Shuningdek operatsion sistemani osilib qolishi kamaydi. Xozirda

Photoshop boshga bir gancha daturlar Bilan bir vaqtda yaxshi ishlashi mumkun.
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Ras Photoshop 7 ekran ko’rinishi.

Rasmda Photoshop programmasida ishlash payti ko’rsatilgan. (1) tugmasi bosib
boshgaruv menyusi ishga tushiriladi. U o’zida quydagi buyruglar (komanda)larni
mujassamlashtirgan: Restore (Qayta tiklash(\Vosstanovit)), Move
(Siljitish(Peremestit)), Size (Ulchami(Razmer)), Minimize (Pastga
tushirish(Svernut)), Maximize (Ochish(Razvernut)) va Close (Yopish(Zakryt)). (7)
tugmasi yordamida xujjatni boshgarish menyusi ishga tushiriladi. Asosiy menyuda
quydagicha komandalar mavjud: Restore (Vosstanovit), Move (Peremestit), Size

(Razmer), Minimize (Svernut), Maximize (Razvernut), Close (Zakryt) va Next

(Keyngi(Sleduyuriy)).

Photoshop va ImageReady programmalariga tasvirni tez ko’rib chigish moduli
kiritilgan. Oldin esa bu ishni amalga oshirish uchun tashqgi programma(utilit)lar
ishlatilardi masalan ACDSee yoki ThumbsPlus. (PDA) chuntak kompyuterlari
uchun rasimni importi va eksporti WBMP formatli filtrlari Kiritilgan.
Kompyuterning ishlash chegarasi doirasida avtomatik tarzda rasmning sifatini
buzmagan xolda moslashuv(optimizatsiya)ni bajaradi.

Photoshop 7 programmasiga gurux(gruppovoy) bo’lib ishlash uchun qushimcha
imkoniyatlar kiritildi. Bu bir kompyuterda turli foydalanuchilar tominidan Adobe
programmasida ishlash imkoniyatini beradigan AfterCast kengaytkich qushildi.
Agar bir foydalanuvchi tasvirga o’zgartirish kiritsa bir vaktni o’zida xama
foydalanuvchilar kuzata oladi. Ammo AfterCast sozlash(nastroyka)ni fakat
administrator boshgara oladi, lekin bu o0’z uy kompyuterlarida Photoshop
programmasida ishlovchi foydalanuvchilar bu muammoga duch kelmaydilar. Biz
yugorida fagatgina Photoshop 7ni asosiy imkoniyatlarini sanab chiqdik.

Asboblar paneli(panel instrumentov)

Ekranda turgan programma asboblarini ishga tushirish uchun sichkoncha Bilan
uniustiga bosing va ekranda kurinayotgan piktogrammani ustiga bosing. Bir xil
piktogrammalar yonida kichik kursatkich(strelochka)lar mavjud. Agar uni ustiga

bosilsa tasvirga tugri keluvchi oyna(palitra)lar ko’rsatiladi, u erdan siz kerakli
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asboblarni
tanlashingiz mumkin. Xar bir asbob uchun o’zining o’lcham(parametr)lari ekran
teppasida joylashgan optsiyalar panelida mavjuddir (masalan, rejim smeshivaniya,

znachenie neprozrachnosti) .

Rasm. 2. asboblar panelida paydo buluvchi maslaxat(podskazka) oynasi

Eslatma :Edit > Preferences > Display& Cursors (Pravka > Ustanovki >
Otobrajenie&kursory) oynasida kursor va asboblar piktogrammalari
ko’rinishlarini so’zlash mumkun.

Optsiyalar paneli (Panel optsiy)

Optsiyalar paneli xar bir asbobning parametorlarini sozlash uchun
ishlariladi(masalan, shaffoflik darajasi yoki tasvirni aralashtirish rijimini) - 3 rasm
. Optsiyalar panelining ung tomonida maxsus ranglarni saglovchi bulim mavjuddir.
Parametrlarni ko’ursatilishi gaysi rasmni tanlanganiga bog’lig(3-8 rasm).
Foydalanuvchi tomonidan Kiritilgan tasvir ko’rinishi  boshga o’zgartirishlar
kiritilguncha saglanadi. Palitra va optsiyalar panelini xam ekranni istalgan joyga
siljitish mumkin.
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Rasm. 3. Brush asbobi uchun optsiyalar paneli
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Rasm. 4. Rectangular Marquee asbobi uchun optsiyalar paneli
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Rasm. 5. Gradient asbobi uchun optsiyalar paneli
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Rasm. 6. Rep asbobi uchun optsiyalar paneli
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Rasm. 7. Rectangle asbobi uchun optsiyalar paneli
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Rasm. 8. Ture asbobi uchun optsiyalar paneli

Eslatma: Edit > Preferences > Display& Cursors (Pravka > Ustanovki >
Otobrajenie&kursory) oynasida kursor va asboblar panelidagi asbob
piktogrammasini tanlashingiz mumkun.

NaOptsiyalar panelining 0’ng tomonida aktiv asbob piktogrammasi ko’rsatilgan.
Agar piktogramma yonidagi strelka ustiga bosilsa , ko’rinmay turgan menyu
ochiladi, unda boshga kerakli bo’lgan asbobni tanlash mumkun. Bu jadvalga
uzgartirishlar kiritish mumkun yani kam ishlatilayotgan asboblarni olib tashlab
urniga kerakli bo’lgan asboblarni joylash mumkun. Xar bir optsiyalar paneliga
kiritilgan uzgartirishlar avtomatik tarzda saqlanib golinadi. Tugmalarni gayta
tiklash va joylashtirish uchun paydo bo’luvchi paneldan amalga oshiriladi.

Paydo buluvchi yordamchi maslaxatlar(vsplyvayuwie podskazki)

Istalgan piktogramma ustiga sichqonchani bosmasdan olib boring shunda siz
ishlatmogsi bo’lgan asbobning nomi va uni klaviatura orkali ishga tushiradigan
tugmachalar ko’rsatiladi. Shu bilan bir gatorda ishlatilayotgan optsiyalar oynasi va
uning vazifasi xagida gisgacha malumot olish mumkin (9 rasm). Edit >
Preferences > General (Pravka > Ustanovki > Obmie) oynasidagi yordamchi
maslaxtlar oynasini ishlatish uchun Show Tool Tips oynasi ustiga bayrogchani

o’rnating (Pokazivat ispravlayushie podskazki)
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Rasm. 9. Optsiyalar panelidagi yordamchi maslaxatlar

Programmaning barcha komandalari uchun Asosiy menyu (Glavnoe menyu)

mavjuddir:
[y Adobe Photoshop - [011_tif @ 100 (RGB]] _ O] x|
@Eile Edit Image Laver Select Filter Yiew ‘Window Help -|5’|5|

Rasm. 10. Asosiy menyu
File (Fayl) menyusi quydagi xolatlarda ishlatiladi: yaratish(sozdat),
ochish(otkryt),  joylashtirish(razmestit),  yopish(zakryt),  saklash(soxranit),

skanirlash(otskanirovat), import va eksport, kog’ozga chigarish(napechatat



izobrajenie), Faylni tarmoq orgali o’zatish(peredat fayl po seti), bir nechta
optsiyalarni avtomatlashtirish uchun va albatta Photoshop dasturidan chikish
uchun.

Edit (Pravka) menyusida, tasvirni redaktirlash yani sozlash uchun komandalar:
nusxalash(kopirovaniya), o’zgartirish(transformatsii), joylashtirish va tasvir
ranglarini tusini va muyqgalam qalinligi va turini tanlash mumkin.

Mode (Rejim) menyuosi orgali Image (lzobrajenie) menyusi, tasvir sakkiz
turdagi tasvir urinishlarini tanlash mumkin.

Layer (Sloy) menyusida joylashgan komandalar, bir necha qatlamlardan
joylashgan tasvir ustidagi amallar yani: gatlamlar aro bog’lanishni gatlamlar ketma
ketligini va gatlamlarni umumiy gatlamga birlashtirish imkoniyatini beradi.

Select (Vydelit) menyusida joylashgan komandalar — kerakli gatlamlarni
tanlashda ishlatiladi.

Filter (Filtr) menyusi 0’zida tasvirlarni birlashtirish va umumiy xolga keltirish
uchun kerakli bo’lgan filtiri mavjuddir.

View (Vid)menyusidagi komandalar, ekrandagi tasvirni ko’rinishlarini nazorat
qgiladi.

Window (Okno) menyusi komandalari, ekrandagi boshga tasvirlarni aks
ettiradi va ulardan kerakli bo’lgan paytda foydalanish imkonini beradi.

Help (Pomosh) menyusidagi komandalar foydalanuvchi uchun kerakli bo’lgan
maslaxatlar orgali ko’mak va xozirda bajarish mumkun bo’lgan imkoniyatlar bilan
tanishtiradi xamda Photoshop ihtiyoriy saytiga murojat gilsh imkoniyatini beradi.

Istalgan tasvirni xoxlagan paytda uzgartirishlar kiritish imkonini va 12 turdagi
Photoshop kengaytma(format)larida saglash imkonini beradi. Ammo odatta asosiy
kuydagi Photoshop formatlari ishlatilad: TIFF, GIF, JPEG, EPS.

Photoshop programmasida ko’pgina operatsiyalar asosan politralar orgali
bajariladi. Ekranda ko’p joy egalamasligi uchun politralar o’zaro guruxlarga
biriktirilgan: Navigator/Info (Boshkaruv/Informatsiya), Color/Swatches/ Styles

(Rang/Namuna/Uslublar), History/Actions/Tool Presets



(Tarixi/Xarakatlar/Asboblar tanlash), Layers/Channels/Paths
(Katlamlar/Kanallar/Konturlar) i Character/Paragraph (Shrift/Abzats).

Palitralar (palitry)

Photoshop programmasida ko’p operatsiyalar palitralar orgali bajariladi ularni
0’zaro aralashtirish xam mumkun. lIstalgan palitrani ochish uchun esa Window
(Okno) menyu komandasidan amalga oshiriladi. Belgilangan palitra boshga shu
gkruxga kiruvchi politralardan eng yugrida avtomatik tarizda joylashadi.
Photoshop progrpmmasidan chikish: Windows Operatsion dasturida bu dastur
oynasini yopish uchun File > Exit (Fayl > Vyxod)menyusidan kursatilgan
komandani tanlang yoki (Ctrl+Q) tugmalar kombinatsiyasini bosing

Qatlamlar xuddi oyna qatlamlariga o’xshagandir fagat tasvir bo’lgan
joylarigina ko’rinishga egadir. Xar bir gatlam uchun o’zining shffoflik darajasi
bo’lib uni undan oldingi va kengi turgan gatlamlar bilan xamoxangligini moslash
mumkin. Qatlamlarni joylashish urnini almashtirish yoki ularni yagona gatlamga
birlashtirish mumkin. Bir vaqtni o’zida xar xil gatlamlarda turgan tasvirni
birgalikda o’zgartirish va bir gatlamda turgan rasmni fagat bir gismini o’zgartirish
mumkin emas.

Layers (Sloi) oynasida gatlamlar ustida turgan qatlamdan eng tagidagi
katlamgacha aks etirilgan. Bunda fon ganlami oxirida joylashadi(1lrasm). Xozirda
belgilangan gatlam aktiv bo’lib ko’rinadi va fagat shu gatlam utida amallar bajarish
mumkin.

Istalgan gatlamni aktivlashtirish uchun tartiblanish oynasidan uni ustiga bosish

kerak aktiv bo’lgan gatlam nomi programma nomi yonida akslanib turadi.
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Rasm. Layers palitrasi

Eslatma : Katta xajimdagi tasvirlar bilan ishlayotganda bajarilib bo’lgan
gatlamlarni birlashtirgan yoki o’chirib tashlash maqul shunda programma ishlash
tezlik unimdorligi oshadi va tasvir xajmi kamayadi.

Yangigkatlam xosil kilish(Sozdanie novogo sloya)

1. Eng avvalo 100% shaffof gatlam xosil gilish uchun Create New Layer
tugmasi ustiga bosing.

2. Agar gatlamni ulchamlarini 0’zingiz beriokchi bo’lsangiz unda Alt,
tugmasini bosib turgan xolda Create New Layer tugmasini bosing va qudagicha
yul tuting:

3. Name (Imya) bo’limida katlamni nomini kiriting Group With Previous
Layer (Sgruppirovat s predudushim sloem) bo’limiga bayrogchani urnating.

4. Layers (Sloi) palitrasidan kuz va muqylam ko’rinishidagi piktogrammalarga
bayrogchani o’rnating.

Mode (Rejim smeshivaniya) va Opacity (Neprozrachnost) parametrlaridan tasvir
uchun Yangi parametrlarini berin(keynchalik bu parametrlar uzgartirilishi
mumkin).

5. OK tugmasini bosing. Yangi qatlam ishlatilayotgan qatlai ustida paydo
bo’ladi.

Eslatma: Tasvir xajmini kamaytirish uchun Layers (Sloi) menyusidan Palette
Options (Optsii palitry) buyrug’ini tanlang va shu tasvirga tugri keladigan eng
kichik xajmni tanlang.



Belgilangan gismni gatlamga aylantirish(Prevrawenie vydelennoy oblasti v sloy)

1. Belgilangan gismni xosil giling.

2. Layer > New > Layer Via Soru (Sloy > Novyy > Posredstvom
kopirovaniya) menyusidan komandani bajaring(Ctrl+J tugmalari).

3. tasvirni belgilangan gismini yulib olib tashlash uchun Layer > New > Layer

Via Cut (Sloy >Novyy > Posredstvom vyrezaniya) komandasini bajaring(Ctrl+

Shift+J tugmalari).

Rasm. 2. Layer 1 xiralashtirilgan fondan xosil gilingan tasvir

Qatlamni siljitish(Peremewenie sloya) Layers (Sloi) oynasida o’zgartirish
kiritmokchi bulgan katlamni belgilang.
1.  Move (Peremeshenie) ashobini aktivlashtiring(V klavishasi).

2. Katlamni kursorni ushlabturgan xolatda gatlamni siljiting(3 va 4rasm).




Rasm. 3 . Amaldagi tasvir Rasm. 4. Matnli gatlamni Move

asbobi yordamida

sititilishi
Primechanie: Auto Select Layer (Avtovydelenie sloya) mulimida bayrokcha
turgan bulsa Move (Perememenie) asbobi yordamida tezda katlamni siljitish
mumkin, ammo bu sijitish shaffofligi 50% dan kam bo’lgan gatlamlar uchun
ishlamaydi.

Qatlamlar bilan ishlash uchun asboblar(Instrumenty dlya raboty so sloyami)

Barcha asboblar qatlamlar bilan ishilaydi lekin bu bilan gatlamning
shaffofsizligiga kata tasir o’tkazadi shuning uchun qatlam shaffofsizligini dimo
nazorat qilib turing.

Qatlamni uchirish(Udalenie sloya iz nabora)

Qatlamni uchirishdan oldin uni nomini aktivligini tekshiring, va uni belgilab
o’chirib tishlang.

Qatlamga effektlatgkullash(Primenenie effektov sloya)

Qatlamga quydagi maxsus effektlarni qulash mumkin: Drop Shadow (Otbrosit
ten), Inner Shadow (Vnutrennyaya ten), Outer Glow (Vneshnee svechenie),
Inner Glow (Vnutrennee svechenie), Bevel and Emboss (Skos i relef), Satin
(Atlas), Color Overlay (Nalojenie tsveta), Gradient Overlay (Nalojenie
gradienta), Pattern Overlay (Nalojenie uzora) va Stroke (Kayma). Effektlarni
istalgan paytda istalgancha istalgan gatlamga qgo’lash mumkin lekin gatlamni

shaffofsizligini tekshirib turing.



Eslatma : Uslub(stili) va effektlarni bir biri bilan chalkashtirib yubormang.
Uslub(Stil) — bu bir gancha gatlam effektlarini xamoxangligidir.

Effektlar Layer Style (Stil sloya) mulogat oynasi orgali amalga oshiriladi.

Effekt yonidagi galochka bu effektk shu gatlamga qo’lanilganini ko’rsatadi.
gatlam effektlarini asosiy fon uchun qulash mumkun emas.

Xama gatlamlarni birgalikda ishlatish(Zadeystvovanie vsex sloev)

Agar optsiyalar panelida ko’ydagi asboblar ishlatilayotgan bo’lsa: Blur
(Razmytie), Sharpen (Rezkost), Smudge (Palets), Paint Bucket (Vedro s
kraskoy), Magic Eraser (Volshebnyy lastik) ili Magic Wand (Volshebnaya
palochka) unda Use All Layers (Ispolzovat vse sloi) bo’limiga bayrokchani
urnating shunda rang va boshga o’lchamlar olinayotganda mavjud bo’lgan
ranglarga yaqin bo’lgan tuslar birinchi navbatta ko’rinadi. Fagat aktiv bo’lgan
gatlamda ranglar o’zgaradi

Ikki gatlamni birlashtirish(Sliyanie dvux sloev)

1. Birlashtirmokchi bo’lgan ikki gatlamdan qaysi birisi oldinro bklsa uni
belgilang.

2. Layers (Sloi) menyusidan Merge Down (Slit s nijnim) komandasini
belgilang yoki Ctrl+E tugmalarini birgalikda bosing . Aktiv gatlam o’zidan
pastda turgan qatlam bilan birlashadi. Bir gancha belgilangan qgatlamlarni
birlashtirish uchun Merge Layer Set (Slit nabor.sloev)komandasini tanlang.
Qatlamlarni birlashtirish(Ob’edinenie sloev)

Dikkat : Flatten Image (Ploskoe izobrajenie) komandasi gatlamlarni pastdan
boshlab birlashtiradi va yashirilgan gatlamlarni avtomatik tarzda o’chiradi.

Xama gatlamlar ko’rinib turganligiga amin bo’ling va gaysi gatlam aktiv bo’lishi
muxim emas. Layers (Sloi) menyusidan Flatten Image (Ploskoe izobrajenie)
komandasini tanlang. Agar programmada bekitilgan qatlamlar bo’lsa unda
ogoxlantirish beriladi va OK tugmasini bosing va birlashtirishni davom etiring.
Agarda pastki gatlamlarda ko’rinmaydigan nugtalar bo’lsa ular og ranga kiradi.

QKatlamni uchirish(Udalenie sloya)



Layers (Sloi) menyusidan keraksiz gatlam nomini tanlang. Sungra Trash
(Korzina) tugmasini bosing va Yes (Da) tugmasini xam bosing.

Qatlamni uchirishni Yana bir usuli keraksiz gatlam nomi ustiga olib borib
sichkonsani o’ng tugmasini bosing va menyudan Delete Layer (Udalit sloy)

bo’limini tanlang xamda Yes tugmasini bosing.



ADABIYOTLAR

M.N.Petrov, V.P.Molochkov Kompyuterrnaya grafika. Uchebnik — SPb:
Piter,2003 — 736s.

Konspekt leksiy po dissipline «Primenenie sredstv kompyuternoy grafiki v
sistemax avtomatizirovannogo proektirovaniya » dlya podgotovki
bakalavrov. 2005

Virtualnaya rabota v 3D Studio MAX3.0, M.:-Poznovatelnaya kniga.
Strazniskas M. Photoshop 5.5 dlya podgotovki Web-grafiki. —S.-Peteburg:
Sybex, 2000 — 473s.

Simonovich S.V. i dr. Spesialnaya informatika: Uchebnoe posobie. — M.:
AST - PRESS: Inforkom-Press, 2002. — 480s.

Effektivnaya rabota s CorelDraw 10. , SPb.:Piter, Beyn, Stiv,2002

Karimova D. Computer science. Information Technologies: Part 2-1.,2005
Spravochnoy rukovodstva programm.

. M.Marov, 3D Studio MAX 2.5: spravochnik — SPb: «Piter», 1999. — 672 s.



	R E F E R A T
	ADABIYOTLAR


