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Kirish 

Oxirgi  yillarda  internet  bizning  hayotimizni  juda  qulaylashtirib  berdi.  

O`zimizga  tegishli  korxonani  qidirib  topishimiz  yoki  kerakli  sohada  hamkorlar  

topish  kabi  ishlar  internet  vositasida  juda  osonlashdi.  Hatto,  savdo-sotiq  ishlari  

ham  internet  bilan  amalga  oshayotgani  sir  emas.    Hozirda  deyarli  har  bir  

korxona,    muassasa,  davlat  idorasi  deysizmi,  har    birining  internetdagi  sahifasiga  

ehtiyoj  paydo  bo`lmoqda.  Chunki  korxona  haqida  kerakli  malumotni  olish  uchun  

uning  binosi  oldiga  borib  qabulga  yozilish  va  kerakli  odam  bilan  uchrashish  

ancha  vaqtni  oladi.  Agar  shu  korxonaning  vebsayti  bo‟lsa-chi,  kerakli  ma‟lumotni  

bir  necha  daqiqada  olishingiz  mumkin. Masalan  sizga  biror  universitetning  

fakultetlari  va  o`qituvchilari  haqida  ma‟lumot  kerak.    Buning  uchun  o‟sha  o‟quv  

binosiga  borishdan  ko‟ra  uyingizdan  o‟tirib  internet  orqali  shu  ma‟lumotni  olish  

mumkin.  Buning  uchun  albatta  o‟sha  o‟quv  muassasaning  internetdagi  sayti  

bo‟lishi  lozim. Shuning  uchun  hozirda  universitet  va  kollejlar  ham  o‟z    

vebsaytlarini  tuzib internetga  joylamoqdalar. Bundan  tashqari,  agar  siz  savdo  –

tijorat  bilan  shug‟ullansangiz  o‟z mahsulotingizni  internet  orqali  sotishingiz  

mumkin. Agar  sizda  ijodiy  qobiliyatingiz  bo‟lib  o‟z  fikr  mulohazalaringizni  

internet  orqali  odamlarga  bildirmoqchi  bo‟lsangiz,  u  holda  “blog”  deb  ataluvchi  

shaxsiy  vebsayt  ochishingiz  mumkin.  Bu  orqali  siz  o‟zingiz  kabi  hamfikr  odamlar  

bilan muloqotda  bo‟lasiz. Hozirda  internetga  kirivchilar  soni  kun  sayin  

ko‟paymoqda.  Bir  vaqtning  ozida dunyoda  millionlab  insonlar  internet  tarmog‟idan  

foydalanmoqda.  Shuning  uchun  har  qanday  tadbirkor  uchun  ham  ijodkor  uchun  

ham  internetda  shaxsiy  sayti  bo‟lishi  juda  muhimdir.  Tadbirkor  bo‟lsangiz  sizni  

korxonangiz  va  mahsulotingiz  haqida  odamlar  malumot  oladi.  Ijodkor  bo‟lsangiz  

sizni  ijodingiz  bilan  boshqalar  ham  tanishadi  va  hokazo  . 

Veb  sayt  nima?  Veb  (inglizcha  Web)  so‟zi  aslida  o‟rgimchak  to‟ri  degan  

ma‟noni  bildiradi,  internet  tarmog‟i  hozirda  xuddi  o‟rgimchak  to‟ri  kabi  bir  

biriga  ulanib  ketgan  millionlab  kompyuterlardan  iboratdir.Sayt  esa  ana  shu  

tarmoqda  joylashgan  va  o‟zida  biror  ma‟lumotni  jamlagan  sahifalardir.    Bu  

sahifalarda  asosan  matnlar  (tekst),  rasm,  audio,  video  kabi    malumotlar  joylangan  

bo‟ladi.  Dunyoning  istagan  yeridan  bularni  ochish  va  ko‟rish  imkoni  mavjud  

bo‟ladi.    

Veb  saytlarning  qanday  turlari  bor?  

Bugungi  kunda  saytlarning  turlarini  aniq  sanab  aytish  qiyin,  chunki  har  sohada, 

har  mavzuda  saytlar  ochilmoqda...  Lekin  asosiy  turlarni  sanab  o‟tamiz.  Bular:   -  

internet  do‟konlar  (Masalan:  amazon.com,  souq.com,  esavdo.uz,  korzinka.uz   va  

hkz) 

 -  ijtimoiy  tarmoqlar  (facebook.com,  ok.ru,  vk.ru,  muloqot.uz,  twitter.com)  

-  Korxona,  tashkilot    saytlari  (appla.com,  ucell.uz,  gov.uz,  bank.uz)  

-  Shaxsiy  saytlar  (Mashur  shaxslar,  qo‟shiqchilar,  shoirlar,  davlat  arboblari 

haqidagi  saytlar)  



-Fotogallereyalar    (flickr.com  ,  shutterstock.com)  

-  Yangiliklar  sayti  yoki  portal  (islom.uz,  kun.uz  ,  darakchi.uz,  ziyonet.uz  )  

-  Qidiruv  tizimlari  (Google.uz,  yandex.ru)  

-  Forum  va  chat  (tforum.uz,  forum.ziyouz.com,  forum.islom.uz)  

-  Media  mahsulotlari  -  Audio,  videolar  (mytube.uz,  mover.uz,  mp3.uz)  

-  Elonlar,  umumiy  savdo,  yoki  kataloglar  sayti  (torg.uz,  glotr.uz,  zor.uz, kplus.uz) 

va  boshqa turdagi  saytlar  mavjud. 

Veb  sayt  ochish  nima  uchun  kerak?  

Sayt  ochish  turli  sohadagi  odamlarga  har  xil  maqsadlar  uchun  kerak  bo‟aldi.  

Masalan,  tadbirkorlar  uchun  o‟z  korxonasining  veb  sayti  bo‟lishi  bu  –  mijozlarga 

qulaylik  tug‟diradi.  Hatto  yangi  mijozlar  orttirishga  sabab  bo‟ladi.    Chunki 

internetdan  biror  mahsulot  yoki  xizmat  turini  izlagan  odam  sizni  vebsaytingizga 

duch  keladi  va  sizning  korxonangiz  bilan  tanishadi. Agar  siz  ijodkor  bo‟lsangiz  

yoki  ilm-fan  bilan  shug‟ullansangiz,  u  holda  o`z sohangiz  haqida  veb  sayt  ochib  

bilimlaringizni  boshqalarga  ulashasiz. Yoki ijodingizni  namoyish  qilasiz.  O‟zingiz  

bilan  hamfikr  odamlar  bilan  tanishasiz.   Savdo  bilan  shug`ullansangiz,  tovar  va  

mahsulotlaringizni  o`z  saytingizga  joylab  buyurtmalar  olishingiz  mumkin.  

Mahsulotingizni  odamlarga  reklama  qilasiz. Xullas,  har  qaysi  soha  egasi  uchun  bu  

kitobdagi  bilimlar  foyda  beradi  deb  o`ylaymiz. 

 

  



I BOB MACROMEDIA DREAMWEAVER 

1.1 MACROMEDIA DREAMWEAVER 8 DASTURI 

Macromedia Dreamweaver 8 - bu veb sahifa yaratish uchun eng qulay dastur 

hisoblanadi.   

Bu dastur yordamida siz nimalarni amalga oshira olishingiz mumkin. 

1. Bu dastur avvalo sizga HTML kodlarini o‟zi kiritadi ya‟ni siz kod kiritib 

o‟tirishingizning hojati yo‟q. Masalan. Biz HTML darslarini o‟rganganda Windows 

ning Bloknotidan foydalangan edik va vebsahifaga rasm joylashtirish uchun <img 

src=”rasm_nomi.jpg”> qilib eng kamida kiritishimiz shart edi, endi esa shunchaki 

menyu qatoridan Insert > Image ga kirib kerakli rasmni tanlasak bas o‟zi biz uchun bu 

kodlarni avtomatik tarzda kiritib boradi. 

2. Bu dasturni siz nafaqat HTML yoki CSS lar uchun balki boshqa bir talay vebsayt 

uchun ishlov beriladigan dasturlar, ya‟ni ColdFusion, PHP, ASP VBScript, ASP.NET, 

C#, JavaScript, XML, XSLT, kabilar uchun ham foydalanishingiz mumkindir.  

3. Siz shuningdek bu dastur yordamida Internetdagi vebsaytingizni nazorat 

qilishingiz mumkindir. Ya‟ni siz HTML dokumentizga har qanday o‟zgarishni 

kiritsangiz va “put file” qilsangiz sizni kiritgan o‟zgartmangiz Internetdagi 

vebsaytingizda ham o‟zgaradi.  

4. Hullas siz vebsaytingiz uchun hamma-hamma narsani shu dastur yordamida 

bajarasiz. Aksariyat professional web masterlar shu dasturdan foydalanishadi, albatta 

bunga o‟xshash boshqa web page editor programmalari ko‟p masalan: Microsoft 

FrontPage, Adobe Pagemill, Adobe GoLive, NetObjects Fusion, CutePage, HotDog 

Proffesional, Netscape Composer va Arachnophilia, biroq Kompyuter 

Tehnalogiyalariga ihtisoslashgan chet el unversitetlarida ham birinchi o‟rinda 

Macromedia Dreamweaver o‟qitiladi. Bu dasturni o‟rganishning eng oson yo‟li bu biror 

vebsayt yaratib o‟rganishdir. Biroq avvalo bu dastuning interfeysi bilan tanishib 

chiqsak. Quyida siz bu dasturning umumiy ko‟rinishini ko‟rib turibsiz. Dreamweaver 8 

ning asosiy ko‟rinish quyidagichadir. Asosiy oyna uchga bo‟lingan va o‟ng tarafda 

yordamchi panel joylashgan. Yuqorida HTML kodlar joylashgan, Markazda vebsahifa 

uchun ishlov berish joyi, va quyida Properties joylashgan. Siz asosan Markaziy va Quyi 

qismlardan foydalanasiz, shuning uchun ushbu 

 tugmalardan Design bo‟limini tanlasangiz ham bo‟ladi. Code 

bo‟limi faqat HTML kod uchun, Split esa ikkalasi hamdir. 

 

1.2 Macromedia Dreamweaver 8 dasturida formalar haqida 

<form>.. . .</form> 

Hammamiz biron bir forma tur iga internetda ko'p duch kelganmiz,  

hech bo'lmasa email ochganda bi r talay o'zimiz h aqimizda ma 'lumotlarni  

mahsus katakchalarga to 'ldi rib chiqqanmiz. Bu galgi darsimiz ana 

shunday formalarni Web sahi fangizda yaratish  va unga tashri f  



buyuruvchi larning to 'ldirib sizga ma 'lumotlarni  aftomat ik tarzda 

yuborishini o 'rganamiz.  Forma yarati sh uchun <form> tagin i  

ishlati shimizga to 'g 'r i keadi. <form> ochil ish, </ form> esa formamizni  

yopish demakdir. Bu tagning mahsus attributelari bor. Shu yerda bi r  

maslahatim, formlarni web sahi fangizda juda ko 'p  ishlat ishingiz web 

sahi fa foydalanuvchisiga yoqmasigi mumkin shunning uchun kamroq  

ishlating. Shaxsan men forma to 'ldiri shni uncha yoqt i rmiman.  

 

 
1.3 Macromedia Dreamweaver 8 dasturining ishchi muhiti 

Eng yuqorida Menyu qatori. Asosiy buyruqlar kiritiladi. Har bir Menyuda MS 

Offise (Word, Exsel) dasturlari kabi o‟z vazifalariga egadir. 

 
Masalan yangi dokument ochish kerak bo‟lsa File→New, biror jadval yaratish kerak 

bo‟lsa Insert→Table va hokazo.  



                                   

 
 

Insert Bar 

Insert Bar – bu qator sakkiz hil buyruqlar kiritish bo‟limlaridan tashkil topgan. 

Har birining o‟ziga yarasha vazifalari bor. Bularning aksariyat buyruqlari Menyu 

bo‟limi orqali kiritilishi ham mumkin lekin, Insert bar orqali osonroqdir. Dreamweaver 

da ishlash tuchuntirilganidan so‟ng bu barchasini vebsayt yaratish orqali o‟rganib 

chiqamiz. Quyida faqat qisqacha to‟htalaman. Har bir buyruqlar bo‟limini tanlashda 

 dagi pastga yo‟naltirilgan strelkani bosish kerak bo‟ladi. Va quyidagicha 

ro‟yhat chiqadi. 

 
Ushbu sakkiz hil buyruqlar kiritish bo‟limini birma bir eng muhumlarini ko‟rib 

chiqamiz. Siz ham Dreamweaver 8.0 dasturini ochib olib birga buyruqlarni kiritishni bir 

paytning o‟zida mashq qilib boring. Quyida ko‟rsatilingan rasmlarni aksariyatini 

bosishingiz bilan, ma‟lum bir oynachalar shiqib keladi. O‟sha oynachalarni 

to‟ldirishingiz bilan, to‟ldirgan ma‟lumotlarizga binoan HTML Kodlar bo‟limida o‟z 

o‟zidan qo‟yiladi. 

Masalan quyidagi birinchi tugma  ni olaylik. Unga bosganimizda ushbu oyna chiqadi. 



 
Va uni quyidagiсha to‟ldiramiz. 

 
Va siz uchun HTML dokumentimizning kodlar bo‟limida quyidagiсha kodlar paydo 

bo‟ladi. 

<a href="5.html" title="yo`nalish" target="_blank">Link ga kiring</a> 

 
Common – eng ko‟p qo‟llaniladiganlarini o‟zida mujassam etgandir.  

 
Layout – asosan jadval tuzishda va unga ishlov berishda kerak bo‟ladi. 

 
Forms – Yuqorda ko‟rsatilingan tugmalar faqat forma yaratishda ishlatilinadi. 

 
Text - Yuqorda ko‟rsatilingan tugmalar faqat oddiy matnga ishlov berishda 

ishlatilinadi. Ularning vazifalarini HTML darslaridan juda yahshi bilamiz. 

Biz o‟zi mavjud bo‟lmagan, bir kafeni vebsaytini yaratish orqali Dreamweaver 8.0 ni 

yanayam yahshiroq o‟zlashtiramiz degan umiddaman. Kafe, “Café Townsend” deb 

nomlanadi. Biz bu vebsaytning barcha sahifalarini o‟zimizning kompyuterga saqlab va 

to‟plab boramiz, va darsimiz so‟nggida bu tayyor sahifalarni Internetga joylashni 

o‟rganamiz. Darslarni o‟rganish mobaynida Internetga ulangan bo‟lishingiz shart emas. 

Biroq Masromedia Dreamweaver 8.0 kompyuteringizga o‟rnatilgan bo‟lishi shart. Har 

bir bajarishingiz kerak bo‟lgan jarayonni son ketma ketligida → bilan belgilab boraman. 



1→ Kompyuteringizning HARD DISS (D) ida losal_sites deb nomlanga yangi papka 

oching. Mening kopyuterimda bu papka ushbu manzilda joylashgan D:\losal_sites 

2→Dreamweaver 8.0 ni o‟zini kompyuteringizga o‟rnatilingan papkalari ichida 

café_townsend deb nomlangan yana bitta papka bor, faqt o‟sha papkani losal_sites 

papkangiz ishiga ko‟chirib oling (kesib emas). Menda bu papka ushbu manzilda 

joylashgan.  

S:\Program Files\Masromedia\Dreamweaver 8\Tutorial_assets\safe_townsend 

3→Navbatdagi bajarishimiz kerak bo‟lgan narsa “Manage site” orqali saytimizni faqat 

o‟zimizgina ko‟rishimiz mumkin bo‟lgan holatda joylashdir. Buni sayt yaratishdan 

oldin birinchi bo‟lib qilib olish kerak. Agar bunday qilinmasa Dreamweaver ning ba‟zi 

funktsiyalari bajarilmasligi mumkin. Shuningdek bu holda vebsayt yaratish ancha qulay. 

Buning uchun quyidagilarni bajaring.  

1. Menyu qatoridan Site > Manage Sites ni tanlang. Va quyidagi oynashadan New >  

Site ni tanlang. Quyidagi rasmdagi Final ga e‟tibor bermang. 

 

 
2. Quyidagi oynada boshida e‟tibor bergan bo‟lsangiz Basis (oddiy) va Advanced 

(mukammal) turibdi bizga Advanced bo‟limi kerak. Va uni quyida ko‟rsatilinganday 

to‟ldirib chiqig. 

Local Info 

a. Site name: Sayt nomi: café Townsend bo‟lsin. 



b. Local root folder: café_townsend papkangiz joylashgan joyni ko‟rsating. 

c. Default images folder: rasmlar joylashgan papka manzili. 

d. Links relative to: Dosument da tursin. 

e. HTTP address: Hozirsha bo‟sh tura tursin, qandoq bo‟lsa shundoq turadi. 

f. Cache:  Enable cache. 

g. Ohirida OK ni bosing. 

Remote Info, Testing Server, va hokazolarga hozirsha tegmay turamiz. 

 
3. OK bosganingizda ushbu oynacha chiqadi va keyin Done ni bosing. 

  

 
4. Files paneli Dreamweaver Dokumentingizning o‟ng tarafida quyidagicha 

ko‟rinishda ochiladi.  



 
Endi qilishimiz kerak bo‟lgan narsa bu vebsayt yaratishni boshlashdir. Yodingizda 

bo‟lsin vebsaytlar asosan jadvallar ichiga yasaladi (HTML darslarida o‟tganmiz). 

Demak vebsayt yaratishdan oldin vebsaytimiz qanday strukturada joylashishini biror 

qog‟ozga chizib chiqishimiz kerak. Keyin unga qarab jadval tuzamiz. Darhol 

Dreamweaver ni ochib vebsayt tuzib ketilavermaydi. Keyin tayyor bo‟lgan 

jadvalimizning har hil qismlariga har hil ma‟lumotlarni o‟rnatishimiz kerak bo‟ladi. Biz 

quyida ko‟rsatilingan vebsaytni yaratishni boshlaymiz.  

 
  



1→ Buning uchun birinshi navbatda yangi HTML dokument ochamiz va uni index deb 

saqlab qo‟yamiz. 

a. File > New → Basis page > HTML 

b. File  > Save As 

c. File name: index deb yozsangiz bo‟lgani (index.html) kerak emas. 

d. Ohirida Save. 

 
2→ Keyin Title: bo‟limiga Café Townsend deb yozing. Vaqti vaqti bilin o‟zingizni bilib 

klaviatura yordamida (Ctrl+s) dokumentingizni saqlab boring.  bu rasmdagi 

ushbu yulduzcha dokumentga so‟nggi o‟zgartirish kiritilgandan buyon saqlanmadi, 

degan ma‟noni beradi. 

 
3→ Yuqorida takidlaganimdek endi navbat Jadval tuzishga. Jadvalni 2 hil yo‟l bilan 

tuzishimiz mumkindir.  

Birinshisi:  dagi birinchi rasmga bosish orqali. 

Ikkishisi: Menyu qatoridan Insert > Table orqali. 

 
Jadvalni 3 ta qatorga 1 ta ustun qilib quyidagicha belgilab olamiz. Umumiy 

kengligini esa 700 piksel qilib olamiz 

a. Rows: jadval qatorlari soni 3 ta 

b. Columns: jadval ustunlari soni 1 ta 

c. Table width: Umumiy kengligini esa 700 piksel. 



d. Qolganlarini o‟zgartirmaymiz. 

e. Header: None da tursin 

f. OK 

 
4→ Sizda ushbu ko‟rinishdagi jadval tuziladi. O‟zingizni vebsaytingizni 

yaratayotganingizda biron qator yoki ustun ortiqcha yoki kam bo‟lib qolsa, o‟chirib 

yoki qo‟shishingiz mumkindir. 

 
Agar kursoringiz jadval ishida tursa yashil shiziqlar bilan, har bir ustunlar kengligi 

va jadvalning umumiy kengligi ko‟rinib turadi. Quyidagi misolda (tuzishingiz shart 

emas) 700 umumiy jadvalning kengligi, 140, 230, 330 lar esa ustunlar kengligidir. 

O‟lchamlar piksel yoki foiz da bo‟lishi mumkin. Kursorni jadvaldan tashqariga 

chiqarsingiz sichqonchani jadvalning o‟ng tamoniga tashqariga bosish orqali, bu 

o‟lcham ko‟rsatkichlari yo‟qoladi. Bu ko‟rsatkichlar shunchaki sizga eslatma sifatidadir. 

Agar hohlasangiz bunday eslatmani o‟chirib qo‟yishingiz mumkindir. Uning uchun siz 

Menyudan View > Visual Aids > Table Widths ga bosishingiz kerak bo‟ladi. 

 
5→ Kursorni jadvaldan tashqariga sichqonchani jadvalning o‟ng tamoniga bosish orqali 

chiqaring, klaviaturadan hech qanday tugmani bosmagan holda. Yana bitta ikkinchi 

jadvalni tuzamiz. Bu gal 1 ta qator, 3 ta ustun qilib belgilaymiz. Va qolgan o‟lchamlarni 

o‟zgartirmaymiz. OK bosing. 



 
6→ Kursorni jadvaldan tashqariga sichqonchani jadvalning o‟ng tamoniga bosish orqali 

chiqaring, klaviaturadan hech qanday tugmani bosmagan holda. Yana bitta uchunchi 

jadvalni tuzamiz. Endi esa 1 ta qator, 1 ta ustun qilib belgilaymiz. Va qolgan 

o‟lchamlarni o‟zgartirmaymiz. OK bosing. 

 
Sizni umumuy hama jadvalingiz ushbu ko‟rinishga egadir.  

 
7→ Endi vaqtinchalik jadvalimizni o‟lchamlarini belgilashni osonlashtirish maqsadida 

cell padding va cell spacing joylashtiramiz. Uning uchun shunshaki:  

View > Table Mode > Expanded Tables Mode (F6)  



 
yoki quyidagi qatordan Expanded ga bosamiz.  

 
Va quyidagi natijani olamiz. Biroq o‟lchamlarni joylab bo‟lgach oldingi Standard 

Mode ga qaytishimizga to‟g‟ri keladi. 

 
  



8→ Kursorni yuqoridan eng birinchi qator ichiga joylagan holda, eng quyidagi 

 bo‟limidan “H” ya‟ni height (balandlik)ni 90 (piksel) qilib belgilaymiz.  

  

 
9→ Kursorni yuqoridan ikkinсhi  qator iсhiga joylagan holda, eng quyidagi  

bo‟limidan “H” ya‟ni height (balandlik)ni 166 (piksel) qilib belgilaymiz. 

 
10→ Kursorni yuqoridan uсhinсhi  qator ishiga joylagan holda, eng quyidagi 

 bo‟limidan “H” ya‟ni height (balandlik)ni 24 (piksel) qilib belgilaymiz. Sрu 

bilan birinсhi jadvalimiz o‟lсhamlari tugaydi. 

 
Birinсhi Jadvalimizning o‟lсhamlari o‟rnatilganidan so‟ng umumiy ko‟rinishi 

quyidagiсhadir. 

 
11→ Endi ikkinchi jadvalimizning o‟lсhamlarini kiritamiz. Kursorni сhapdan birinсhi 

ustun ishiga joylagan holda, eng quyidagi  bo‟limidan “W” ya‟ni width 

(kenglik)ni 140 (piksel) qilib belgilaymiz. 

 



12→Ikkinchi va uchunchi ustunlar uchun ham W ni 230 va 330 qilib mos ravishda 

belgilab olamiz. Va bizda umumiy jadvalimiz quyidagicha ko‟rinishga ega bo‟lishi 

kerak bo‟ladi. H uchun hech qanday o‟lcham kiritmaymiz chunki keyinchalik bu 

kataklar ichiga joylashtiradigan ma‟lumotlarimizga qarab jadval balandligi o‟zgarishi 

mumkindir. 

 
13→ So‟nggi jadvalimizning esa (H)ni 24 (pixel) qilib belgilab olamiz. 

 
Eng so‟nggida jami jadvallarimizning umumiy ko‟rinishi quyidagicha bo‟lishi kerak 

bo‟ladi. 

 
14→ Keyin Boshida ta‟kidlaganim Standard Mode ga qaytishimiz kerak bo‟ladi. Uning 

uchun ikki hil uslubni qo‟llashimiz kerak bo‟ladi.  

Birinchisi: Menyu qatoridan View > Table Mode > Standard Mode 

Ikkinchisi:  joydan Standard 

tugmachasiga bosishimizdur. Va Standard holatga o‟tkazganingizdan so‟ng 

dokumentingizni saqlang.  

Image Placeholder va Rang berish 

Vebsite yaratishimizda eng yuqori qatorda odatda biror rasm yoki animatsiya bo‟lishi 

kerak bo‟ladi. Hatto uni oldindan yaratmagan bo‟lsangiz ham u uchun joy ajratib 



qo‟yishingiz kerak, va u joy odatda image placeholder (rasm joyi deb nomlanadi) 

bo‟ladi.  

1→ Jadvalimizning eng yuqori qatoriga kursorni joylagan holda dokumentimizning 

Menyu qismidan Insert > Image Objects > Image Placeholder ga kiramiz. 

 
2→Undan so‟ng quyidagi oynacha chiqib keladi va uni quyidagicha to‟ldirishimiz 

kerak bo‟ladi.  

a. Name: banner_graphic 

b. Width: 700 

c. Height: 90 

d. Color: #993300 

e. Alternative text: esa bo‟sh qola tursin. 

f. Va ohirida OK 

 
3→Endigi qilishimiz kerak bo‟lgan ish, bu jadvalimizning ba‟zi kataklariga rang berib 

chiqishimizdir. Uning uchun birinchi navbatda uch ustunlik jadvalimizning birinchi 

ustuniga kursorni joylaymiz. 

 
4→Biz shu holda umumiy katakni tanlashimiz kerak bo‟ladi, uning uchun ishlash 

panelimizning quyi qismidagi <td> belgisini tanlashimiz kerak bo‟ladi  

 
5→ Dokumentimizning eng quyi qismidagi Properties bo‟limidan background color 

(bg) dan #993300 rangini tanlang va Enter ni bosing. U qiyidagich ko‟rinishga ega 

bo‟lishi kerak bo‟ladi. 



 
6→ Endi esa ikkinchi ustunni tanlashimiz kerak bo‟ladi va u uchun biz yana kursorni 

katak ichiga joylaymiz va <td> ni tanlaymiz, #F7EEDF rangni bg color uchun 

belgilaymiz.  

7→ Uchunchi ustun uchun ham (6→) ni takrorlaymiz. Va jadvalimiz ushbu ko‟rinishga 

ega bo‟ladi. 

 

 
8→Endigi qilishimiz kerak bo‟lgan narsa bu butun bir sahifamizning o‟zini Page 

Properties yordamida background rangini qora (#000000) qilib belgilab olishdir, siz 

shuningdek text turi, matn o‟lchami va hokazolar uchun ham bu yerda moslab olishingiz 

mumkindir, biroq hozircha faqat rangini o‟zgartiramiz. Page Properties oynasini ikki 

yo‟l bilan ochishimiz mumkindir.  

Birinchisi: Albatta Menyu qatoridan Modify > Page Properties. 

 
Ikkinchisi: Dokumentimizning quyi qismidagi Properties bo‟limidagi, Page Properties 

tugmachasi yordamidadir, u tugmacha yuqoridagi rasmda o‟ng-quyi burchakda 

joylashgandir. 



 
9→Rangni tanlab bo‟lganimizdan keyin boshqa hech narsani o‟zgartirmagan holda OK 

ni bosamiz. Va sizning butun bir sahifangiz qora rangga aylandi. Shu yerda 

dokumentingizni yana bir bor saqlab qo‟ying. 

 

 
Veb sahifamizni Matnini to‟ldirish 

Bu darsda qilishimiz kerak bo‟lgan narsa jadvalimizning ichini asosiy ma‟lumotlar bilan 

to‟ldirishdir. Dars so‟nggida bizning sahifamiz quyidagicha ko‟rinishga ega bo‟lishi 

kerak bo‟ladi. Keyin biz CSS document yaratib HTML bilan bog‟lab biriktiramiz 

shunda matnimiz yanayam ko‟rkamlashadi. 



 
1→ Jadvalimizning eng yuqoridagi bo‟limiga (banner_graphic) ga ikki marta 

sichqonchani bosing. Va images papkasidan banner_graphic rasmini tanlang, va OK ni 

bosing. Jadval tashqarisiga sichqonchani bosish orqali umumiy ko‟rinishini ko‟ring. 

Agar browserda ko‟rish niyatingiz bo‟lsa F12 ni klaviaturadan bosing. Va shu yerda 

yana bir dokumentizni saqlang. 



 
2→ Birinchi jadvalimizning yuqoridan uchunchi qatori ichiga kursorni joylang. Menyu 

qismidagi Insert > Image dan body_main_header.gif faylini tanlang va OK ni bosing. 

Ushbu holat quyida ko‟rsatilingandir. 

 

 
3→ Quyidagi ushbu oynachaga e‟tibor bermagan holda shunchaki OK ni bosing. 



 
4→ Uchunchi jadvalimizning qatori ichiga kursorni joylang. Menyu qismidagi  Insert > 

Image dan body_main_footer.gif faylini tanlang va OK ni bosing. Keyingi chiqqan 

oynaga ham OK ni bosing. Siz shuningdek Files bo‟limidan rasmni sichqoncha 

yordamida ushlab katak ichiga olib kelib tashlash yordamida ham rasmlarni 

joylashingiz mumkindir. Ushbu holat quyida ko‟rsatilingandir. 

 
5→ Dokumentingizni shu yerda yana bir saqlab oling. Veb sahifangiz umumiy 

ko‟rinishi quyidagichadir. 

 
6→ Uch-ustunlik jadvalimizning ikkinchi ustuniga kursorni joylagan holda Assets 

Bo‟limidan rasm joylash uslubini ham bir ko‟rib o‟tamiz. Buning uchun avval katak 

ichidagi ma‟lumotni vertikal joylashuvini yuqoridan va gorizontal joylashuvini esa 

markazdan qilib belgilaymiz. Uning uchun kursor katak ichida turgani holda Properties 

bo‟limidan ushbu ko‟rsatkichlarni tanlaymiz. 



 
So‟ngra quyidagi ko‟rsatilingan rasmni sichqoncha yordamida ushlagan holda shu 

katakga joylab, chiqib kelgan oynachaga OK ni bosamiz. 

 
  



Sizning sahifangiz ushbu ko‟rinishga ega bo‟lishi kerak.  

 
7→ Endigi navbat Flash faylgadir. Flash fayllar odatda vebsaytlarda juda keng 

qo‟llaniladi, ular rasmlarni o‟zi navbatma navbat almashinib turishini ta‟minlaydi, 

bunday flash fayllar tayyorlash Dreamweaverda mumkin emas, mahsus dasturlarda 

tuziladi, biroq biz hozircha tayyor yasalganini olib joylaymiz, broq vaqti kelib bularni 

ham o‟rganamiz. Buning uchun birinchi jadvalimizning ikkinchi qatorini tanlaymiz va 

kursorni joylaymiz. Insert > Media > Flash yordamida flash faylni tanlaymiz. 

  
U fayl quyida ko‟rsatilgani kabi bo‟ladi va OK ni bosing, keying chiqgan oynachaga 

OK ni bosing.  

 
8→ Sizda quyidagicha ko‟rinish paydo bo‟ldi. 



 
Biroq flash faylini ko‟rish uchun uni sichqoncha bilan jadval ichida yuqorida 

ko‟rsatilingan holda tanlab Properties bo‟limidan  ni bosishingizga to‟g‟ri 

keladi. Va quyidagi natijani olasiz. 

 
9→Endi quyidagi rasmni chap tarafiga kursorni joylashtiring.  

 
  



11→ Va Insert > Media > Flash Video ga kiring. 

 
12→ Ushbu oyna huddi ko‟rsatilingani kabi to‟ldirilsin. Va OK 

 

a. Video type: Progressive Download Video 

b. URL: café_townsend_home.flv 

c. Skin: Halo Skin 2 

d. Width: 180 

e. Height 135 

Constrain: eni va bo‟yi o‟lchamining nisbatini belgilash uchun 

Auto Play: web sahifa ochilganda o‟zi ishga tushsinmi yoki vebsayt foydalanuvchisi 

o‟zi play ni bosgandami degan tushunchani belgilash uchun. 

Auto rewind: video flash tugaganda yana boshiga qaytarish uchun. 

 



Endi vebsahifamizga text kiritishni boshlaymiz. 

1→ Files panelida sample_text.txt dokumntimi sichqonchni ikki marta bosish orqali 

Dreamweaverda oching. 

 
2→ Matnni qora qilib ko‟chirgan holda uch-ustunlik jadvalimizning uchunchi ustuniga 

joylang. Va shu yerda yana bir bor dokumentingizni saqlab qo‟ying. 

 
3→ Joylangan matnni, vertikal joylashuvini kursorni matn ichida turgani holida 

Properties bo‟limidan Vertikal ni Top qilib oling. Horizontal bo‟limiga tegman. Endi 

F12 yoki boshqa yo‟l bilan Internet Explorer da website ko‟rinishida ochib ko‟ring. 

 

 
CSS dokumentini HTML dokumentga bog‟lash 

So‟ngida siz yaratgan vebsite ushbu ko‟rinishda bo‟lishi kerak. 



 
 

 

 
Bu autoplayning yaratish jarayoni. Bunda yangi loyiha yaratishimiz mumkin yoki 

yaratilgan loyihani chaqirib olishimiz mumkin. 

 

 



 
 

Bu bizning birinchi varaqimiz bo`ladi. Shunga o`xshagan bir nechta varaqlar yaratamiz.  

 
Bu vedio qo`yish jarayoni  



Bu autoplayda yaratilgan loyihanining ko`rinishi   

 

 
Bunda pdf formatdagi dokumentni yaratish ko`rsatilgan. Buning uchun Adober reader 

programmasini o`rnatish kerak. Shundagina ishlaydi.  



XULOSA 

 

Men bu loyihada Macromedia dreamweaver 8 dasturi haqida batafsil bo`masa ham 

bafurcha tushuntirib o`tdim. Uning qanday ishlashi qanday dastur  qanday qulayliklarga 

egaligi haqida gapirib o`tdim. Forma nima forma qanday to`ldrilishi haqida batafsil 

tushuntirib o`tdim. Men bu loyihadan olgan narsam Macromedia dasturlardan 

foydalangan holda loyiha yaratdim. Bu menga bilimim qanday darjadaligini va bu 

dasturlardan qanaqa foydalanishimni o`zim bilib oldim. Bu loyiham sizga ham yoqadi 

degan umiddaman .   

 

 

 

  



FOYDALANILGAN ADABIYOTLAR. 

 

Bu loyihani tayyorlashda Macromedia Dreamweaver 8 dasturi yordamida qildim. 

Nazariy qismlarni tayyorlashda WORD, CAMTASE, POWER POINT va albatta 

kompyuter kerak bo`ldi. Internetdan www.uzbekhtml.com sayti yordam berdi shu 

saytga kirib ma`lumotlarni topishga muvaffaq bo`ldim. 

Google.uz 

Dasturchi.uz 

Autoplay dasturi. 

 

http://www.uzbekhtml.com/

