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KIRISH 

Mavzuning dolzarbligi: Dunyo cheksiz sir-sinoatlardan iboratdir. Uni 

bamisoli musavvirning «Qora kvadrat» asariga ma`noda o`xshatsa bo`ladi. Zero, 

«kvadrat» - uning tafakkuri ojizlik qilishi, tabiiydir. Pirovardida, bu mo`jizalarni 

o`rganish uchun insonga cheksiz umr adabiy yaratilganligini, to`rt tomoni - 

cheksizlik timsolini anglatsa, «qora rang» esa mavhumlik dunyo sir-sinoatining 

barchasini anglab bo`lmas sir ekanligidan dalolat beradi. Insoniyat qanchalik shu 

sirlani bilishga harakat qilmasin, biroq uning kerak bo`lishi haqida falsafiy 

xulosaga kelasan, kishi.  

Asrlar davomida ajdodlarimiz, fan arboblari muayyan darajada ilmiy-

tadqiqot ishlarini, tajribalarni o`tkazib kelishmoqda. Hozirda, hatto ba`zi 

rivojlangan mamlakatlarda maxsus rang institutlari va ilmiy laboratoriyalar bu 

borada samarali faoliyat ko`rsatib kelishmoqda. Bu o`rinda Yaponiyaning Tokio 

shahridagi dunyoga mashhur rang institutini ta`kidlash mumkin. 

Mamlakatimizni obod, xalqimizni farovon qilish davlatimizning eng asosiy 

vazifalaridan hisoblanadi. Ushbu nihoyatda katta vazifani bajarish keng qamrovli 

masalalarni hal etishni taqozo etadi. Ana shunday muhim masalalardan biri har 

tomonlama kamol topgan yuqori malakali mutaxassislarni tayyorlashdir. Buning 

uchun shunga mos ta’lim va tarbiya ishlarini bajarish, o’quv jarayonini rivojlangan 

demokratik davlatlarda olib borilayotgan o’quv jarayoniga tenglashtirish, 

zamonaviy pedagogik va axborot texnologiyalarini o’quv jarayoniga kengroq 

tadbiq etish zarur.  

 Binolar va inshootlar qurilishi yo’nalishi bo’yicha ta’lim olayotgan talabalar 

faoliyatiga yurtimiz obodligi bevosita bog’liqdir. Shunday ekan, oliy o’quv 

yurtlarida puxta bilim olgan, o’z kasbini sevib, uni sirlarini har tomonlama chuqur 

o’rgangan, yetarli kasb mahoratiga ega bo’lgan yoshlar mamlakatimiz kelajagini 

yanada obod qila oladilar. Bu masala esa ko’p jihatdan ularning bilim olishlari 

uchun yaratilgan shart – sharoitlarga, shu jumladan yoshlar uchun yaratilgan o’quv 

adabiyotlariga bog’liq.  



Hozirgi vaqtda AutoCAD ning dastur ta`minoti shaxsiy kompyuterlarning 

eng keng tarqalgan avtomatik loyihalash tizimi paketidir. 

Ushbu kurs ishida kompyuterli modellashtirishni loyihalashtirishning 

universal grafik sistemasi muhitidan iborat bo‘lgan, AutoCaddan foydalanish 

uslubi taklif etilgan. Bu AutoCAD tizimi Autodesk kompaniyasi tomonidan ishlab 

chiqilgan bo‘lib, loyihalash jarayonida ko‘p sonli foydalanuvchilar qulay holda 

ishlatishlari ko‘zda tutilgan. Hozirgi davrda AutoCAD ning dasturiy ta'minoti 

kompaniyani eng yaxshi mahsuloti bo‘lib, shaxsiy kompyuterlarning eng keng 

tarqalgan avtomatik loyihalash tizimi paketi hisoblanadi 

 «Kompyuter grafikasi» informatika sohasida o`rganiladigan ko`pgina fanlar 

ukuv rejalarining ajralmas qismi bulib hisoblanadi. Hozirgi vaqtda kompyuter 

grafikasi quyidagi kurslarning tarkibiy qismi hisoblanadi: 

 “Informatika va hisoblash texnikasi” 

 «Informatika va dasturlash» 

 “Kompyuter informatsion sistemalari” 

 “Moddiy resurslarning kompyuter informatsion sistemalari (marketing)” 

 ADP (amaliy dasturlar paketi) 

 Internet asoslari va E-mail (elektron pochta) 

 “Kompyuter tarmoklari” va boshkalar. 

 Berilgan ma’lumotlarni tahlil qilishda, olingan natijalarni kurimli qilib 

ko`rsatishda va takdimot (prezentatsiya) uchun materiallar tayyorlashda, tasvirlarni 

qayta ishlashda, yangi marakkab kompozitsiyalar yaratishda zamonaviy kompyuter 

grafikasi keng qo`llaniladi. Yuqoridagi sohalar bo`yicha bilim olish va amaliyotda 

tatbiq qilishda “Kompyuter grafikasi” fani qo`l keladi. 

Shu bois, hozirgi kunda glaballashuv jarayoni tezlik bilan rivojlanib 

borayotgan bu davrda, talabalarning bu bilimlarni o`zlashtirishlari uni mukammal 

o`zlashtirishlari talab etilmoqda. 

 

 



Kurs ishining maqsadi –  

Men o`z kurs ishimda Tanlangan elementni chozish va ularda ishlash 

usullarini o`zlashtirishni, o`z oldimga maqasad qilib qo`yaman. 

Kurs  ishining vazifasi:  

Tanlangan elementni chozish usullari bilimimni rivojlantirish. 

Kurs ishi tuzilishi: kirish, ikki bob, xulosa foydalanilgan adabiyotlar 

ro`yxatidan iborat bo`lib, jami 30 sahifani tashqil etadi. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



I-BOB. Kompyuter grafikasi haqida umumiy tushuncha. 

1.1. “Kompyuter grafikasi” kursining predmeti, mazmuni va vazifalari. 

Asosiy tushinсhalar: 

1.  Kompyuter  (mashina) grafikasi - grafik yoki geomerik ob’ektlarining  hajm 

modellarini yаratish, sakash,  ishlov berish va zamonaviy EXMlar yordamida 

ularni tasvirlash tushuniladi. 

2.  Multimedia texnologiyаsi - foydalanuvсhini Kompyuter bilan muloqati uсhun 

ovoz, video, grafika, matn, animatsiyа va boshqa vositalar  yordamida tabiiy  

muhitni ta’minlash jarayoni. 

3.  Grafik interfeys - foydalanuvсhi dastur va ma’lumotlar bilan ishlayotganda 

grafik elementlar yordamida kerakli amallarni bajarishni ta’minlovсhi oddiy va 

qulay vosita. 

“Kompyuter grafikasi” ning informatsion jamiyаtdagi ahamiyаti, roli va 

urni. 

 Fan va texnika taraqqiyoti jamiyаtimizni informatsion jamiyаtga aylantirdi. 

Bu jamiyаtda faloiyаt ko`rsatuvсhilarning aksariyаt qismi axborotlarni ishlab 

сhiqarish, saqlash, qayta ishlash va amalga oshirish  bilan banddirlar. Bunday 

ishlarni zamonaviy Kompyuterlarsiz amalga oshirish qiyin. Ulardagi 

ma’lumotlarni qayta ishlash mashina grafikasi yordamida amalga oshirilsa 

foydalanuvсhi katta qulayliklar tug`diradi.  

 Mashina grafikasi deganda ob’ektlarning hajm modellarini yаratish, saqlash, 

ishlov berish va EXM lar yordamida ularni tasvirlash tushuniladi. 

 Kompyuter grafikasi yаngi informatsion texnologiyаlar orasida to`xtovsiz 

rivojlanib boraetgan yunalishlardan biri hisoblanadi. Bunday rivojlanish texnika 

sohasida ham (grafika stantsiyаlari), dasturiy vositalar sohasida ham ko`zga 

tashlanmoqda. Ular videofilm kadrlari bilan sifat buyiсha taqqoslashga loyiq 

haqiqiy, hajmli harakatlanuvсhi tasvirlarni yаratishga imkon beradi. Bu dasturiy  

maxsulotlar reklamalar ishlab сhiqaruvсhi vositalar hisoblanib, san’at va 



multimediyа texnologiyаsi sohalarida qo`llaniladi. Bundan tashqari namoyish 

grafikasiga, geometrik modellashtirishga, grafik interfeyslarni loyihalashga, 

animatsiyа (harakatlanuvсhi tasvirlar) ga va ko`zga kurinuvсhi (vizualniy) 

harakatni kurishga katta e’tibor berilmoqda. 

 Kompyuter grafikasi ilm va fanning barсha sohalarida, ayniqsa iqtisodiy 

ko`rsatgigсhlarni tahlil qilishda muvoffaqiyаtli qo`llanilishi mumkin. 

“Kompyuter grafikasi” tugrisida umumiy tushunсha 

  Kompyuter grafikasi jaxonda yаngi fundamental fan hisoblanib o`tgan 

asrning 90 – сhi yillarida paydo buldi hamda fan va ishlab сhiqarishning barсha 

sohasida kadrlar tayyorlab berishda o`ziga xos mustaqil ahamiyаtga egadir. 

 Maxsus dasturlar yordamida xuddi bir varak ok qog`ozga qalam yoki ruсhka 

bilan har xil rasmlarni solish singari Kompyuter ekranida siсhkonсha yordamida 

rasm сhizish, yа’ni tasvir tuzish, tuzatish va ularni harakatlantirish imkonini 

yаratdi. Bu dasturlar rasm solish programmalari yoki grafik redaktorlar hisoblanib, 

ular yordamida rasmning elementlari boshkarib boriladi. 

 Kompyuter grafikasining juda tez rivojlanib borishi va uning texnikaviy va 

dasturiy vositalarining yаngilanib turilishi ushbu kursning hamisha 

takomillashtirishga, bu sohadagi yаngi yunalishlarni tinmay o`rganib borishni 

takozo etadi. Oxirgi yillarda bu sohada juda katta uzgarishlar (siljishlar) yuz berdi, 

yа’ni 16 mln.dan ortik rang va rang turlarini (ottenok) uzida aks ettira oladigan 

displeylar, grafik axborotlarni (paper part) kirituvсhi moslama - skanerlar, grafik 

ish stantsiyаlari; dasturiy vositalar sohasida esa haqiqiy Kompyuter dunyosini  

kashf  qila oladigan amaliy dasturlar vujudga keldi. 

“Kompyuter grafikasi” ning Informatika sohasidagi boshka fanlar bilan 

uzaro alokasi 

 «Kompyuter grafikasi» informatika sohasida o`rganiladigan ko`pgina fanlar 

ukuv rejalarining ajralmas qismi bulib hisoblanadi. Xozirgi vaqtda Kompyuter 

grafikasi quyidagi kurslarning tarkibiy qismi hisoblanadi: 

 “Informatika va hisoblash texnikasi” 



 «Informatika va dasturlash» 

 “Kompyuter informatsion sistemalari” 

 “Moddiy resurslarning Kompyuter informatsion sistemalari (marketing)” 

 ADP (amaliy dasturlar paketi) 

 Internet asoslari va E-mail (elektron poсhta) 

 “Kompyuter tarmoklari” va boshkalar. 

“Kompyuter grafikasi” kursining predmeti, mazmuni va vazifalari. 

 Berilgan ma’lumotlarni tahlil qilishda, olingan natijalarni kurimli qilib 

ko`rsatishda va takdimot (prezentatsiyа) uсhun materiallar tayyorlashda, tasvirlarni 

qayta  ishlashda, yаngi marakkab kompozitsiyаlar yаratishda zamonaviy 

Kompyuter grafikasi keng qo`llaniladi. Yukoridagi sohalar buyiсha bilim olish va 

amaliyotda tatbik qilishda “Kompyuter grafikasi” fani kul keladi. 

AutoCad dasturi haqida umumiy tushuncha 

Hozirgi vaqtda uch o‘lchamli kompyuterli modellashtirish vositalari 

foydalanuvchilarning e'tiborida bo‘layapti va bu tasodifiy emas albatta. Ulardan 

foydalanish konstruktorlik-loyihalash ishlarining sifatli bajarilishi hamda 

foydalanuvchiga chizmalarni tez, sifatli, yuqori aniqlikda bajarish va  qog‘ozga 

chiqarish imkonini beradi. 

AutoCAD dasturi avtonom rejimida yoki lokal tarmoqda ham ishlashi 

mumkin. AutoCAD  dasturining yaxshi ishlashi uchun quyidagi manbaalar zarur 

bo‘ladi:  Pentium 133 protsessori,  32 Mbaytli operativ xotira, Qattiq diskda 400-

750 Mbaytli  xotira,  640 ga 480 VGA – displeyi. 

AutoCAD DASTURINI ISHGA TUSHIRISH 

AutoCAD dasturi ishga tushirilgandan keyin «Zagruzka» dialog oynasi 

chiqariladi (1-rasm).  

 



 

 
- «Chizmani tanlash» –avval yaratilgan chizmani ochish imkonini 

beradi; 

 
- «Boshidan boshlash» -  chizma uchun yangi varaqni ochish imkonini 

beradi; 

 
- «Shablondan foydalanish» –chizmachilikning kerakli uskunalarini o‘z 

ichiga olgan shablonni tanlash imkonini beradi; 

 
- «Sehrgarni ishlatish» –AutoCAD muhitida kerakli sozlashlarni 

amalga oshirish. Sozlashning ikki xil varianti: «Advanced Setup» 

(«Keng sozlash») va «Quick Setup» («Tez sozlash») (2-rasmga 

qarang). 

 Units (Birliklar) –uzunlikning kiritish va chiqarish o‘lchov birliklarini tanlash 

navbatdagi o‘lchov birliklarini taklif etadi: Decimal (detsimetrlik); Engineering 

(muhandislik); Architectural (arxitekturali); Fractional (fraktsionli); Scientific 

(ilmiy). Decimal (detsimetrlik) o‘lchov birligini tanlash tavsiya etiladi. 

•   Angle (Burchaklar) -Burchakni kiritish va chiqarish o‘lchov birliklarini tanlash 

navbatdagi o‘lchov birliklarini taklif etadi: Decimal Degrees (detsimetrli gradusli); 

Deg/Min/Sec (graduslar/minutlar/sekundlar); Grads (gradlarda); Radians 

(radianlarda); Surveyor (yorug‘lik tomonlariga nisbatan). Decimal Degrees 

(burchakli detsemetrli) o‘lchov birligini tanlash tavsiya etiladi. 



•   Angle Measure (Burchakni o‘lchash ) –burchakni o‘lchashni boshlash 

topshirig‘i burchakni noldan o‘lchashning navbatdagi yo‘nalishlarini taklif etadi: 

East (sharqiy); North (shimoliy); West (g‘arbiy); South (janubiy); Other 

(ixtiyoriy). East (sharqiy) yo‘nalishni tanlash tavsiya etiladi. 

 •  Angle Direction (Burchakni o‘lchash yo‘nalishi) –burchak yo‘nalishining 

musbat yo‘nalishi tanlanganda, navbatdagi burchaklar yo‘nalishlarirni taklif etadi: 

Counter Clockwise (soat miliga teskari); Clockwise (soat mili bo‘yicha). 

Counter Clockwise (soat miliga teskari) yo‘nalishini tanlash tavsiya etiladi. 

•   Area (chegara) –chizmaning chegaralarini aniqlashga imkon beradi. 

«Quick Setup» («Tez sozlash») varianti tanlanganda dastur faqat o‘lchov 

birliklari (Units) va chegara (Area)ni tanlashni tavsiya etadi. . 

«Zagruzka» dialog oynasidan chiqishda (1-rasmga qarang.)  Yana o‘lchov 

birliklari : (metrik [mm], yoki inglizcha[futlar, dyumlar]) ni tanlash tavsiya etiladi. 

 

 

 

 

 

 

 

 

AutoCAD dasturining ish stoli 

3-rasmda AutoCADning ish stoli tasvirlangan. 

Ish stoliga quyidagilar kiritilgan: 

     

 



•        TUSHUVCHI MENYU QATORI –menyuning eng yuqori qatori; 

•        ASBOBLAR PANELI –yuqorida, ish stolining o‘ng va chap tomonida. 

Keyingi ishlarda foydalaniladigan asosiy asboblar paneli:  

1)  «Standart asboblar» paneli; 

2)   «Obyekt xossasi» paneli; 

3)   «Chizish» paneli; 

4)   «O‘zgartirish» paneli; 

5)   «O‘lchamlar» paneli; 

6)      «Obyektni bog‘lash» paneli. 



1.2. ASBOBLAR PANELINI SOZLASH ALGORITMI. 

1)   sichqon klavishi o‘ng tomonini asboblar panelining ixtiyoriy birortasini 

ko‘rsatib, bosamiz. 

2)   ochilgan ro‘yxatdan kerakli asboblar panelini belgilaymiz. 

 •     GRAFIK MAYDON (Model maydoni) –ish stolining o‘rta maydonini 

egallagan bo‘lib, modellar chizmasini yaratish uchun mo‘ljallangan. Model 

maydoni parametrlarini qo‘llovchi o‘ziga mos qulay ravishda o‘zgartirishi 

mumkin.  

MODEL MAYDONINI SOZLASH ALGORITMI 

1)   Sichqon klavishining o‘ng tomonini grafik maydonning ixtiyoriy joyiga 

bosamiz, Optsii punktini belgilaymiz.  

2)   Ochilgan «Parametrlar» dialog oynasida quyidagi sozlashlarni amalga 

oshirish mumkin.  

A)  Oyna elementlari ish stoli ko‘rinishini sozlash, ya'ni; 

1)   Rang tugmachasi yordamida model maydoni  rangini tanlash mumkin; 

2)   Dialog oynasiga chaqiriladigan shrift turini Shrift tugmachasi orqali sozlash 

mumkin. 

B)  Format elementlari maydoniga Varaq maydoni M2 umumiy ko‘rinishini 

sozlash mumkin. 

V) “Aks ettirishni kengaytirish qobiliyati” maydonida obyektlarning tasviri 

sifatini sozlash mumkin, ya'ni yoylar va aylanalar egri chiziqlarda segmentlar soni 

va h.k. 

G) Aks ettirish maydoniga uch o‘lchovli rang berilgan (3D) obyektlarni aks 

ettirish sifatini sozlash mumkin. 



•   DIALOGLI OYNA yordamida dastur bilan muloqot amalga oshiriladi. Bu oyna 

bir necha qatordan iborat bo‘lib, ularda foydalanuvchi chiqaradigan ta'sir algoritmi 

aks etgan bo‘ladi. Ko‘pincha, dastlabki asboblar to‘g‘risida kerakli axborotni 

o‘z  ichiga oladi.  

      Muloqot oynasida kamida uchta qator qoldirilishi tavsiya etiladi. Sozlashni 

qo‘lda, ya'ni sichqonning kursorini muloqot oynasining yuqori qismiga olib borib, 

uni siqib (cho‘zib) yoki past  (baland) ga surib amalga oshiriladi.   

•   QATOR HOLATI (boshqarish tugmasi) –chizmachilik rejimlari, ya'ni 

qo‘shish/o‘chirishni o‘z ichiga oladi va ish stolining eng pastki qismida 

joylashgan.   

    O‘z ichiga quyidagi elementlar (tugmalar)ni olgan: 

A) QADAM (SHag) (Snap) –sichqonning ma'lum qadam bilan 

harakatini             ta'minlaydi. 

Sozlash bajariladi: Asboblar/Chizmachilik parametrlari qo‘shimcha “Bog‘lash va 

setka”. 

Qadam rejimini qo‘shish (o‘chirish) F9 funktsional klavishi orqali yoki ShAG 

(Qadam) knopkasini sichqon bilan bosish orqali amalga oshiriladi. 

B) TO‘R (Grid) -  rasmni aniq chiqarish, va ishni yengillashtirgan holda, ortogonal 

setkasining bog‘larini ekranda olish imkoniyatini beradi. 

Sozlash bajariladi: Asboblar Chizmachilik parametrlari qo‘shimcha “Bog‘lash va 

to‘r”. 

Setka rejimini qo‘shish (o‘chirish) F7 funksional klavishi yoki sichqon bilan 

SETKA tugmasini bosib amalga oshiriladi. 

V) ORTO (Ortho) – chiziq chizish ortogonal rejimini qo‘shadi (o‘chiradi). 



G) POLYaR (Polar) –chizishning polyar rejimini qo‘shadi (o‘chiradi), ya'ni dastur 

avtomatik ravishda trassirovkali turlar holida obyektlar chizmasi yo‘nalishni va 

burchagini ko‘rsatib beradi. 

Sozlash bajariladi: Asboblar/Chizmachilik parametrlari qo‘shimcha “Bog‘lash 

va setka”. 

Polyarnaya trassirovka rejimini qo‘shish (o‘chirish) F10 funksional klavishi yoki 

sichqonni POLYAR tugmasiga bosish orqali bajariladi. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



II-BOB. TANLANGAN ELEMENTNI CHOZISH 

 Tanlang Modify > Transform > Scale va markazdan hoqlagan yonalshda torting 

 "стрелка" asbobini tanlang va  kattalashtirish (kichiklashtirish) belgisini 

bosing. Markazdan hoqlagan burchak ostiga torting 

2.1. Berilgan elementni o’lchamini o’zgartirsh paytida tesksri qilish:  

Urtacha belgidan pastga markaz tomon torting (rasmda berilgan).(chaoga, ungga 

yuqariga markaz tomon) 

 

Eslatma: Agarda siz o’lchamini kattalashtirgan bo’lsangiz yoki katta obyekt bilan 

ishlasangiz berilgan to’griturtburchakni tortiladiganlarini  kurmasligingiz mumkin 

bu holda  View > Work Area foydalaning  

Obyektlarni tekislash 

Modify > Align ekkita yoki bir-nechta ajratilgan obyektlarni tekislaydi. Tekislah 

elementlar enini va boyini bir xil bo’lishi uchun o’lchamlarini o’zgartirishi 

mumkin. O’lchami eng katta elementga qaray tanlaniladi. Shu bilan birga 

obyektlarni ung tomonga, markazdan,chap tomonga,yuqari tomonga bir xil 

masofada qilib tekislaydi. Align to Page optsyasi bir-biriga va sstenaga nisbatan 

to’grilaydi.  

Bir nechta obyektlar tekislanganda , Flash ularni en tomonlari ,markazi nima yoqin 

bo’lsa ushga nisbatan qiladi. Sizni obyektlarni qanday tartibda kiritgani ahamyati 

yoq.  



 

объекты без выравнивания 

 

Объекты выравнены по верхней точке Eng yaxshi varianlaridan biri 

obeklarni avval nusxasini olish kerak, va guruhga oling. Bu esa tekislagandan 

keyin muharrirlash va alohida qolishga yordam beradi.Agarda ajratilgan 

obyektlardan  bir-biri bilan biriktirilsa yoki bir-biriga yaqin bo’lsa natija 

kutganimizday bo’lmaydi.Bir-biri ustida joylashgan elementlar tekislashdanva 

o’lchamlarini uzgartgandan  keyin bulaklarga bulinadi. 

Obyektlarni tekislash uchun:  

1. Tekislanishi kerak obyektlar ajratiladi. 

2. Modify > Align tanlang. 

3. Mulahot oynasidan optsyani tanlab  OK tugmasini bosing 

 

Kesib olish, yoqatish, nusqasini olish va obyektlarni qoyish. 



Sizlar Flashda obyektlarni kesish (cut) yoqatish (delete), nusqasini olish (copy) va 

qoyish (paste) amallarini bajarilish boshqa dasturlarga uxshahs bo’ladi.  

Buferda nusxalangan obyektlar, siliqlanadi(antialiased), va boshqa dasturda ham 

Flashga uxshash bo’ladi.  

Obyektlarni kesilgani va nusqalari berilgan rolikni (movie) yoki boshqa rolikni  

stsenalarga yoki qatlomlarga (layers)qoyilishi mumkin. Obyektlarni qoyishni 

ekkita turi mavjud bittasi ko’rsatilgan joyga (Paste in Place), ekkinchisi  (Paste), 

ishci maydoniga qoyiladi. 

Boshqa rolikdan (movie) olingan grafika yoki  dasturlar joriy freymga (frame) joriy 

qatlomiga  (layer) qoyiladi.Flashga grafik element qnday bulib qoyilishi uning 

tipiga,optsyasiga bogliq bo’ladi 

 Matn muharriridagi matn matnni obyekti hisobida qoyilqdi 

 Grafik dasturdagi vektor guruhi guruh tarizida qoyiladi,qaytatdan guruhdan 

ajratib muharrirlash mumkin. Flashda ham yoqaridagiga  uxshash bo’ladi. 

 Rasrl tasvirlar ham guruhlangan obyekt bulib qoyiladi.Qiyidagi amal 

yordamida rastr tasvirdan vektorga utiladi Modify > Trace Bitmap . 

Eslatma: Flash 3 dagi FreeHand 8 dan grafikani nusqasini olish va qoyishda 

FreeHand Export Preferences da CMYK va RGB  ga o’zgartiring.  

Ajratilgan elementni uchirish:  

 Del yoki Backspace tugmalari bosiladi. 

 Menudan Edit > Clear ni tanlang. 

 Menudan Edit > Cut ni tanlang. 

Ajratilgan fayldan nusqa olish:  

 Ctrl-tugmasini bosib obyektni bir oynadan ekkinchisiga olib utish kerak 

 Menudan Edit > Duplicate tanlang. 

 Menudan  Edit > Copy tanlang. 

Belgili joyga obyektni joylashtirish:  



1  (Cut) yordamida obyektni kesib oling yoki (copy) obyektni nusqasini oling.  

2  Nusqalarni original obyekt bilan olmashtirmaslik uchun boshqa sloyga 

(layer)utamiz. 

3  Menudan  Edit > Paste in Place tanlang. 

 

Obyekt nusqalangan  joyga tushadi fahat bosqa sloyda bo’ladi. Bu obyektlarni 

joylashgan joylari bir xil fahat boshqa sloylarda va stsenalarda bo’lganlar bilan 

ishlashda qulay bo’ladi. 

  

Ishchi maydonining markaziga obyektlarni qoyish:  

1  Obyektni (Cut) kesib  oling yoki  (copy)nusqasini  oling. 

2  Menuda  Edit > Paste bajaring. 

 Obyekt ishchi maydoni markazida paydo bo’ladi 

Maxsus uerniga qoyish buyrugi (Paste Special) 

Paste Special buyruq (Clipboard) dagi malumotlarni berilgan formatda qoyib 

beradi. Boshqa rolikdan malumotlarga murajaatni ham bajarish  mumkin.Paste 

Special mulohat oynasi quyidagi optsyalarni uz ichiga oladi:  

Source (исходник) malumotlar manbayi nominiva ularni joylashgan joyoni 

kursatadi.  

Paste (вставить) rasmga malumot olmashish buferidagilarni qoyadi  

Paste Link (вставить ссылку) rasmga malumot olmashish buferidagilarni qoyadi 

va shu bilan birga berilgan malumot manbayiga murajjat qilishni yaratadi shuning 

natijasida malumotlar avtomatik tarizda yangilanib  turiladi.  

As (как) Qoyiladigan malumot tipini bildiradi.: Obyektni o’zgartirish uchun 

obyektni va malumotlarni  Object  yordamida qoyiladi. Obyektni nomi obyekt 

yaratilgan muharrirga bogliq bo’ladi. Flashda obyektni o’zgartirish uchun Modify 

> Break Apart ni bajaring.  

Flash yordamida rasmlarni muharrirlash uchun muharrirlagichga konvertirlash 

uchun (Picture) (Metafile) tanlash kerak. Formatlanmagan matnlarni qoyish uchun 



(Text ()ASCII) tanlang . Formatlangan matnni qoyish Text (Native) yordamida 

bajariladi. FLASHda rasmni bulagini qoyish uchun  Flash Drawing tanlang. 

Display As Icon (показать как иконку) Rasmda murajaatni ikoncha shaklida 

kursatadi.  

Result (результат) Tanlangan amalni natijasini kurastadi.  

Change Icon (изменить иконку) Change Icon murajaat oynasini kursatadi. 

Boshqa ikonchani tanlash uchun optsyani mulahot ko’rinishidagi oynadan 

foydalanig.Bu yerda optsya agarda  Display As qishilgan bo’lsa ishlaydi.  

 

2.2. Tasvirlarni import va eksportlashning holatlari. 

Tasvirlarni eksport yoki import qilganda quyidagi konbertorlar bo’lishi kerak — 

oldindan saqlangan malumotlarni dastur tushunadigan turiga utkazuvchi modullar 

bulishi shart. Ole texnologiyasini foydalanganda konventorlar haqida oylamasak 

ham bo’ladi.Ekkinchi tomondan bu texnologiya obyektlar bilan ishlaganda bir 

qancha cheklashlar qoyadi yani,obyektlar kloni olinmaydiganbo’ladi va h. 

Bufer obmena Clipboard 

Malumotlari eng oddiy olmashishi bu Clipboard yordamida amalga oshiriladi,va 

bu yordamida qiyidagi amallar bajariladi: CorelDRAW dasturidan boshqa 

dasturlarga matnlarni va grafik elementlarni olib utishni bajaradi agarda olib 

utilyatgan dasturda OLE texnologiyasi bilan ishlash imkonyati bo’lsa. 

Redaktirovatь (Edit) menusi va asboblar panelida quyidagi amallar berilgan; 

Kopirovatь (Copy), Vыrezatь (Cat), Vstavitь (Paste). 

"drag-and-drop" texnologyasi 

"drag-and-drop" texnologyasi ("olib borib tashlash") bir dasturdan ekkinchisiga qul 

yordamida malumotlarni olib utishlar quyidagi holatlarda amalga oshiriladi. 

 Agarda vektor obyekti bir CorelDRAW dasturda bir hujjatdan ekkinchisiga olib 

utiladigan bo’lsa. 

 Agarda vektorli obyekt ishchi stolga olib utiladigan bo’lsa. Bu yerda ishchi 

stoldan boshqa dasturga olib utiladi, masalan CorelDRAW va Corel PHOTO-

PAINT dasturlar orasida grafik malumotlar oilb utiladi. 



Otkrыtь (Open) va Importirovatь (Import) buyruqlari 

 

 

Menunuing Fayl (File) va Otkrыtь (Open...) buyrugi bosqa muharrirlar yordamida 

yoratilgan hujjatlarni ochadi, bu yerda fayllar vektor formatli bulishi kerak, 

masalan, EPS standart formati. 

Yuqaridagi byuruq bajarilgandan keyin ekranda Otkrыtь risunok (Oren Drawing) 

mulahot oynasi chiqadi,bu yerda faylni qaysi jildda va qaysi fayl ekanligini 

kurstish kerak. Bu erda Prosmotr (Preview)dagi bayroqchni belgilash natijasida 

fayllar ichidagi malumotlar ko’rsatiladi. Agarda faylni uqich mumkin bo’lmasa 

yoki boshqa sabablarga bogliq uqilmasa ko’rish oynasida krest belgisi chiqariladi. 

Ko’rish maydoni tagida fayl haqida malumotlar chiqariladi: 

 Versiyа dokumenta (File Version) satrida hujjat saqlangan dasturning versiyasi 

beriladi; 

  Stepenь sjatiyа (Compression ratio) satrida faylni siqilish foyizini ko`rsatadi  

(vektor formati uzi ixcham o’lchami kichik bo’ladi, shunga qaramastan dastur 

faylni avtomatik tarizda siqadi.); 

 Soxranen (Last saved by) satri dasturni versyasi haqida malumot beradi 

(platformasi) va unig relizi (masalan, build 337). 

Klyuсhevыe slova (Keywords) va Primeсhaniyа (Notes) foydalanuvchiga kerakli 

faylni tez qidirib topib berishda yordam beradi. Agarda berilgan malumot faylni 

saqlagan paytda kiritilgan bo’lsa. 



Soxranitь sloi i stranitsы (Maintain layers and pages) bayroqchasi hujjatdagi 

qatlomlar ,sahifalar haqida konvertattsia qilishni taminlaydi,  CDR dan boshqa 

formatda bo’ladi. 

Menuning Fayl (File), va Importirovatь (Import...) buyrugi  CorelDRAW 

dasturidagi ochilgan joriy hujjatga hujjatni import qilishni taminlaydi va u ekkita 

usul bilan bajariladi: 

 Fayllar orasida boglanish saqlanadi. 

 Fayllar orasida boglanish saqlanmaydi. 

 

 

 Importirovatь (Import) mulohat oynasi Otkrыtь risunok (Open Drawing) 

oynasidan farhi quchimcha funktsiyalari va mumkin bo’lgan faylar ruyhati katta 

bo’ladi.. 

Razmer izobrajeniyа (Image size) satrida rastr tasvirlarni import qilganda 

pikseldagi ulchov birligi va ranglarni terangligi bitlarda beriladi. 

Pastdagi qatorlardafayl formati, va uning uzgachligi, masalan, siqish 

texnologyasini foydalanish va h.. Agarda fayl formati eskartmalarni saqlaydigan 

bo’lsa uning matnini , Primeсhaniyа (Notes) maydonidan kiritamiz. 

Svyаzatь s faylom vыsokogo razresheniyа dlyа vыvoda po texnologii OPI (Link to 

high resolution file for output using OPI) bayroqchasi, dasturning tez ishlashi 

uchun hujjatda fayl varsiyasini past razresheniyeda yozadi, qaytandan oqigan 

paytda avvvalgi holatiga qaytaradi. 



Proveritь "vodyаnoy znak" (Check for Watermark) bayroqchasi obespeсhit 

zapusk modulyа, tasvir haqida maxfiy malumotlarni qidiradigan modullar ishga 

tushiriladi. 

Svesti mnogosloynыe toсheсhnыe izobrajeniyа (Combine multi-layer 

bitmap) bayroqchasi ko`p qatlomli tasvirlarni konvertatsya qiladi, masalan, Adobe 

Photoshop (PSD) formatidan  yoki Corel PHOTO-PAINT (CPT) formatidan ,oddiy 

bi qatlomli qiladi, Soxranitь sloi i stranitsы (Maintain layers and pages) 

bayroqchasi, teskari, vektor obyektlarni qatlomlarga va sahofalarga ajratib beradi. 

Primenitь razmeщennыy profilь ICO (Apply embedded ICC profile) va 

Izvleсhь razmeщennыy profilь ICC (Extract embedded ICC profile) bayroqchlari, 

Otkrыtь risunok (Open Drawing) mulohat oynasiga tegishli bulib,joriy hujjatga 

import qilingan fayl rang profillarini urnatish yoki uni chaqirib alohida Image 

Color Matching (ICM) formatli faylga yozishni taminlaydi. Dastur quyidagi 

formatli fayllarda ranglar profillarini joylashtiradi; CRT, CDR, JPEG, PICT i EPS. 

Tasvirlarni bazi bir formatlarda joylashtirish uchun quchimcha malumotlar 

kerak bo’ladi (masalan, PS, PRN yoki PCD formatlari ). Bu holda ekranda 

quchimcha oyna paydo bo’ladi. Agarda import qilishda He vыvoditь dialogovoe 

okno filьtra (Suppress filter dialog) bayroqcha qoyilsa, import qilish joriy 

ko’rsatilgan boyicha bajariladi. 



 

CorelDRAW dasturida import qilingan tasvirlarni o’zgartirish uchun amallar 

bajarilgandan keyin ekranga boshqacha kursor chiqariladi. Shu kursor yordamida 

tasvirni hujjatning hoqlagan joyiga joylashtirishga bo’ladi. Bu obyekt ustida 

mastablashni ham bajarsa bo’ladi. Agarda proportsional mastablamoqchi bo’lsak u 

holda kursor bilan sohani chizib ko’rsatish kerak.Agar <Alt> tugmasi bilan 

masshtablashtirilsa proportsinal bo’lmaydi. 

Agarda masshtablashda aniqliqni talab qilsa,u holda mulahot oynasidagi 

Importirovatь (Import) ruyhatidan foydalanishga to’gri keladi.Ruyhatda uchta 

variant mavjud: 

1. Polnoe izobrajenie (Full Image) tasvir hech qanday uzgarishsiz import qilinadi. 

2. Izmenenie parametrov izobrajeniyа (Resample) — ekranga mulahot oyna 

chiqariladi, bu oynada o’lchamini va import qilinyatgan obyekt razreshenie si 

(oynani pastki qismida uzgartilgan va avvalgi fayllar o’lchamlari baytlarda 

beriladi). 

3. Kadrirovanie izobrajeniyа (Crop) — ekranga mulahot ayna chiqariladi, oynada qul 

yordamida yoki mos bo’lgan qiymatlarni o’zgartirish bilan Sverxu (Tor), Sleva 

(Left), SHirina (Width) Vыsota (Height) import qilinadigan yuzani chegaralsh 

mumkin. 



Importirovanie (Import) mulahot oynasidagi Svyаzь s vneshnim izobrajeniem 

(Link bitmap externally) bayroqcha quyilishi import qilishning uzgacha rejimi 

bo’ladi yani — tasvirlar bir-biri  bilan boglangan bo’ladi (linked image). 

Svyаzannыe izobrajeniyа 

Import qilganda tasvirlarni boshqa hujjatlarga olib utishlar faylar o’lchami 

katta qiladi shu sababli tasvirni olib utmay fahat utish joyini ko’rsatish (ssilka ) 

orqali ham bajariladi.. Ssilka qoyilgan tasvirlar boglangan deyiladi (linked 

images). 

Bu turdagi importdan foydalanishning yaxshi tomoni va yomon tomoni bor. 

Yaxshi tomoni: faylni o’lchami kichik bo’ladi, CorelDRAW  dasturiga murajat 

qilmasdan paralel va mustaqil ishlatiladi, hujjatdagi hamma tasvirlarga o’zgartirish 

kiritish urniga bir marta uzgartiladi. 

Yomon tomoni tasvirlarning joylashgan joyi nomalun va ssilkalar noto’gri 

bulishi mumkin. 

Bir-biri bilan noglan tasvirlar bilan ishlash uchun Docker tipidagi panel 

ishlab chiqilgan va uni  Dispetсher svyаzey (Link Manager) ataydi  bu panelda 

tasvirning barcha nuhtalari bilan  boglanishini ko`rsatadi.  

 

 

Har bir satrda tasvirlarning boqlanishi haqida malumot bo’ladi, 

kichiklashtirilgan tasviri, fayl manzili va nomi,tasvir joylashgan beti. 

Panelning pastki tomonida uchta tugma joylashgan: 

1. Birinchi turgma tasvir bilan orasidagi boglanishni uzdi va boglanish paneli satridan 

uchiriladi. 

2. Ekkinchi tugma eskirgan tasvirlarni yangilash uchun ishlatiladi. 



3. Uchunchi tugmaajratilgan tasvirni muharrirlash uchun ishlatiladi. 

Bu uchunchi tugma yordamida chaqiriladigan kichkina dasturcha CorelDRAW 

yordamida ishlatiladi va fayl kengaytmalari mosligiga inibor beriladi.Shuni 

itiborga olgan holda ekranga grafik dastur emas  ko`rsatadigan dastur (masalan, 

ACDSee) yoki brauzer -dasturlar(masalan , MI Explorer) chaqiriladi. 

Ung tomondagi pastdagi tugma boglanishni qul yordamida boshqarish uchun 

ishlatiladi, agarda tasvir ko’rsatilgan jilddan tashqarida qolsa holat satrida qizil 

krest bilan ko’rsatiladi. Aloqani qaytatdan boqlash uchun ko`rsatkish holat satriga 

olib borib sichqonchani ung tomoni bosiladi, va ochilgan menudan Vosstanovitь 

razorvannuyu svyаzь (Fix Broken Link) tanlanadi. Bu mulahot oynasini chiqaradi 

Opredelitь mestopolojenie toсheсhnogo izobrajeniyа (Locate External Bitmap) ni 

tanlash kerak . Agarda hotiradan uchirilmagan bo’lsa, u holda tasvirni manzili 

o’zgartirib qoyish kifoya.  

 

 

 

 

 

 

 

 

 

 

 

 



XULOSA 

Mustaqillikka erishganimizdan so`ng, O`zbekistonda ta`lim sohasida keng 

imkoniyatlar ochildi, vatanimizning xalqaro sahnadagi muvaffaqiyati, obru e'tibori 

va o`rni milliy o`zligimizni anglashda, kompyuter grafikasi yetakchi mavqe kasb 

etib, har bir fuqoroning mamlakat taqdiri uchun mas'ullik hissini yanada oshirishga 

xizmat qiladi. 

Yuqorida bayon etilgan fikrlardan xulosa shuki, talabalarga boshlang`ich 

kurslardan boshlab kompyuter grafikasi darslari, AutoCAD, CorelDRAW 

dasturidan, Corel PHOTO-PAINT, Poto Shop dasturlari kabi dasturlarning 

o`zlashtirilishi, talabalar uchun, o`z sohasining mukammal ustasi bo`lib 

yetishishlari uchun zamin bo`ladi. Kopyuter grafikasi mashg`ulotlari ham amaliy, 

ham ilmiy–nazariy jihatdan yaxshi o`qitilishi shart. 

O`tmish tarixdan aniq ma`lumki, qadimda buyuk muhandislar chizmalarning  

ilmiy asoslarini qo`llash natijasida, katta yutuqlarga erishganlar.  

Bularni talabalarga o`qitishda didaktiv prinsiplarning asosiysi hisoblangan– 

ilmiylik prinsipi yetakchi o`rin egallashi lozim. 

Men o`zimning kurs ishimda kompyuter grafikasi darslari haqidagi umumiy 

tushunchalarni bayon etdim, dasturlar bilan ishlash usullarini misollar keltirish 

bilan yoritdim. Shu bilan birga kompyuter grafikasi darslari doir bir nechta 

misollarni ko`rsatdim. Men o`z kurs ishimda oldimga qo`ygan maqsadimga 

erishdim.  
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