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NAVOIY DAVLAT PEDAGOGIKA INSTITUTI 5
Pedagogika fakulteti =
Tasviriy san at va muhandislik grafikasi kafedrasi %

Tasvirly san'at va muhandislik grafikasi ta’lim yo'nalishi
4-kurs talabasi
Nazarova Mohiraning 5
KOMPYUTER GRAFIKASI %
fanidan %
TANLANGAN ELEMENTNI CHOZISH 5
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«TASDIQLAYMAN »
Kafedra mudiri
« » 20 .

KURS (ishi) LOYIHASI

fan bo'yicha
Guruh talaba ning
Rahbar
TOPSHIRIQ
1. Ishlanadigan kurs ishi mavzusi
2. Kurs (ishi) loyihasini bajarish rejasi
1.
2.
3.
4.

Kurs ishining yakuniy natijalari

Uslubiy | Ko'rgazmali

: Adabiyotlar | Rasmiylashtirish | Himoyachi | Jami ball
gism qurollar

Rahbar




NAVOIY DAVLAT PEDAGOGIKA INSTITUTI
PEDAGOGIKA FAKULTETI

Tasviriy san at va muhandislik grafikasi kafedrasining
20 il dagi ___ —sonli yiglish garoridan

KO CHIRMA

Qatnashdilar:

KUN TARTIBI
20 20 —o'quvyilida fakulteti
ta’'lim yo nalishi talabasi
ning

kurs ishi mavzusini tasdiglash to g risida

ESHITILDI:

Kafedra mudiri: katta o'gituvchi S.A.Shovdirov so'zga chigib kafedra
a'zolarini kurs ishi mavzusi bilan tanishtirdi va mavzuning dolzarbligi bugungi
kundagi ahamiyatini nazarda tutib:

nomli kurs ishining mavzusi qilib tasdiglansin.
IImiy rahbar etib belgilansin.

Kafedra mudiri: katta o qituvchi. S.A.Shovdirov



NAVOIY DAVLAT PEDAGOGIKA INSTITUTI
PEDAGOGIKA FAKULTETI

Tasviriy san at va muhandislik grafikasi kafedrasining
20 il dagi ___ —sonli majlis garoridan

KO CHIRMA

Qatnashdilar:

KUN TARTIBI
4—kurs talabalarining kurs ishi muhokamasi.

ESHITILDI:

Kafedra mudiri: katta o'gituvchi S.A.Shovdirov so'zga chiqgib, kafedra
a’zolarining san'at tarixi va tasviriy san'at o'qitish metodikasi hamda kompyuter
grafikasi fanlari boyicha tayyorlagan kurs ishilari hagida to xtalib, ishning to’lig
talab asosida tayyorlanganligini, kurs ishining xulosasi, zaruriy hujjatlari
rasmiylashtirilganligini ta’kidlab o tdi.

Shundan so"ng talaba:

O’z mavzusi bo'yicha uning dolzarbligi, magsadi, vazifalari, olib borilgan
uslubiy ishlarning natijalari hagida o"zining xulosa va tavsiyalarini bayon etdi.
Kurs ishining mavzusi yuzasidan berilgan savollarga to'lig javob gaytardi.

MAJLIS QAROR QILDI:
1. Talaba: ning

mavzusidagi kurs ishi tugallangan ish deb hisoblansin.
2. Kurs ish himoyaga tavsiya etilsin.

Kafedra mudiri: katta o gituvchi S.A.Shovdirov



MUNDARIJA
KIRISH. .. e,

I-BOB. UMUMIY TA'LIM MAKTABLARDA KOMPYUTER
GRA-FIKASINI O QTILISHI HAQIDA ..cuiviiiiiiiiniiiiieiiiicnenneeee

1.1.“Kompyuter grafikasi” kursining predmeti, mazmuni va vazifa-



KIRISH

Mavzuning dolzarbligi: Dunyo cheksiz sir-sinoatlardan iboratdir. Uni
bamisoli musavvirning «Qora kvadraty asariga ma'noda o'xshatsa bo'ladi. Zero,
«kvadrat» - uning tafakkuri ojizlik gilishi, tabiiydir. Pirovardida, bu mo jizalarni
o rganish uchun insonga cheksiz umr adabiy yaratilganligini, to'rt tomoni -
cheksizlik timsolini anglatsa, «qora rang» esa mavhumlik dunyo sir-sinoatining
barchasini anglab bo’Imas sir ekanligidan dalolat beradi. Insoniyat ganchalik shu
sirlani bilishga harakat qilmasin, birog uning kerak bo’lishi hagida falsafiy
xulosaga kelasan, kishi.

Asrlar davomida ajdodlarimiz, fan arboblari muayyan darajada ilmiy-
tadgiqot ishlarini, tajribalarni o'tkazib kelishmogda. Hozirda, hatto ba'zi
rivojlangan mamlakatlarda maxsus rang institutlari va ilmiy laboratoriyalar bu
borada samarali faoliyat ko rsatib kelishmoqgda. Bu o'rinda Yaponiyaning Tokio
shahridagi dunyoga mashhur rang institutini ta’kidlash mumkin.

Mamlakatimizni obod, xalgimizni farovon qilish davlatimizning eng asosiy
vazifalaridan hisoblanadi. Ushbu nihoyatda katta vazifani bajarish keng gamrovli
masalalarni hal etishni tagozo etadi. Ana shunday muhim masalalardan biri har
tomonlama kamol topgan yugori malakali mutaxassislarni tayyorlashdir. Buning
uchun shunga mos ta’lim va tarbiya ishlarini bajarish, o’quv jarayonini rivojlangan
demokratik davlatlarda olib borilayotgan o’quv jarayoniga tenglashtirish,
zamonaviy pedagogik va axborot texnologiyalarini o’quv jarayoniga kengroq
tadbiq etish zarur.

Binolar va inshootlar qurilishi yo’nalishi bo’yicha ta’lim olayotgan talabalar
faoliyatiga yurtimiz obodligi bevosita bog’liqdir. Shunday ekan, oliy o’quv
yurtlarida puxta bilim olgan, o’z kasbini sevib, uni sirlarini har tomonlama chuqur
o’rgangan, yetarli kasb mahoratiga ega bo’lgan yoshlar mamlakatimiz kelajagini
yanada obod qila oladilar. Bu masala esa ko’p jihatdan ularning bilim olishlari
uchun yaratilgan shart — sharoitlarga, shu jumladan yoshlar uchun yaratilgan o’quv

adabiyotlariga bog’liq.



Hozirgi vaqtda AutoCAD ning dastur ta'minoti shaxsiy kompyuterlarning
eng keng targalgan avtomatik loyihalash tizimi paketidir.

Ushbu kurs ishida kompyuterli modellashtirishni loyihalashtirishning
universal grafik sistemasi mubhitidan iborat bo‘lgan, AutoCaddan foydalanish
uslubi taklif etilgan. Bu AutoCAD tizimi Autodesk kompaniyasi tomonidan ishlab
chigilgan bo‘lib, loyihalash jarayonida ko‘p sonli foydalanuvchilar qulay holda
ishlatishlari ko‘zda tutilgan. Hozirgi davrda AutoCAD ning dasturiy ta'minoti
kompaniyani eng yaxshi mahsuloti bo‘lib, shaxsiy kompyuterlarning eng keng
targalgan avtomatik loyihalash tizimi paketi hisoblanadi

«Kompyuter grafikasi» informatika sohasida o rganiladigan ko pgina fanlar
ukuv rejalarining ajralmas gismi bulib hisoblanadi. Hozirgi vaqtda kompyuter
grafikasi quyidagi kurslarning tarkibiy qismi hisoblanadi:

e “Informatika va hisoblash texnikasi”

e «Informatika va dasturlash»

e “Kompyuter informatsion sistemalari”

e “Moddiy resurslarning kompyuter informatsion sistemalari (marketing)”

e ADP (amaliy dasturlar paketi)

Internet asoslari va E-mail (elektron pochta)

“Kompyuter tarmoklari” va boshkalar.

Berilgan ma’lumotlarni tahlil qilishda, olingan natijalarni kurimli qilib
ko rsatishda va takdimot (prezentatsiya) uchun materiallar tayyorlashda, tasvirlarni
gayta ishlashda, yangi marakkab kompozitsiyalar yaratishda zamonaviy kompyuter
grafikasi keng go’llaniladi. Yuqgoridagi sohalar boyicha bilim olish va amaliyotda

tatbiq gilishda “Kompyuter grafikasi” fani go'| keladi.

Shu bois, hozirgi kunda glaballashuv jarayoni tezlik bilan rivojlanib
borayotgan bu davrda, talabalarning bu bilimlarni o zlashtirishlari uni mukammal

o0 zlashtirishlari talab etilmoqda.



Kurs ishining magsadi —

Men o'z kurs ishimda Tanlangan elementni chozish va ularda ishlash
usullarini o zlashtirishni, 0"z oldimga magasad gilib qo"yaman.

Kurs ishining vazifasi:

Tanlangan elementni chozish usullari bilimimni rivojlantirish.

Kurs ishi tuzilishi: kirish, ikki bob, xulosa foydalanilgan adabiyotlar

ro"yxatidan iborat bo'lib, jami 30 sahifani tashqil etadi.



I-BOB. Kompyuter grafikasi hagida umumiy tushuncha.
1.1. “Kompyuter grafikasi” kursining predmeti, mazmuni va vazifalari.

Asosiy tushinchalar:

1. Kompyuter (mashina) grafikasi - grafik yoki geomerik ob’ektlarining hajm
modellarini yaratish, sakash, ishlov berish va zamonaviy EXMlar yordamida
ularni tasvirlash tushuniladi.

2. Multimedia texnologiyasi - foydalanuvchini Kompyuter bilan mulogati uchun
ovoz, video, grafika, matn, animatsiya va boshga vositalar yordamida tabiiy
mubhitni ta’minlash jarayoni.

3. Grafik interfeys - foydalanuvchi dastur va ma’lumotlar bilan ishlayotganda
grafik elementlar yordamida kerakli amallarni bajarishni ta’minlovchi oddiy va
qulay vosita.

“Kompyuter grafikasi” ning informatsion jamiyatdagi ahamiyati, roli va

urni.

Fan va texnika taragqiyoti jamiyatimizni informatsion jamiyatga aylantirdi.
Bu jamiyatda faloiyat ko'rsatuvchilarning aksariyat gismi axborotlarni ishlab
chiqarish, saglash, gayta ishlash va amalga oshirish bilan banddirlar. Bunday
ishlarni  zamonaviy = Kompyuterlarsiz amalga oshirish  giyin.  Ulardagi
ma’lumotlarni gayta ishlash mashina grafikasi yordamida amalga oshirilsa
foydalanuvchi katta qulayliklar tug diradi.

Mashina grafikasi deganda ob’ektlarning hajm modellarini yaratish, saqlash,

ishlov berish va EXM lar yordamida ularni tasvirlash tushuniladi.

Kompyuter grafikasi yangi informatsion texnologiyalar orasida to xtovsiz
rivojlanib boraetgan yunalishlardan biri hisoblanadi. Bunday rivojlanish texnika
sohasida ham (grafika stantsiyalari), dasturiy vositalar sohasida ham ko 'zga
tashlanmoqda. Ular videofilm kadrlari bilan sifat buyicha taqgoslashga loyiq
haqiqiy, hajmli harakatlanuvchi tasvirlarni yaratishga imkon beradi. Bu dasturiy

maxsulotlar reklamalar ishlab chiqaruvchi vositalar hisoblanib, san’at va



multimediya texnologiyasi sohalarida gollaniladi. Bundan tashgari namoyish

grafikasiga, geometrik modellashtirishga, grafik interfeyslarni loyihalashga,

animatsiya (harakatlanuvchi tasvirlar) ga va ko'zga kurinuvchi (vizualniy)

harakatni kurishga katta e’tibor berilmoqda.

Kompyuter grafikasi ilm va fanning barcha sohalarida, aynigsa igtisodiy

ko'rsatgigchlarni tahlil gilishda muvoffaqiyatli o llanilishi mumkin.

“Kompyuter grafikasi ” tugrisida umumiy tushuncha
Kompyuter grafikasi jaxonda yangi fundamental fan hisoblanib o°tgan

asrning 90 — chi yillarida paydo buldi hamda fan va ishlab chiqarishning barcha
sohasida kadrlar tayyorlab berishda o°ziga xos mustaqil ahamiyatga egadir.

Maxsus dasturlar yordamida xuddi bir varak ok gqog ozga galam yoki ruchka
bilan har xil rasmlarni solish singari Kompyuter ekranida sichkoncha yordamida
rasm chizish, ya’ni tasvir tuzish, tuzatish va ularni harakatlantirish imkonini
yaratdi. Bu dasturlar rasm solish programmalari yoki grafik redaktorlar hisoblanib,
ular yordamida rasmning elementlari boshkarib boriladi.

Kompyuter grafikasining juda tez rivojlanib borishi va uning texnikaviy va
dasturiy  vositalarining  yangilanib  turilishi  ushbu  kursning  hamisha
takomillashtirishga, bu sohadagi yangi yunalishlarni tinmay o'rganib borishni
takozo etadi. Oxirgi yillarda bu sohada juda katta uzgarishlar (siljishlar) yuz berdi,
ya’ni 16 min.dan ortik rang va rang turlarini (ottenok) uzida aks ettira oladigan
displeylar, grafik axborotlarni (paper part) kirituvchi moslama - skanerlar, grafik
ish stantsiyalari; dasturiy vositalar sohasida esa haqigiy Kompyuter dunyosini

kashf gila oladigan amaliy dasturlar vujudga keldi.

“Kompyuter grafikasi” ning Informatika sohasidagi boshka fanlar bilan

uzaro alokasi

«Kompyuter grafikasi» informatika sohasida o rganiladigan ko pgina fanlar
ukuv rejalarining ajralmas gismi bulib hisoblanadi. Xozirgi vagtda Kompyuter
grafikasi quyidagi kurslarning tarkibiy gismi hisoblanadi:

e “Informatika va hisoblash texnikasi”



e «Informatika va dasturlashy»

o “Kompyuter informatsion sistemalari”

e “Moddiy resurslarning Kompyuter informatsion sistemalari (marketing)”
e ADP (amaliy dasturlar paketi)

¢ Internet asoslari va E-mail (elektron pochta)

o “Kompyuter tarmoklari” va boshkalar.

“Kompyuter grafikasi” kursining predmeti, mazmuni va vazifalari.

Berilgan ma’lumotlarni tahlil qilishda, olingan natijalarni kurimli qilib
ko rsatishda va takdimot (prezentatsiya) uchun materiallar tayyorlashda, tasvirlarni
gayta  ishlashda, yangi marakkab kompozitsiyalar yaratishda zamonaviy
Kompyuter grafikasi keng go llaniladi. Yukoridagi sohalar buyicha bilim olish va

amaliyotda tatbik gilishda “Kompyuter grafikasi” fani kul keladi.

AutoCad dasturi hagida umumiy tushuncha

Hozirgi vaqtda uch o‘lchamli kompyuterli modellashtirish vositalari
foydalanuvchilarning e'tiborida bo‘layapti va bu tasodifiy emas albatta. Ulardan
foydalanish  konstruktorlik-loyihalash ishlarining sifatli bajarilishi hamda
foydalanuvchiga chizmalarni tez, sifatli, yuqori aniglikda bajarish va qog‘ozga

chigarish imkonini beradi.

AutoCAD dasturi avtonom rejimida yoki lokal tarmogda ham ishlashi
mumkin. AutoCAD dasturining yaxshi ishlashi uchun quyidagi manbaalar zarur
bo‘ladi: Pentium 133 protsessori, 32 Mbaytli operativ xotira, Qattiq diskda 400-
750 Mbaytli xotira, 640 ga 480 VGA — displeyi.

AutoCAD DASTURINI ISHGA TUSHIRISH

AutoCAD dasturi ishga tushirilgandan keyin «Zagruzka» dialog oynasi

chigariladi (1-rasm).
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1-rasm. «Zagruzka» dialogli oynangni ish boshi.

ﬂ - «Chizmani tanlash» —avval yaratilgan chizmani ochish imkonini

beradi;

QI - «Boshidan boshlash» - chizma uchun yangi varagni ochish imkonini
beradi;

QI - «Shablondan foydalanish» —chizmachilikning kerakli uskunalarini oz

ichiga olgan shablonni tanlash imkonini beradi;

@I - «Sehrgarni ishlatish» —AutoCAD muhitida kerakli sozlashlarni
amalga oshirish. Sozlashning ikki xil varianti: «Advanced Setup»
(«Keng sozlash») va «Quick Setup» («Tez sozlash») (2-rasmga

garang).

Units (Birliklar) —uzunlikning kiritish va chigarish o‘lchov birliklarini tanlash
navbatdagi o‘lchov birliklarini taklif etadi: Decimal (detsimetrlik); Engineering
(muhandislik); Architectural (arxitekturali); Fractional (fraktsionli); Scientific

(ilmiy). Decimal (detsimetrlik) o‘Ichov birligini tanlash tavsiya etiladi.

» Angle (Burchaklar) -Burchakni kiritish va chiqarish o‘Ichov birliklarini tanlash
navbatdagi o‘Ichov birliklarini taklif etadi: Decimal Degrees (detsimetrli gradusli);
Deg/Min/Sec  (graduslar/minutlar/sekundlar); Grads (gradlarda); Radians
(radianlarda); Surveyor (yorug‘lik tomonlariga nisbatan). Decimal Degrees

(burchakli detsemetrli) o‘lchov birligini tanlash tavsiya etiladi.



* Angle Measure (Burchakni of‘lchash ) —burchakni o‘lchashni boshlash

topshirig‘i burchakni noldan o‘lchashning navbatdagi yo‘nalishlarini taklif etadi:

East (shargiy); North (shimoliy); West (g‘arbiy); South (janubiy); Other

(ixtiyoriy). East (sharqiy) yo‘nalishni tanlash tavsiya etiladi.

* Angle Direction (Burchakni of‘lchash yo‘nalishi) —burchak yo‘nalishining

navbatdagi burchaklar yo‘nalishlarirni taklif etadi:

nalishi tanlanganda,

(4

musbat yo

bo‘yicha).

Clockwise (soat mili

Counter Clockwise (soat miliga teskari);

nalishini tanlash tavsiya etiladi.

Counter Clockwise (soat miliga teskari) yo°

imkon beradi.

» Area (chegara) —chizmaning chegaralarini aniglashga

«Quick Setup» («Tez sozlash») varianti tanlanganda dastur fagat o‘lchov

birliklari (Units) va chegara (Area)ni tanlashni tavsiya etadi. .

rasmga garang.) Yana o‘lchov

«Zagruzka» dialog oynasidan chigishda (1

dyumlar]) ni tanlash tavsiya etiladi.

, Yoki inglizcha[futlar

birliklari : (metrik [mm]
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2-rasm. Chizmachilik parametrlarini sozlovchi diologli oyna.

AutoCAD dasturining ish stoli

3-rasmda AutoCADning ish stoli tasvirlangan.

Ish stoliga quyidagilar kiritilgan:



. TUSHUVCHI MENYU QATORI —menyuning eng yuqori gatori;

ASBOBLAR PANELI —yuqorida, ish stolining o‘ng va chap tomonida.
Keyingi ishlarda foydalaniladigan asosiy asboblar paneli:

1) «Standart asboblar» paneli;

2) «Obyekt xossasi» paneli;

3) «Chizish» paneli;

4) «O‘zgartirish» paneli;

5) «O‘lchamlar» paneli;

6) «Obyektni bog‘lashy» paneli.



1.2. ASBOBLAR PANELINI SOZLASH ALGORITMI.

1) sichgon klavishi o‘ng tomonini asboblar panelining ixtiyoriy birortasini

ko‘rsatib, bosamiz.
2) ochilgan ro‘yxatdan kerakli asboblar panelini belgilaymiz.

« GRAFIK MAYDON (Model maydoni) —ish stolining o‘rta maydonini
egallagan bo‘lib, modellar chizmasini yaratish uchun mo‘ljallangan. Model
maydoni parametrlarini qo‘llovchi o‘ziga mos qulay ravishda o‘zgartirishi

mumkin.
MODEL MAYDONINI SOZLASH ALGORITMI

1) Sichqon klavishining o‘ng tomonini grafik maydonning ixtiyoriy joyiga

bosamiz, Optsii punktini belgilaymiz.

2) Ochilgan «Parametrlar» dialog oynasida quyidagi sozlashlarni amalga

oshirish mumkin.
A) Oyna elementlari ish stoli ko‘rinishini sozlash, ya'ni;

1) Rang tugmachasi yordamida model maydoni rangini tanlash mumkin;

2) Dialog oynasiga chagiriladigan shrift turini Shrift tugmachasi orgali sozlash

mumkin.

B) Format elementlari maydoniga Varag maydoni M2 umumiy ko‘rinishini

sozlash mumkin.

V) “Aks ettirishni kengaytirish qobiliyati” maydonida obyektlarning tasviri
sifatini sozlash mumekin, ya'ni yoylar va aylanalar egri chiziglarda segmentlar soni
va h.k.

G) AKks ettirish maydoniga uch o‘lchovli rang berilgan (3D) obyektlarni aks

ettirish sifatini sozlash mumkin.



* DIALOGLI OYNA yordamida dastur bilan mulogot amalga oshiriladi. Bu oyna
bir necha qatordan iborat bo‘lib, ularda foydalanuvchi chiqaradigan ta'sir algoritmi
aks etgan bo‘ladi. Ko‘pincha, dastlabki asboblar to‘g‘risida kerakli axborotni

o‘z ichiga oladi.

Mulogot oynasida kamida uchta gator goldirilishi tavsiya etiladi. Sozlashni
go‘lda, ya'ni sichqonning kursorini muloqot oynasining yuqori qismiga olib borib,

uni siqib (cho‘zib) yoki past (baland) ga surib amalga oshiriladi.

« QATOR HOLATI (boshgarish tugmasi) —chizmachilik rejimlari, ya'ni
qo‘shish/o‘chirishni o‘z ichiga oladi va ish stolining eng pastki gismida

joylashgan.
O‘z ichiga quyidagi elementlar (tugmalar)ni olgan:

A) QADAM (SHag) (Snap) -sichgonning ma'lum gadam bilan
harakatini ta'minlaydi.

Sozlash bajariladi: Asboblar/Chizmachilik parametrlari qo‘shimcha “Bog‘lash va

setka”.

Qadam_rejimini_go ‘shish_(o‘chirish) F9 funktsional klavishi orgali yoki ShAG

(Qadam) knopkasini sichgon bilan bosish orgali amalga oshiriladi.

B) TO‘R (Grid) - rasmni aniq chigarish, va ishni yengillashtirgan holda, ortogonal

setkasining bog‘larini ekranda olish imkoniyatini beradi.

Sozlash bajariladi: Asboblar Chizmachilik parametrlari qo‘shimcha “Bog‘lash va

[P
.

to'r

Setka_rejimini_go ‘shish (o ‘chirish) F7 funksional klavishi yoki sichgon bilan

SETKA tugmasini bosib amalga oshiriladi.

V) ORTO (Ortho) — chiziq chizish ortogonal rejimini qo‘shadi (o‘chiradi).



G) POLYaR (Polar) —chizishning polyar rejimini qo‘shadi (o‘chiradi), ya'ni dastur
avtomatik ravishda trassirovkali turlar holida obyektlar chizmasi yo‘nalishni va

burchagini ko‘rsatib beradi.

Sozlash bajariladi: Asboblar/Chizmachilik parametrlari qo‘shimcha “Bog‘lash

va setka”.

Polyarnaya trassirovka rejimini qo ‘shish (o ‘chirish) F10 funksional klavishi yoki

sichqonni POLYAR tugmasiga bosish orgali bajariladi.



11-BOB. TANLANGAN ELEMENTNI CHOZISH

= Tanlang Modify > Transform > Scale va markazdan hoglagan yonalshda torting

= '‘ctpenka" asbobini tanlang va  Kattalashtirish (kichiklashtirish) belgisini

bosing. Markazdan hoglagan burchak ostiga torting

2.1. Berilgan elementni o’lchamini o’zgartirsh paytida tesksri qilish:

Urtacha belgidan pastga markaz tomon torting (rasmda berilgan).(chaoga, ungga

yugariga markaz tomon)

¢

Eslatma: Agarda siz o’lchamini kattalashtirgan bo’Isangiz yoki katta obyekt bilan
ishlasangiz berilgan to’griturtburchakni tortiladiganlarini kurmasligingiz mumkin
bu holda View > Work Area foydalaning

Obyektlarni tekislash

Modify > Align ekkita yoki bir-nechta ajratilgan obyektlarni tekislaydi. Tekislah
elementlar enini va boyini bir xil bo’lishi uchun o’lchamlarini o’zgartirishi
mumkin. O’lchami eng katta elementga qaray tanlaniladi. Shu bilan birga
obyektlarni ung tomonga, markazdan,chap tomonga,yugari tomonga bir xil
masofada qilib tekislaydi. Align to Page optsyasi bir-biriga va sstenaga nisbatan

to’ grilaydi.

Bir nechta obyektlar tekislanganda , Flash ularni en tomonlari ,markazi nima yoqin

bo’lsa ushga nisbatan qiladi. Sizni obyektlarni qanday tartibda kiritgani ahamyati
yoqg.



O0beKkTHI BBIPpABHEHBI MO BepxHeii Touke Eng yaxshi varianlaridan Dbiri
obeklarni avval nusxasini olish kerak, va guruhga oling. Bu esa tekislagandan
keyin muharrirlash va alohida qolishga yordam beradi.Agarda ajratilgan
obyektlardan  bir-biri bilan biriktirilsa yoki bir-biriga yaqin bo’lsa natija
kutganimizday bo’lmaydi.Bir-biri ustida joylashgan elementlar tekislashdanva
o’lchamlarini uzgartgandan keyin bulaklarga bulinadi.

Obyektlarni tekislash uchun:

1. Tekislanishi kerak obyektlar ajratiladi.
2. Modify > Align tanlang.

3. Mulahot oynasidan optsyani tanlab OK tugmasini bosing
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Kesib olish, yoqgatish, nusqasini olish va obyektlarni qoyish.




Sizlar Flashda obyektlarni kesish (cut) yoqatish (delete), nusgasini olish (copy) va
goyish (paste) amallarini bajarilish boshqga dasturlarga uxshahs bo’ladi.

Buferda nusxalangan obyektlar, siliglanadi(antialiased), va boshga dasturda ham
Flashga uxshash bo’ladi.

Obyektlarni kesilgani va nusqalari berilgan rolikni (movie) yoki boshga rolikni
stsenalarga yoki gatlomlarga (layers)goyilishi mumkin. Obyektlarni goyishni
ekkita turi mavjud bittasi ko’rsatilgan joyga (Paste in Place), ekkinchisi (Paste),
ishci maydoniga goyiladi.

Boshqga rolikdan (movie) olingan grafika yoki dasturlar joriy freymga (frame) joriy
gatlomiga (layer) qoyiladi.Flashga grafik element gnday bulib qoyilishi uning
tipiga,optsyasiga bogliq bo’ladi

= Matn muharriridagi matn matnni obyekti hisobida qoyilqdi

= Grafik dasturdagi vektor guruhi guruh tarizida qoyiladi,gaytatdan guruhdan

ajratib muharrirlash mumkin. Flashda ham yogaridagiga uxshash bo’ladi.
= Rasrl tasvirlar ham guruhlangan obyekt bulib gqoyiladi.Qiyidagi amal
yordamida rastr tasvirdan vektorga utiladi Modify > Trace Bitmap .

Eslatma: Flash 3 dagi FreeHand 8 dan grafikani nusgasini olish va goyishda
FreeHand Export Preferences da CMYK va RGB ga o’zgartiring.

Ajratilgan elementni uchirish:

= Del yoki Backspace tugmalari bosiladi.
= Menudan Edit > Clear ni tanlang.

= Menudan Edit > Cut ni tanlang.

Ajratilgan fayldan nusga olish:

= Ctrl-tugmasini bosib obyektni bir oynadan ekkinchisiga olib utish kerak
= Menudan Edit > Duplicate tanlang.

= Menudan Edit > Copy tanlang.

Belgili joyga obyektni joylashtirish:



1 (Cut) yordamida obyektni kesib oling yoki (copy) obyektni nusgasini oling.

2 Nusgalarni original obyekt bilan olmashtirmaslik uchun boshga sloyga

(layer)utamiz.
3 Menudan Edit > Paste in Place tanlang.

Obyekt nusgalangan joyga tushadi fahat bosqa sloyda bo’ladi. Bu obyektlarni
joylashgan joylari bir xil fahat boshqa sloylarda va stsenalarda bo’lganlar bilan

ishlashda qulay bo’ladi.

Ishchi maydonining markaziga obyektlarni goyish:
1 Obyektni (Cut) kesib oling yoki (copy)nusgasini oling.
2 Menuda Edit > Paste bajaring.

Obyekt ishchi maydoni markazida paydo bo’ladi

Maxsus uerniga goyish buyrugi (Paste Special)

Paste Special buyruq (Clipboard) dagi malumotlarni berilgan formatda qoyib
beradi. Boshga rolikdan malumotlarga murajaatni ham bajarish mumkin.Paste
Special mulohat oynasi quyidagi optsyalarni uz ichiga oladi:

Source (ucxoonux) malumotlar manbayi nominiva ularni joylashgan joyoni
kursatadi.

Paste (scmasums) rasmga malumot olmashish buferidagilarni goyadi

Paste Link (scmasumb ccoinxy) rasmga malumot olmashish buferidagilarni qoyadi
va shu bilan birga berilgan malumot manbayiga murajjat gilishni yaratadi shuning
natijasida malumotlar avtomatik tarizda yangilanib turiladi.

As (kax) Qoyiladigan malumot tipini bildiradi.: Obyektni o’zgartirish uchun
obyektni va malumotlarni Object yordamida qoyiladi. Obyektni nomi obyekt
yaratilgan muharrirga bogliq bo’ladi. Flashda obyektni o’zgartirish uchun Modify
> Break Apart ni bajaring.

Flash yordamida rasmlarni muharrirlash uchun muharrirlagichga konvertirlash

uchun (Picture) (Metafile) tanlash kerak. Formatlanmagan matnlarni qoyish uchun



(Text ()ASCII) tanlang . Formatlangan matnni qoyish Text (Native) yordamida
bajariladi. FLASHda rasmni bulagini qoyish uchun Flash Drawing tanlang.
Display As lIcon (rnoxazame xax uxouxy) Rasmda murajaatni ikoncha shaklida
kursatadi.

Result (pesyrsmam) Tanlangan amalni natijasini kurastadi.

Change Icon (usmenums uxonxy) Change lcon murajaat oynasini kursatadi.
Boshga ikonchani tanlash uchun optsyani mulahot ko’rinishidagi oynadan

foydalanig.Bu yerda optsya agarda Display As qishilgan bo’lsa ishlaydi.

2.2. Tasvirlarni import va eksportlashning holatlari.

Tasvirlarni eksport yoki import gilganda quyidagi konbertorlar bo’lishi kerak —

oldindan saglangan malumotlarni dastur tushunadigan turiga utkazuvchi modullar

bulishi shart. Ole texnologiyasini foydalanganda konventorlar hagida oylamasak

ham bo’ladi.Ekkinchi tomondan bu texnologiya obyektlar bilan ishlaganda bir

qancha cheklashlar qoyadi yani,obyektlar kloni olinmaydiganbo’ladi va h.

Bufer obmena Clipboard

Malumotlari eng oddiy olmashishi bu Clipboard yordamida amalga oshiriladi,va

bu yordamida qiyidagi amallar bajariladi: CoreIDRAW dasturidan boshga

dasturlarga matnlarni va grafik elementlarni olib utishni bajaradi agarda olib

utilyatgan dasturda OLE texnologiyasi bilan ishlash imkonyati bo’lsa.

Redaktirovats (Edit) menusi va ashoblar panelida quyidagi amallar berilgan;

Kopirovats (Copy), Veirezats (Cat), Vstavits (Paste).

""drag-and-drop"" texnologyasi

"drag-and-drop" texnologyasi (“olib borib tashlash") bir dasturdan ekkinchisiga qul

yordamida malumotlarni olib utishlar quyidagi holatlarda amalga oshiriladi.

e Agarda vektor obyekti bir CorelDRAW dasturda bir hujjatdan ekkinchisiga olib
utiladigan bo’lsa.

e Agarda vektorli obyekt ishchi stolga olib utiladigan bo’lsa. Bu yerda ishchi
stoldan boshqa dasturga olib utiladi, masalan CoreIDRAW va Corel PHOTO-

PAINT dasturlar orasida grafik malumotlar oilb utiladi.



Otkreits (Open) va Importirovats (Import) buyruglari
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Menunuing Fayl (File) va Otkreits (Open...) buyrugi bosga muharrirlar yordamida

yoratilgan hujjatlarni ochadi, bu yerda fayllar vektor formatli bulishi kerak,

masalan, EPS standart formati.

Yugaridagi byuruq bajarilgandan keyin ekranda Otkreite risunok (Oren Drawing)

mulahot oynasi chigadi,bu yerda faylni qaysi jildda va qaysi fayl ekanligini

kurstish kerak. Bu erda Prosmotr (Preview)dagi bayrogchni belgilash natijasida

fayllar ichidagi malumotlar ko’rsatiladi. Agarda faylni uqich mumkin bo’lmasa

yoki boshqga sabablarga bogliq uqilmasa ko’rish oynasida krest belgisi chiqgariladi.
Ko’rish maydoni tagida fayl hagida malumotlar chiqariladi:

Versiya dokumenta (File Version) satrida hujjat saglangan dasturning versiyasi

beriladi;

Stepens sjatiya (Compression ratio) satrida faylni sigilish foyizini ko rsatadi

(vektor formati uzi ixcham o’lchami kichik bo’ladi, shunga qaramastan dastur

faylIni avtomatik tarizda sigadi.);

Soxranen (Last saved by) satri dasturni versyasi hagida malumot beradi

(platformasi) va unig relizi (masalan, build 337).

Klyucheveie slova (Keywords) va Primechaniya (Notes) foydalanuvchiga kerakli

faylni tez gidirib topib berishda yordam beradi. Agarda berilgan malumot faylni

saglagan paytda kiritilgan bo’lsa.



Soxranite sloi i stranitser (Maintain layers and pages) bayrogchasi hujjatdagi
gatlomlar ,sahifalar hagida konvertattsia gilishni taminlaydi, CDR dan boshga
formatda bo’ladi.

Menuning Fayl (File), va Importirovate (Import...) buyrugi  CoreIDRAW
dasturidagi ochilgan joriy hujjatga hujjatni import gilishni taminlaydi va u ekkita
usul bilan bajariladi:

Fayllar orasida boglanish saglanadi.

Fayllar orasida boglanish saglanmaydi.
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Importirovats (Import) mulohat oynasi Otkreite risunok (Open Drawing)
oynasidan farhi quchimcha funktsiyalari va mumkin bo’lgan faylar ruyhati katta
bo’ladi..

Razmer izobrajeniya (Image size) satrida rastr tasvirlarni import gilganda
pikseldagi ulchov birligi va ranglarni terangligi bitlarda beriladi.

Pastdagi gatorlardafayl formati, va uning wuzgachligi, masalan, sigish
texnologyasini foydalanish va h.. Agarda fayl formati eskartmalarni saglaydigan
bo’lsa uning matnini , Primechaniya (Notes) maydonidan kiritamiz.

Svyazats S faylom veisokogo razresheniya dlya veivoda po texnologii OPI (Link to
high resolution file for output using OPI) bayroqchasi, dasturning tez ishlashi
uchun hujjatda fayl varsiyasini past razresheniyeda yozadi, gaytandan ogigan

paytda avvvalgi holatiga gaytaradi.



Proverits "vodyanoy znak" (Check for Watermark) bayrogchasi obespechit
zapusk modulya, tasvir hagida maxfiy malumotlarni gidiradigan modullar ishga
tushiriladi.

Svesti mnogosloyneie tochechneie izobrajeniya (Combine multi-layer
bitmap) bayroqchasi ko'p gatlomli tasvirlarni konvertatsya giladi, masalan, Adobe
Photoshop (PSD) formatidan yoki Corel PHOTO-PAINT (CPT) formatidan ,oddiy
bi gatlomli qgiladi, Soxranits sloi i stranitser (Maintain layers and pages)
bayroqchasi, teskari, vektor obyektlarni gatlomlarga va sahofalarga ajratib beradi.

Primenits razmemennety profile ICO (Apply embedded ICC profile) va
Izvlechs razmemennsry profils ICC (Extract embedded ICC profile) bayroqgchlari,
Otkreite risunok (Open Drawing) mulohat oynasiga tegishli bulib,joriy hujjatga
import gilingan fayl rang profillarini urnatish yoki uni chaqirib alohida Image
Color Matching (ICM) formatli faylga yozishni taminlaydi. Dastur quyidagi
formatli fayllarda ranglar profillarini joylashtiradi; CRT, CDR, JPEG, PICT i EPS.

Tasvirlarni bazi bir formatlarda joylashtirish uchun quchimcha malumotlar
kerak bo’ladi (masalan, PS, PRN yoki PCD formatlari ). Bu holda ekranda
guchimcha oyna paydo bo’ladi. Agarda import qilishda He veivodite dialogovoe
okno filstra (Suppress filter dialog) bayrogcha qoyilsa, import qilish joriy
ko’rsatilgan boyicha bajariladi.
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CoreIDRAW dasturida import qilingan tasvirlarni o’zgartirish uchun amallar
bajarilgandan keyin ekranga boshgacha kursor chigariladi. Shu kursor yordamida
tasvirni hujjatning hoqlagan joyiga joylashtirishga bo’ladi. Bu obyekt ustida
mastablashni ham bajarsa bo’ladi. Agarda proportsional mastablamogqchi bo’lsak u
holda kursor bilan sohani chizib ko’rsatish kerak.Agar <Alt> tugmasi bilan
masshtablashtirilsa proportsinal bo’lmaydi.

Agarda masshtablashda anigligni talab qilsa,u holda mulahot oynasidagi
Importirovats (Import) ruyhatidan foydalanishga to’gri keladi.Ruyhatda uchta
variant mavjud:

. Polnoe izobrajenie (Full Image) tasvir hech ganday uzgarishsiz import gilinadi.

. lzmenenie parametrov izobrajeniya (Resample) — ekranga mulahot oyna
chigariladi, bu oynada o’lchamini va import qilinyatgan obyekt razreshenie si
(oynani pastki qismida uzgartilgan va avvalgi fayllar o’lchamlari baytlarda
beriladi).

. Kadrirovanie izobrajeniya (Crop) — ekranga mulahot ayna chiqariladi, oynada qul
yordamida yoki mos bo’lgan giymatlarni o’zgartirish bilan Sverxu (Tor), Sleva
(Left), SHirina (Width) Vweisota (Height) import gilinadigan yuzani chegaralsh

mumkin.



Importirovanie (Import) mulahot oynasidagi Svyaze s vneshnim izobrajeniem
(Link bitmap externally) bayrogcha quyilishi import gilishning uzgacha rejimi
bo’ladi yani — tasvirlar bir-biri bilan boglangan bo’ladi (linked image).
SvyazannsbI€ izobrajeniya

Import gilganda tasvirlarni boshga hujjatlarga olib utishlar faylar o’Ichami
katta giladi shu sababli tasvirni olib utmay fahat utish joyini ko’rsatish (ssilka )
orgali ham bajariladi.. Ssilka qoyilgan tasvirlar boglangan deyiladi (linked
images).
Bu turdagi importdan foydalanishning yaxshi tomoni va yomon tomoni bor.
Yaxshi tomoni: faylni o’lchami kichik bo’ladi, CoreIDRAW dasturiga murajat
gilmasdan paralel va mustaqil ishlatiladi, hujjatdagi hamma tasvirlarga o’zgartirish
Kiritish urniga bir marta uzgartiladi.

Yomon tomoni tasvirlarning joylashgan joyi nomalun va ssilkalar noto’gri
bulishi mumkin.

Bir-biri bilan noglan tasvirlar bilan ishlash uchun Docker tipidagi panel
ishlab chigilgan va uni Dispetcher svyazey (Link Manager) ataydi bu panelda

tasvirning barcha nuhtalari bilan boglanishini ko rsatadi.
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Har bir satrda tasvirlarning boqlanishi haqida malumot bo’ladi,

kichiklashtirilgan tasviri, fayl manzili va nomi,tasvir joylashgan beti.
Panelning pastki tomonida uchta tugma joylashgan:
1. Birinchi turgma tasvir bilan orasidagi boglanishni uzdi va boglanish paneli satridan
uchiriladi.

2. Ekkinchi tugma eskirgan tasvirlarni yangilash uchun ishlatiladi.



3. Uchunchi tugmaajratilgan tasvirni muharrirlash uchun ishlatiladi.
Bu uchunchi tugma yordamida chagiriladigan kichkina dasturcha CorelDRAW
yordamida ishlatiladi va fayl kengaytmalari mosligiga inibor beriladi.Shuni
itiborga olgan holda ekranga grafik dastur emas ko'rsatadigan dastur (masalan,
ACDSee) yoki brauzer -dasturlar(masalan , M1 Explorer) chagiriladi.

Ung tomondagi pastdagi tugma boglanishni qul yordamida boshgarish uchun
ishlatiladi, agarda tasvir ko’rsatilgan jilddan tashqarida qolsa holat satrida qizil
krest bilan ko’rsatiladi. Alogani qaytatdan boqglash uchun ko rsatkish holat satriga
olib borib sichgonchani ung tomoni bosiladi, va ochilgan menudan Vosstanovits
razorvannuyu svyaze (Fix Broken Link) tanlanadi. Bu mulahot oynasini chigaradi
Opredelite mestopolojenie tochechnogo izobrajeniya (Locate External Bitmap) ni
tanlash kerak . Agarda hotiradan uchirilmagan bo’lsa, u holda tasvirni manzili

o’zgartirib qoyish kifoya.



XULOSA

Mustagillikka erishganimizdan so'ng, O zbekistonda ta'lim sohasida keng
imkoniyatlar ochildi, vatanimizning xalgaro sahnadagi muvaffagiyati, obru e'tibori
va o rni milliy o zligimizni anglashda, kompyuter grafikasi yetakchi mavge kasb
etib, har bir fugoroning mamlakat taqdiri uchun mas'ullik hissini yanada oshirishga

xizmat qiladi.

Yugorida bayon etilgan fikrlardan xulosa shuki, talabalarga boshlang ich
kurslardan boshlab kompyuter grafikasi darslari, AutoCAD, CoreIDRAW
dasturidan, Corel PHOTO-PAINT, Poto Shop dasturlari kabi dasturlarning
0 zlashtirilishi, talabalar uchun, 0°z sohasining mukammal ustasi bo'lib
yetishishlari uchun zamin boladi. Kopyuter grafikasi mashg ulotlari ham amaliy,

ham ilmiy—nazariy jihatdan yaxshi o qitilishi shart.

O tmish tarixdan aniq ma lumki, gadimda buyuk muhandislar chizmalarning

ilmiy asoslarini qo’llash natijasida, katta yutuglarga erishganlar.

Bularni talabalarga o qitishda didaktiv prinsiplarning asosiysi hisoblangan—

ilmiylik prinsipi yetakchi o'rin egallashi lozim.

Men o°zimning kurs ishimda kompyuter grafikasi darslari hagidagi umumiy
tushunchalarni bayon etdim, dasturlar bilan ishlash usullarini misollar keltirish
bilan yoritdim. Shu bilan birga kompyuter grafikasi darslari doir bir nechta
misollarni ko'rsatdim. Men o'z kurs ishimda oldimga go'ygan magsadimga

erishdim.
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