
 

 

O’ZBEKISTON RESPUBLIKASI OLIY VA O’RTA MAXSUS TA`LIM 

VAZIRLIGI 

 

 

 

BUXORO MUHANDISLIK-TEXNOLOGIYA INSTITUTI 

 

 

«ELEKTROTEXNIKA VA ISHLAB CHIQARISHDA AXBOROT 

KOMMUNIKASIYA TEXNOLOGIYALARI » FAKULTETI 

  

 

”AXBOROT TEXNOLOGIYALARI”  

KAFEDRASI 

 

“WEB – DASTURLASH” 

fanidan 

 

 
 

MAVZU: DREAMWEAVER WEB-MUHARRIRI. 

 
Bajardi:         14-12 MIAT guruhi talabasi 

            Najmiddinov Jalol  
 

 

Qabul qildi:      Sariyev R.B. 

 

 

 

BUXORO – 2016



 

DREAMWEAVER WEB-MUHARRIRI. 

 

REJA: 

1. Dasturning ishchi sohasi 

2. HTML - sahifaning tuzilishi (strukturasi) 

3. Elementlar, HTML-teglar va xususiyatlar. 

 

 

Dasturning ishchi sohasi. 

Dreamweaver MX  dasturini ishga tushirish uchun quyidagi kadamlarni 

bajarish kerak: Pusk > Programmы > Macromedia > Macromedia 

Dreamweaver MX. 

Dasturning ishchi sohasini har qanday foydalanuvchi didiga va tajribasiga 

mos ravishda sozlab olishi mumkin. 

 

Rasm. 1. Dreamweaver MX dasturining interfeysi. 

Ishchi sohaning asosiy tashkil etuvchilari quyidagilar hisoblanadi: 

Hujjat oynasi 

Xususiyatlar palitrasi 

Ob`ekt palitrasi 



 Hujjat oynasi - tahrirlanayotgan hujjatni ko’rsatadi. 

 Ob`ekt palitrasi (Insert) - turli xil tipdagi ob`ektlarni (rasmlar, 

jadvallar, maxsus simvollar va boshqalar) sahifada tezda joylashtirish uchun 

xizmat qiladigan tugmalarga ega; 

 Xususiyatlar palitrasi (Properties) - belgilangan matn yoki ob`ekt 

xususiyatlarini ko’rsatadi va ularni tahrirlash imkonini beradi. 

 O’zgaruvchan palitralar (Floating Palettes)- oynalar, inspektorlar 

va palitralarni umumiy bloka birlashtirish uchun xizmat qiladi. 

 

Hujjat oynasi Dreamweaver MX dasturining asosiy oynasi hisoblanib, 

unda hujjatni yaratish va tahrirlash jarayonini ko’rish mumkin; Hujjatning 

brauzer oynasida qanday ko’rinishini taxminiy ko’rsatib turadi; Joriy loyixaga 

bog’liq bo’lgan turli xil ma`lumotlardan foydalanish imkonini beradi. 

Ob`ekt palitrasi jadvallar, rasmlar, katlamlar va boshqa ob`ektlarni tezda 

joylashtirishga mo’ljallangan tugmalardan tashkil topgan. Ob`ektlar palitrasini 

ochish\yopish uchun bosh menyudan Window > Insert bo’limini tanlang yoki 

Ctrl+F2 klavishlar birligini bosing. 

Ob`ektlar palitrasi quyidagi bo’limlarga ega: 

 Characters - maxsus simvollarni sahifaga o’rnatish va simvollarni 

tanlov asosida o’rnatish imkonini beradi; 

 Common - rasm, jadval, Flash kliplari, Shochweve, Java apletlari 

va boshqa ko’p ishlatiladigan ob`ektlar; 

 Forms - shakllar va boshqarish elementlarini yaratish; 

 Frames - sahifada ko’p qo’llaniladigan freymlar tuzilishlarini o’zida 

saqlaydi; 

 Head - sahifa sarlavhasi teglari: META, KEYWORDS va Base, 

Refresh  va boshqalar; 



Xususiyatlar palitrasi sahifaning belgilangan elementlari xususiyatlarini 

ko’rish va tahrirlash imkonini beradi. Ob`ektlarni belgilash nafaqat hujjatning 

asosiy oynasida, balki HTML-kod oynasida ham bajarilishi mumkin. 

Xususiyatlar oynasini ko’rish uchun bosh menyudan Window > Properties 

bo’limini tanlash yoki Ctrl+F3 tugmalarini bosish kerak. 

Ko’pgina xususiyat o’zgartirishlari shu vaqtning o’zida ob`ektda 

qo’llaniladi. (Ayrim xususiyatlarni qo’llash uchun esa sichqoncha tugmasini 

xususiyatlar palitrasi sohasida bosish kerak.) 

Birinchi marta xususiyatlar palitrasida ko’p foydalaniladigan ob`ekt 

xususiyatlari chiqadi. Qo’shimcha parametrlarini chiqarish uchun esa o’ng 

tomondan, pastdagi uchburchak belgisini bosish kerak.  

 

HTML-sahifa tuzilishi. 

HTML sahifada hujjat sarlavhasi (Head) va tanasini (Body) ajratib 

ko’rsatish mumkin. Sarlavhada, asosan sahifa to’g’risidagi ma`lumotlar 

saqlanadi va ularning ko’pchiligi  Web-sahifa ko’rinishiga ta`sir kilmaydi. 

Sarlavhadan tashqari barcha ma`lumotlar sahifa tanasida joylashtiriladi va 

ekranda ko’rinadi.  

Sahifa sarlavhasi va tanasi aniq ketma-ketlikda joylashtiriladigan maxsus 

teglar bilan aniqlanadi. 

Sahifaning HTML-kod tuzilishi. 

< HTML> 

< Head > 

Sahifaning sarlavha bo’limi. Bu erda ishchi ma`lumotlar teglari 

joylashtiriladi. 

</ Head > 

 < Body> 

Bu erda joylashtirilgan barcha ma`lumotlar  Web-sahifada akslantiriladi.  

 </ Body> 

</ HTML> 



Tuzilishi jihatdan to’g’ri HTML-kod < HTML> tegdan boshlanadi. 

Ochilgan < Head > tegi va yopilgan < \Head > tegi sarlavha bo’limini tashkil 

etadi. Sarlavha tarkibiga hujjat haqidagi boshlang’ich ma`lumotlar kiritiladi. 

HTML-faylning asosiy qismi hujjat tanasidir va u < Body> va  </ Body> teglari 

yordamida tashkil etiladi. Bu teglar orasida brauzer oynasida ko’rsatiladigan 

barcha ma`lumotlar joylashtiriladi. HTML-kod yopiladigan </ HTML> teg 

orqali tugallanadi. 

 

Elementlar, HTML-teglar va xususiyatlar (atributlar). 

HTML tili elementlar, teglar va xususiyatlarga ajratilgan. Element - 

ma`lumotlar joylashtirilgan ochiladigan va yopiladigan teglardan tashkil topgan. 

Misol: <p align=”justify”> Bu oddiy abzatc </p> 

Bu erda sahifadagi abzatc element hisoblanadi. 

Teglar nomlar orqali ajratiladi hamda katta va kichik belgisi  («<» va  «>» 

simvollari) orqali ko’rsatiladi. Teg nomi element tarkibidagi ma`lumot ekranda 

qanday ko’rsatilishini aniqlaydi. Masalan, birinchi misoldagi <p> tegi abzatcni 

hosil qiladi.  

Atributlar teg harakatini aniqlashtiradi. Masalan, align=”justify” ushbu 

abzatc uchun ikki tomondan tekislashni o’rnatadi. 

Teglardan foydalanish vaqtida quyidagi qoidalarga rioya qilish kerak: 

 Barcha standart teglar «<» simvolidan boshlanadi va «>» simvoli 

bilan tugaydi. (Masalan, <HTML>) 

 Teg nomini tashkil etuvchi simvollar orasida bo’sh joylar (probel) 

qo’yish mumkin emas. Shuningdek, teg nomi va belgilar orasida ham bo’sh joy 

qo’yish tavsiya etilmaydi. 

 Xar qaysi ochiladigan teg uchun mos ravishda yopiladigan teg ham 

bo’lishi kerak. Yopiladigan teg bilan ochiladigan teg o’rtasidagi farq uning nomi 

oldidagi «/» belgisi hisoblanadi. (</HTML>). 

 HTML-kodni yaratishda teg nomi uchun faqat quyi registrdagi 

simvollarni ishlating. 



 Teglarni ajratish uchun, shuningdek birinchi atributni teg nomidan 

ajratishda bo’sh joy ishlatiladi. Atribut qiymati tarkibidagi bo’sh joylar ham 

xatoliklarga olib kelishi mumkin.  

 HTML-hujjat tuzilishiga e`tibor bering. Asosiy teglarni to’g’ri 

tartibda va qat`iy ierarxiyada joylashtiring. 

Atributlar  teg ishini aniqlashtiradi. Ko’pgina teglarda atributlar berilishi 

shart emas, lekin shunday teglar ham mavjudki, ularda atributlar keltirilishi 

shart. 

         <p> va </p> teglari sahifada abzatc o’rnatadi. Ochuvchi <p> tegi 

faqat nomdan tashkil topgan bo’lishi mumkin. Lekin, zaruriyat tug’ilganda 

uning tarkibiga ayrim atributlarni qo’shish mumkin. Masalan, <p> tegi tarkibida 

abzatc tekislanishini o’rnatuvchi align atributi keltirilishi mumkin. 

Atributlar faqat ochuvchi teg tarkibida bo’lishi mumkin. Yopuvchi teg 

tarkibida atribut o’rnatishga urinmang. Masalan, ochuvchi teg <p 

align=”justify”> to’g’ri tuzilgan. Unga  yopuvchi teg </p>  mos keladi. Teg 

tarkibida bir necha atributlar joylashtirilishi mumkin. 

Kupchilik atributlarga qiymat beriladi. Aynan ana shular oxirgi bosqichda 

teg bajarilish tartibini belgilaydi. Yuqorida keltirilgan align atributiga justify 

qiymati o’rnatilgan. Atribut qiymati qo’shtirnoqlarda ko’rsatiladi. 

 

Avval juda muhim tushuncha bilan tanishib utamiz. 

Lokal Web-sayt - ishlab chiquvchi kompyuterida 

joylashgan Web-saytning «xaqiqiy» nusxasi hisoblanadi. 

Tarmoqda undan foydalana olmaymiz; undan faqat 

muallifgina foydalanishi mumkin. 

Boshqacha qilib aytganda, saytni Internetga 

joylashtirishdan oldin saytning fayllari kompyuteringiz qattiq 

diskida bo’lishi shart va bu lokal sayt deb ataladi. 

Lokal saytning barcha sahifalari diskning aniq katalogi 



ichida saqlanadi. Bu katalogni biz saytning  lokal papkasi  yoki  oddiy qilib, 

sayt papkasi deb ataymiz. 

Lokal Web-saytni aniqlash uchun Site Definition oynasidan foydalanamiz. 

Oyna bosh menyuning (Site>New Site…) bo’limi orqali ishga tushiriladi. 

Site palitrasi - saytning fayllarini (web-sahifalarni) ko’rish uchun 

mo’ljallangan. Birinchi ochiladigan ro’yxatda dasturda aniqlangan sayt nomini 

tanlaysiz. Palitraning asosiy sohasida ushbu saytning barcha fayllari ro’yxati 

paydo bo’ladi. Ixtiyoriy fayl ustida sichqoncha tugmasini ikki marta bosish joriy 

sahifani hujjat oynasida tahrirlash imkonini beradi. 

Shuningdek, ushbu palitra yordamida saytni Internet tarmog’ida 

joylashtirish jarayoni ham amalga oshiriladi. Bu jarayonlarni keyirok kurib 

chikamiz. 

 

Web-sahifada matnli ma`lumotlarni joylashtirish va formatlash. 

Ko’pgina Web-dizaynerlar uchun multimedia ma`lumotlarini tayyorlash 

ularga zavk bagishlovchi juda ham kizikarli mashgulotdir, lekin Web-sahifaning 

asosiy komponenti bo’lib matn hisoblanadi. Ko’pgina hollarda foydalanuvchilar 

qidirayotgan ma`lumot aynan matn ko’rinishda ifodalanadi. Odatda sayt 

foydalanuvchilari uzlariga kerakli ma`lumotlarni tezda qidirib topishga urinadi 

va katta hajmdagi axborotlarni o’qishni hohlamaydi. 

Matn - sayt «ovozi» hisoblanadi va Web-dizayner ushbu «ovoz»ni 

mo’ljallangan auditoriya eshitishi uchun bor imkoniyatlarini ishga solishi  kerak. 

Matnning kiska va tushunarli hamda grammatik xatolardan holi bo’lishi juda 

muhim hisoblanadi. 

Buyurtmachi asosan matnli ma`lumotlarni  «kulyozma» yoki elektron 

ko’rinishda etkazib beradi. Lekin bu Web-dizaynerlarni matn ustida ishlashdan 

ozod kilmaydi. Xususan, Web-sahifani tuzish vaqtida bo’lim va qism  

bo’limlarga sarlavhalar va shu bilan birga ma`lumotlar hamda qo’shimcha matn 

ma`lumotlar yaratishga to’g’ri keladi, masalan, haridor «savatini» to’ldirish 

buyicha ko’rsatmalar. Ba`zan Web-dizayner buyurtmachi bilan birgalikda Web-



sahifa uchun yangi matnlarni yaratishiga yoki mavjud matnni qayta ishlashiga 

to’g’ri keladi. Ko’pgina  Web-dizaynerlar Web-saytga matn yaratish uchun, 

matnlar tuzishga ixtisoslashgan malakali mutaxassislar xizmatidan 

foydalanishadi. 

1. Dreamweaver MX dasturini ishga tushiring (Pusk/Programmы/ 

Macromedia / Macromedia Dreamweaver MX). 

2. Dastur ishga tushishi bilan yangi HTML-hujjat hosil bo’ladi. Ob`ektlar 

palitrasi (Insert)  va xususiyatlar paneli (Properties) ni toping. 

3. Agar birorta palitra ekranda bo’lmasa, Window menyusidan foydalanib 

uni ekranga chaqiring. 

4. Window menyusidan Insert  va  Properties punktlari oldidagi belgini olib 

tashlab, Insert va Properties panellarini yoping. 

5. Window menyusidagi Others>History buyrug’ini tanlab, History panelini 

ekranga chiqaring. 

6. Ekranning o’ng qismida bir nechta palitralardan tarkib topgan panel hosil 

buldi, lekin joriy vaqtda faqat History palitrasi faollashtirilgan holos. Boshqa 

palitrani faollashtirish uchun sichqoncha tugmasini uning sarlavhasi ustida 

bosish kerak. 

7. Insert va Properties palitralarini ekranga chiqaring. Buning uchun 

Window menyusidan avval Inserts buyrug’ini, so’ngra Properties buyrug’ini 

bajaring. 

Dreamweaver MX dasturida yangi sayt yaratish tartibi: 

1. Site menyusidan NewSite buyrug’ini bajaring. 

2. Advanced bo’limiga o’ting. Site Name maydoniga yaratiladigan sayt 

nomini kiriting. Masalan, My Site. 

3. Local Root Folder maydonida sayt papkasini ko’rsatish kerak. 

Maydon yonidagi papka rasmini sichqoncha yordamida ishlating. 

4. Ochilgan muloqot oynasidan sahifa fayllari saqlanadigan papkani 

tanlang. 

5. Papka ro’yxatidan Moi dokumentы papkasini tanlang. 



6. Sichqoncha yordamida yangi papka yaratish piktogrammasini 

ishlating. 

7. Papka nomini kiriting (lotin alifbosi harflari bilan ismingizni kiriting). 

Enter tugmasini bosing. 

8. Yangi papkaga kirish uchun uning ustida sichqoncha tugmasini ikki 

marta bosing. 

9. Soxranit tugmasini ishlating. Saytning lokal papkasi tanlandi. 

10.  HTTP Adress maydoniga hech narsa kiritmang. Enabled Cache dan 

bayroqchani olib tashlamang. 

11.  OK tugmasini bosing. Yangi sayt yaratildi. 

12. Site (sayt fayllari) oynasini ishga tushiring. Buning uchun Window 

menyusidan Site palitrasini tanlang. 

13. Sayt fayllari bilan ishlash uchun Windows dagi «Provodnik» oynasiga 

o’xshash oyna ochiladi. 

14. Yangi fayl yaratamiz. File menyusidan New File buyrug’ini bosing. 

15. Ekranning o’ng qismida yangi HTML-faylning piktogrammasi paydo 

bo’ladi va uning nomi Untitled 1.htm bo’ladi. 

16. Bu nomni index.htm ga o’zgartiring. Buning uchun sichqoncha 

tugmasini fayl nomi ustida ikki marta bosing. 

17. Saytimizning barcha grafik ob`ektlari uchun yangi papka yaratamiz. 

Buning uchun File menyusidan New Folder buyrug’ini bajaramiz va papkaga 

Images nomini beramiz. 

18. index.htm faylini oching. Buning uchun Site oynasidagi fayl nomi 

ustida sichqoncha tugmasini ikki marta bosing. 

19. Bir vaqtda kod va dizaynni ko’rsatuvchi muhitga o’ting. Buning 

uchun View menyusidan Code and Design buyrug’ini bajaring. Sahifada hech 

narsa bo’lmasa ham HTML-kod sahifa haqidagi ayrim ma`lumotlarni o’zida 

saqlaydi. 



20. Hujjat oynasidagi yopish tugmasini bosgan holda, HTML-fayl 

oynasini yoping. Yuqoridan ikkinchi yopish belgisini ishlating, chunki birinchi 

tugma Dreamweaver dasturi oynasiga tegishlidir. 

Sahifa parametrlarini o’rnatish 

1. Ishlash uchun saytni faollashtiring. Buning uchun Site palitrasidagi 

ro’yxatdan saytingiz nomini tanlang. 

2. index.htm fayli bilan ishlash uchun uning ustida sichqoncha 

tugmasini ikki marta bosing. 

3. Kirill alifbosidagi harflarning to’g’ri ko’rinishini saqlang. Buning 

uchun Edit menyusidan Preferendes buyrug’ini tanlang. 

4. Fonts bo’limiga o’ting. Buning uchun bo’lim nomi ustida sichqoncha 

tugmasini bosing. 

5. Font Settings ro’yxatidan Cyrillic qiymatini tanlang. 

6. New Document  kategoriyasiga o’ting. 

7. Default Encoding ochiluvchi ro’yxatidan Cyrillic (Windows 1251) ni 

tanlang. 

8. OK tugmasini bosing. 

9. Sahifaning ixtiyoriy qismida sichqonchi o’ng tugmasini bosing va 

hosil bo’lgan kontekst menyusini Page Properties buyrug’ini tanlang. 

10. Title maydoniga sahifaning sarlavhasini kiriting (Mening birinchi 

Web-sahifam). 

11. Document Encoding – ochiluvchi ro’yxatdan Cyrillic (Windows 

1251) ni tanlang. 

12. OK tugmasini bosing. 

 

Matnni formatlash 

Mavzuga oid barcha fayllar Source katalogida keltirilgan. (C: /Web design/ 

Source). 



1. Source papkasidan teor5.doc faylini ishga tushiring. Hozir bu 

hujjatdagi barcha matnli ma`lumotlarni Web-sahifaga ko’chiramiz. Microsoft 

Word dasturini yopmang. (faylni yopmang). 

2. Dreamweaver MX dasturini ishga tushiring. 

3. Site palitrasida yuqorida yaratilgan sayt (My Site) nomi 

tanlanganiga ishonch hosil qiling. 

4. Yangi sahifa yarating (File>New…) va uni teor 5.htm nomi bilan 

xotirada saqlang. 

5. Windows muammolar paneli yordamida (Alt+Tab) Word  dasturi 

oynasiga o’ting. 

6. Pravka<Vыdelit vse buyrug’i yordamida barcha matnni belgilang. 

7. Pravka>Kopirovat buyrug’i yordamida matnni buferga nusxalang. 

8. Dreamweaver MX dasturi oynasiga o’ting. (Alt+Tab) 

9. Design muhitida Web-sahifaning boshida kursorni o’rnating. 

10. Edit>Paste buyrug’i yordamida joriy sahifaga buferdagi matnni 

o’rnating. Web-sahifaga matn o’rnatildi, lekin matn hech qanday formatga ega 

emas. Boshqa dasturdan nusxalangan matnni Dreamweaver MX mustakil 

ravishda formatlay olmaydi. 

Ushbu sahifa HTML-kodiga e`tibor bering (buning uchun Code and Design 

muhitini ishga tushiring). O’rnatilgan matnning har bir qatori <br> tegi bilan 

tugagan bo’lib, matnda abzatc yo’q. Shuning uchun formatlashni matnni 

abzatclarga bo’lishdan boshlash kerak. 

11. Matndagi abzatclarni aniqlaymiz. Buning uchun quyidagi 

amallarni bajaramiz. Kursorni abzatc o’rnatiladigan joyga keltirib, Enter 

tugmasini bosamiz va bo’sh qatorni o’chirish uchun Del tugmasi bosiladi. 

12. Joriy sahifa matnidagi barcha abzatclarni aniqlang. Ish davomida 

sahifani xotirada saqlashni esdan chiqarmang. (File>Save) 

13. Sahifa boshiga utib, sichqoncha yordamida «Stcenarii na storone 

servera» matnini belgilang va xusisiyatlar paneli yordamida ochiluvchi ro’yxat – 

Format dagi Heading2 qiymatini o’rnating. 



14. Xuddi shunga o’xshash har bir serverli dasturlash tillari nomlari 

(Perl, ASP va boshqalar) uchun ham ochiluvchi Format ro’yxatiga Heading3 

qiymatini o’rnating. 

15. Shriftni o’rnatuvchi ro’yxatdagi barcha sarlavhalar uchun “Arial, 

Hevetica…” ni, asosiy matn uchun esa “Verdana…” ni kiriting. 

16. Asosiy matn uchun Size – ochiluvchi ro’yxatidagi 3 o’lchamini 

o’rnating. 

17. Sarlavhalar uchun rangni tanlash uchun mo’ljallangan ochiluvchi 

ro’yxatdan rang tanlang. 

18. Bosh menyudan Modify>Page Properties buyrug’ini bajaring. 

19. Hosil bo’lgan muloqot oynasidagi Background maydonida sahifa 

foni uchun rang tanlang. 

20. Text maydonida sahifaning asosiy matni uchun rang tanlang. 

Rangni tanlash jarayonida Apple tugmasi yordamida oynani yopmasdan rangni 

o’rnatib, baxolashimiz mumkin. Page Properties oynasida ishni tugallash uchun 

OK tugmasini bosing. 

21. «B» va «I» tugmalari yordamida didingizga qarab, matn ostiga 

chizishni o’zgartiring. 

22. Sarlavhalar tekislanishini o’rtadan va asosiy matn uchun esa ikki 

tomondan tekislanishni o’rnating. 

23. Sahifani xotirada saqlang. (File>Save). 
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